[Asus X550LD] Touchpad not working - Ubuntu 14.04

Bug #1328392 reported by gsoundsgood on 2014-06-10
54
This bug affects 9 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

Touchpad on the Asus X550LD is not working on Ubuntu 14.04 with either default or mainline kernel 3.15.0-031500-generic.

Cursor does make some movements if you insist toying and clicking on the touchpad, but only seldomly (just using it normally often would produce no move), and in a direction that apparently has no relation with touch. Generally moves towards bottom, bottom/left, but insisting one can have patchy movements in other directions. However, clicking has no effect.

Mouse connected with USB works normally, until you try to use the touchpad. If you touch the touchpad, the cursor mostly keeps on moving as per the mouse, but click mostly does not work. Logging out and logging in or restarting fixes the problem.

WORKAROUND: Use external USB mouse but don't touch the touchpad.

WORKAROUND: To get this to work as PS/2 use kernel boot parameter:
psmouse.proto=bare

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-29-generic 3.13.0-29.53
ProcVersionSignature: Ubuntu 3.13.0-29.53-generic 3.13.11.2
Uname: Linux 3.13.0-29-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: g 1530 F.... pulseaudio
 /dev/snd/controlC0: g 1530 F.... pulseaudio
CurrentDesktop: GNOME
Date: Tue Jun 10 08:18:41 2014
HibernationDevice: RESUME=UUID=205b0b44-7997-42f7-806d-3b367ebfdceb
InstallationDate: Installed on 2014-06-09 (0 days ago)
InstallationMedia: Ubuntu-GNOME 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.2)
MachineType: ASUSTeK COMPUTER INC. X550LD
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-29-generic.efi.signed root=UUID=ee58b2b6-1d8c-4137-beca-6a52a4634265 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-29-generic N/A
 linux-backports-modules-3.13.0-29-generic N/A
 linux-firmware 1.127.2
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/17/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: X550LD.300
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: X550LD
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrX550LD.300:bd01/17/2014:svnASUSTeKCOMPUTERINC.:pnX550LD:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnX550LD:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: X550LD
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

gsoundsgood (gsoundsgood) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
description: updated
tags: added: bios-outdated-306 kernel-bug-exists-upstream-3.15
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
gsoundsgood (gsoundsgood) wrote :

Hi Cristopher.
As requested, I updated the BIOS. this is the output of the command you suggested:

X550LD.306
05/14/2014

I haven't noticed any substantial change, same behaviour as described in the bug description.

I'm not sure what you mean by "Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful."

Any suggestion or advise on how to proceed is welcome.

gsoundsgood, the issue you are reporting is an upstream one. Could you please report this problem through the appropriate channel by following the instructions _verbatim_ at https://wiki.ubuntu.com/Bugs/Upstream/kernel ?

Please provide a direct URL to your e-mail to the mailing list once you have made it so that it may be tracked.

Thank you for your understanding.

tags: added: latest-bios-306
removed: bios-outdated-306
Changed in linux (Ubuntu):
importance: Low → High
status: Incomplete → Triaged
gsoundsgood (gsoundsgood) wrote :

Hi Christopher.
As suggested, I followed word by word the instructions I found at the link you suggested, and sent it at both "L:" addresses indicated on the mantainer lists (http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/tree/MAINTAINERS) under Asus notebook

here's a link to my bug report on the mailing list:
https://<email address hidden>/msg05299.html

attached, the whole bug report for reference

maniuz (ziuperi) wrote :

Hi everyone, maybe i've found the solution for this problem. I recently bought an Asus F550LD (which in realty is an X550) and i have some problem, but the strange thing is that when i try the live version of ubuntu 14.04 on this notebook in exposure everything works (or almost). So before changing it, I used the command "sudo lshw -html" and I got the hardware list of pc.
Then when I changed the notebook with the one in exposure i repeat the commandon this one.
Finally I compared the two hardware cards. There are two difference. one litttle difference on the clock of processor (which is the same) and the Ram. The Ram is the same for power, but different for producer.

I think the problem is the Ram, on which the OS is loaded.

I report the two hardware cards for you.
I hope I was helpful

maniuz (ziuperi) wrote :

I have to write another comment to attach the second file

maniuz, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

nilesh (chatenilesh) wrote :

I don't know for touchpad but if EXTERNAL USB MOUSE isn't working try this

1. Open the Terminal : ctrl+alt+t
2. cd /etc/modprobe.d/
3. sudo gedit options.conf
4. Type the following in the file which is opened by previous command:
    options psmouse proto=imps
5 .Save the file and close it.
6. sudo modprobe -r psmouse
7. sudo modprobe psmouse

And its done.

gsoundsgood (gsoundsgood) wrote :

I temporarily fixed this using the workaround suggested in this comment: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1314198/comments/31

description: updated
Pilot6 (hanipouspilot) wrote :

The bug has been fixed in

linux-generic-lts-wily package.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers