err:module:attach_process_dlls "krnl386.exe16" failed to initialize, aborting

Bug #1327532 reported by Jaime Cruz on 2014-06-07
40
This bug affects 9 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

After installing the latest software updates to Trusty, my Win16 apps no longer launch. Attempting to launch from the command line yields the following error messages:

err:module:attach_process_dlls "krnl386.exe16" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"C:\\windows\\system32\\winevdm.exe" failed, status c0000005

Running the 64-bit version of Trusty with the lastest 3.13.0-29 kernel. It worked with the previous 3.13.0-27 kernel.

Thanks,
---
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jaime 2129 F.... pulseaudio
CurrentDesktop: Unity
DistroRelease: Ubuntu 14.04
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-05-03 (35 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: LENOVO 274673U
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-29-generic root=UUID=4a232e29-6c76-4506-b946-8303ab446fd1 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.13.0-29.53-generic 3.13.11.2
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-29-generic N/A
 linux-backports-modules-3.13.0-29-generic N/A
 linux-firmware 1.127.2
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Tags: trusty
Uname: Linux 3.13.0-29-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 12/01/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6AET64WW
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: 274673U
dmi.board.vendor: LENOVO
dmi.board.version: LENOVO 6AET64WW
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: LENOVO 6AET64WW
dmi.modalias: dmi:bvnLENOVO:bvr6AET64WW:bd12/01/2010:svnLENOVO:pn274673U:pvrThinkPadSL500:rvnLENOVO:rn274673U:rvrLENOVO6AET64WW:cvnLENOVO:ct10:cvrLENOVO6AET64WW:
dmi.product.name: 274673U
dmi.product.version: ThinkPad SL500
dmi.sys.vendor: LENOVO

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1327532/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Jaime Cruz (jaime-cruz) on 2014-06-07
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1327532

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected trusty
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Jaime Cruz, thank you for reporting this and helping make Ubuntu better. Could you please test the latest upstream kernel available (the one all the way at the top, and not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-3.15

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: latest-bios-1.30 regression-update
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Jaime Cruz (jaime-cruz) on 2014-06-11
tags: added: kernel-fixed-upstream kernel-fixed-upstream-3.14.1-031401
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: needs-reverse-bisect

Jaime Cruz, the next step is to fully reverse commit bisect the kernel in order to identify the fix commit. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection#How_do_I_reverse_bisect_the_upstream_kernel.3F ?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Jaime Cruz (jaime-cruz) wrote :

Just tested 3.13.11-03131103-generic, which is the latest kernel I found in the 3.13 branch. It failed.

Jaime Cruz (jaime-cruz) wrote :

And just confirmed it works with 3.14.0-031400-generic.

So it works with the 3.13 kernel up to 3.13.0-27-generic but is broken in every version I've tested of the 3.13 kernels. It works in both of the 3.14 kernels I've tested, so it looks like it got broken somewhere between 3.13.0-27-generic and 3.13.0-29-generic.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Jaime Cruz (jaime-cruz) wrote :

Problem still exists in latest Trusty kernel 3.13.0-30-generic.

Jaime Cruz (jaime-cruz) wrote :

I'm going to need some help here running that process outlined. I know the Win16 apps work with the 3.13.0-27-generic kernel, and that they were broken in the 3.13.0-29-generic kernel. I've solved MY problem by reinstalling the 3.13.0-27-generic kernel and "pinning" it so I doesn't get over-written by the automated update process. However, I WOULD like to see the problem fixed in an upstream kernel.

I'm a n00b, so the kernel names on that link you gave me mean nothing, really. How do I know which kernel corresponds to the GA 3.13.0-27-generic kernel, and which one corresponds to the 3.13.0-29-generic kernel and if I find the time I'll run through that process outlined above. Barring that, I'd be more than happy to provide the files to install a Win16 app so someone else can play with this problem. Let me know?

Jesper Skov (jskov) wrote :

See https://lkml.org/lkml/2014/5/7/508 for a fix from Linus.

Jaime Cruz (jaime-cruz) wrote :

Did some research. That fix is not available in the 3.13 kernel, it is apparently only in the 3.14 kernel. I've pinned the 3.13 kernel at the "27" level so I'm good for the time being. I understand Linus and the WINE team are looking for a way around this issue so SOMETHING should be coming soon.

Loïc Minier (lool) wrote :

With latest linux from -updates, I can run apps under wine if I run:
sudo sysctl abi.ldt16=1

For this to be applied on boot, I've added a new /etc/sysctl.d/20-wine-ldt16.conf with:
abi.ldt16=1

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers