desktop start rotated

Bug #1326885 reported by Zhang Weiwu on 2014-06-05
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Running Ubuntu 14.04 on bModo12 (same hardware as WeTab). Right after login the screen rotates to rightwards (no matter what direction the screen is actually at). I had to run this everytime:

$ xrandr -o normal

Note this is not gravity sensor at work. If gravity sensor is at work, and turned screen leftwards or rightwards, 'xrandr -o normal' will not have any effect.

Expected behaviour: the desktop rotation should be decided by gravity sensor, or, without its input, defaults to normal. If it is intended that even without gravity sensor input the desktop should rotate anyway (because it consider itself running on a tablet) then it should do so since login screen, not to change orientation right after login.
---
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CurrentDesktop: Unity
DistroRelease: Ubuntu 14.04
InstallationDate: Installed on 2014-04-28 (38 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
Package: linux (not installed)
Tags: trusty
Uname: Linux 3.15.0-031500rc5-generic x86_64
UnreportableReason: The running kernel is not an Ubuntu kernel
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1326885

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected trusty
description: updated
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
description: updated
description: updated
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.15 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-rc8-utopic/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Zhang Weiwu (zhangweiwu) wrote :

I was expecting you to ask me to try development kernel - I am a sysop and I do not think this is a kernel issue, more like you automatically require trying development kernel - so, in fact when I collect data I was already using development kernel. And yes for sure I experience this problem using Ubuntu's release kernel as well.

Can you add to the workflow to check whether or not the bug report already uses latest kernel, before asking for testing on latest kernel?

summary: - desktop start rotated
+ desktop start rotated kernel-bug-exists-upstream
tags: added: kernel-bug-exists-upstream
summary: - desktop start rotated kernel-bug-exists-upstream
+ desktop start rotated
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

  With the recent release of this Ubuntu release, would like to confirm if this bug is still present. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.13.0-24.46
Zhang Weiwu (zhangweiwu) wrote :

I won't report again with latest kernel because (from my experience) I do not expect it to be solved (or that it solved because of people reporting bugs), but I still provide the following information to save the time for those who wish to find a workaround - I do not know a workaround, but I know the following would not work:

The following methods would not prevent the desktop to rotate automatically after login:
- delete /lib/udev/accelerometer
- comment out the only line in /lib/udev/rules.d/61-accelerometer.rules

Since the rotate-after-login does not alter input matrix, which is still horizental, touch-screen will be useless right after login, until you rotate the screen back (with xrandr -o randr). If, instead of preventing auto-rotate-after-login, you wish to rotate input matrix as well to make the machine at least usable, the following command would not work:

$ xinput set-prop 9 --type=float "Coordinate Transformation Matrix" 0 -1 1 1 0 0 0 0 1

The effect of that command is zero: input matrix remain the same (horizental) while the screen is auto-rotated to vertical.

If you wish to study the issue, a starting point is the accelerometer device, which can be found in
/proc/bus/input/devices

Find out the event device (in my case event4) then you can find out which driver drives it by:
$ cat /sys/devices/platform/asus_laptop/input/input4/device/driver

Zhang Weiwu (zhangweiwu) wrote :

I noticed this bug is marked as kernel-bug-exists-upstream -- I do not think this is a kernel bug, because everything was fine before login, a kernel bug should exhabit before login. Also that it only affects after-login, not affecting screen rotation during the session. But I am no expert to remove that tag with confidence.

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Alex ivanov (alexivanov97) wrote :

Can confirm for linux mint 16, was not fixed after upgrading to mint 17.

Changed in linux (Ubuntu):
status: Expired → Confirmed
Daniel Holz (daniel-holz91) wrote :

I wrote this guide because I had the same problem with my WeTab:

http://lackofalucidmind-en.blogspot.de/2014/06/wrong-screen-orientation-at-greeter-and.html

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments