ppc64el: Add Opal firmware dump facility

Bug #1326015 reported by Tim Gardner on 2014-06-03
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Tim Gardner
Utopic
Undecided
Unassigned

Bug Description

Backport 2 upstream patches that provide a facility for dumping firmware information.

c7e64b9ce04aa2e3fad7396d92b5cb92056d16ac - powerpc/powernv Platform dump interface
774fea1a38c6a5a8ccc10969db84da24565f276f - powerpc/powernv: Read OPAL error log and export it through sysfs

Tim Gardner (timg-tpi) on 2014-06-03
Changed in linux (Ubuntu Utopic):
status: New → Fix Released
Changed in linux (Ubuntu Trusty):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
description: updated
description: updated
Tim Gardner (timg-tpi) wrote :
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Breno Leitão (breno-leitao) wrote :

Thanks, I just verified the commits in the utopic and Trusty kernel repository and the patches seems fine. I will test the proposed kernel on trusty and let you know.

Thank you

Breno Leitão (breno-leitao) wrote :

Hi,

How do I try the proposed kernel? I tried to enable it using the trusty-proposed distribution, but there is no ppc64el binaries there.
I added the following line to my apt/sources.list:

         deb http://archive.ubuntu.com/ubuntu/ trusty-proposed restricted main multiverse universe

Anyway, I was expecting to have ppc64el binaries at http://archive.ubuntu.com/ubuntu/dists/trusty-proposed/main/, but I can't find them.

Tim Gardner (timg-tpi) wrote :

Breno,

sudo apt-get update; sudo apt-get -u dist-upgrade

This should upgrade your kernel to Ubuntu-3.13.0-30.54. Failing that you caan find binaries at https://launchpad.net/ubuntu/+source/linux/3.13.0-30.54

Ah, ok. it went to the main repository already.
Thank you.

On Wed, Jun 18, 2014 at 9:17 PM, Tim Gardner <email address hidden>
wrote:

> Breno,
>
> sudo apt-get update; sudo apt-get -u dist-upgrade
>
> This should upgrade your kernel to Ubuntu-3.13.0-30.54. Failing that you
> caan find binaries at
> https://launchpad.net/ubuntu/+source/linux/3.13.0-30.54
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1326015
>
> Title:
> ppc64el: Add Opal firmware dump facility
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1326015/+subscriptions
>

Tim Gardner (timg-tpi) on 2014-06-20
Changed in linux (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-done-trusty
removed: verification-needed-trusty
Launchpad Janitor (janitor) wrote :
Download full text (19.3 KiB)

This bug was fixed in the package linux - 3.13.0-30.54

---------------
linux (3.13.0-30.54) trusty; urgency=low

  [ Adam Conrad ]

  * [Config] Enable building the sata-modules udeb on ppc64el.
    - LP: #1323980

  [ Anton Blanchard ]

  * SAUCE: (no-up) powerpc: 64bit sendfile is capped at 2GB
    - LP: #1328230

  [ Ben Widawsky ]

  * SAUCE: i915_bdw: drm/i915: Fix PSR programming
    - LP: #1321729
  * SAUCE: i915_bdw: drm/i915: Correct PPGTT total size
    - LP: #1321729

  [ Chris Wilson ]

  * SAUCE: i915_bdw: drm/i915: Broadwell expands ACTHD to 64bit
    - LP: #1321729

  [ Damien Lespiau ]

  * SAUCE: i915_bdw: drm/i915/bdw: Implement
    Wa4x4STCOptimizationDisable:bdw
    - LP: #1321729

  [ Dave Chiluk ]

  * [Config] Enable CONFIG_IP_VS_IPV6=y
    - LP: #1300739

  [ Kamal Mostafa ]

  * [Config] add debian/gbp.conf
  * Release Tracking Bug
    - LP: #1328286

  [ Mika Kuoppala ]

  * SAUCE: i915_bdw: drm/i915: add render state initialization
    - LP: #1321729

  [ Paulo Zanoni ]

  * SAUCE: i915_bdw: drm/i915: fix assert_cursor on BDW
    - LP: #1321729

  [ Steven Rostedt ]

  * SAUCE: i915_bdw: drm/i915: Do not dereference pointers from ring buffer
    in evict event
    - LP: #1321729

  [ Tim Gardner ]

  * [Config] CONFIG_POWERNV_CPUFREQ=y for ppc64el
    - LP: #1324571
  * [Debian] Treat vdso install as an environment variable
  * [Config] Treat vdso install as an environment variable
  * [Config] CONFIG_MLX4_DEBUG=y
    - LP: #1328256
  * [Config] CONFIG_I40EVF=m, CONFIG_I40E_DCB=y, CONFIG_I40E_VXLAN=y
    - LP: #1328037

  [ Timo Aaltonen ]

  * SAUCE: i915_bdw: Rebase to drm-intel-next-2014-03-07 + fixes
    - LP: #1321729
  * SAUCE: i915_bdw: Add BDW specific power well calls
    - LP: #1317865

  [ Upstream Kernel Changes ]

  * drm: expose subpixel order name routine v3
  * drm: dp helper: Add DP test sink CRC definition.
  * drm: export cmdline and preferred mode functions from fb helper
  * hugetlb: ensure hugepage access is denied if hugepages are not
    supported
    - LP: #1328251
  * powerpc/powernv: Move SG list structure to header file
    - LP: #1326015
  * powerpc/powernv: Read OPAL error log and export it through sysfs
    - LP: #1326015
  * powerpc/powernv Platform dump interface
    - LP: #1326015
  * pci_regs.h: Add PCI bus link speed and width defines
    - LP: #1328037
  * net_tstamp: Add SIOCGHWTSTAMP ioctl to match SIOCSHWTSTAMP
    - LP: #1328037
  * PCI/MSI: Add pci_enable_msi_range() and pci_enable_msix_range()
    - LP: #1328037
  * net: Change skb_get_rxhash to skb_get_hash
    - LP: #1328037
  * net: Add utility functions to clear rxhash
    - LP: #1328037
  * net: Add function to set the rxhash
    - LP: #1328037
  * i40e: set pf_id based on device and function numbers
    - LP: #1328037
  * i40e: register file updates
    - LP: #1328037
  * i40e: clear AQ head and tail registers
    - LP: #1328037
  * i40e: simplify aq head-tail-len setups
    - LP: #1328037
  * i40e: firmware version fields offsets update
    - LP: #1328037
  * i40e: allow one more vector for VFs
    - LP: #1328037
  * i40e: select reset counters correctly
    - LP: #1328037
  * i40e: retry call on timeout
    - LP: #...

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers