powerpc: enable powernv-cpufreq as built-in (vs. module)

Bug #1324571 reported by Mauricio Faria de Oliveira on 2014-05-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Tim Gardner
Trusty
Undecided
Tim Gardner
Utopic
Undecided
Tim Gardner

Bug Description

The cpufreq driver for powernv is currently built as a module (powernv-cpufreq.ko; see bug 1309576).

It is not automatically loaded in the boot process (even when included in the initrd).

It is desirable to have it built-in so it automatically loads on systems booting in PowerNV mode.
One of the reaons is to save power by default (the default cpufreq governor is ondemand).

That cpufreq driver fails gracefully on other (non IBM, OPAL) powerpc platforms that don't have the expected files in the device-tree (see [2]).

A patch will be sent to the kernel-team mailing list.

Thanks.

[1] https://lists.ubuntu.com/archives/kernel-team/2014-April/042431.html

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1324571

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

Hi,

> This bug is missing log files that will aid in diagnosing the problem. [...]
> [...]
> This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Since the problem's diagnostic is clear (i.e., see the current config files), and the patch sent to the kernel-team mailing list already received an ACK [1], I'll skip the suggested step (known to be originated from an automatic script).

[1] https://lists.ubuntu.com/archives/kernel-team/2014-May/043171.html

Tim Gardner (timg-tpi) on 2014-05-29
Changed in linux (Ubuntu Trusty):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → Fix Committed
Changed in linux (Ubuntu Utopic):
assignee: nobody → Tim Gardner (timg-tpi)
status: Incomplete → In Progress
Tim Gardner (timg-tpi) on 2014-05-29
Changed in linux (Ubuntu Utopic):
status: In Progress → Fix Committed
Adam Conrad (adconrad) wrote :

In reviewing the latest SRU upload, I see that Tim only enabled this on ppc64el/generic. It would probably be a good idea to enable this on powerpc/powerpc64-smp as well, as both kernels should be able to install and boot on POWER8 bare metal. Can we get this changed, either for this SRU cycle or the next?

Tim Gardner (timg-tpi) wrote :

Adam - I was not positive that this change was generally applicable, so I chose to be conservative. I'll enable it for powerpc as well.

Adam Conrad (adconrad) wrote :

The claim that "That cpufreq driver fails gracefully on other (non IBM, OPAL) powerpc platforms that don't have the expected files in the device-tree" seems to imply it should be perfectly harmless on pre-power8 platforms. Of course, I'll put it through its paces on a couple such machines to make sure anyway. :P

Adam Conrad (adconrad) wrote :

(And, for the record, it only needs to be on in the powerpc64-smp flavour, as none of the other flavours could conceivably boot on a POWER8/OPAL system anyway)

Launchpad Janitor (janitor) wrote :
Download full text (8.4 KiB)

This bug was fixed in the package linux - 3.15.0-6.11

---------------
linux (3.15.0-6.11) utopic; urgency=low

  [ Adam Conrad ]

  * Enable building the sata-modules udeb on ppc64el.
    - LP: #1323980
  * [Packaging] Set bootloader and loader on ppc64el to grub

  [ Adam Lee ]

  * SAUCE: (no-up) rtlwifi: rtl8723be: disable MSI interrupts mode
    - LP: #1310512, #1320070

  [ Alex Hung ]

  * SAUCE: (no-up) dell-led: add mic mute led interface
    - LP: #1308297

  [ Andy Whitcroft ]

  * [Config] d-i -- add hyperv_keyboard to serial-modules udeb
    - LP: #1285434
  * [Config] tools -- enable cpupower on ppc64el
  * [Config] ppc64el -- enable perf tools
  * [Config] powerpc -- enable perf tools
  * [Config] ppc64el -- reduce MAX_ORDER with 64k pages
  * [Config] arm64 -- enable tools
    - LP: #1326050
  * [Config] switch hyper-keyboard to virtual
    - LP: #1325306
  * [Config] fix up Breaks/Replaces on linux-cloud-tools-common to fix
    upgrades
  * SAUCE: kvm: BIOS disabled kvm support should be a warning
    - LP: #1300247
  * SAUCE: nouveau: missing outputs should be warnings
    - LP: #1300244
  * [Config] d-i -- add nvme devices to block-modules udeb
    - LP: #1303710

  [ Anton Blanchard ]

  * SAUCE: (no-up) powerpc: 64bit sendfile is capped at 2GB
    - LP: #1328230

  [ Colin Ian King ]

  * SAUCE: intel_pstate: inform user that thermald is worth considering

  [ Dave Chiluk ]

  * [Config] Enable CONFIG_IP_VS_IPV6=y
    - LP: #1300739

  [ Paolo Pisati ]

  * [Config] build vexpress a9 dtb
    - LP: #1303657

  [ Tetsuo Handa ]

  * SAUCE: kthread: Do not leave kthread_create() immediately upon SIGKILL.

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #1329045
  * [Debian] Treat vdso install as an environment variable
    - LP: #1325713
  * [Config] Treat vdso install as an environment variable
    - LP: #1325713
  * [config] Set IPMI suppoort default to "y"
  * [Config] powerpc -- CONFIG_SCSI_IBMVSCSI=y
  * [Config] CONFIG_RT_GROUP_SCHED=n
    - LP: #1284731
  * [Config] ppc64el -- switch to 64K system pages
  * [Config] CONFIG_MICROCODE_EARLY=y
  * [Config] SND_DAVINCI_SOC && SND_AM33XX_SOC_EVM =m
  * [Config] armhf: DRM_TILCDC=m
  * SAUCE: (no-up) mei_me: Add module parameter to disable MSI
  * [Config] arm64: KVM=y
  * [Config] armhf: LEDS_TRIGGER_HEARTBEAT=y
  * [Config] armhf: generic: disable CPU_IDLE
  * [Config] armhf: CPU_FREQ=y
  * [Config] Add new mlx modules to d-i
  * [Config] Added Muti-Arch support for linux-headers-PKGVER-ABINUM, linux-tools-common, and linux-cloud-tools-common
    - LP: #1295112
  * [Config] CONFIG_EXYNOS_ADC=n, CONFIG_HW_RANDOM_EXYNOS=n, CONFIG_MMC_DW_EXYNOS=n, CONFIG_USB_DWC3_EXYNOS=n
    - LP: #1294353
  * [Config] CONFIG_ABX500_CORE=y for ppc64el
  * [Config] CONFIG_ALX=m for powerpc
  * [Config] CONFIG_ACENIC_OMIT_TIGON_I=n for ppc64el
  * [Config] CONFIG_ACORN_PARTITION_*=n for ppc64el
  * [Config] CONFIG_ANDROID=n for powerpc
  * [Config] CONFIG_ASYNC_RAID6_TEST=m for ppc64el
  * [Config] CONFIG_BIG_KEYS=y for ppc64el
  * [Config] CONFIG_BSD_PROCESS_ACCT=y for ppc64el
  * rebase to v3.15
  * [Config] CONFIG_PHY_XGENE=y
  * [Config] CONFIG_MLX4_DEBUG=y
    - LP: #1328256
  * [C...

Read more...

Changed in linux (Ubuntu Utopic):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Tim Gardner (timg-tpi) on 2014-06-12
tags: added: verification-done-trusty
removed: verification-needed-trusty
Launchpad Janitor (janitor) wrote :
Download full text (19.3 KiB)

This bug was fixed in the package linux - 3.13.0-30.54

---------------
linux (3.13.0-30.54) trusty; urgency=low

  [ Adam Conrad ]

  * [Config] Enable building the sata-modules udeb on ppc64el.
    - LP: #1323980

  [ Anton Blanchard ]

  * SAUCE: (no-up) powerpc: 64bit sendfile is capped at 2GB
    - LP: #1328230

  [ Ben Widawsky ]

  * SAUCE: i915_bdw: drm/i915: Fix PSR programming
    - LP: #1321729
  * SAUCE: i915_bdw: drm/i915: Correct PPGTT total size
    - LP: #1321729

  [ Chris Wilson ]

  * SAUCE: i915_bdw: drm/i915: Broadwell expands ACTHD to 64bit
    - LP: #1321729

  [ Damien Lespiau ]

  * SAUCE: i915_bdw: drm/i915/bdw: Implement
    Wa4x4STCOptimizationDisable:bdw
    - LP: #1321729

  [ Dave Chiluk ]

  * [Config] Enable CONFIG_IP_VS_IPV6=y
    - LP: #1300739

  [ Kamal Mostafa ]

  * [Config] add debian/gbp.conf
  * Release Tracking Bug
    - LP: #1328286

  [ Mika Kuoppala ]

  * SAUCE: i915_bdw: drm/i915: add render state initialization
    - LP: #1321729

  [ Paulo Zanoni ]

  * SAUCE: i915_bdw: drm/i915: fix assert_cursor on BDW
    - LP: #1321729

  [ Steven Rostedt ]

  * SAUCE: i915_bdw: drm/i915: Do not dereference pointers from ring buffer
    in evict event
    - LP: #1321729

  [ Tim Gardner ]

  * [Config] CONFIG_POWERNV_CPUFREQ=y for ppc64el
    - LP: #1324571
  * [Debian] Treat vdso install as an environment variable
  * [Config] Treat vdso install as an environment variable
  * [Config] CONFIG_MLX4_DEBUG=y
    - LP: #1328256
  * [Config] CONFIG_I40EVF=m, CONFIG_I40E_DCB=y, CONFIG_I40E_VXLAN=y
    - LP: #1328037

  [ Timo Aaltonen ]

  * SAUCE: i915_bdw: Rebase to drm-intel-next-2014-03-07 + fixes
    - LP: #1321729
  * SAUCE: i915_bdw: Add BDW specific power well calls
    - LP: #1317865

  [ Upstream Kernel Changes ]

  * drm: expose subpixel order name routine v3
  * drm: dp helper: Add DP test sink CRC definition.
  * drm: export cmdline and preferred mode functions from fb helper
  * hugetlb: ensure hugepage access is denied if hugepages are not
    supported
    - LP: #1328251
  * powerpc/powernv: Move SG list structure to header file
    - LP: #1326015
  * powerpc/powernv: Read OPAL error log and export it through sysfs
    - LP: #1326015
  * powerpc/powernv Platform dump interface
    - LP: #1326015
  * pci_regs.h: Add PCI bus link speed and width defines
    - LP: #1328037
  * net_tstamp: Add SIOCGHWTSTAMP ioctl to match SIOCSHWTSTAMP
    - LP: #1328037
  * PCI/MSI: Add pci_enable_msi_range() and pci_enable_msix_range()
    - LP: #1328037
  * net: Change skb_get_rxhash to skb_get_hash
    - LP: #1328037
  * net: Add utility functions to clear rxhash
    - LP: #1328037
  * net: Add function to set the rxhash
    - LP: #1328037
  * i40e: set pf_id based on device and function numbers
    - LP: #1328037
  * i40e: register file updates
    - LP: #1328037
  * i40e: clear AQ head and tail registers
    - LP: #1328037
  * i40e: simplify aq head-tail-len setups
    - LP: #1328037
  * i40e: firmware version fields offsets update
    - LP: #1328037
  * i40e: allow one more vector for VFs
    - LP: #1328037
  * i40e: select reset counters correctly
    - LP: #1328037
  * i40e: retry call on timeout
    - LP: #...

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers