[Lenovo Yoga 2 Pro] ideapad_laptop kernel module breaks wireless

Bug #1324095 reported by Andreas Olsson on 2014-05-28
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

With the ideapad_laptop module loaded there is no wlan0 (or other wifi device) present. Booting without any explicit blacklist config the ideapad_laptop kernel module gets loaded, and there are no wlan0 device present.

If I yet again load the ideapad_laptop module, using modprobe, the wlan0 device goes away. Here is the dmesg output from that.
[ 234.351406] input: Ideapad extra buttons as /devices/platform/VPC2004:00/input/input17
[ 234.353261] wlan0: deauthenticating from d8:5d:4c:bb:1a:f2 by local choice (reason=3)
[ 234.398900] cfg80211: Calling CRDA to update world regulatory domain
[ 234.401410] cfg80211: World regulatory domain updated:
[ 234.401412] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 234.401414] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 234.401415] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 234.401416] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 234.401418] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 234.401419] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 234.555068] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

WORKAROUND: For the wireless network to work on my Lenovo Yoga 2 Pro Laptop I need blacklist/rmmod the ideapad_laptop kernel module. Running rmmod on the module results in the wlan0 device becoming present, and NetworkManager being able to connect to a local wifi network. Here is the dmesg output after the rmmod command:
[ 74.908411] iwlwifi 0000:01:00.0: L1 Disabled; Enabling L0S
[ 74.908627] iwlwifi 0000:01:00.0: L1 Disabled; Enabling L0S
[ 74.920538] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 76.371036] wlan0: authenticate with d8:5d:4c:bb:1a:f2
[ 76.372069] wlan0: send auth to d8:5d:4c:bb:1a:f2 (try 1/3)
[ 76.376670] wlan0: authenticated
[ 76.378169] wlan0: associate with d8:5d:4c:bb:1a:f2 (try 1/3)
[ 76.381908] wlan0: RX AssocResp from d8:5d:4c:bb:1a:f2 (capab=0x411 status=0 aid=2)
[ 76.383305] wlan0: associated
[ 76.383333] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-27-generic 3.13.0-27.50
ProcVersionSignature: Ubuntu 3.13.0-27.50-generic 3.13.11
Uname: Linux 3.13.0-27-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: andreas 2492 F.... pulseaudio
 /dev/snd/controlC0: andreas 2492 F.... pulseaudio
CurrentDesktop: Unity
Date: Wed May 28 14:00:22 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-05-20 (8 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: LENOVO 20266
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-27-generic.efi.signed root=UUID=e70835c5-4ffe-49d3-aecc-403dbf538c1a ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-27-generic N/A
 linux-backports-modules-3.13.0-27-generic N/A
 linux-firmware 1.127.2
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/31/2013
dmi.bios.vendor: LENOVO
dmi.bios.version: 76CN31WW
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Yoga2
dmi.board.vendor: LENOVO
dmi.board.version: 31900056PRO
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo Yoga 2 Pro
dmi.modalias: dmi:bvnLENOVO:bvr76CN31WW:bd10/31/2013:svnLENOVO:pn20266:pvrLenovoYoga2Pro:rvnLENOVO:rnYoga2:rvr31900056PRO:cvnLENOVO:ct10:cvrLenovoYoga2Pro:
dmi.product.name: 20266
dmi.product.version: Lenovo Yoga 2 Pro
dmi.sys.vendor: LENOVO

Andreas Olsson (andol) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Andreas Olsson, thank you for reporting this and helping make Ubuntu better. Could you please test the latest mainline kernel via http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-rc7-utopic/ and advise to the results?

tags: added: latest-bios-76cn31ww
tags: added: kernel-bug-exists-upstream-3.15-rc5
description: updated
summary: - ideapad_laptop kernel module breaks wireless on Lenovo Yoga 2 Pro Laptop
+ [Lenovo Yoga 2 Pro] ideapad_laptop kernel module breaks wireless
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Andreas Olsson (andol) wrote :

Same result with the v3.15-rc7-utopic kernel.

Andreas Olsson, did this problem not occur in a release prior to Trusty?

tags: added: kernel-bug-exists-upstream-3.15-rc7
removed: kernel-bug-exists-upstream-3.15-rc5
Andreas Olsson (andol) wrote :

Recently bought laptop, which I have only been running Ubuntu 14.04 on.

Andreas Olsson, the issue you are reporting is an upstream one. Could you please report this problem through the appropriate channel by following the instructions _verbatim_ at https://wiki.ubuntu.com/Bugs/Upstream/kernel ?

Please provide a direct URL to your e-mail to the mailing list once you have made it so that it may be tracked.

Thank you for your understanding.

Changed in linux (Ubuntu):
status: Incomplete → Triaged

came across this and it appears that the fedora guys have rolled in a patch recently that resolved the issue. I'm unable to locate the upstream defect for this, but their defect (which is essentially identical to this one) is here:

https://bugzilla.redhat.com/show_bug.cgi?id=1021036

The patch appears to be relatively simple:

https://bugzilla.redhat.com/attachment.cgi?id=911300

Is there a link to the upsteam kernel defect to see if this has been resolved?

Additionally, the latest release of the ubuntu kernel that has the fix for this, won't actually fix it for all of the systems.

The error is here:

+/* Blacklist for devices where the ideapad rfkill interface does not work */
+static struct dmi_system_id rfkill_blacklist[] = {
+ /* The Lenovo Yoga 2 11 always reports everything as blocked */
+ {
+ .ident = "Lenovo Yoga 2 11",
+ .matches = {
+ DMI_MATCH(DMI_SYS_VENDOR, "LENOVO"),
+ DMI_MATCH(DMI_PRODUCT_VERSION, "Lenovo Yoga 2 11"),
+ },
+ },
+ {}
+};

This patch will only solve the problem for the Lenovo Yoga 2 11, not the Yoga 2 pro 13's which report with "Lenovo Yoga 2".

The patch should be updated to reflect this by adding:

DMI_MATCH(DMI_PRODUCT_VERSION, "Lenovo Yoga 2")

Also need to add:

DMI_MATCH(DMI_PRODUCT_VERSION, "Lenovo Yoga 2 Pro")

Tom Kowalski (tom-kowalski) wrote :

I am running trusty on a Lenovo Y40 and have this same bug. I have blacklisted the module in order to use Wireless.

Gabriel Faure (faure212) wrote :

I also USED to run (L)ubuntu 14.04 on a Yoga 2 pro 13, but after an "upgrade" (around the middle of June, 2014), I lost the ability to connect to WiFi. When I tried to re-install Lubuntu from a USB with an ISO on it, it failed to connect to the WiFi, and claims that the WiFi is Harware blocked, even though there are no switches or function keys to block the WiFi hardwarely.
This ideapa_laptop module has been a pain from the first day with the (otherwise very nice) Yoga 2 Pro.
WHEN IS THERE GOING TO BE A VERSION OF (L)ubuntu which will be installable without bug-avoiding tweaking like compiling patches, etc.? Should I wait for 14.10?

Thanks.

At this point in time, the fix has been pushed upstream with hopes to be included in the 3.17 revision; however, there are no promises until it becomes a thing.

Kévin Commaille (zekeco) wrote :

There's already a patch included upstream in 3.16 only for yoga 2 pro. There's another patch for all yoga 2s which has been pushed and is now included in 3.17-rc1. Would be nice to backport it for ubuntu 14.04 though.

Tim Edwards (tkedwards) wrote :

I have a Yoga 2 Pro and I can confirm that the ideapad_laptop module in 3.17 rc6 is fixed. Can we look at backporting this module to the trusty kernel as a fix? Happy to help with testing or anything like that

Linux localhost 3.17.0-031700rc6-generic #201409211935 SMP Sun Sep 21 23:37:11 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

I have to blacklist the ideapad_laptop module too if i want to get my wifi ON. I have a Lenovo g50-30. Should it be added in the patch too somehow? I tested ubuntu 15.04 beta2 live and still no wifi detected.

A friend suggested me to follow this instructions. It worked:
1- download http://iseborn.eu/downloads/ubuntu_yoga_2_wifi/Makefile
2- download http://iseborn.eu/downloads/ubuntu_yoga_2_wifi/ideapad-laptop.c
4- open ideapad-laptop.c and change this line
DMI_MATCH(DMI_PRODUCT_VERSION, "Lenovo Yoga 2"),
in
DMI_MATCH(DMI_PRODUCT_VERSION, "Lenovo G50-30"),

3- go with a terminal where you downloaded the files and type "make" and then "make install"

note: remove any previously workaround you did before (like the blacklisting one).

So is there a way to include a patch for this models too?

Tim Edwards (tkedwards) wrote :

I no longer get this problem with the Utopic kernel from the LTS Enablement Stack in Ubuntu 14.04.2. Previously I had to manually build a fixed version the driver ideapad-laptop after each kernel update, this seems to no longer be necessary on my Yoga 2 Pro.

Daniel d'Andrada (dandrader) wrote :

It was working fine in Vivid. But now this problem is back in Wily (4.2 kernel)

Daniel d'Andrada, it will help immensely if you filed a new report via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

Changed in linux (Fedora):
importance: Unknown → Undecided
status: Unknown → Fix Released

Andreas Olsson, as per upstream, this potential fix for your issue was incorporated upstream back in 2014. Could you please advise if this still affects you?

tags: added: bios-outdated-76cn43ww
removed: latest-bios-76cn31ww
Changed in linux (Ubuntu):
status: Triaged → Incomplete
no longer affects: linux (Ubuntu)
affects: linux (Fedora) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Fix Released → New
no longer affects: linux (Ubuntu)
affects: linux → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Unknown → Undecided
status: Unknown → New
importance: Undecided → Low
status: New → Incomplete
Andreas Olsson (andol) wrote :

I no longer have that Yoga 2 Pro laptop.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.