[Asus X550LB] Touchpad not working

Bug #1323371 reported by Anthonin L. on 2014-05-26
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

The touchpad works well on Windows 8.

Tested in Fedora 20, also not working.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-27-generic 3.13.0-27.50
ProcVersionSignature: Ubuntu 3.13.0-27.50-generic 3.13.11
Uname: Linux 3.13.0-27-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: anthonin 1939 F.... pulseaudio
 /dev/snd/controlC1: anthonin 1939 F.... pulseaudio
CurrentDesktop: Unity
Date: Mon May 26 19:38:41 2014
HibernationDevice: RESUME=UUID=4828e9e2-c2aa-4173-be4f-76d9b657a1ac
InstallationDate: Installed on 2014-05-10 (15 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: ASUSTeK COMPUTER INC. X550LB
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-27-generic.efi.signed root=UUID=3b43be57-492f-4b57-a265-adc49ff7c91d ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-27-generic N/A
 linux-backports-modules-3.13.0-27-generic N/A
 linux-firmware 1.127.2
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/19/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: X550LB.402
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: X550LB
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrX550LB.402:bd11/19/2013:svnASUSTeKCOMPUTERINC.:pnX550LB:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnX550LB:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: X550LB
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

Anthonin L. (anthonin-lize) wrote :
description: updated

Anthonin L., could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-3.15-rc7

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: latest-bios-402
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Anthonin L. (anthonin-lize) wrote :

Thanks for the quick reply !

I have tested 3.15-rc7, unfortunatelly still not working.
I'm updating the tags.

tags: added: kernel-bug-exists-upstream-3.15-rc7
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Anthonin L., the issue you are reporting is an upstream one. Could you please report this problem through the appropriate channel by following the instructions _verbatim_ at https://wiki.ubuntu.com/Bugs/Upstream/kernel ?

Please provide a direct URL to your e-mail to the mailing list once you have made it so that it may be tracked.

Thank you for your understanding.

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Pilot6 (hanipouspilot) wrote :

The bug has been fixed in

linux-generic-lts-wily package.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers