networking dies under heavy load, unable to recover w/o reboot

Bug #132109 reported by Reuben Firmin on 2007-08-13
4
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

My desktop is periodically losing network connectivity. It happens when azureus is running, pulling down a large amount of data. It doesn't happen immediately, but often 2-3 hours after I start azureus. I've tried the following to restore networking, but the only course of action that connects me back up is a system reboot:
* dbus restart
* networking restart
* ditzing with NetworkManager

As you can see from the attached logs, it's not just that I've lost my IP address. The logs suggest that maybe something stole the IRQ, but there are no device changes associated with the failure.

I didn't know what package to file this against. Let me know what other diagnostics I can do.

Reuben Firmin (reubenf) wrote :
Reuben Firmin (reubenf) wrote :
Reuben Firmin (reubenf) wrote :

If you're quick (in letting me know what output to get) I can get you some good diagnostics. With the current torrents I have queued, both Azureus and Deluge kill the networking within 3-4 minutes.

Reuben Firmin (reubenf) wrote :

My latest theory on this is that it's the 3com drivers. I tried another 3com NIC (not the same model, slightly different) and while it initially worked (for torrenting etc), it failed after several hours. Interestingly, when I rebooted, it failed again almost immediately (somewhat shooting down my theory.) Is it perhaps possible that bad drivers are causing damage to the cards?

Or, maybe the second card I tested with was "bad" also? I will be trying a third NIC card when I can get my hands on one.

Reuben Firmin (reubenf) wrote :

OK, this was the network card (or was it). I replaced the old 3com with a new netgear, and all is well. There is still the question of why both 3com cards behaved in the same bad way...surely the 3com driver is stable?

(If it is, please make this bug a wishlist and file against some layer that could theoretically detect hardware "going bad").

Jean-Baptiste Lallement (jibel) wrote :

This problem is not directly related to the 3com driver but more likely to an IRQ conflict. I'm closing this report because you don't use that hardware anymore and there are no recent comment about this issue. If you're still experiencing this problem with the 3com cards, then don't hesitate to reopen.

Thanks for you time.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers