[Lenovo ThinkCentre M93p] reboots instead of shutting down

Bug #1320282 reported by Gioele Barabucci on 2014-05-16
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Using `shutdown -h now` on a Lenovo ThinkCentre M93p causes it to reboot instea of shutting down.

This happens on an up-to-date Ubuntu Trusty 14.04.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-24-generic 3.13.0-24.47
ProcVersionSignature: Ubuntu 3.13.0-24.47-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: gioele 1975 F.... pulseaudio
 /dev/snd/controlC0: gioele 1975 F.... pulseaudio
CurrentDesktop: Unity
Date: Fri May 16 17:28:30 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-05-15 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: LENOVO 10A7000LGE
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=f2abe8d7-641e-4e8a-917e-b909f8d55171 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-24-generic N/A
 linux-backports-modules-3.13.0-24-generic N/A
 linux-firmware 1.127.2
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/26/2014
dmi.bios.vendor: LENOVO
dmi.bios.version: FBKT72AUS
dmi.board.name: SHARKBAY
dmi.board.vendor: LENOVO
dmi.board.version: 0B98401 PRO
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnLENOVO:bvrFBKT72AUS:bd01/26/2014:svnLENOVO:pn10A7000LGE:pvrThinkCentreM93p:rvnLENOVO:rnSHARKBAY:rvr0B98401PRO:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: 10A7000LGE
dmi.product.version: ThinkCentre M93p
dmi.sys.vendor: LENOVO

Gioele Barabucci (gioele) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.15 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-rc5-utopic/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: bios-outdated-fbkt75a
summary: - Lenovo ThinkCentre M93p reboots instead of shutting down
+ [Lenovo ThinkCentre M93p] reboots instead of shutting down
Gioele Barabucci (gioele) wrote :

This problem seems resolved using the suggested v3.15-rc5-utopic kernel.

    $ uname -a
    Linux federwolke 3.15.0-031500rc5-generic #201405091635 SMP Fri May 9 20:36:31 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Will the fix be backported to Ubuntu Trusty 14.04 LTS?

tags: added: kernel-fixed-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Gioele Barabucci, the next step is to fully reverse commit bisect in order to identify the fix commit. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection#How_do_I_reverse_bisect_the_upstream_kernel.3F ?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Gioele Barabucci (gioele) wrote :

I do not have the time to do a full git bisect, but I tried all the versions available from the mainline archive and I achieved some success.

The last kernel version that shows this error is v3.14.2-utopic (3.14.2-031402.201404262053). The first version without this problem is v3.14.3-utopic (3.14.3-031403.201405061153).

The fix has thus been added between v3.14.2 and v3.14.3.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Gioele Barabucci, thanks for updating this report with your current reverse commit bisect progress. When you have more time, and have identified the fix commit, please feel free to post the commit specifically and change this to Confirmed.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Gioele Barabucci (gioele) wrote :

I do not have, nor will have in the future, the possibility to do full git bisect. Please revert the status to Confirmed so that the bug does will not expire for lacks of updates.

Wulf Richartz (wulf-richartz) wrote :

https://bugzilla.kernel.org/show_bug.cgi?id=76291

please leave a comment with Mainbopard and Bios Information

thx

Wulf Richartz (wulf-richartz) wrote :

addition: you must have a Lynx Point-LP, that the fix is working for you; for Lynx Point the fix is doing the contrary. it causes the problem

Gioele Barabucci (gioele) wrote :

Wulf Richartz, I hope this output from dmidecode is enough. Could you please forward it to the kernel.org bugzilla?

Mainboard:

Handle 0x0001, DMI type 1, 27 bytes
System Information
        Manufacturer: LENOVO
        Product Name: 10A7000LGE
        Version: ThinkCentre M93p
        Wake-up Type: Power Switch
        SKU Number: LENOVO_MT_10A7
        Family: To be filled by O.E.M.

Handle 0x0002, DMI type 2, 15 bytes
Base Board Information
        Manufacturer: LENOVO
        Product Name: SHARKBAY
        Version: 0B98401 PRO
        Features:
                Board is a hosting board
                Board is replaceable
        Location In Chassis: To be filled by O.E.M.
        Chassis Handle: 0x0003
        Type: Motherboard
        Contained Object Handles: 0

BIOS:

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
        Vendor: LENOVO
        Version: FBKT72AUS
        Release Date: 01/26/2014
        Address: 0xF0000
        Runtime Size: 64 kB
        ROM Size: 6656 kB
        Characteristics:
                PCI is supported
                BIOS is upgradeable
                BIOS shadowing is allowed
                Boot from CD is supported
                Selectable boot is supported
                BIOS ROM is socketed
                EDD is supported
                5.25"/1.2 MB floppy services are supported (int 13h)
                3.5"/720 kB floppy services are supported (int 13h)
                3.5"/2.88 MB floppy services are supported (int 13h)
                Print screen service is supported (int 5h)
                8042 keyboard services are supported (int 9h)
                Serial services are supported (int 14h)
                Printer services are supported (int 17h)
                ACPI is supported
                USB legacy is supported
                BIOS boot specification is supported
                Targeted content distribution is supported
                UEFI is supported
        BIOS Revision: 1.72
        Firmware Revision: 1.13

Wulf Richartz (wulf-richartz) wrote :

lspci -vvv would be nice

Wulf Richartz (wulf-richartz) wrote :

I see, information is on top

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: needs-reverse-bisect
Gioele Barabucci (gioele) wrote :

penalvch, no need to bisect: the bugzilla entry posted by Wulf Richartz contains the info about the commit that solves this problem for me (and creates an opposite problem for him).

Gioele Barabucci, which commit # specifically addresses your issue?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Gioele Barabucci (gioele) wrote :

Dear Christopher M. Penalver, if a normal user like me can be asked to perform a git bisection on a kernel, I suppose it is reasonable to ask you to have a look at the linked bugzilla kernel report, read inside it the SHA of the commit that has landed into the stable branch and that solved this problem and finally track it up to the equivalent commit in the mainline kernel.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Gioele Barabucci, please do not be rude and passive aggressive. As there are multiple commits mentioned, and how you still have not advised which one specifically fixed your problem, please do not mark this from Incomplete until you mentioned explicitly the information requested in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1320282/comments/15 .

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
MadMat (madmat) wrote :

I had the same issue on a Lenovo Thinkcentre 93p Tiny running Ubuntu 14.04 x64, but the latest kernel update (3.13.0-32.57) seems to have fixed this.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
MadMat (madmat) on 2014-07-25
information type: Public → Public Security
information type: Public Security → Public

Same issue with Lenovo M93z. Using Kernel 3.14.3, as suggested by Gioele Barabucci, solves the problem.
The Lenovo M93p Tiny had the same problem; however, on 2014-08-13 Lenovo released a BIOS update, which solves the issue.

So I recommend anyone still affected by this to just use the vanilla Kernel.

Simon Rettberg, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

As well, please do not announce in this report you created a new bug report.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
MadMat (madmat) wrote :

As mentioned in comment #19 this bug disappeared with kernel 3.13.0-32, but now it resurfaced with 3.13.0-44. It had no problems with the previous version 3.13.0-43 though.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
MadMat (madmat) wrote :

Flashing the recent BIOS update (FBKTA5A released 2015-01-06) resolved the problem for me:
http://support.lenovo.com/downloads/ds035753
Shutdown works now with kernel 3.13.0-44.

As I did a bisect from 3.13.0-43 to 3.13.0-44 before I did the BIOS update here's the result anyway:

01414f897d20874f6f5d7ef2f756f5bf2df526fc is the first bad commit
commit 01414f897d20874f6f5d7ef2f756f5bf2df526fc
Author: Denis Turischev <email address hidden>
Date: Tue May 20 14:00:42 2014 +0300

    xhci: Switch only Intel Lynx Point-LP ports to EHCI on shutdown.

    BugLink: http://bugs.launchpad.net/bugs/1402853

    commit 0a939993bff117d3657108ca13b011fc0378aedb upstream.

    Patch "xhci: Switch Intel Lynx Point ports to EHCI on shutdown."
    commit c09ec25d3684cad74d851c0f028a495999591279 is not fully correct

    It switches both Lynx Point and Lynx Point-LP ports to EHCI on shutdown.
    On some Lynx Point machines it causes spurious interrupt,
    which wake the system: bugzilla.kernel.org/show_bug.cgi?id=76291

    On Lynx Point-LP on the contrary switching ports to EHCI seems to be
    necessary to fix these spurious interrupts.

    Signed-off-by: Denis Turischev <email address hidden>
    Reported-by: Wulf Richartz <email address hidden>
    Cc: Mathias Nyman <email address hidden>
    Signed-off-by: Greg Kroah-Hartman <email address hidden>
    Signed-off-by: Kamal Mostafa <email address hidden>

:040000 040000 2017c75e797dd6fde9e00f73db85fa32eeb19775 7d11924d8262e57dab18920cf19ec4c14e93db5f M drivers

Gioele Barabucci (gioele) wrote :

Thank you madmat for the bisection.

Luckily the commit you have found is the same described in the linked kernel bugzilla entry.

Svetlana Belkin (belkinsa) wrote :

If you guys want to do the update, the USB Drive UEFI BIOS Flash Package is your best bet. Make sure you use Windows (didn't work on Ubuntu and Wine for me) and a program called Rufus that allows you to create a MS-DOS bootable drive. BUT! Don't stick the files from USB Drive UEFI BIOS Flash Package on it when creating the bootable disk, DO IT AFTER.

Svetlana Belkin (belkinsa) wrote :

Adding a link: Rufus: https://rufus.akeo.ie/

MadMat (madmat) wrote :

You can create a bootable USB stick from Ubuntu using UNetbootin (from the repository) to install FreeDOS (see http://askubuntu.com/questions/46886/how-to-create-a-bootable-usb-stick-to-flash-a-bios). Booting with this and just executing the autoexec.bat to flash the BIOS worked for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.