black screen after resume from suspend to ram / disk

Bug #131628 reported by MyName on 2007-08-10
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by f1anker

Bug Description

It seem my Notebook is successfully suspend to RAM (led blinks) and suspend to DISK (led off). But after resume from suspend the screen doesn't turn on and stay black. (have to press powerbutton)

Linux 2.6.22-9-generic #1 SMP Fri Aug 3 00:50:37 GMT 2007 i686 GNU/Linux

MyName (rk.) wrote :
Andrew Frank (frank-geoinfo) wrote :

i have two very similar tablets (futjitsu-siemens 5010 and 5032). on the 5010 the suspend to ram works (despite the fact that the hal detection tool reports that it did not work -> it would be useful to have precise information what did not work there); on the 5032 it does not work, in the sense, that the system is back, but the screen is not bachlighted (i can faintly see something that seems ok on the screen). the hal detection tool does not report anything here).

what can be done? would be nice (on the 5010 it works really fast !!! great job!)

if you need more details about the two machines, please ask what outputs would be useful!

andrew

daniel.wang (wang-woo) wrote :

my laptop has the same phenomena with yours, andrew, I can type my password and log in so I could see faintly that the screen changes a bit, then I know on top it's gnome-terminal. I type "sudo reboot", then the laptop reboots. After restarted, it becomes normal.
it only goes wrong when I use suspend (suspend to ram, standby) but not hibernate, the hibernate option works fine, at least I don't find anything wrong, yet.

arn (belmondo) wrote :
Download full text (27.6 KiB)

[ 0.096525] pci_bus 0000:02: resource 3 io: [0x00-0xffff]
[ 0.096528] pci_bus 0000:02: resource 4 mem: [0x000000-0xffffffff]
[ 0.096532] pci_bus 0000:03: resource 0 io: [0x3400-0x34ff]
[ 0.096535] pci_bus 0000:03: resource 1 io: [0x3800-0x38ff]
[ 0.096538] pci_bus 0000:03: resource 2 pref mem [0x20000000-0x23ffffff]
[ 0.096542] pci_bus 0000:03: resource 3 mem: [0x28000000-0x2bffffff]
[ 0.096580] NET: Registered protocol family 2
[ 0.096684] IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
[ 0.096980] TCP established hash table entries: 16384 (order: 5, 131072 bytes)
[ 0.097108] TCP bind hash table entries: 16384 (order: 5, 131072 bytes)
[ 0.097230] TCP: Hash tables configured (established 16384 bind 16384)
[ 0.097233] TCP reno registered
[ 0.097307] NET: Registered protocol family 1
[ 0.097376] Trying to unpack rootfs image as initramfs...
[ 0.354871] Freeing initrd memory: 7706k freed
[ 0.362535] Simple Boot Flag at 0x36 set to 0x1
[ 0.362643] cpufreq-nforce2: No nForce2 chipset.
[ 0.362676] Scanning for low memory corruption every 60 seconds
[ 0.362858] audit: initializing netlink socket (disabled)
[ 0.362900] type=2000 audit(1266132878.360:1): initialized
[ 0.373394] HugeTLB registered 4 MB page size, pre-allocated 0 pages
[ 0.375075] VFS: Disk quotas dquot_6.5.2
[ 0.375144] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[ 0.375775] fuse init (API version 7.12)
[ 0.375879] msgmni has been set to 975
[ 0.376133] alg: No test for stdrng (krng)
[ 0.376147] io scheduler noop registered
[ 0.376149] io scheduler anticipatory registered
[ 0.376152] io scheduler deadline registered
[ 0.376199] io scheduler cfq registered (default)
[ 0.376220] pci 0000:00:02.0: Boot video device
[ 0.376290] pci 0000:02:08.0: Firmware left e100 interrupts enabled; disabling
[ 0.376400] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[ 0.376428] pciehp: PCI Express Hot Plug Controller Driver version: 0.4
[ 0.376830] ACPI: AC Adapter [ACAD] (on-line)
[ 0.376903] input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input0
[ 0.377132] ACPI: Lid Switch [LID0]
[ 0.377187] input: Power Button as /devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input1
[ 0.377194] ACPI: Power Button [PWRB]
[ 0.377663] Marking TSC unstable due to TSC halts in idle
[ 0.377679] ACPI: CPU0 (power states: C1[C1] C2[C2])
[ 0.377706] processor LNXCPU:00: registered as cooling_device0
[ 0.377711] ACPI: Processor [CPU0] (supports 8 throttling states)
[ 0.380058] Switched to high resolution mode on CPU 0
[ 0.381447] thermal LNXTHERM:01: registered as thermal_zone0
[ 0.381456] ACPI: Thermal Zone [ATF0] (34 C)
[ 0.381512] isapnp: Scanning for PnP cards...
[ 0.735625] isapnp: No Plug & Play device found
[ 0.736895] Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
[ 0.737433] ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 9
[ 0.737440] serial 0000:00:1f.6: PCI INT B -> Link[LNKB] -> GSI 9 (level, low) -> IRQ 9
[ 0.737448] serial 0000:00:1f.6: PCI INT B disabled
[ 0.738512] brd: module loaded
[ 0...

arn (belmondo) wrote :

I have the same problem on sony vaio VGN-B1XP, since Karmic Koala.

Martin Emrich (emme) wrote :

I have this on my new Lenovo Ideapad S10-3: After resuming from suspend-to-ram, the screen stays black (backlight off, too), only the power and wifi LEDs turn on. Then, I have to hit the power button, then the backlight goes on and after moving the mouse/pressing a key, the gnome-screensaver unlock dialog appears.

I am running lucid i386 updated today.

f1anker (ianspigeon) wrote :

Same issue here since Karmic on a Dell Latitude E6400. During a restore from hibernation the screen is lit and the splash screen is visible. As soon as the restore has completed the screen appears to enter a power saving state and switches off.

Moving the mouse or pressing the power button will cause the screen to switch on and the screensaver lock screen to appear after which I can login and continue as normal.

What info can I supply to help diagnose this issue? I'm currently using an up to date Ubuntu Lucid.

Martin Emrich (emme) wrote :

I just noticed that in my case, not only the screen stays black, but also the system seems to remain half-asleep: only when I hit the power button and the screen reappears, network-manager starts to connect and the battery applet updates its state.

Martin Emrich (emme) wrote :

I just confirmed my assumption: I opened the display, but waited a minute before pressing the power button. In the syslog (attached), I noticed that the first entry today is from the time I pressed the button (09:07:09), not from when I opened the lid. I don't know if it's normal that all the suspend-related messages are logged only after resuming fully.

Joe Ubuntu (josephdm) wrote :

I have a Latitude e6500 have a similar problem. I know for sure that the problem has been present since Ubuntu 9.04, and is still present in Ubuntu 10.4. After resume from suspend, the screen does not power on.

As a result, I have not used Ubuntu on my laptop. This bug is extremely frustrating and has been in Ubuntu for ages. Can you please fix it?!?

Martin Emrich (emme) wrote :

I just tried Linux 2.6.34 from kernel.org, and this fixes it for me.

rpaco (rpa-rpaco) wrote :

I have just tried kernel 2.6.34-020634-generic as well on my Dell Latitude D600, but it does not fix the problem.
It still suspends ok but will not resume under any provocation, eg opening top, FnEsc CntlAltBacksp, CntlAlt1 power button or any single key or combination. The power light slowly flashes as it should (and used to before 10.4) in suspend mode. Worked fine in Karmic.
I note that there are more recent kernels listed, will these be of any use, I wonder, could any have been written to fix this bug? rc7 perhaps?
As written elsewhere I have also tried changing back to Grub instead of grub2 (some of the suspend scripts certainly refer to files and dirs that are not there in Lynx.) Also note that my grub menu is no longer accessible
My pm-suspend log seems to show successful suspends every time.
Unfortunately there is no pm-resume or unfreeze or thaw log (that I could see) to indicate what is going wrong.
Also tried other remedy of changing Appearance>visual effects to Extra and back also a no go.
Frankly I don't think its in the kernel but in some other peripheral files which 10.4 Lynx has changed/moved/or done away with.

Philip Muškovac (yofel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in the kernel (linux)

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Also please follow https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume#Debugging%20Suspend to gather information about your issue, thanks!

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the results of https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume#Debugging%20Suspend Thanks!

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu development release http://cdimage.ubuntu.com/daily-live/current/ . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers