rt2x00 driver doesn't load for 57c:8501 (AVM Fritz Stick Nv2)

Bug #1310055 reported by karmen on 2014-04-19
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

So i tried to use the wifi USB AVM Fritz Stick N v2 , USB ID 57c:8501 with Saucy and Trusty.
Unfortunately it fails to initialise properly.

According to the label on it , this device is powered by a Ralink RT5572N chipset.

The rt2x00 driver seems to recognize this device:

[ 0.000000] Linux version 3.13.0-19-generic (buildd@akateko) (gcc version 4.8.2 (Ubuntu 4.8.2-17ubuntu1) ) #40-Ubuntu SMP Mon Mar 24 02:36:06 UTC 2014 (Ubuntu 3.13.0-19.40-generic 3.13.6)
[ 20.057058] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 5592, rev 0222 detected
[ 20.103139] ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x09 failed for offset 0x0000 with error -32
[ 20.103144] ieee80211 phy0: rt2x00lib_probe_dev: Error - Failed to allocate device
[ 20.103158] rt2800usb: probe of 1-1.3:1.0 failed with error -32
[ 20.103199] usbcore: registered new interface driver rt2800usb

As we can see it fails to properly initialize the device.

I am running the most recent Kubuntu 14.04 64bit release that came out this week.

What i exspect to happen is that the device works and i would be able to connect to my wifi network, what happens instead is that only the ethernet card is visible and usable.
---
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: imho 2165 F.... pulseaudio
                      imho 2225 F.... pulseaudio
 /dev/snd/controlC0: imho 2165 F.... pulseaudio
                      imho 2225 F.... pulseaudio
CurrentDesktop: KDE
DistroRelease: Ubuntu 14.04
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-04-18 (1 days ago)
InstallationMedia: Kubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.1)
IwConfig:
 eth0 no wireless extensions.

 eth1 no wireless extensions.

 lo no wireless extensions.
MachineType: System manufacturer System Product Name
Package: linux (not installed)
ProcFB: 0 nouveaufb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=22de8a22-b2b4-4eca-aadf-921bf4783437 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-24-generic N/A
 linux-backports-modules-3.13.0-24-generic N/A
 linux-firmware 1.127
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
Tags: trusty
Uname: Linux 3.13.0-24-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 05/02/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1606
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P8P67 EVO
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1606:bd05/02/2011:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP8P67EVO:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1310055

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: trusty
karmen (blue-t) wrote : AlsaInfo.txt

apport information

tags: added: apport-collected
description: updated
karmen (blue-t) wrote : BootDmesg.txt

apport information

karmen (blue-t) wrote : CRDA.txt

apport information

apport information

karmen (blue-t) wrote : Lspci.txt

apport information

karmen (blue-t) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

karmen (blue-t) wrote : UdevDb.txt

apport information

karmen (blue-t) wrote : UdevLog.txt

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.15 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-rc2-trusty/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
karmen (blue-t) wrote :

No dice, tested with 3.15-rc2 from said ppa, still not loading

tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
AZ (m-dev) wrote :
AZ (m-dev) wrote :
AZ (m-dev) wrote :

Please find attached two patches on top of 3.15-rc7 (vanilla kernel) that makes my 57c:8501 (AVM Fritz Stick N v2 - B) device work.

tags: added: patch
karmen (blue-t) wrote :

patches have been merged upstream in 3.16-rc3 which was just released.

tags: added: kernel-fixed-upstream
removed: kernel-bug-exists-upstream
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers