[Dell Inspiron 1525] suspend/resume failure

Bug #1305371 reported by Ashraf Ali on 2014-04-10
88
This bug affects 18 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

suspend/resume failed. restart required to bring back system

ProblemType: KernelOops
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-23-generic 3.13.0-23.45
ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
Uname: Linux 3.13.0-23-generic x86_64
Annotation: This occured during a previous suspend and prevented it from resuming properly.
ApportVersion: 2.14.1-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ashraf 1484 F.... pulseaudio
Date: Thu Apr 10 06:30:00 2014
ExecutablePath: /usr/share/apport/apportcheckresume
Failure: suspend/resume
HibernationDevice: RESUME=UUID=f4caffe3-3165-417b-bd56-386b8e3852b8
InstallationDate: Installed on 2014-03-29 (11 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Beta amd64 (20140326)
InterpreterPath: /usr/bin/python3.4
MachineType: Dell Inc. Inspiron 1525
ProcCmdline: /usr/bin/python3 /usr/share/apport/apportcheckresume
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-23-generic root=UUID=26592a1f-092c-4949-9107-771865219fcd ro quiet splash
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-23-generic N/A
 linux-backports-modules-3.13.0-23-generic N/A
 linux-firmware 1.127
SourcePackage: linux
Title: [Dell Inc. Inspiron 1525] suspend/resume failure
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 10/27/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A17
dmi.board.name: 0U990C
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA17:bd10/27/2009:svnDellInc.:pnInspiron1525:pvr:rvnDellInc.:rn0U990C:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Inspiron 1525
dmi.sys.vendor: Dell Inc.

Ashraf Ali (sharali) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.14 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14-trusty/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete

'kernel-bug-exists-upstream'.

On Thu, Apr 10, 2014 at 9:07 PM, Joseph Salisbury <
<email address hidden>> wrote:

> Would it be possible for you to test the latest upstream kernel? Refer
> to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest
> v3.14 kernel[0].
>
> If this bug is fixed in the mainline kernel, please add the following
> tag 'kernel-fixed-upstream'.
>
> If the mainline kernel does not fix this bug, please add the tag:
> 'kernel-bug-exists-upstream'.
>
> If you are unable to test the mainline kernel, for example it will not
> boot, please add the tag: 'kernel-unable-to-test-upstream'.
> Once testing of the upstream kernel is complete, please mark this bug as
> "Confirmed".
>
>
> Thanks in advance.
>
>
> [0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14-trusty/
>
>
> ** Changed in: linux (Ubuntu)
> Importance: Undecided => Medium
>
> ** Changed in: linux (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1305371
>
> Title:
> [Dell Inc. Inspiron 1525] suspend/resume failure
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1305371/+subscriptions
>

--
ashrafalipk

Ashraf Ali, did this problem not occur in a release prior to Trusty?

tags: added: kernel-bug-exists-upstream-3.14 latest-bios-a17 regression-potential
summary: - [Dell Inc. Inspiron 1525] suspend/resume failure
+ [Dell Inspiron 1525] suspend/resume failure

Yes. Works ok with Ubuntu 13.10. Ubuntu 13.10 is still available in my
laptop
Ashraf Ali

On Mon, Apr 14, 2014 at 1:59 AM, Christopher M. Penalver <
<email address hidden>> wrote:

> Ashraf Ali, did this problem not occur in a release prior to Trusty?
>
> ** Tags added: kernel-bug-exists-upstream-3.14 latest-bios-a17
> regression-potential
>
> ** Summary changed:
>
> - [Dell Inc. Inspiron 1525] suspend/resume failure
> + [Dell Inspiron 1525] suspend/resume failure
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1305371
>
> Title:
> [Dell Inspiron 1525] suspend/resume failure
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1305371/+subscriptions
>

--
ashrafalipk

Ashraf Ali, the next step is to fully commit bisect from Saucy to Trusty in order to identify the offending commit. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection ?

tags: added: regression-release
removed: regression-potential
tags: added: needs-bisect

Sorry. It is beyond my technical ability
Ashraf Ali

On Mon, Apr 14, 2014 at 4:15 PM, Christopher M. Penalver <
<email address hidden>> wrote:

> Ashraf Ali, the next step is to fully commit bisect from Saucy to Trusty
> in order to identify the offending commit. Could you please do this
> following https://wiki.ubuntu.com/Kernel/KernelBisection ?
>
> ** Tags removed: regression-potential
> ** Tags added: regression-release
>
> ** Tags added: needs-bisect
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1305371
>
> Title:
> [Dell Inspiron 1525] suspend/resume failure
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1305371/+subscriptions
>

--
ashrafalipk

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

I have the same problem with my Dell inspiron 1525 and Ubuntu 14.04. with kernel 3.13.0-24 generic x86. The kernel oops seems to be caused by the kernel module snd_hda_intel. Resuming from standby works in most cases with a standby hook which kills pulseaudio and unloads the module snd_hda_intel before standby and reloads snd_hda_intel after resume. See attached file. In some cases the computer doesn't go to standby when I close the lid. When I reopen it, the display remains black and the computer doesn't respond. So this workarround is not reliable.

I updated from Ubuntu 13.10, the Saucy kernel 3.11.0-19-generic remained installed. When I boot Ubuntu 14.04 with this kernel, standby and resume work fine (of course without the standby hook mentioned above).

I just tried mainline kernel 3.12.18-031218-generic for trusty - standby and resume work fine with this kernel version. So the bug seems to be new in 3.13.

Many laptops from different manufacturers show similar problems. They all use the snd_hda_intel kernel module but different codecs.

Carsten Wehmeier, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

David Fraser (davidf) wrote :

Same problem - after upgrading from 12.04 to 14.04, suspend works but resume shows completely black screen and requires a hard reboot. Initial testing seems to show that killing pulseaudio and running rmmod snd_hda_intel allows a successful suspend and resume.

I've been working on a script to suspend and resume pulseaudio; it currently looks like this:

#!/bin/bash
case "$1" in
        suspend|hibernate)
                echo module usage:
                lsmod | grep ^snd_hda_intel
                echo searching for pulseaudio sessions...
                for p in /run/user/*/pulse/ ; do
                        ud=`dirname $p`
                        uid=`basename $ud`
                        echo unloading module for user $uid
                        sudo -u \#$uid PULSE_RUNTIME_PATH="$p" -i pacmd list-modules | grep -A1 'name: <module-alsa-card>' | grep 'argument:' | sed 's/^.*argument: <\(.*\)>.*$/\1/' > /var/run/pm-suspend-pa-alsa-arguments-$uid
                        sudo -u \#$uid PULSE_RUNTIME_PATH="$p" -i pacmd unload-module module-alsa-card
                done
                echo post-pulseaudio unload module usage:
                lsmod | grep ^snd_hda_intel
                rmmod snd_hda_intel
                echo pre-suspend module usage:
                lsmod | grep ^snd_hda_intel
                echo hopefully ready to suspend
                ;;
        resume|thaw)
                echo resume module usage:
                lsmod | grep ^snd_hda_intel
                modprobe snd_hda_intel
                echo post-modprobe module usage:
                lsmod | grep ^snd_hda_intel
                for p in /run/user/*/pulse/ ; do
                        ud=`dirname $p`
                        uid=`basename $ud`
                        arguments="`</var/run/pm-suspend-pa-alsa-arguments-$uid`"
                        echo loading module for user $uid
                        sudo -u \#$uid PULSE_RUNTIME_PATH="$p" -i pacmd load-module module-alsa-card $arguments
                done
                echo post-pulseaudio load module usage:
                lsmod | grep ^snd_hda_intel
                ;;
esac

David Fraser (davidf) wrote :

Carsten, I can't see the script you were using - did you attach it?

David Fraser, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

  With the recent release of this Ubuntu release, would like to confirm if this bug is still present. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.13.0-24.46
shacharr (shacharr) wrote :

Hi,

The same issue (no resume after suspend) occurs on my machine as well (also an inspiron 1525).

Will be happy to follow through and assist debugging. Per the request in the thread here, I opened a new bug report for this issue at LP:1330043

shacharr (shacharr) on 2014-06-14
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Mark smith (zebiddy8) wrote :

I'm running the 3.13.0-30-55 kernel on a 1525 laptop and unfortunately this problem still exists.
Suspend always works, resume works maybe 80% of the time. It's the wife's laptop so it's high visibility. ;-)
I can give more info if given specific instructions, thanks.

Mark smith, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Gopala (krishna-ggk+ubuntuone) wrote :

Faced the same problem. David Fraser's script seem to have fixed for me though (put the script in /etc/pm/sleep.d)

Mark smith (zebiddy8) wrote :

I have 3 files in that directory (sleep.d),

10_grub-common
10_unattended-upgrades-hibernate
novatel_3g_suspend

what would this script be called or is it appended to one of these files?
Thanks!

Gopala (krishna-ggk+ubuntuone) wrote :

I just called it "suspend_resume_fix" - the filename doesn't matter but I made sure it is invoked in the end (based on alphabetic order).

Gopala (krishna-ggk+ubuntuone) wrote :

The filename should be executable though - (sudo chmod a+x suspend_resume_fix)

Mark smith (zebiddy8) wrote :

So I'm assuming that all the scripts in the sleep.d directory get executed on a suspend/resume event?

Noobinit (familywe) wrote :

I am totally new to Linux/Ubuntu. I have no idea how to fix this suspend/resume failure problem. I have an Inspiron 6000. What i do know is that i see records of this bug going all the way back to 2009 - except no resolutions. PLEASE somebody tell me i'm wrong and that there is a solution. Would also be nice to know how i - with my lack of expertise - could do it. thanks all.

Noobinit, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

As well, please do not announce in this report you created a new bug report.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Download full text (3.8 KiB)

I will try. I do not know what you mean by the default Ubuntu kernel vs. mainline one.
Also, I realized that the Ubuntu OS is having several problems at once despite clean install.
Can u advise?
Thanks
Peter

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Christopher M. Penalver
Sent: Wednesday, September 03, 2014 10:13 PM
To: <email address hidden>
Subject: [Bug 1305371] Re: [Dell Inspiron 1525] suspend/resume failure

*** This bug is a duplicate of bug 1331654 ***
    https://bugs.launchpad.net/bugs/1331654

Noobinit, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

As well, please do not announce in this report you created a new bug report.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

--
You received this bug notification because you are subscribed to the bug report.
https://bugs.launchpad.net/bugs/1305371

Title:
  [Dell Inspiron 1525] suspend/resume failure

Status in “linux” package in Ubuntu:
  Confirmed

Bug description:
  suspend/resume failed. restart required to bring back system

  ProblemType: KernelOops
  DistroRelease: Ubuntu 14.04
  Package: linux-image-3.13.0-23-generic 3.13.0-23.45
  ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
  Uname: Linux 3.13.0-23-generic x86_64
  Annotation: This occured during a previous suspend and prevented it from resuming properly.
  ApportVersion: 2.14.1-0ubuntu1
  Architecture: amd64
  AudioDevicesInUse:
   USER PID ACCESS COMMAND
   /dev/snd/controlC0: ashraf 1484 F.... pulseaudio
  Date: Thu Apr 10 06:30:00 2014
  ExecutablePath: /usr/share/apport/apportcheckresume
  Failure: suspend/resume
  HibernationDevice: RESUME=UUID=f4caffe3-3165-417b-bd56-386b8e3852b8
  InstallationDate: Installed on 2014-03-29 (11 days ago)
  InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Beta amd64 (20140326)
  InterpreterPath: /usr/bin/python3.4
  MachineType: Dell Inc. Inspiron 1525
  ProcCmdline: /usr/bin/python3 /usr/share/apport/apportcheckresume
  ProcEnviron:
   TERM=linux
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-23-generic root=UUID=26592a1f-092c-4949-9107-771865219fcd ro quiet splash
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
  RelatedPackageVersions:
   linux-restricted-modules-3.13.0-23-generic N/A
   linux-backports-modules-3.13.0-23-generic N/A
   linux-firmware ...

Read more...

Gopala (krishna-ggk+ubuntuone) wrote :

I picked up updates today which updated kernel package to 3.13.0-36. I had disabled my script to ensure the update worked.

I no longer see any failures and looks like the fix has worked!

Its worked for others too in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1331654

A. Saavedra (alxsvdr) wrote :

Hi,

I also have a Dell Inspiron 15R. Standby used to work with Ubuntu 12, but stopped working upon upgrading to Ubuntu trusty 14.04. I attempted upgrading kernel to 3.13.0-36, but this didn't solve the issue either. Since I don't know to downgrade to previous kernel, I just disabled trusty-proposed repository.

Then I decided to try David Fraser's script which worked like a charm.

Thank you,

Alex S.

Mark smith (zebiddy8) wrote :

But a "Dell Inspiron 15R" isn't an Dell Inspiron 1525. ;-)
Glad that script cures it, that script worked well until I installed the kernel 3.13.0-35.62 on our Dell Inspiron 1525.

Luis Lobo (luislobo) wrote :

I have 3.16.0-41.57 on Ubuntu 14.10 and it is still failing

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers