Wireless connection keeps disconnecting

Bug #1297286 reported by Ahmed Toulan on 2014-03-25
106
This bug affects 27 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

Hi,

I have a wireless access point that is at most 2 meters away. It keeps disconnecting with no apparent reason. I read somewhere that setting a static ip should help with the problem, but the problem seems pretty persistent.

Thanks.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: network-manager 0.9.8.8-0ubuntu5
ProcVersionSignature: Ubuntu 3.13.0-19.39-lowlatency 3.13.6
Uname: Linux 3.13.0-19-lowlatency x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Mar 25 15:20:15 2014
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2014-03-20 (5 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140319)
IpRoute:
 default via 192.168.1.1 dev wlan0 proto static
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.245 metric 9
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.NetworkManager.NetworkManager.conf: 2014-03-23T16:50:07.398742
nmcli-con:
 NAME UUID TYPE TIMESTAMP TIMESTAMP-REAL AUTOCONNECT READONLY DBUS-PATH
 NETGEAR 74dc69be-e44f-4e15-a614-6c284d83d16b 802-11-wireless 1395737193 Tue 25 Mar 2014 10:46:33 AM EET yes no /org/freedesktop/NetworkManager/Settings/2
 Wired connection 1 7ac79166-e72e-455b-ad9e-34574ee5d94e 802-3-ethernet 1395571025 Sun 23 Mar 2014 12:37:05 PM EET yes no /org/freedesktop/NetworkManager/Settings/1
 Egy Cloud 05f6b118-d332-4196-a7b0-810bba89bbf7 802-11-wireless 1395753542 Tue 25 Mar 2014 03:19:02 PM EET yes no /org/freedesktop/NetworkManager/Settings/0
 AndroidAP 46037856-999f-4b3b-878d-13243f4ae958 802-11-wireless 1395592043 Sun 23 Mar 2014 06:27:23 PM EET yes no /org/freedesktop/NetworkManager/Settings/3
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 wlan0 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/1
 eth0 802-3-ethernet unavailable /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.8.8 connected enabled enabled enabled enabled disabled

Ahmed Toulan (thelinuxer) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed

Hello guys,

I have the same issue. After upgrading from 13.10 to 14.04, it seems that I get random disconnects from the wireless connection. Here is a dmesg snippet that I see after every disconnection:

[ 6072.816923] wlan0: deauthenticated from b0:48:7a:d1:69:c4 (Reason: 6)
[ 6072.843782] cfg80211: Calling CRDA to update world regulatory domain
[ 6072.851353] cfg80211: World regulatory domain updated:
[ 6072.851362] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 6072.851368] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 6072.851374] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 6072.851379] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 6072.851383] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 6072.851387] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 6088.493025] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

Charles Green (chick) wrote :

I added an IW registration:

sudo iw reg set US

This seems to have solved many of my problems

Changed in network-manager (Ubuntu):
importance: Undecided → High
psnizek (psnizek-i) wrote :

Kernel 3.18 appears to be fixing Ubuntu bug #1297286 (wireless disconnecting) at least in my case. Since I upgraded the kernel from 3.13 to 3.18 the issue appears to be gone completely. Using Asus USB-N53 adapter with Ralink RT3572 chipset. Stable wifi connection in 802.11n mode (300+ mbit/s) connecting to local network and no disconnects anymore! Highly recommended!! OS: Ubuntu 14.04.1 LTS.

Darius Damalakas (darkcloud) wrote :

Guidance on how to upgrade kernel (if that indeed fixes it) would be appreciated. Thanks

psnizek (psnizek-i) wrote :

Kernel update:

Step 1)
go to URL: kernel.ubuntu.com/~kernel-ppa/mainline/v3.18-vivid/

Step 2)
Choose the kernel suitable for your system (32-bit or 64-bit)

In my case I chose: linux-image-3.18.0-031800-generic_3.18.0-031800.201412071935_amd64.deb

Step 3)
Download it

Step 4)
Open it using the Ubuntu Software Center for installing it.

Step 5)
Reboot

Step 6)
Check kernel version: Open Terminal with CTRL-ALT-T, type "uname -a" and then hit <ENTER> in the command prompt. The kernel version should be on 3.18 now and your wifi issue hopefully fixed.

Hope that helps.

psnizek (psnizek-i) wrote :

Update: I had not a single wifi disconnect since the kernel upgrade about 1 week ago. I am using 802.11n at 300mbps, accessing intranet servers, file servers as well as the internet very reliably. This is making me extremely happy :-))

tlue (tlueber) wrote :

can't check kernel version at the moment (as I have to post form Windows again) but today it failed again but this time I got a popup error message as follows:

(1) Creating object for path '/org/freedesktop/NetworkManager/ActiveConnection/1' failed in libnm-glib.

is that of any help?

tlue (tlueber) wrote :

just updated to Kernel 3.18 as described in the post above. After reboot I got disconnected again and a dialog with this error came popped up:

(4) Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

uname -a did show the new kernel (though I wonder how I would keep up to date with this kernel regarding security bugs. I guess there would need be a backport for the last LTS, right? Do we know what exact part has changed?

Please let me know, if I can help with any tests in this.

tlue (tlueber) wrote :

just installed all update of last 3 weeks or so (still running on newer Kernel as described above) but still not working reliably (not longer than 20 minutes).
Now did this one here
echo "options rtl8723be fwlps=N ips=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
taken from http://ubuntuforums.org/showthread.php?p=13119513#post13119513
and rebooted again. Seems to be better now (30 minutes by now)...

tlue (tlueber) wrote :

I now removed Kernel 3.18 again and rebooted. Still working fine for a good while now with the fix mentioned in my last post.

uname -a is showing: Linux ....Lenovo-Flex-2-15 3.13.0-49-generic

I have also tried upgrading from 3.13 to 3.18 kernel. It did not solve the problem.

After going through a lot of articles, today saw this bug, and the workaround given in tlue's post.

I have tried it now. Wifi is up from last 22 minutes. I will update here after using it for sometime.

Ok, so as I said in my previous comment, I have tested the performance of wifi in Ubuntu 14.04 in 3-4 laptops in last 1 week.

After fresh installation, wifi keeps on dropping. Then I applied tlue's workaround on all of them which was:
echo "options rtl8723be fwlps=N ips=N" | sudo tee /etc/modprobe.d/rtl8723be.conf

Now after doing this, the wifi stabilizes but after long usage (2-4 hours continuously) it drops for 5-20 seconds and then either comes back automatically or needs a reconnect (Reboot is not required to reconnect in this case).

So after digging about incompatibility related to msi in rtl8723be, I added one extra parameter in above command:
echo "options rtl8723be fwlps=N ips=N msi=1" | sudo tee /etc/modprobe.d/rtl8723be.conf

After using for 4-5 hours I didn't see a drop. Still I am keeping fingers crossed.

Aron Xu (happyaron) on 2016-12-20
affects: network-manager (Ubuntu) → linux (Ubuntu)
gabybosetti (gabybosetti) wrote :

ALso in Ubuntu 17

khushbu (kushi09) wrote :

My friend suggest me this website https://fixconnectionsbluetoothaudiodeviceswirelessdisplayswindows10.net/ to fix this error when i was facing the same issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers