Sony Vaio PCV-RS320 Desktop Hard Drive LED always lit despite zero activity

Bug #129645 reported by Stratus on 2007-08-01
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned
Nominated for Dapper by Stratus
Declined for Edgy by Luca Falavigna
Nominated for Feisty by Stratus
Nominated for Gutsy by Stratus
Nominated for Hardy by Stratus
Nominated for Maverick by rusivi2

Bug Description

I would guess this is a problem for all Sony Vaio PCV-RS320's.

I installed Ubuntu a week ago and my Hard Disk LED has been lit ever since.
At first I thought the hard drive was constantly being utilized, but the
System Monitor shows zero activity and the LED is constantly lit.
(It does get brighter with real activity though.)

ProblemType: Bug
Architecture: i386
Date: Wed Aug 1 04:38:57 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/gnome-panel
Package: gnome-panel 1:2.18.1-0ubuntu3.1
PackageArchitecture: i386
ProcCmdline: gnome-panel --sm-client-id default1
ProcCwd: /home/stratus
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-panel
Uname: Linux EnGlow 2.6.20.3-ubuntu1-custom #1 SMP Sun Jul 29 21:26:04 EDT 2007 i686 GNU/Linux

Stratus (saftousmis) wrote :
Stratus (saftousmis) on 2007-08-01
description: updated
Stratus (saftousmis) on 2007-08-01
description: updated
Stratus (saftousmis) wrote :

Does anyone need me to provide any information or anything?

Stratus (saftousmis) wrote :
Download full text (8.4 KiB)

Output of `lspci -vv':

00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR-
        Latency: 0
        Region 0: Memory at f8000000 (32-bit, prefetchable) [size=64M]
        Capabilities: <access denied>

00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02) (prog-if 00 [Normal decode])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
        Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
        Memory behind bridge: fd900000-fe9fffff
        Prefetchable memory behind bridge: f3f00000-f7efffff
        Secondary status: 66MHz+ FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
        BridgeCtl: Parity- SERR- NoISA- VGA+ MAbort- >Reset- FastB2B-

00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02) (prog-if 00 [UHCI])
        Subsystem: Sony Corporation Unknown device 8159
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin A routed to IRQ 19
        Region 4: I/O ports at e400 [size=32]

00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02) (prog-if 00 [UHCI])
        Subsystem: Sony Corporation Unknown device 8159
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin B routed to IRQ 20
        Region 4: I/O ports at e800 [size=32]

00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02) (prog-if 00 [UHCI])
        Subsystem: Sony Corporation Unknown device 8159
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin C routed to IRQ 16
        Region 4: I/O ports at ec00 [size=32]

00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02) (prog-if 20 [EHCI])
        Subsystem: Sony Corporation Unknown device 8159
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin D routed to IRQ 21
        Region 0: Memory at febffc00 (32-bit, non-prefetchable) [size=1K]
        Capabilities: <access denied>

00:1e.0 PCI bridge: Intel Corporation 82801...

Read more...

Stratus (saftousmis) wrote :

Output of `lspci -vvn':

Stratus (saftousmis) wrote :

Output of `dmesg':

Stratus (saftousmis) wrote :

This problem has disappeared.

Henrik S. (henrik-hw0) wrote :

Assume this problem has been fixed.

Henrik S. (henrik-hw0) on 2008-06-03
Changed in kernel-package:
status: Fix Released → Incomplete
Stratus (saftousmis) wrote :

I thought it was after an update but it was back two days later; in this issue has been around for the 9 months I've used Ubuntu.
I've tried kernel compiles, tweaks, and tons of other stuff through web searches and nothing seems to turn the LED off (in Ubuntu).

Stratus (saftousmis) wrote :

This bug was marked for expiration.

It's still exists though; not enough people with the PCV-RS320?

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Stratus (saftousmis) wrote :

It's still glowing all the time unfortunately after reboot.

Thanks though for keeping this issue in mind.

Stratus (saftousmis) wrote :

I just noticed it's working correctly.

I rebooted and it's still working fine...

Stratus (saftousmis) wrote :

The light was on again when I booted up this afternoon.

I did something yesterday I hadn't done in awhile; I used the CD drive (to play a CD).

I reached down and hit the CD drive eject button (eject -t /dev/scd2 doesn't work for me), and the light immediately flickers and works correctly.

I've done it twice now between reboots at different times and the results are the same...

Stratus (saftousmis) wrote :

OK; now I notice when I use the CD drive the hard drive light is responding to CD disc read.

If I eject the CD tray shortly after booting the light will darken and I can see hard drive activity, but any time I use the CD drive the light is also reacting to that so maybe lines are crossed somewhere.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Low
status: Incomplete → Triaged
Stratus (saftousmis) wrote :

It's also worth noting (and to keep this alive) it only works if I eject my CD drive tray and not my DVD drive tray...

This doesn't happen in any other operating system I use so I assume this is Ubuntu specific...

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Stratus (saftousmis) wrote :

I'm running an updated Jaunty now.

Here's a visual example of the problem:

http://www.youtube.com/watch?v=Kkjwach1PpE

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Triaged a while ago but has not had any updated comments for quite some time. Please let us know if this issue remains in the current Ubuntu release, http://www.ubuntu.com/getubuntu/download . If the issue remains, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Stratus (saftousmis) wrote :

Yes it's still an issue.

The video I posted above is your example....

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired

Just installed Ubuntu 10.04 LTS - and all current updates - on Sony Vaio PCV-RS320, and I can confirm this bug.

After a normal boot the disk activity light remains solidly lit, even when there is no I/O in process. Opening and closing the DVD-RW drive has no effect. Opening and closing the CD-ROM drive causes the light to go out, then blink three times, then it stays out unless there is activity from 1) the HDD 2) the DVD-RW drive 3) the CD-ROM drive.

All three peripherals are on an Intel ICH5/ICH5R PATA controller. The HDD is Port 1 (ATA), DVD-RW and CD-ROM are on on Port 2 (SCSI).

Changed in linux (Ubuntu):
status: Expired → New

Leap Frog Group, Inc.: Thanks for checking! Does this occur in Maverick as well?

Just booted 10.10 beta Live CD and yes, the problem still exists, with the same workaround (open / close the CD-ROM drive).
The CD-ROM and DVD-RW drives are IDE.

Note that there are NOT separate DVD/CD/HDD activity lights -- there is a single LED for all three.

ubuntu@ubuntu:~$ lspci -v (edited)

00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02) (prog-if 8a [Master SecP PriP])
    Subsystem: Sony Corporation Device 8159
    Flags: bus master, medium devsel, latency 0, IRQ 18
    I/O ports at 01f0 [size=8]
    I/O ports at 03f4 [size=1]
    I/O ports at 0170 [size=8]
    I/O ports at 0374 [size=1]
    I/O ports at fc00 [size=16]
    Memory at 40000000 (32-bit, non-prefetchable) [size=1K]
    Kernel driver in use: ata_piix

Charlie Kravetz (charlie-tca) wrote :

Thanks for confirming this issue. I am marking this triaged, since there should be enough informtion for the developers to attempt again to resolve this.

Please continue to report bugs you find.

tags: added: maverick
removed: kj-expired
Changed in linux (Ubuntu):
status: New → Triaged

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers