Unable to install 64-bit kernel on 64-bit-capable system installed with 32-bit userland+kernel

Bug #1295112 reported by James Hunt on 2014-03-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Tim Gardner
Trusty
High
Tim Gardner

Bug Description

$ arch
i686
$ dpkg -l linux-generic
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-======================================-========================-========================-==================================================================================
ii linux-generic 3.13.0.18.22 i386 Complete Generic Linux kernel and headers
$ sudo dpkg --add-architecture amd64
$ sudo apt-get update
$ sudo apt-get install linux-generic:amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 linux-generic:amd64 : Depends: linux-headers-generic:amd64 (= 3.13.0.18.22) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
$ sudo apt-get install linux-generic:amd64 linux-headers-generic:amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 linux-headers-generic:amd64 : Depends: linux-headers-3.13.0-18-generic:amd64 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
$ sudo apt-get install linux-generic:amd64 linux-headers-generic:amd64 linux-headers-3.13.0-18-generic:amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 linux-headers-3.13.0-18-generic:amd64 : Depends: linux-headers-3.13.0-18:amd64 but it is not installable
E: Unable to correct problems, you have held broken packages.
$ sudo apt-get install linux-generic:amd64 linux-headers-generic:amd64 linux-headers-3.13.0-18-generic:amd64 linux-headers-3.13.0-18:amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package linux-headers-3.13.0-18:amd64 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'linux-headers-3.13.0-18:amd64' has no installation candidate
$

cjwatson identified the issue:

12:52:11 <cjwatson> the bug is that linux-headers-3.13.0-18 isn't Multi-Arch: foreign fwiw

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-18-generic 3.13.0-18.38
ProcVersionSignature: Ubuntu 3.13.0-18.38-generic 3.13.6
Uname: Linux 3.13.0-18-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.13.3-0ubuntu1
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: james 3834 F.... pulseaudio
 /dev/snd/controlC0: james 3834 F.... pulseaudio
 /dev/snd/pcmC0D0p: james 3834 F...m pulseaudio
CurrentDesktop: Unity
Date: Thu Mar 20 12:52:29 2014
HibernationDevice: RESUME=UUID=67e3cd44-242b-4bbf-918b-28fff81e0312
InstallationDate: Installed on 2010-10-21 (1246 days ago)
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
MachineType: LENOVO 2516CTO
ProcFB:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-18-generic root=UUID=7ad192e9-7b26-49d1-8e1c-fefc7dc495cb ro quiet splash intel_pstate=enable
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-18-generic N/A
 linux-backports-modules-3.13.0-18-generic N/A
 linux-firmware 1.126
SourcePackage: linux
UpgradeStatus: Upgraded to trusty on 2013-11-01 (138 days ago)
dmi.bios.date: 08/27/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6IET72WW (1.32 )
dmi.board.name: 2516CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6IET72WW(1.32):bd08/27/2010:svnLENOVO:pn2516CTO:pvrThinkPadT410:rvnLENOVO:rn2516CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2516CTO
dmi.product.version: ThinkPad T410
dmi.sys.vendor: LENOVO

James Hunt (jamesodhunt) wrote :
summary: - Unable to install 64-bit kernel on 64-bit-capable system installed
+ Unable to install 64-bit kernel on 64-bit-capable system installed with
+ 32-bit userland+kernel
Colin Watson (cjwatson) wrote :

This is an important part of being able to transition people in-place to amd64, so I'd like to see this fixed in trusty if possible.

James Hunt (jamesodhunt) wrote :

$ sudo apt-get install linux-generic:amd64 linux-headers-generic:amd64 linux-headers-3.13.0-18-generic:amd64 linux-headers-3.13.0-18
Reading package lists... Done
Building dependency tree
Reading state information... Done
linux-headers-3.13.0-18 is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 linux-headers-3.13.0-18-generic:amd64 : Depends: linux-headers-3.13.0-18:amd64 but it is not installable
E: Unable to correct problems, you have held broken packages.
$

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: kernel-key
Changed in linux (Ubuntu):
importance: Undecided → High
Joseph Salisbury (jsalisbury) wrote :

Does this issue happen if you try to just install the linux-image package and not include the headers package at the same time?

James Hunt (jamesodhunt) wrote :

Yes:

$ sudo apt-get install linux-generic:amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 linux-generic:amd64 : Depends: linux-headers-generic:amd64 (= 3.13.0.18.22) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
$ sudo apt-get install linux-image:amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package linux-image:amd64 is a virtual package provided by:
  linux-image-3.13.0-18-lowlatency:amd64 3.13.0-18.38
  linux-image-3.13.0-18-generic:amd64 3.13.0-18.38
You should explicitly select one to install.

E: Package 'linux-image:amd64' has no installation candidate
$ sudo apt-get install linux-image-3.13.0-18-generic:amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  fdutils:amd64 linux-doc-3.13.0:amd64 linux-source-3.13.0:amd64 linux-tools:amd64 linux-headers-3.13.0-18-generic:amd64
The following packages will be REMOVED
  linux-generic linux-image linux-image-3.13.0-18-generic linux-image-extra-3.13.0-18-generic linux-image-generic linux-image-generic-pae linux-image-server
The following NEW packages will be installed
  linux-image-3.13.0-18-generic:amd64
0 to upgrade, 1 to newly install, 7 to remove and 11 not to upgrade.
Need to get 14,9 MB of archives.
After this operation, 104 MB disk space will be freed.

That last operation looks wrong as apt seems to want to remove my 32-bit (??) kernel.

Tim Gardner (timg-tpi) on 2014-03-23
Changed in linux (Ubuntu Trusty):
assignee: nobody → Tim Gardner (timg-tpi)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.13.0-19.40

---------------
linux (3.13.0-19.40) trusty; urgency=low

  [ Tim Gardner ]

  * [Config] Add new mlx modules to d-i
  * [Config] Fix d-i spelling error: ahxi_xgene --> ahci_xgene
  * [Config] Added Muti-Arch support for linux-headers-PKGVER-ABINUM,
    linux-tools-common, and linux-cloud-tools-common
    - LP: #1295112
  * Release Tracking Bug
    - LP: #1296484

  [ Upstream Kernel Changes ]

  * Drivers: hv: vmbus: Specify the target CPU that should receive
    notification
    - LP: #1295813
 -- Tim Gardner <email address hidden> Sun, 23 Mar 2014 19:54:50 -0600

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
Tim Gardner (timg-tpi) wrote :

Verified that this now works correctly,

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers