Displayport pada Thinkpad T420s tidak dapat digunakan

Bug #1292036 reported by Rovanion on 2014-03-13
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Hi,
I'm trying to connect an external screen to my thinkpad T420s. I'm running Ubuntu 14.04 and here is the output of xrandr:

$ xrandr
Screen 0: minimum 320 x 200, current 1600 x 900, maximum 32767 x 32767
LVDS1 connected primary 1600x900+0+0 (normal left inverted right x axis y axis) 309mm x 174mm
   1600x900 60.0*+ 40.0
   1440x900 59.9
   1360x768 59.8 60.0
   1152x864 60.0
   1024x768 60.0
   800x600 60.3 56.2
   640x480 59.9
VGA1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

LVDS1 is the LCD-display on the laptop. This is the output of lspci:

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [NVS 4200M] (rev ff)

The screen recognises that something is plugged into the DisplayPort but Ubuntu is unable to send output to it. It's probably related to the whole dual graphics card thing.

Thank you for reading this bug!

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xorg 1:7.7+1ubuntu8
ProcVersionSignature: Ubuntu 3.13.0-16.36-generic 3.13.5
Uname: Linux 3.13.0-16-generic i686
ApportVersion: 2.13.3-0ubuntu1
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: None
Date: Thu Mar 13 15:32:36 2014
DistUpgraded: 2014-02-24 23:10:48,392 DEBUG enabling apt cron job
DistroCodename: trusty
DistroVariant: ubuntu
EcryptfsInUse: Yes
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21d3]
 NVIDIA Corporation GF119M [NVS 4200M] [10de:1056] (rev ff) (prog-if ff)
InstallationDate: Installed on 2013-08-07 (217 days ago)
InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release i386 (20130213)
MachineType: LENOVO 4174PEG
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=sv_SE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-16-generic root=UUID=7d44dac8-470f-4bb6-a331-e31a6e61ea51 ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: Upgraded to trusty on 2014-02-24 (16 days ago)
dmi.bios.date: 11/01/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8CET50WW (1.30 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4174PEG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8CET50WW(1.30):bd11/01/2011:svnLENOVO:pn4174PEG:pvrThinkPadT420s:rvnLENOVO:rn4174PEG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4174PEG
dmi.product.version: ThinkPad T420s
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.11+14.04.20140305-0ubuntu1
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0~rc3-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0~rc3-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.15.0-1ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Thu Mar 13 14:44:03 2014
xserver.configfile: default
xserver.errors: Failed to load module "nvidia" (module does not exist, 0)
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 8510
 vendor AUO
xserver.version: 2:1.15.0-1ubuntu6

Rovanion (rovanion-luckey) wrote :
Timo Aaltonen (tjaalton) wrote :

yes, don't hold your breath waiting for a fix

affects: xorg (Ubuntu) → xserver-xorg-video-nouveau (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Confirmed
tags: added: bios-outdated-1.39
removed: optimus xorg
Changed in xserver-xorg-video-nouveau (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Rovanion (rovanion-luckey) wrote :

I still cannot seem to get any output to a screen plugged in through the Display Port.

>$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
8CET59WW (1.39 )
04/29/2015

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → New

Rovanion, any change updating to the Vivid enablement stack as outlined in https://wiki.ubuntu.com/Kernel/LTSEnablementStack ?

tags: added: latest-bios-1.39
removed: bios-outdated-1.39
Changed in xserver-xorg-video-nouveau (Ubuntu):
importance: Low → Medium
status: New → Incomplete
Rovanion (rovanion-luckey) wrote :

I installed the packages mentioned on that wiki page and rebooted. But no change, I'm afraid.

Rovanion, could you please test the 64-bit (not 32-bit) version of http://cdimage.ubuntu.com/daily-live/current/ and advise to the results?

Download full text (5.0 KiB)

Sure

2015-09-27 20:11 GMT+02:00 Christopher M. Penalver <
<email address hidden>>:

> Rovanion, could you please test the 64-bit (not 32-bit) version of
> http://cdimage.ubuntu.com/daily-live/current/ and advise to the results?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1292036
>
> Title:
> Displayport on Thinkpad T420s is not usable
>
> Status in xserver-xorg-video-nouveau package in Ubuntu:
> Incomplete
>
> Bug description:
> Hi,
> I'm trying to connect an external screen to my thinkpad T420s. I'm
> running Ubuntu 14.04 and here is the output of xrandr:
>
> $ xrandr
> Screen 0: minimum 320 x 200, current 1600 x 900, maximum 32767 x 32767
> LVDS1 connected primary 1600x900+0+0 (normal left inverted right x axis
> y axis) 309mm x 174mm
> 1600x900 60.0*+ 40.0
> 1440x900 59.9
> 1360x768 59.8 60.0
> 1152x864 60.0
> 1024x768 60.0
> 800x600 60.3 56.2
> 640x480 59.9
> VGA1 disconnected (normal left inverted right x axis y axis)
> VIRTUAL1 disconnected (normal left inverted right x axis y axis)
>
> LVDS1 is the LCD-display on the laptop. This is the output of lspci:
>
> $ lspci | grep VGA
> 00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core
> Processor Family Integrated Graphics Controller (rev 09)
> 01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [NVS 4200M]
> (rev ff)
>
> The screen recognises that something is plugged into the DisplayPort
> but Ubuntu is unable to send output to it. It's probably related to
> the whole dual graphics card thing.
>
> Thank you for reading this bug!
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: xorg 1:7.7+1ubuntu8
> ProcVersionSignature: Ubuntu 3.13.0-16.36-generic 3.13.5
> Uname: Linux 3.13.0-16-generic i686
> ApportVersion: 2.13.3-0ubuntu1
> Architecture: i386
> CompizPlugins:
> [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
> CompositorRunning: None
> Date: Thu Mar 13 15:32:36 2014
> DistUpgraded: 2014-02-24 23:10:48,392 DEBUG enabling apt cron job
> DistroCodename: trusty
> DistroVariant: ubuntu
> EcryptfsInUse: Yes
> ExtraDebuggingInterest: Yes
> GraphicsCard:
> Intel Corporation 2nd Generation Core Processor Family Integrated
> Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
> Subsystem: Lenovo Device [17aa:21d3]
> NVIDIA Corporation GF119M [NVS 4200M] [10de:1056] (rev ff) (prog-if ff)
> InstallationDate: Installed on 2013-08-07 (217 days ago)
> InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release i386
> (20130213)
> MachineType: LENOVO 4174PEG
> ProcEnviron:
> TERM=xterm
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=sv_SE.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-16-generic
> root=UUID=7d44dac8-470f-4bb6-a331-e31a6e61ea51 ro quiet splash vt.hando...

Read more...

The results are in: I was unable to boot the daily image to desktop with modesetting turned on, the OS froze just as it reached the desktop; ctrl-alt-f1 didn't take me to a TTY. With modesetting off I was able to reach the desktop but the display settings tool didn't display any external screen with a screen connected over DP and xrandr showed nothing interesting at all.

Rovanion, could you please test the latest upstream kernel available from the very top line at the top of the page from http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D (the release names are irrelevant for testing, and please do not test the daily folder)? Install instructions are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds . This will allow additional upstream developers to examine the issue.

If the latest kernel did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this issue is fixed in the mainline kernel, please add the following tags by clicking on the yellow circle with a black pencil icon, next to the word Tags, located at the bottom of the report description:
kernel-fixed-upstream
kernel-fixed-upstream-X.Y-rcZ

Where X, Y, and Z are numbers corresponding to the kernel version.

If the mainline kernel does not fix the issue, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-X.Y-rcZ

Please note, an error to install the kernel does not fit the criteria of kernel-bug-exists-upstream.

Once testing of the latest upstream kernel is complete, please mark this report's Status as Confirmed. Please let us know your results.

Thank you for your understanding.

tags: added: wily
affects: xserver-xorg-video-nouveau (Ubuntu) → linux (Ubuntu)
Rovanion (rovanion-luckey) wrote :

I was able to test with the latest 4.3 rc3 kernel. The output of xrandr is no different to that above and neither lxrandr nor arandr was able to detect an external screen as they usually are when I plug them in on the VGA port.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-bug-exists-upstream-4.3-rc3

Rovanion, does using the proprietary nvidia drivers provide a WORKAROUND as outlined in https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia ?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Rovanion (rovanion-luckey) wrote :

I've got the nvidia proprietary drivers setup now and it makes no difference. Running:

$ optirun lxrandr

has the same effec, i.e. no external screens shown in the list, as running the normal

$ lxrandr

Changed in linux (Ubuntu):
status: Incomplete → Triaged

Computer: Lenovo Thinkpad T420
Ubuntu 16.10: Display port still don't work

I am using a cable displayport to Hdmi with an asus screen with no displayport (but 2xhdmi)

sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
83et79ww (1.49)
09/05/2016

in the bios : Screen not found, only the built in lcd.
in ubuntu: System/screen => both screens are detected although the 2nd screen seems not to receive any data & the screen shuts off automatically very fast (stand by)

Irwansurya (irwansur) on 2018-09-18
Changed in linux (Ubuntu):
status: Triaged → Fix Released
summary: - Displayport on Thinkpad T420s is not usable
+ Displayport pada Thinkpad T420s tidak dapat digunakan
Rovanion (rovanion-luckey) wrote :

In which release of which package was this fixed?

Brad Figg (brad-figg) on 2019-07-24
tags: added: cscc
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers