[Radeon HD 8670A][1002:6660] Unable to load into live desktop after clicked "Try Ubuntu" on 12.04.4 bootable usb drive

Bug #1290745 reported by Yung Shen on 2014-03-11
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Failed to load into live desktop after clicked the "Try Ubuntu" button on welcome screen.

Expected:
Log into live desktop

Actual result:
Following prompted window, trying to run low-graphic mode still not able to load the desktop, will fallback to console.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version k3.11.0-15-generic.
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 1: PCH [HDA Intel PCH], device 0: ALC292 Analog [ALC292 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 3516 F.... pulseaudio
 /dev/snd/controlC1: ubuntu 3516 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'MID'/'HDA Intel MID at 0xf7d34000 irq 48'
   Mixer name : 'Intel Haswell HDMI'
   Components : 'HDA:80862807,80860101,00100000'
   Controls : 21
   Simple ctrls : 3
Card1.Amixer.info:
 Card hw:1 'PCH'/'HDA Intel PCH at 0xf7d30000 irq 49'
   Mixer name : 'Realtek ALC292'
   Components : 'HDA:10ec0292,102805bd,00100001'
   Controls : 28
   Simple ctrls : 13
CasperVersion: 1.315.1
DistroRelease: Ubuntu 12.04
LiveMediaBuild: Ubuntu 12.04.4 LTS "Precise Pangolin" - Release amd64 (20140204)
MachineType: Dell Inc. Latitude E6440
MarkForUpload: True
Package: linux (not installed)
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB:
 0 inteldrmfb
 1 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/username.seed boot=casper quiet splash --
ProcVersionSignature: Ubuntu 3.11.0-15.25~precise1-generic 3.11.10
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-15-generic N/A
 linux-backports-modules-3.11.0-15-generic N/A
 linux-firmware 1.79.9
Tags: precise
Uname: Linux 3.11.0-15-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 07/03/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: X23
dmi.board.name: 02P3T1
dmi.board.vendor: Dell Inc.
dmi.board.version: X03
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrX23:bd07/03/2013:svnDellInc.:pnLatitudeE6440:pvr01:rvnDellInc.:rn02P3T1:rvrX03:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6440
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.
---
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: amd64
CasperVersion: 1.315.1
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
DistUpgraded: Fresh install
DistroCodename: precise
DistroRelease: Ubuntu 12.04
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, even including gdb or git bisection work if needed
GraphicsCard:
 Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:05bd]
   Subsystem: Dell Device [1028:05bd]
LiveMediaBuild: Ubuntu 12.04.4 LTS "Precise Pangolin" - Release amd64 (20140204)
MachineType: Dell Inc. Latitude E6440
MarkForUpload: True
Package: xorg 1:7.6+12ubuntu2
PackageArchitecture: amd64
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/username.seed boot=casper quiet splash --
ProcVersionSignature: Ubuntu 3.11.0-15.25~precise1-generic 3.11.10
Tags: precise ubuntu referred-by-support
Uname: Linux 3.11.0-15-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 07/03/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: X23
dmi.board.name: 02P3T1
dmi.board.vendor: Dell Inc.
dmi.board.version: X03
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrX23:bd07/03/2013:svnDellInc.:pnLatitudeE6440:pvr01:rvnDellInc.:rn02P3T1:rvrX03:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6440
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.7.12-0ubuntu3
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.46-1ubuntu0.0.0.1
version.libgl1-mesa-dri: libgl1-mesa-dri N/A
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core N/A
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

Yung Shen (kaxing) on 2014-03-11
tags: added: apport-collected precise
description: updated
tags: added: referred-by-support ubuntu
description: updated
Yung Shen (kaxing) wrote : Lspci.txt

apport information

apport information

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Yung Shen (kaxing) on 2014-03-11
summary: - Unable to load into live desktop after clicked "Try Ubuntu" on 12.04.4
- bootable usb drive
+ [Radeon HD 8670A][1002:6660] Unable to load into live desktop after
+ clicked "Try Ubuntu" on 12.04.4 bootable usb drive
Joseph Salisbury (jsalisbury) wrote :

Can you see if this issue also exists with the latest development release? It can be downloaded from:

http://cdimage.ubuntu.com/daily-live/current/trusty-desktop-amd64.iso

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Yung Shen (kaxing) wrote :

No, Live Desktop works fine with trusty-desktop-amd64.iso from 11-Mar-2014 07:51 on the same system.

Pali (pali) wrote :

Maybe there is problem with fglrx blob (closed amd radeon driver) and new kernel which is part of 12.04.4? Which version of fglrx is on 12.04.4 Live CD and which on above trusty-desktop-amd64.iso?

Po-Hsu Lin (cypressyew) on 2014-03-17
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Po-Hsu Lin (cypressyew) wrote :

Also affects 201305-13641
This system will enter the low-graphic mode when booting with 12.04.4 USB
Console (Ctrl+Alt+F1) works fine.

14.04 Trusty dailylive works fine on this system too.

00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Richland [Radeon HD 8610G] [1002:990f]
01:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A] [1002:6660]

Some error message could be found in dmesg:
[ 21.267329] [drm] radeon: irq initialized.
[ 21.287395] [drm] ring test on 0 succeeded in 1 usecs
[ 21.287404] [drm] ring test on 1 succeeded in 1 usecs
[ 21.287410] [drm] ring test on 2 succeeded in 1 usecs
[ 21.287474] [drm] ring test on 3 succeeded in 2 usecs
[ 21.287484] [drm] ring test on 4 succeeded in 1 usecs
[ 21.289263] [drm] ib test on ring 0 succeeded in 0 usecs
[ 21.289347] [drm] ib test on ring 1 succeeded in 0 usecs
[ 21.289536] [drm] ib test on ring 2 succeeded in 0 usecs
[ 21.289632] [drm] ib test on ring 3 succeeded in 0 usecs
[ 21.289736] [drm] ib test on ring 4 succeeded in 1 usecs
[ 21.290020] [drm] Radeon Display Connectors
[ 21.290029] [drm] Internal thermal controller without fan control
[ 21.290114] [drm] radeon: power management initialized
[ 21.290120] radeon 0000:01:00.0: No connectors reported connected with modes
[ 21.290123] [drm] Cannot find any crtc or sizes - going 1024x768
[ 21.292543] [drm] fb mappable at 0xE1150000
[ 21.292544] [drm] vram apper at 0xE0000000
[ 21.292546] [drm] size 3145728
[ 21.292547] [drm] fb depth is 24
[ 21.292548] [drm] pitch is 4096
[ 21.292795] radeon 0000:01:00.0: fb1: radeondrmfb frame buffer device
[ 21.293009] [drm:radeon_acpi_init] *ERROR* Cannot find a backlight controller
[ 21.293079] [drm] Initialized radeon 2.34.0 20080528 for 0000:01:00.0 on minor 1

Yung Shen (kaxing) wrote :

Since fglrx does not installed on live USB, it should not be a fglrx issue.

I've did a further testing with the same hardware,

By replacing xserver-xorg-lts-saucy 1:7.7_1ubuntu6~precise1 with xserver-xorg-lts-raring 1:7.7+1:ubuntu4~precise1 then restart X, now I can load into 12.04.4 live desktop.

Steps:

Boot with live usb or cd

Click on try ubuntu, wait until low graphic prompt

Switch to VT, ctrl-alt-F1

$ sudo apt-get update; sudo apt-get dist-upgrade

$ sudo apt-get remove xserver-xorg-lts-saucy
# ignored dpkg errors message

$ sudo apt-get install xserver-xorg-lts-raring
# ignored dpkg errors message

$ sudo service lightdm restart

Now you should see the live desktop.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Yung Shen (kaxing) on 2014-03-17
affects: xorg-lts-raring (Ubuntu) → xorg-lts-saucy (Ubuntu)
Changed in xorg-lts-saucy (Ubuntu):
status: New → Confirmed
Daniel Manrique (roadmr) on 2014-03-17
Changed in xorg-lts-saucy (Ubuntu):
importance: Undecided → Medium
Po-Hsu Lin (cypressyew) wrote :

Also affects 201305-13624 HP Pavilion 14 Notebook PC
With device [1002:6660]
It works with Trusty dailylive as well.

tags: added: 201305-13624
Po-Hsu Lin (cypressyew) wrote :

For 201305-13624 it also works with 12.04.3 LiveUSB

Po-Hsu Lin (cypressyew) on 2014-03-26
tags: added: 201305-13641
Po-Hsu Lin (cypressyew) wrote :

Also affects 201303-13115 HP Pavilion 14
 With device [1002:6660]
But it didn't work with Trusty dailylive anymore, I will double check other systems.

tags: added: 201303-13115
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-lts-saucy (Ubuntu):
status: New → Confirmed
Po-Hsu Lin (cypressyew) wrote :

Double checked with 14.04 dailylive (2014 Apr.2) on 201306-13688
It's not working, but it works with Beta2 image.
This might be a potential regression, bug 1301839 opened

Ara Pulido (ara) on 2014-04-03
tags: added: blocks-hwcert-enablement
Pali (pali) wrote :

After upgrading kernel to 3.14 (plus adding radeon.runpm=0 to kernel cmdline) and upgrading xserver ati/radeon & intel drivers from git (version in trusty is not enough!), then *both* graphics cards (via dri prime) on Dell Latitude E6440 in Ubuntu Precise 12.04.4 started working.

$ glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile
OpenGL version string: 3.0 Mesa 10.2.0-devel
OpenGL shading language version string: 1.30
OpenGL extensions:

$ xrandr --setprovideroutputsource 1 0
$ DRI_PRIME=1 glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD HAINAN
OpenGL version string: 2.1 Mesa 10.2.0-devel
OpenGL shading language version string: 1.30
OpenGL extensions:

You can find kernel 3.14 (works with precise) on:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14-trusty/

And xserver drivers in my PPA (for precise):
https://launchpad.net/~pali/+archive/graphics-drivers

Po-Hsu Lin (cypressyew) wrote :

Also affects 201309-14197 HP 242 G2
8086:0416 Intel Corporation 4th Gen Core Processor Integrated Graphics Controller
1002:6663 AMD Radeon HD 8570A/8570M

tags: added: 201precise
removed: precise
tags: added: 201309-14197 precise
removed: 201precise
no longer affects: xorg-lts-saucy (Ubuntu)
tags: added: bios-outdated-a11

Yung Shen, could you please test for this via http://cdimage.ubuntu.com/daily-live/current/ and advise to the results?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Yung Shen (kaxing) wrote :

@penalvch
tried on both stable vivid and 14.04.2 image,
it cannot be reproduce( and uma/integrated graphic is under use)

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.