cifs: connect: dfs doesn't work where servers using package signing are mixed with servers which don't use package signing

Bug #1285723 reported by Lorenz on 2014-02-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Joseph Salisbury
Precise
Medium
Joseph Salisbury

Bug Description

As mentioned in https://lkml.org/lkml/2014/2/27/360 this was fixed in commit 0b7bc84000d71f3647ca33ab1bf5bd928535c846.
Please backport it to the current LTS Ubuntu 12.04 kernel (3.2.0-53-generic )

Lorenz (lqb) on 2014-02-27
summary: - cifs: connect: dfs doesn't work where servers using package signing
- aremixed with servers which don't use package signing
+ cifs: connect: dfs doesn't work where servers using package signing are
+ mixed with servers which don't use package signing

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1285723

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: precise
Lorenz (lqb) wrote :

A solution is already mentioned.
apport logs might not be useful at this point.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: bot-stop-nagging kernel-da-key
Joseph Salisbury (jsalisbury) wrote :

This change will also require upstream commit:
8830d7e07a5e38bc47650a7554b7c1cfd49902bf

Changed in linux (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Joseph Salisbury (jsalisbury)
status: Confirmed → In Progress
Joseph Salisbury (jsalisbury) wrote :

I backported commit 0b7bc84000d71f3647ca33ab1bf5bd928535c846 and created a Precise test kernel with it applied.

The test kernel can be downloaded from:
http://kernel.ubuntu.com/~jsalisbury/lp1285723/

Can you test this kernel and post back if it resolves this bug or not?

Lorenz (lqb) wrote :

Yes, i will test it tomorrow. thx

Lorenz (lqb) wrote :

Mounting (used Options: sec=krb5,multiuser,auto,username=LB-TEST$) and using dfs seems to work.

Joseph Salisbury (jsalisbury) wrote :

Thanks for testing. I submitted a request for this to be included in upstream 3.2.y:

https://lkml.org/lkml/2014/2/28/490

I'll also submit an SRU request for Precise once we get feedback from upstream.

Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
assignee: nobody → Joseph Salisbury (jsalisbury)
status: New → In Progress
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise
Brad Figg (brad-figg) wrote :

Please verify this has been fixed.

Lorenz (lqb) wrote :

The kernel from jsalisbury worked at Feb, 28th (http://kernel.ubuntu.com/~jsalisbury/lp1285723/)

Today, I get the error-message: mount error(126): Required key not available
on both (
Linux 3.2.0-61-generic #92-Ubuntu SMP Mon Mar 31 23:47:59 UTC 2014
Linux 3.2.0-60-generic #91~lp1285723v1 SMP Thu Feb 27 21:14:31 UTC 2014
) kernels

I couldn't isolate the problem, yet.

Joseph Salisbury (jsalisbury) wrote :

Do you get the error message while using my kernel, or the kernel from -proposed? It would be great if you could test the -proposed kernel, if you are not already running it. Comment #8 has a link on how to enable proposed.

Joseph Salisbury (jsalisbury) wrote :

Just to clarify my comment. Does the -proposed kernel fix the original issue reported in this bug report? Or are you not able to confirm that due to this new "Required key not available" error?

Lorenz (lqb) wrote :

I am not able to confirm that the -proposed kernel solves the Problem. The "Required key not available" error might be a configuration error.

Brad Figg (brad-figg) on 2014-04-21
tags: added: verification-done-precise
removed: verification-needed-precise
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.2.0-61.92

---------------
linux (3.2.0-61.92) precise; urgency=low

  [ Kamal Mostafa ]

  * Release Tracking Bug
    - LP: #1300455

  [ Upstream Kernel Changes ]

  * cifs: set MAY_SIGN when sec=krb5
    - LP: #1285723
  * veth: reduce stat overhead
    - LP: #1201869
  * veth: extend device features
    - LP: #1201869
  * veth: avoid a NULL deref in veth_stats_one
    - LP: #1201869
  * veth: fix a NULL deref in netif_carrier_off
    - LP: #1201869
  * veth: fix NULL dereference in veth_dellink()
    - LP: #1201869
  * ioat: fix tasklet tear down
    - LP: #1291113
 -- Kamal Mostafa <email address hidden> Mon, 31 Mar 2014 14:33:18 -0700

Changed in linux (Ubuntu Precise):
status: In Progress → Fix Released
Changed in linux (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers