unable to boot after install on 2013 macbook air

Bug #1284085 reported by Richard Harding on 2014-02-24
62
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
linux (Ubuntu)
High
Unassigned

Bug Description

Booting and installing from a live usb for trusty does work. However, on restart the machine will not boot. It hangs at:

https://www.dropbox.com/s/behviox991o01o1/2014-02-23%2016.15.15.jpg

Per apw in #ubuntu-kernel a test to add nr_cpus=1 does work to boot the machine.

Note that wifi does not work at this point, but it does work in the live usb boot.

For more information I did hit this with both the 3.13.0-8 and 3.13.0-11 kernels as I tried to update.

--- Original notes ---

I'm attempting to install and run 14.04 trusty on a macbook air in a dual boot configuration. I have a Mac 64bit iso bootable usb device that I used to install on top of refind. The very first time I installed and setup it worked. I was in Ubuntu. I installed updates and some basic packages and when I rebooted it would no longer boot.

I had gotten an updated kernel so I attempted to boot to the older -08 kernel with no luck.

I then attempted to reinstall. I figured I could avoid updates for the moment. I used the USB stick to do an install using the "Remove 14.04 and install" option. When it was done, it would not boot just as before.

I attempted to use the usb stick to rebuild grub using http://howtoubuntu.org/how-to-repair-restore-reinstall-grub-2-with-a-ubuntu-live-cd with no luck.

I've tried setting boot params in grub of nomodeset noapic. When I turn off the quiet mode I get the following screenshot where it hangs very early in the boot process around "Booting SMP configuration".

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-generic 3.13.0.8.12
ProcVersionSignature: Ubuntu 3.13.0-8.28-generic 3.13.2
Uname: Linux 3.13.0-8-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.13.2-0ubuntu4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 3336 F.... pulseaudio
 /dev/snd/controlC1: ubuntu 3336 F.... pulseaudio
CasperVersion: 1.337
CurrentDesktop: Unity
CurrentDmesg: [ 149.733266] ERROR @wl_cfg80211_get_tx_power : error (-1)
Date: Mon Feb 24 07:08:09 2014
LiveMediaBuild: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64+mac (20140218)
MachineType: Apple Inc. MacBookAir6,1
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-8-generic N/A
 linux-backports-modules-3.13.0-8-generic N/A
 linux-firmware 1.124
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/12/2013
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBA61.88Z.0099.B07.1311121319
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-35C1E88140C3E6CF
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookAir6,1
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-35C1E88140C3E6CF
dmi.modalias: dmi:bvnAppleInc.:bvrMBA61.88Z.0099.B07.1311121319:bd11/12/2013:svnAppleInc.:pnMacBookAir6,1:pvr1.0:rvnAppleInc.:rnMac-35C1E88140C3E6CF:rvrMacBookAir6,1:cvnAppleInc.:ct10:cvrMac-35C1E88140C3E6CF:
dmi.product.name: MacBookAir6,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Richard Harding (rharding) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.13 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14-rc4-trusty/

Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → Incomplete
tags: added: kernel-da-key
Richard Harding (rharding) wrote :

Sorry for the delay. I had to wait to get an ethernet adapter so I could get network connectivity as wifi doesn't work on it currently after you leave the usb boot thumbdrive.

I've gotten network and verified that the latest kernel available in trusty, 3.13.0-16, does not work and has the same multi-cpu error.

I'll work those those notes to try to build an upstream kernel to see if that corrects things.

Richard Harding (rharding) wrote :

I tested out linux-image-3.14.0-031400rc5-generic_3.14.0-031400rc5.201403022235_amd64.deb

I had the same boot issue. It would not boot, but if I set nr_cpus=1 it would boot up fine. It hands at the same "Booting SMP configuration" point as the older kernels.

tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report[0]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

Please follow the instructions on the wiki page[0]. The first step is to email the appropriate mailing list. If no response is received, then a bug may be opened on bugzilla.kernel.org.

Once this bug is reported upstream, please add the tag: 'kernel-bug-reported-upstream'.

[0] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Jeff Pihach (hatch) wrote :

I'd like to add that this bug does not only effect Air's, I have the identical issue on a late 2013 Pro 15"

Joseph Salisbury (jsalisbury) wrote :

Are you able to boot without the nr_cpus parameter with older kernels? Was this not happening with prior Ubuntu releases? If you don't know, can you test a prior kernel, maybe the 3.11[0] or 3.2[1] upstream kernel:

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11-saucy/
[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/

Joseph Salisbury (jsalisbury) wrote :

You could also create a live CD with one of the earlier Ubuntu releases.

LiveCD info:
https://help.ubuntu.com/community/LiveCD

Earlier Ubuntu releases:
http://releases.ubuntu.com/

tags: added: kernel-key
removed: kernel-da-key
Jeff Pihach (hatch) wrote :

Thanks for the information!

On my late 2013 15" MBP I tried with the following versions:
14.04 3.13.0-17
14.04 3.13.0-20
3.10 3.11.0-12

None of which were able to boot past the stage in the image posted by the original reporter after installing.
But all were able to be run via usb livecd.
I was also not able to boot using nr_cpus.

Seth Forshee (sforshee) wrote :

From a little searching I turned up:

https://bugzilla.kernel.org/show_bug.cgi?id=60635

which indicates that this is a problem related to Apple's bios-compatible boot support, so one workaround is to do a native EFI install (which I think is a better option most of the time). I'd suggest using a boot manager like rEFInd.

Otherwise please boot up the machine with nr_cpus=1 (nosmp is also reported to work) and grab a copy of the ACPI tables by running 'sudo acpidump > acpi-tables.txt' in a terminal, then attach acpi-tables.txt to the bug. Also for comparison it might be useful if you did the same from an EFI boot (doing this when running from the installer iso is fine, the ACPI tables won't change).

Andy Whitcroft (apw) wrote :

Adding a Release Notes task as this is very confusing and needs manual work arounds to get out of.

Jeff Pihach (hatch) wrote :
Jeff Pihach (hatch) wrote :
Jeff Pihach (hatch) wrote :
Jeff Pihach (hatch) wrote :

Using nr_cpus=1 allowed 13.10 3.11.0-12 to boot

I've added the outputs from:
acpidump
dpkg -l | grep grub
dmesg

Seth Forshee (sforshee) wrote :

So that's definitely a legacy bios installation, which really isn't recommended anymore for most systems because EFI boot usually works fine and exposes more functionality.

I'd at least like to confirm that booting in native EFI works without nr_cpus=1. You should be able to just run 'sudo apt-get install grub-efi', then when you reboot rEFInd will have an option that's labeled something like "Boot EFI\ubuntu\grub64.efi". Use that one, remove nr_cpus=1, and let us know what happens. Note that this will remove grub-pc, but it doesn't actually erase grub so you should still be able to boot back to the legacy mode if something goes wrong.

I'm also curious whether you're intentionally doing the legacy bios install. If not, how exactly are you flashing the iso and starting the installer? The only way I can get that is to select the "Boot Legacy OS from HD" option to start the installer.

Jeff Pihach (hatch) wrote :

Thanks a lot! Installing via EFI worked like a charm, I was choosing the legacy os option every time. I'll add the acpi output from this install as well as you requested.

Thanks again,

Jeff Pihach (hatch) wrote :
Richard Harding (rharding) wrote :

I was using the OSX daily image from http://cdimage.ubuntu.com/daily-live/current/ which did not present the options for efi or legacy.

On Fri, Apr 04, 2014 at 01:28:23AM -0000, Richard Harding wrote:
> I was using the OSX daily image from http://cdimage.ubuntu.com/daily-
> live/current/ which did not present the options for efi or legacy.

The default 64-bit desktop image works fine on relatively recent Macs.
Maybe some of the older Intel Macs still need the Mac image, I'm
honestly not sure though.

Seth Forshee (sforshee) wrote :

If anyone still has the legacy bios install, I'd be interested to know if passing processor.nocst in the kernel boot options has any affect on the problem. Thanks!

Andy Whitcroft (apw) wrote :

It sounds like we are getting into this situation because people are using the +mac image when they do not need to. Some new text might be needed.

tags: added: kernel-da-key
removed: kernel-key

I have a 13 " MBP 11,1, I was running Ubuntu 14.04 which was working great for a period of time. After my battery died, it hangs with the same "booting SMP configuration node #0 CPUs #1" as described above.

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

  With the recent release of this Ubuntu release, would like to confirm if this bug is still present. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.13.0-24.46
Ofer Springer (ofersp) on 2014-06-19
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Ofer Springer (ofersp) wrote :

I have a MacBookPro11,1 (specific configuration is 2.6 i5/8GB/256-Flash) and using the standard (not mac) 14.04 ubuntu img results in the exact same behavior as above. I.e. I can boot from usb successfully but when booting the installed system the sequence stops immediately after the point where "booting SMP configuration node #0 CPUs #1" is printed.

Changed in ubuntu-release-notes:
status: New → Incomplete
wvengen (wvengen) wrote :

On my MacBookPro11,1 I installed 14.10 beta-2 and have the same problem. Booting from usb works, booting from harddisk not (after installation), booting from harddisk while passing nr_cpus=1 on kernel cmdline works (but only works with 1 core, obviously).

Víctor R. Ruiz (vrruiz) wrote :

In my MacBookAir (6,2) I just installed the last daily build of 14.10 and had the same problem. I can boot from the live CD but after install, it won't boot. I tried to re-run refind, but that doesn't fix it. Passing nr_cpus=1 does the trick, though.

wvengen (wvengen) wrote :

My problem of comment #27 was solved by picking a 14.10 daily-live amd64 image (without mac suffix - 14.10 beta-2 happened to only have images with the mac suffix).

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1284085

tags: added: iso-testing

On Fri, Oct 17, 2014 at 08:33:42AM -0000, wvengen wrote:
> My problem of comment #27 was solved by picking a 14.10 daily-live amd64
> image (without mac suffix - 14.10 beta-2 happened to only have images
> with the mac suffix).

The mac images really aren't needed except for quite old hardware.
Everyone else is much better off using the standard desktop images.

Also please see my request in comment #22.

Peter (pdevietien1) wrote :

Hello!

I'm quite unfamiliar with programming, but I'm a PhD student who wants to install Ubuntu on his Macbook Air6,2. I drink a lot of coffee and am more than willing to help, although I will need very explicit instructions.

I am experiencing this issue, and I tried to go in and set nr_cpus=1 (I pressed 'e' at the Ubuntu splash screen, and entered it there), but that didn't do anything (I would have been dumfounded if it did, as I had no idea what I was doing).

Seth. I would gladly try to pass processor.nocst in the kernel boot options if you are willing to give me instructions on how to do so (including setting nr_cpus=1).

Thanks!

Caio Begotti (caio1982) wrote :

Nope, processor.nocst=1 does not help. It still hangs reading the CPU info and that's it. The only way to boot the mac-type images in such state is using nr_cpus=1 in the boot options, which is pretty far from optional... I honestly don't remember how that happened but a few weeks ago I was stuck in this loop and eventually I just shut down my Macbook Air and in the next morning it was working again after the nr_cpus and processor.nocst tricks I've tried the night before. I wonder if a "clean" shut down after a successful boot cleans something up?

Anyway, I had this problem again today and I'm not running with a single core... until I have the time to back up and install the regular image from the site, not the crippled mac-type one. That's some really poor phrasing on the web site, it's getting people's machines in a broken state because it's not clear at all which image they should be downloading.

Yrjö Selänne (yselnne) wrote :

I bountied this and also found this page :
https://help.ubuntu.com/community/MacBookAir

Jeff Lane (bladernr) wrote :

I have trusty on a 2013 MBA 13" and ran into this exact problem...

I can at least confirm that Seth's comment #17 above seems to have been the solution... installing grub-efi seems to have fixed things.

What I find interesting is that it booted fine when I first installed and then after letting it sit for a few weeks (I dual boot with OSX using rEFInd) it stopped booting, hanging in exactly the same place mentioned in the original summary.

elishakratty (ekratty) on 2015-08-04
Changed in ubuntu-release-notes:
status: Incomplete → Opinion
Yrjö Selänne (yselnne) wrote :

There seems to be an issue on the 2015 model to:-

https://bugzilla.kernel.org/show_bug.cgi?id=108331 (Macbook 12inch 2015)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.