linux freezes with threadirqs parameter when rt73usb is loaded

Bug #1279081 reported by Kaj Ailomaa on 2014-02-11
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned
Trusty
High
Unassigned

Bug Description

While my usb wifi device is connected, the kernel will freeze while booting.
I can boot into recovery mode, but freeze happens as soon as I enable networking. I can boot and login fine without the device attached. As soon as I plug it in, the system freezes.

WORKAROUND: linux-lowlatency with boot parameter:
nothreadirqs

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-lowlatency 3.13.0.8.12
ProcVersionSignature: Ubuntu 3.13.0-8.27-generic 3.13.2
Uname: Linux 3.13.0-8-generic i686
ApportVersion: 2.13.2-0ubuntu2
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: zequence 2598 F.... pulseaudio
 /dev/snd/controlC2: zequence 2598 F.... pulseaudio
 /dev/snd/controlC0: zequence 2598 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory: 'iw'
CurrentDesktop: GNOME
Date: Tue Feb 11 22:02:39 2014
HibernationDevice: RESUME=UUID=ede81b37-17df-4f30-a234-1f1fb7f003ad
MachineType: Gigabyte Technology Co., Ltd. 965P-DS4
ProcFB: 0 nouveaufb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-8-generic root=UUID=7e51aea4-9325-401e-b318-bbf42e368c45 ro quiet splash
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-8-generic N/A
 linux-backports-modules-3.13.0-8-generic N/A
 linux-firmware 1.124
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: Upgraded to trusty on 2013-10-11 (123 days ago)
dmi.bios.date: 06/25/2009
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F12
dmi.board.name: 965P-DS4
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF12:bd06/25/2009:svnGigabyteTechnologyCo.,Ltd.:pn965P-DS4:pvr:rvnGigabyteTechnologyCo.,Ltd.:rn965P-DS4:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: 965P-DS4
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Kaj Ailomaa (zequence) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.13 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14-rc2-trusty/

Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: kernel-key
Joseph Salisbury (jsalisbury) wrote :

Also, does this issue only happen with the lowlatency kernel? Do you have a similar issue if you boot the -generic kernel?

On Tue, Feb 11, 2014, at 11:36 PM, Joseph Salisbury wrote:
> Also, does this issue only happen with the lowlatency kernel? Do you
> have a similar issue if you boot the -generic kernel?
>

Nope. This only happens with linux-lowlatency.

I tried booting linux-generic with the boot parameter "threadirqs", and it froze, just the same as linux-lowlatency.

So, I recommend removing the config that makes threadirqs a default boot parameter for linux-lowlatency, until the bug has been fixed.

Kaj Ailomaa (zequence) on 2014-02-13
summary: - linux-lowlatency freezes when rt73usb is loaded
+ linux freezes with threadirqs parameter when rt73usb is loaded
Joseph Salisbury (jsalisbury) wrote :

Can you try booting the lowlatency kernel with the "nothreadirqs" boot parameter?

Kaj Ailomaa (zequence) wrote :

I can confirm that booting linux-lowlatency with "nothreadirqs" boot parameter worked, while having the wifi device attached.

Joseph Salisbury (jsalisbury) wrote :

It would be good to know if when using the threadirqs parameter is a regression. If that is the case, we can bisect to identify the commit that introduced this.

Can you test the following kernels with the threadirqs parameter enabled and post back if any do not exhibit the bug:

v3.2 final: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/
v3.4 final: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-quantal/
v3.8 final: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-raring
v3.12 final: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-trusty/

You don't have to test every kernel, just up until the kernel that first has this bug. If 3.2 has the bug, no need to test the rest.

Thanks in advance!

Bharat Rajagopalan (mendred) wrote :

Hi there,

I can confirm that issue doesn't exist in v3.12 final. I have used both the generic version of that kernel (from the ppa) and a recompiled version with lowlatency params (which is right now the main kernel i am using in 14.04)

The issue exists in the latest 3.13 kernel as well i.e. 3.13.0.12 lowlatency - this works fine with my Xstation USB audio interface when i disable threadirqs

I am currently downloading the 3.14 rc2 debs - will test them and report back

Bharat

Bharat Rajagopalan (mendred) wrote :

I can confirm that this issue doesn't arise with 3.14-rc2 from the http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14-rc2-trusty/ ppa

Bharat

Joseph Salisbury (jsalisbury) wrote :

Can you also see if this bug is resolved in the latest 3.13 stable kernel, which can be downloaded from:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.13.5-trusty/

description: updated
Bharat Rajagopalan (mendred) wrote :

Hi,

I have tested the mainline kernel and also need to post a correction - this issue also arises in both the mainline and 3.14-rc2 just at a different stage to the earlier kernels

In the earlier kernels that i checked , the kernel would panic on boot i.e. before getting to the X login screen. On both the 3.13 mainline and 3.14-rc2, the kernel panics when logging in- it seems that it locks up when compositing is switched on but am not sure. I can't test this completely in 3.14 as i cant get fglrx to compile against it (i see the lockup happening when logging in).

I am able to boot and log into the kde session with compositing enabled on 3.13 mainline when i put in nothreadirq as a param so not too different from the earlier kernels

Bharat

Bharat Rajagopalan (mendred) wrote :

sounds like there is now a patch available - the following sounds similar to my issue

http://www.spinics.net/lists/linux-usb/msg102504.html

Joseph Salisbury (jsalisbury) wrote :

The following commit has landed in upstream v3.14-rc5:

commit a1227f3c1030e96ebc51d677d2f636268845c5fb
Author: Stanislaw Gruszka <email address hidden>
Date: Wed Feb 19 10:29:01 2014 +0100

    usb: ehci: fix deadlock when threadirqs option is used

It has also been cc'd to stable, so it will make it's way into the stable releases through the usual stable update process.

Tim Gardner (timg-tpi) on 2014-03-03
Changed in linux (Ubuntu Trusty):
status: Confirmed → Fix Committed
Joseph Salisbury (jsalisbury) wrote :

I built a Trusty test kernel that has a cherry pick of commit a1227f3c1030e96ebc51d677d2f636268845c5fb. This test kernel can be downloaded from:

http://kernel.ubuntu.com/~jsalisbury/lp1275116/

Can you test this kernel and confirm it resolves this bug? I built an i386 and amd_64 version of the kernel. You will need to install both the linux-image and linux-image-extra packages.

Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package linux - 3.13.0-16.36

---------------
linux (3.13.0-16.36) trusty; urgency=low

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #1287903

  [ Andy Whitcroft ]

  * Revert "[Config] lowlatency -- turn CONFIG_IRQ_FORCED_THREADING_DEFAULT
    off temporarily"

  [ Chris Bainbridge ]

  * SAUCE: x86: set Pentium M as PAE capable
    - LP: #930447

  [ Dave Jones ]

  * SAUCE: taint: repurpose TAINT_UNSAFE_SMP to TAINT_CPU_OUT_OF_SPEC
    - LP: #930447

  [ Paolo Pisati ]

  * [Config] SND_DAVINCI_SOC && SND_AM33XX_SOC_EVM =m
  * [Config] armhf: DRM_TILCDC=m

  [ Philippe Bergheaud ]

  * SAUCE: powerpc: fix xmon disassembler for little-endian
    - LP: #1286255

  [ Tim Gardner ]

  * [Config] CONFIG_MICROCODE_EARLY=y
  * [Config] CONFIG_R8821AE=m
  * [Config] Add some virtio drivers to -virtual
    - LP: #1287401
  * [Config] inclusion-list: vesafb and virtio_balloon are built-in
  * SAUCE: vmwgfx: Expose U32_MAX

  [ Upstream Kernel Changes ]

  * Revert "drm/vmwgfx: Fix regression caused by "drm/ttm: make ttm
    reservation calls behave like reservation calls""
  * Revert "drm/vmwgfx: Fix the driver for large dma addresses"
  * usb: ehci: fix deadlock when threadirqs option is used
    - LP: #1274987, #1279081
  * Staging: rtl8812ae: Add Realtek 8821 PCI WIFI driver
    - LP: #1287298
  * intel_pstate: Remove periodic P state boost
  * intel_pstate: Add trace point to report internal state.
  * intel_pstate: Take core C0 time into account for core busy calculation
  * intel_pstate: Use LFM bus ratio as min ratio/P state
  * intel_pstate: Add support for Baytrail turbo P states
  * intel_pstate: Change busy calculation to use fixed point math.
  * PM / hibernate: Fix restore hang in freeze_processes()
  * ipmi: remove deprecated IRQF_DISABLED
  * ipmi: use USEC_PER_SEC instead of 1000000 for more meaningful
  * ipmi: fix timeout calculation when bmc is disconnected
  * ipmi: Cleanup error return
  * ipmi: Add missing rv in ipmi_parisc_probe()
  * drm/ttm: ttm object security fixes for render nodes
  * drivers: gpu: Mark functions as static in vmwgfx_kms.c
  * drivers: gpu: Mark functions as static in vmwgfx_buffer.c
  * drivers: gpu: Mark functions as static in vmwgfx_fence.c
  * drm/vmwgfx: Fix the driver for large dma addresses
  * drm/vmwgfx: Update the svga3d register header file for new device
    version
  * drm/vmwgfx: Update the driver user-space interface for guest-backed
    objects
  * drm/vmwgfx: Replace vram_size with prim_bb_mem for calculation of max
    resolution
  * drm/vmwgfx: Update the svga register definition
  * drm/vmwgfx: Adapt capability reporting to new hardware version
  * drm/vmwgfx: Add MOB management
  * drm/vmwgfx: Hook up MOBs to TTM as a separate memory type
  * drm/vmwgfx: Read bounding box memory from the appropriate register
  * drm/vmwgfx: Add the possibility to validate a buffer as a MOB
  * drm/vmwgfx: Hook up guest-backed queries
  * drm/vmwgfx: Detach backing store from its resources when it is evicted
  * drm/vmwgfx: Hook up guest-backed contexts
  * drm/vmwgfx: Hook up guest-backed surfaces
  * drm/vmwgfx: Add guest-backed shaders
  * drm/vmwgfx: Validate guest...

Read more...

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released

Just did a test, and the kernel is booting fine for me now, with
threadirqs and the wifi device.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers