wifi can't be switched on by button on Acer Aspire 3000

Bug #127627 reported by Juranus on 2007-07-22
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: kernel acer-acpi module

There is button for WiFi at the front of notebook and it doesn't works properly. It can't be switched on.

ProblemType: Bug
Architecture: i386
Date: Sun Jul 22 23:00:30 2007
DistroRelease: Ubuntu 7.04
Package: hal 0.5.8.1-4ubuntu12
PackageArchitecture: i386
SourcePackage: hal
Uname: Linux ACER 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 GNU/Linux

Juranus (jiri-holasek) wrote :
Pierre Slamich (pierre-slamich) wrote :

On an Acer Aspire 1640Z, I have two buttons: one for bluetooth on the left which isn't supposed to do anything (this model doesn't have bluetooth), and one for wifi which lights up in orange when wifi is activated on Windows.
On Ubuntu, it seems to have an effect on wifi, but it doesn't light up when wifi is activated.
Is there a way to fix this ?
Can I help fixing it ?

Martin Pitt (pitti) wrote :

Did you enable it in the BIOS? Can you please try it on current hardy?

Changed in hal:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in hal:
status: Incomplete → Invalid
el es (el-es-poczta) wrote :
Download full text (7.8 KiB)

https://wiki.ubuntu.com/LaptopTestingTeam/AcerAspire3023 on this laptop, I need to modprobe the acer-acpi module with an wireless=1 option. I put it into /etc/modprobe.d/acer_acpi file, containing "options acer-acpi wireless=1' and then the wi-fi is enabled always.

This is what is added to /var/log/syslog when the wifi button is pressed (acer-acpi modprobe'd with wireless=1 option)

Jun 5 23:02:23 lukasz-laptop kernel: [ 4759.160188] atkbd.c: Unknown key released (translated set 2, code 0x55 on isa0060/serio0).
Jun 5 23:02:23 lukasz-laptop kernel: [ 4759.160199] atkbd.c: Use 'setkeycodes 55 <keycode>' to make it known.
Jun 5 23:02:23 lukasz-laptop kernel: [ 4759.160320] atkbd.c: Unknown key released (translated set 2, code 0x55 on isa0060/serio0).
Jun 5 23:02:23 lukasz-laptop kernel: [ 4759.160326] atkbd.c: Use 'setkeycodes 55 <keycode>' to make it known.
Jun 5 23:02:27 lukasz-laptop kernel: [ 4762.776658] wlan0: No ProbeResp from current AP[mac] - assume out of range
Jun 5 23:02:27 lukasz-laptop NetworkManager: <info> Supplicant state changed: 0
Jun 5 23:02:27 lukasz-laptop kernel: [ 4762.944500] b43-phy0: Radio turned on by software
Jun 5 23:02:28 lukasz-laptop kernel: [ 4763.693386] wlan0: Initial auth_alg=0
Jun 5 23:02:28 lukasz-laptop kernel: [ 4763.693400] wlan0: authenticate with AP [mac]
Jun 5 23:02:28 lukasz-laptop kernel: [ 4763.694907] wlan0: RX authentication from [mac] (alg=0 transaction=2 status=0)
Jun 5 23:02:28 lukasz-laptop kernel: [ 4763.694917] wlan0: authenticated
Jun 5 23:02:28 lukasz-laptop kernel: [ 4763.694923] wlan0: associate with AP [mac]
Jun 5 23:02:28 lukasz-laptop kernel: [ 4763.736066] wlan0: RX ReassocResp from [mac] (capab=0x411 status=0 aid=1)
Jun 5 23:02:28 lukasz-laptop kernel: [ 4763.736076] wlan0: associated
Jun 5 23:02:28 lukasz-laptop kernel: [ 4763.736084] wlan0: switched to short barker preamble (BSSID=[mac])
Jun 5 23:02:28 lukasz-laptop NetworkManager: <info> Supplicant state changed: 1

Upon modprobe'ing the acer-acpi module with debug=2 option :
Jun 5 23:13:27 lukasz-laptop kernel: [ 5489.107590] acer_acpi: Acer Laptop ACPI Extras version 0.11.1
Jun 5 23:13:27 lukasz-laptop kernel: [ 5489.107609] acer_acpi: Detected Acer AMW0 version 2 interface
Jun 5 23:13:27 lukasz-laptop kernel: [ 5489.108213] acer_acpi: Args: 0x00009610 0x0000a235 0x00000000 0x00000000
Jun 5 23:13:27 lukasz-laptop kernel: [ 5489.108219] acer_acpi: Wireless hardware available - enabling
Jun 5 23:13:27 lukasz-laptop kernel: [ 5489.108724] acer_acpi: Args: 0x00009610 0x00000234 0x00000000 0x00000000
Jun 5 23:13:27 lukasz-laptop kernel: [ 5489.109212] acer_acpi: Args: 0x00000086 0x00000000 0x00000000 0x00000000
Jun 5 23:13:27 lukasz-laptop kernel: [ 5489.109217] acer_acpi: Mail LED available - enabling
Jun 5 23:13:27 lukasz-laptop kernel: [ 5489.109221] acer_acpi: Finding quirks
Jun 5 23:13:27 lukasz-laptop kernel: [ 5489.109224] acer_acpi: Looking for quirks
Jun 5 23:13:27 lukasz-laptop kernel: [ 5489.109235] acer_acpi: No quirks known for this laptop
Jun 5 23:13:27 lukasz-laptop kernel: [ 5489.125272] Registered led device: acer_acpi:mail
Jun 5 23:13:27 luka...

Read more...

Changed in hal:
status: Invalid → New
el es (el-es-poczta) wrote :

Well this is not in Ubuntu as such only - and the binary package hint is wrong, it should be linux-kernel (as the acer-acpi module is mainstream).

Oh, and forgot :

root@lukasz-laptop:/etc/modprobe.d# uname -a
Linux lukasz-laptop 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686 GNU/Linux
root@lukasz-laptop:/etc/modprobe.d#

I did not test with 2.6.24-18.

description: updated

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

el es (el-es-poczta) wrote :

@Greg: Yes. I haven't however tried much to resolve this, must admit ;) I do not travel on a plane much these days so the rf-kill switch is not much an issue. Curently my uname is

{{{
lukasz@lukasz-laptop:~$ sudo uname -a
[sudo] password for lukasz:
Linux lukasz-laptop 2.6.24-19-generic #1 SMP Fri Jul 11 23:41:49 UTC 2008 i686 GNU/Linux
lukasz@lukasz-laptop:~$
}}}

The only difference is that it doesn't complain for the unknown keycode in dmesg any more when the rfkill is pressed/released.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Simon Wenner (nowic) wrote :

I made a fresh Install of hardy on a Acer Aspire 3000 and the wlan switch still does not work. Due to this problem I'm not able to configure wlan at all.

I donwloaded Intrepid Ibex Alpha 6 as requested. I only tested the LiveCD mode. There are no improvements as far as I can see. I pressed the button several times. See dmesg for the error messages:

[ 1220.956614] atkbd.c: Unknown key released (translated set 2, code 0xd6 on isa0060/serio0).
[ 1220.956621] atkbd.c: Use 'setkeycodes e056 <keycode>' to make it known.
[ 1221.758620] atkbd.c: Unknown key pressed (translated set 2, code 0xd8 on isa0060/serio0).
[ 1221.758627] atkbd.c: Use 'setkeycodes e058 <keycode>' to make it known.

If you need any other logs/info please tell me as soon as possible, as I have only for some days access to this system.

ubuntu@ubuntu:~$ sudo uname -a
Linux ubuntu 2.6.27-3-generic #1 SMP Wed Sep 10 16:02:00 UTC 2008 i686 GNU/Linux

ubuntu@ubuntu:~$ sudo lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 760/M760 Host (rev 03)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SG86C202
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media IO] (rev 25)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 91)
00:06.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter

Simon Wenner (nowic) wrote :
fj401971 (fj401971) wrote :

Hardware: Acer TravelMate 8000

Confirmed, that this bug still exists in Ubuntu 8.10 Intrepid with the 2.6.27-7-generic kernel.

dmesg output when button is pressed and pressed again:

[29879.185623] ipw2200: Firmware error detected. Restarting.
[31889.482986] ipw2200: Failed to send SSID: Command timed out.
[31899.383425] ipw2200: Failed to send CARD_DISABLE: Command timed out.
[31899.383440] firmware: requesting ipw2200-bss.fw
[31899.830479] ADDRCONF(NETDEV_UP): eth1: link is not ready
[31899.850045] firmware: requesting ipw2200-ibss.fw
[31900.288454] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready

The button does work, in order to get wireless to work, the button must be pressed twice after startup. After that, it can be pushed once to turn on/off. This problem has occurred since Ubuntu 7.04

Changed in linux:
assignee: nobody → ubuntu-kernel-team
status: Confirmed → Triaged

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

fj401971 (fj401971) wrote :

On an Acer TravelMate 8000, I was able to get the wireless LED working by using the following:

From the System76 website: http://knowledge76.com/index.php/Wireless_LED_on_Ubuntu

sudo -s
echo "options ipw2200 led=1" >> /etc/modprobe.d/ipw2200.modprobe
modprobe -r ipw2200
modprobe ipw2200
exit

Jaunty fixed the led on my Acer Aspire 1640z.
What about other models ?

Tim Gardner (timg-tpi) wrote :

Fixed in Jaunty, see LP #319825

Changed in linux (Ubuntu):
status: Triaged → Fix Released

As the acer-wmi maintainer, I can reliably inform you this is _not_ a duplicate of 319825 and needs to be reopened, as it is not resolved.

Basically, this bug seems to have spawned into three separate and unrelated issues:

1) The original issue - wireless button on the front of the TravelMate 8000 doesn't work.

Given that the TM 8100 isn't supported by acer-wmi, I suspect the TravelMate 8000 also falls into this category. So whatever issue is causing the problem there, it is not acer-wmi related. And it is still not resolved, as other replies have pointed out (and the bug in question referenced isn't related to this, so I don't know why this was closed as a duplicate of the Aspire One bug...)

2) Issue #2 - an aside about acer_acpi on the Aspire 3020 series needing some magic to be autoloaded. Not relevant or related to the original issue.

3) Issue #3 - broken wireless LED on the Aspire 1640 series. Appears to have been fixed, likely due to a wireless driver issue. (and not acer-wmi related, since acer-wmi doesn't support this laptop).

Dimitrios Symeonidis (azimout) wrote :

removed duplicate, setting back to "triaged"

Changed in linux (Ubuntu):
status: Fix Released → Triaged
Dimitrios Symeonidis (azimout) wrote :

re-assigning to hotkey-setup

affects: linux (Ubuntu) → hotkey-setup (Ubuntu)
Steve Langasek (vorlon) wrote :

Has nothing to do with hotkey-setup. Reassigning back to the kernel where this belongs.

affects: hotkey-setup (Ubuntu) → linux (Ubuntu)
Simon Wenner (nowic) wrote :

Tested with the live CD of karmic (9.10), and the switch still does not work.

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
korgman (korgie) wrote :

I'm in acer 1640z and I just presses the right led. I connected to the network.

Ubuntu 12.04.

Weird stuff: I connected external wifi via pcmcia and the message was the same: wifi is disabled via switch (!!!) But this is for another bug report.

Mark as fixed in Ubuntu 12.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers