10ec:8178 Wireless not working in 13.10 and 14.04 for rtl8192ce (RTL8188CE)/asus pce-n15

Bug #1268833 reported by obedlink on 2014-01-14
108
This bug affects 21 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

in ubuntu / kubuntu 13.10/14.04 with kernel version lower than 3.12 network manager asks the wifi password again and again.

using the kernel 3.13rc7 or higher connection is successful, but no access to internet or the router, the ping command is not responding.

obed@Kubuntu:~$ sudo lshw -C net
[sudo] password for obed:
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: eth0
       version: 06
       serial: 8c:89:a5:2a:27:e2
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168e-3_0.0.4 03/27/12 ip=192.168.1.65 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:51 ioport:d000(size=256) memory:d0004000-d0004fff memory:d0000000-d0003fff
  *-network
       description: Wireless interface
       product: RTL8188CE 802.11b/g/n WiFi Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: wlan0
       version: 01
       serial: f4:6d:04:a2:9f:dd
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8192ce driverversion=3.12.0-031200-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:19 ioport:c000(size=256) memory:fb300000-fb303fff
obed@Kubuntu:~$
---
ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
DistroRelease: Ubuntu 13.10
InstallationDate: Installed on 2014-01-10 (3 days ago)
InstallationMedia: Kubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MarkForUpload: True
Package: linux (not installed)
Tags: saucy
Uname: Linux 3.13.0-999-generic x86_64
UnreportableReason: The running kernel is not an Ubuntu kernel
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin netdev plugdev sambashare sudo
---
ApportVersion: 2.12.5-0ubuntu2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: kubuntu 4941 F.... pulseaudio
 /dev/snd/controlC2: kubuntu 4941 F.... pulseaudio
 /dev/snd/controlC1: kubuntu 4941 F.... pulseaudio
CasperVersion: 1.336ubuntu1
DistroRelease: Ubuntu 13.10
LiveMediaBuild: Kubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MachineType: MSI MS-7681
MarkForUpload: True
Package: linux (not installed)
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/username.seed boot=casper maybe-ubiquity initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-12-generic N/A
 linux-backports-modules-3.11.0-12-generic N/A
 linux-firmware 1.116
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Tags: saucy
Uname: Linux 3.11.0-12-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 05/31/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V22.2
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Z68A-GD65 (MS-7681)
dmi.board.vendor: MSI
dmi.board.version: 4.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MSI
dmi.chassis.version: 4.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV22.2:bd05/31/2011:svnMSI:pnMS-7681:pvr4.0:rvnMSI:rnZ68A-GD65(MS-7681):rvr4.0:cvnMSI:ct3:cvr4.0:
dmi.product.name: MS-7681
dmi.product.version: 4.0
dmi.sys.vendor: MSI

description: updated

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1268833

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: trusty

apport information

tags: added: apport-collected saucy
description: updated

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.13 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.13-rc8-trusty/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report[0]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

Please follow the instructions on the wiki page[0]. The first step is to email the appropriate mailing list. If no response is received, then a bug may be opened on bugzilla.kernel.org.

Once this bug is reported upstream, please add the tag: 'kernel-bug-reported-upstream'.

[0] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Sergio Benjamim (sergio-br2) wrote :

Same here, but maybe this wifi card is a little bit different:

Linux xubuntu 3.13.0-18-generic #38-Ubuntu SMP Mon Mar 17 21:39:16 UTC 2014 i686 i686 i686 GNU/Linux

baseboard-manufacturer: ASUSTeK Computer INC.
baseboard-product-name: P5KPL-CM
baseboard-version : x.xx
system-manufacturer : System manufacturer
system-product-name : System Product Name
system-version : System Version
bios-vendor : American Megatrends Inc.
bios-version : 0702
bios-release-date : 08/27/2010

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8192CE PCIe Wireless Network Adapter (rev 01)

  *-network
       description: Wireless interface
       product: RTL8192CE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: e0:8f:ec:00:d3:61
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8192ce driverversion=3.13.0-18-generic firmware=N/A ip=163.173.118.14 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 ioport:e800(size=256) memory:febfc000-febfffff

José Marinho (jmarinho) wrote :

I have the same issue. My wifi card is:

01:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
 Subsystem: Device 7392:7622
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 4 bytes
 Interrupt: pin A routed to IRQ 16
 Region 0: I/O ports at de00 [size=256]
 Region 2: Memory at fbdfc000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: rtl8192ce
 Kernel modules: rtl8192ce
Now running ubuntu 12.04 with generic kernel (3.2) and I found a solution that works fine for me. The solution is install the realtek driver that was modified for the user Freedon Ben (the second one answering) in this thread from Askubuntu: http://askubuntu.com/questions/342076/step-by-step-ubuntu-12-04-install-of-realtek-rtl8188ce-driver

I tested it with kernel 3.11 (ubuntu 13.10) and worked fine too.

I'm not an advanced user, so I can't give tecnichal information but esentially what I experience is that I lose the connection frecuently and with this solution the wifi card works non stop. The creator says that works with Ubuntu kernels (3.2, 3.8 and 3.11) and with Fedora 19 and 20 but he doesn't know if that works with other kernels or linux distributions.

obedlink (obedlink-gmail) wrote :

I notify the problem to the maintainer of the kernel, larry finger and he said the following:

"There are a lot of changes in this driver in the wireless-testing tree that will not be in the mainline tree until 3.14. Please generate a kernel from that repo."

actually there were changes affecting the kernel wifi drivers, but I'm currently be using the most current kernel that appears on the website of ubuntu mainline kernel.

the problem persists. this problem appeared in the kernel v.3.9

Sergio Benjamim (sergio-br2) wrote :

I installed kernel 3.14.0-031400rc7 from ubuntu mainline, and it is not working too.

The git repo from this FreedomBen has not a branch for kernel 3.13 or 3.14, so it is useless to trusty (well, i don't know if it's possible to use ubuntu-13.10 branch for trusty). And there is a issue reported, with wifi connection ok but without internet connection:

https://github.com/FreedomBen/rtl8188ce-linux-driver/issues/7

summary: - Wireless not working in 13.10 and 14.04 for rtl8192ce (RTL8188CE)/asus
- pce-n15
+ 10ec:8178 Wireless not working in 13.10 and 14.04 for rtl8192ce
+ (RTL8188CE)/asus pce-n15

Just tested an rtl8188ce with Ubuntu 14.04 (with kernel 3.13.0-24).
The wifi works, but performance is low

Pietrek B. (ptrbrzozowski) wrote :

Some thing here for me on Ubuntu 13.10/daily snaphot of 14.04 (from 10.04.2014) I have an MSI U2700 with Realtek 8188CE and it's totally useless with these newer kernels. Connection drops, packets get lost, signal strenght bounces around even 2 meters from the router. Tried disabling power-saving using "options rtl8192ce swlps=0 ips=0" - still useless.

Any help?

Shichao Wang (sw9) wrote :

I am experiencing the connection drops with Realtek 8188CE on the 64bit version of Ubuntu 14.04 but not in the 32bit version. Using wavemon, it appears that the signal strength rarely drops below -72 dBm in the 32 bit version but it frequently does so in the 64 bit version even though I haven't moved my laptop nor changed anything besides rebooting.

I installed a 32 bits 14.04 and I don't see any difference. That said, in my case I don't see connection drops, I only see really poor performance, compared with other gear I have in the house.
Using wavemon the signal strength and the link quality are similar on the same spot with different hardware, but the bitrate is an awfull lot lower (1 Mbit/s compared to 36 Mbit/s at a reasonable distance from the router) and with max power (100mW - power management apparently off be default), while my faster gear is happy with 39,81 mW.

Shichao Wang (sw9) wrote :

I compared my wavemon results under 32 bit 14.04 to signal strength in dBm under Windows 8.1 64 bit and they were similar. So it seems, at least in my case, that 64 bit Ubuntu is the odd man out. lspci outputs "02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01)" if that's at all relevant. Perhaps there are different varieties of rtl8188ce?

José Marinho (jmarinho) wrote :

For me, the situation is getting worst: I try a live session with a ISO of the final release of Trusty (64 bits) and now the system, despite it recognizes the card, but when I try to log in my wifi network it's impossible because it acts as if I write an incorrect password and always ask me to introduce my password over and over again without any conexion. Before on beta ISO'S that didn't happen, the only thing was that the connexion were very poor and failed frecuently ,but at least, I could connect to my router. My wifi card:

01:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)

newuser (newuser) wrote :

Same problem here, wifi is not working under kernel 3.13.0-24 but works just well under kernel 3.13.0-23.
I tested upstream kernels (3.15rc1, rc2 but the problem still exists).

Maybe caused by this fix: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1296591

01:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter [10ec:8179] (rev 01)
Subsystem: Hewlett-Packard Company Device [103c:197d]
Kernel driver in use: rtl8188ee

Adam Lee (adam8157) wrote :

@newuser your issue is not related to this bug, and #1296591 is not related to this bug either(judging by kernel version)

Dimitree (dimitree) wrote :

Can Linux stop breaking things please?
How is it that this card worked in all distros before and all of a sudden is performing bad, disconnects, loses signal, can't connect?!
Will you people stop breaking it?!
I really don't understand who's business it is to break working things, and who are the people to regulate against such things?!

jbus (jbus) wrote :

I'm having the same problems as others here on Ubuntu 14.04 & 14.10 Daily. Poor performance, packet loss, disconnects on my Thinkpad E420 with a RTL8188CE. The driver for the 8188CE evidently works just fine in previous versions of Ubuntu since it seems to work well with no problems in ElementaryOS Luna, which is based on 12.04LTS.

Toshiba NB500, with rtl8188ce wireless card.

Lubuntu 14.04 32 bit up-to-date. Tested with 3.13.0.32, 3.13.0.36 & 3.13.0.37.

The wifi is unstable. The connection is lost after about 30 minutes. Reboot is needed for reconnecting.

Tried different solutions:

http://askubuntu.com/questions/456453/realtek-rtl8188ce-wireless-driver-unstable-in-ubuntu-14-04

http://askubuntu.com/questions/414974/realtek-rtl8192ce-wireless-slow-intermittent-access

http://askubuntu.com/questions/503763/connection-dropouts-with-realtek-rtl8188ce

https://github.com/FreedomBen/rtl8188ce-linux-driver

The best solution (for me) seems to be:

echo "options rtl8192ce ips=0 fwlps=0 swlps=0 swenc=0" | sudo tee /etc/modprobe.d/rtl8192ce.conf
sudo reboot

I'm testing now. It seems to increment stability but after 1 or 2 hours, no connection.

I'm using iwevent on a terminal to control how much time it takes to fail.

The command:

modinfo rtl8192ce

provides some information about the options for the module rtl8192ce (used for the rtl8188ce card).

And:

systool -v -m rtl8192ce

permits to see the state of these options. For systool, package sysfsutils is needed.

I have more than 100 netbooks with this problem. They used 10.04 and 12.04 before, without this problem!

* Tested with 3.13.0.32, 3.13.0.36 & 3.13.0.37 kernels.

Testing Toshiba NB500 (32 bit) with 3.14.1 kernel...

Module rtl8192ce has these default options:

fwlps=1
ips=1

and it's UNSTABLE. Connection lost after about 30 minutes. Nor more iwevent. nm-applet doesn't show wifis anymore.

Tried the parameters used by the FredomBen driver ( https://github.com/FreedomBen/rtl8188ce-linux-driver ):

echo "options rtl8192ce ips=1 fwlps=0 swlps=0 swenc=1" | sudo tee /etc/modprobe.d/rtl8192ce.conf
sudo reboot

It seems to be STABLE. I started the test 3 hours ago and the connection is still alive!

With 3.14.1 kernel...

ips=1 fwlps=0 swlps=0 swenc=1 makes the connection stable but I have troubles at startup.

Not always, but many times wifi doesn't connect at startup. At syslog it says time out connecting to the AP.

Returning to original fwlps=1 ips=1 (no /etc/modprobe.d/rtl8192ce.conf file) and no problems at startup.

Trying with rtlwifi_new drivers ( https://github.com/lwfinger/rtlwifi_new )...

With last 14.04 LTS official (32 bit) kernel, 3.13.0.37

sudo apt-get update
sudo apt-get -y install git
git clone http://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new
make
sudo make install
sudo reboot

It seems to be STABLE after 2 hours.

krot (krot-mstu) wrote :

Hi Team,
I have the same isue. I've tryed this drivers, but it didn't help. The same issue.

Sasha (marusic-sasha) wrote :

So, has this been fixed yet? Been struggling with this c*** for over a year now. So annoying. I have 100Mbit(10MB speed). line and I am lucky if I could pull off 15Mbit STABLE over a periode of several hours. Normally it jumps all over. From as low as 3-4Mbit! I did a ping on www.google.com and the return on the packets were dismal. The ping was ranging from 7 m/s and jumping to 1000m/s.

When connected with cable everything works perfect. When I am on wireless all hell breaks loose. Everything lags, indefinitenly. Restarting computer fixes the problem for a periode but then it's all back. I have the rtl8192ce version.

Though, after following these steps, even though it was for rtl8192cu version, it boosted my speed to 45Mbit(the loss is still 50Mbit) but the internet hasn't opened this quick for I don't know how long. And when I test my speed it is showing constant speed at 44-46Mbit. Which is pretty darn good considering what I had just few hours ago.

Try this:

https://sites.google.com/site/easylinuxtipsproject/reserve-7

Btw, can someone please post some updates on this thread. Has this issue been completely solved or is this still unsolved?

Kevin (wittyman37) wrote :

This problem is present for me with Ubuntu 14.04 with linux 3.13.0-49-generic and an ASUS PCE-N15.

Kevin (wittyman37) wrote :

I just installed the 4.0 kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/ on my 14.04 system and so far things are much better! `iwconfig` used to report 1 Mb/s and now it reports 54 Mb/s.

Sergio Fdez (sergui2002) on 2015-07-25
Changed in linux (Ubuntu):
status: Triaged → Confirmed
Ta (talu4513) wrote :

So is there a resolution to this. Do i need to upgrade to Ubuntu 15 in order to get the new kernel?

Ta (talu4513) wrote :

I updated my kernel to 4.2
https://wiki.ubuntu.com/Kernel/LTSEnablementStack

The connection is fast after a reboot but it seems to be slowing down after a while

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers