14e4:4727 [Asus 1015PE] BIOS WiFi was changed to disabled upon installation of Ubuntu 13.10

Bug #1264863 reported by Jeffrey Warren on 2013-12-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Initially, in my BIOS the WiFi was enabled. I successively upgraded from 12.04 LTS to 12.10 to 13.04 to 13.10 on my Asus EEE PC 1015PED, and upon booting, I saw "wifi disabled via hardware switch" in the network-manager toolbar menu. rfkill list returned
4: brcmwl-0: Wireless LAN
 Soft blocked: no
 Hard blocked: yes

and I wasn't able to use the hardware switch (Fn-F2 or the custom button) or sudo rfkill unblock all to enable it.

WORKAROUND: Enable it in the BIOS.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: linux-image-3.11.0-14-generic 3.11.0-14.21
ProcVersionSignature: Ubuntu 3.11.0-14.21-generic 3.11.7
Uname: Linux 3.11.0-14-generic i686
NonfreeKernelModules: wl
ApportVersion: 2.12.5-0ubuntu2.2
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: warren 2306 F.... pulseaudio
CurrentDmesg:
 [ 24.161461] init: anacron main process (1036) killed by TERM signal
 [ 51.494938] atl1c 0000:01:00.0: irq 46 for MSI/MSI-X
 [ 51.509895] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
 [ 51.515677] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
 [ 64.223104] perf samples too long (2525 > 2500), lowering kernel.perf_event_max_sample_rate to 50000
Date: Sun Dec 29 11:40:56 2013
HibernationDevice: RESUME=UUID=f83d49e0-b9d7-4bb9-8a7c-eca9b7eb48c5
InstallationDate: Installed on 2012-01-18 (711 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
MachineType: ASUSTeK Computer INC. 1015PE
MarkForUpload: True
ProcFB:
 0 inteldrmfb
 1 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-14-generic root=UUID=224d803b-2f44-4541-8acb-508041eb63f7 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-14-generic N/A
 linux-backports-modules-3.11.0-14-generic N/A
 linux-firmware 1.116
SourcePackage: linux
UpgradeStatus: Upgraded to saucy on 2013-12-28 (1 days ago)
dmi.bios.date: 06/12/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0502
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1015PE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0502:bd06/12/2010:svnASUSTeKComputerINC.:pn1015PE:pvrx.x:rvnASUSTeKComputerINC.:rn1015PE:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
dmi.product.name: 1015PE
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.

Jeffrey Warren (jeff-t) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
affects: linux (Ubuntu) → network-manager (Ubuntu)
Changed in network-manager (Ubuntu):
status: Confirmed → Invalid
Jeffrey Warren (jeff-t) wrote :

Hello - thank you Christopher. I will post something there, but WiFi was not disabled before Ubuntu was updated; something in the update process disabled it. I imagine it might still be difficult or impossible to re-enable it in software, but I think a helpful indication *in the wifi settings interface* might do a lot to help people solve this bug in the future. This could be in Network Manager or in the Network system prefs pane.

Thank you!

affects: network-manager (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Invalid → Incomplete
summary: - WiFi disabled in BIOS upon installation of Ubuntu 13.10
+ 14e4:4727 [Asus 1015PE] WiFi disabled in BIOS upon installation of
+ Ubuntu 13.10
tags: added: bios-outdated-1202

Jeffrey Warren as per :
[ 0.136514] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored

Hence, as per http://www.asus.com/Notebooks_Ultrabooks/Eee_PC_1015PE_Seashell/#support an update is available for your BIOS (1202). If you update to this following https://help.ubuntu.com/community/BiosUpdate , does it change anything?

If not, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful.

For more on BIOS updates and linux, please see https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette .

Thank you for your understanding.

Jeffrey Warren (jeff-t) wrote :

Hello Christopher - yes, it was enabled before and not after. However, as I've already completed the upgrade, I'm not confident that I can provide helpful information on whether the 13.10 upgrade (or 13.04 or 12.10) cause this to happen again. While it's frustrating not to be able to test the change, it's a bit much for me at this time to reinstall/downgrade my system to confirm it.

The BIOS upgrade seems like a reasonable suspect, and as you suggest, having an old BIOS makes my bug report less relevant. Thank you again!

summary: - 14e4:4727 [Asus 1015PE] WiFi disabled in BIOS upon installation of
- Ubuntu 13.10
+ 14e4:4727 [Asus 1015PE] BIOS WiFi was changed to disabled upon
+ installation of Ubuntu 13.10
description: updated
Changed in linux (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers