Kubuntu 14.04 freezes after LightDM login

Bug #1264807 reported by hyper_ch on 2013-12-29
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

I have re-setup my notebook with Kubuntu 14.04. I have an nVidia Optimus platform and hence wanting to try out kerne 3.12 with native switching support. Also the whole system is encrypted with LUKS/dm-crypt.

At bootup I get nicely prompted for the LUKS key, I enter it and afterwords I end up at LightDM. I provide the password there and then the KDE screen appears on which different icons would appear within seconds. However the computer freezes at that point - or rather the display freezes.

I tried to ctrl-alt-f2 but that didn't open a terminal.

Upon suggestion, I then tried to ssh into the computer. That worked fine.

So it seems there are graphic problems or something. In order to use that installation I currently use the Saucy kernel.

While SSHing I made a backup of the whole /var/log folder. I don't know which of them are relevenat but I can provide them when asked.

According the lshw I have:

product: GF119M [GeForce GT 520M]
vendor: NVIDIA Corporation

and

product: 2nd Generation Core Processor Family Integrated Graphics Controller
vendor: Intel Corporation
---
ApportVersion: 2.12.7-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: hyper 2607 F.... pulseaudio
 /dev/snd/controlC1: hyper 2607 F.... pulseaudio
 /dev/snd/pcmC1D0p: hyper 2607 F...m pulseaudio
CRDA: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
CurrentDesktop: KDE
DistroRelease: Ubuntu 14.04
MachineType: ASUSTeK Computer Inc. U36SD
MarkForUpload: True
Package: linux (not installed)
ProcFB:
 0 inteldrmfb
 1 nouveaufb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.11.0-15-generic root=UUID=8f533cbf-2fab-4d0c-b9df-ab113f79f022 ro splash quiet pcie_aspm=force vt.handoff=7
ProcVersionSignature: Ubuntu 3.11.0-15.23-generic 3.11.10
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-15-generic N/A
 linux-backports-modules-3.11.0-15-generic N/A
 linux-firmware 1.117
Tags: trusty
Uname: Linux 3.11.0-15-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 07/12/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: U36SD.205
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: U36SD
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrU36SD.205:bd07/12/2011:svnASUSTeKComputerInc.:pnU36SD:pvr1.0:rvnASUSTeKComputerInc.:rnU36SD:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: U36SD
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1264807/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1264807

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: trusty

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Since I rebooted multiple times and I have the logs on tmpfs the current logs are of now use IMHO. Also running apport-collect 1264807 didn't attach anything here but opened a new screen with "Ask a question"

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: bios-outdated-206

hyper_ch, thank you for reporting this and helping make Ubuntu better. As per your https://launchpadlibrarian.net/161032660/BootDmesg.txt :
[ 1.770772] [drm] Wrong MCH_SSKPD value: 0x16040307
[ 1.770774] [drm] This can cause pipe underruns and display issues.
[ 1.770775] [drm] Please upgrade your BIOS to fix this.

Hence, as per http://support.asus.com/download.aspx?SLanguage=en&m=U36SD&os=30 an update is available for your BIOS (206). If you update to this following https://help.ubuntu.com/community/BiosUpdate , does it change anything? If it doesn't, could you please both specify what happened, and just provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful.

For more on BIOS updates and linux, please see https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette .

Thank you for your understanding.

Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → Incomplete

That was it..... downloaded the Bios Update ISO from Asus and put it on a usb stick with unetbootin.... updated BIOS and now it works.

Thx, this can be closed.

hyper_ch, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1264807/comments/20 regarding this being fixed with a BIOS update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers