Ubuntu

No external microphone detected on the Dell machines with realtek codec

Reported by Hui Wang on 2013-12-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Status tracked in Trusty
Trusty
High
Hui Wang
linux (Ubuntu)
High
Hui Wang
Declined for Quantal by Brad Figg
Declined for Raring by Brad Figg
Saucy
Undecided
Unassigned

Bug Description

Steps:
1. boot into OS
2. Plugin a 3-ring headset into the headset port
3. Go to "sound setting" > "input" tab and check if external mic is detected
4. Launch sound recorder and try to record sound from external mic

This bug is for tracking purposes, please do not triage.

Hui Wang (hui.wang) on 2013-12-12
tags: added: blocks-hwcert-enablement
Changed in hwe-next:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Hui Wang (hui.wang)
Hui Wang (hui.wang) wrote :

The machine Subsystem ID is: 0x10280610, 0x1028063e, 0x10280629

summary: - No external microphone detected on the machines with codec Subsystem
- ID0x10280610
+ No external microphone detected on the machines with codec alc269 family

Another machine shows up. the codec Subsystem ID is: 0x10280640

Hui Wang, thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 1260303
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Hui Wang (hui.wang) wrote :

This bug is for tracking purposes, please do not triage.

description: updated
madbiologist (me-again) wrote :

A patch for this issue has been included in the upstream 3.13-rc5 kernel, and also cc'd to stable.

Launchpad Janitor (janitor) wrote :
Download full text (4.8 KiB)

This bug was fixed in the package linux - 3.13.0-1.16

---------------
linux (3.13.0-1.16) trusty; urgency=low

  * First 3.13 upload.
  * Release tracker
    - LP: #1266852

linux (3.13.0-0.15) trusty; urgency=low

  [ Tim Gardner ]

  * rebase to v3.13-rc7

  [ Upstream Kernel Changes ]

  * rebase to v3.13-rc7

linux (3.13.0-0.14) trusty; urgency=low

  [ Andy Whitcroft ]

  * rebase to 7a262d2ed9fa42fad8c4f243f8025580b58cf2f6

  [ Tim Gardner ]

  * Remove ubuntu/dm-raid4-5 in favor of CONFIG_MD_RAID456
  * Update lttng to Version 2.4.0-rc2
  * lttng: Disabled trace_kvm_async_pf_completed
  * [Config] CONFIG_IMA=y
    - LP: #1244627

  [ Upstream Kernel Changes ]

  * rebase to 7a262d2ed9fa42fad8c4f243f8025580b58cf2f6

linux (3.13.0-0.13) trusty; urgency=low

  [ Andy Whitcroft ]

  * ubuntu: aufs3 -- (no-up) aufs3-base.patch
  * ubuntu: aufs3 -- (no-up) aufs3-mmap.patch
  * ubuntu: aufs3 -- (no-up) aufs3-standalone.patch
  * ubuntu: AUFS (no-squash): basic framework and update machinary
  * ubuntu: AUFS -- update to 7b136a27b021da9010d8b6c101939dd298e46be7
  * ubuntu: aufs3 -- enable
  * ubuntu: aufs3 -- update configs

linux (3.13.0-0.12) trusty; urgency=low

  [ Upstream Kernel Changes ]

  * rebase to v3.13-rc6

linux (3.13.0-0.11) trusty; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: suspicious unlocked ->status reading and writing in ipc/sem.c
  * [Config] ppc64el -- initial defconfig based -generic flavour
  * [Config] initial defconfig for ppc64el
  * [Config] ubuntuise ppc64el config
  * [Config] ubuntuise ppc64el config part 2
  * [Config] d-i -- update empty udebs list
  * [Config] ppc64el -- split extras package

  [ Anton Blanchard ]

  * SAUCE: KVM: PPC: Book3S HV: Add little-endian guest support

  [ Benjamin Herrenschmidt ]

  * SAUCE: powerpc/powernv: Add calls to support little endian

  [ Cédric Le Goater ]

  * SAUCE: KVM: PPC: Book3S: add helper routine to load guest instructions
  * SAUCE: KVM: PPC: Book3S: add helper routines to detect endian order
  * SAUCE: KVM: PPC: Book3S: MMIO emulation support for little endian
    guests

  [ Paul E. McKenney ]

  * SAUCE: powerpc: Make 64-bit non-VMX copy_tofrom_user() bi-endian

linux (3.13.0-0.10) trusty; urgency=low

  [ Andy Whitcroft ]

  * rebase to v3.13-rc5
  * [Config] updateconfigs following rebase to v3.13-rc5

  [ Upstream Kernel Changes ]

  * rebase to v3.13-rc5
    - LP: #1260303
    - LP: #1260303
    - LP: #1260225

linux (3.13.0-0.9) trusty; urgency=low

  [ Andy Whitcroft ]

  * [Config] d-i -- allow missing firmware

linux (3.13.0-0.8) trusty; urgency=low

  [ Andy Whitcroft ]

  * [Config] annotations -- first pass over entire config
  * [Config] drop libunwind8-dev from Build-Depends for ppc64el

  [ Tim Gardner ]

  * [Config] Add arm64 device tree files
    - LP: #1262901

linux (3.13.0-0.7) trusty; urgency=low

  [ Rajesh B Prathipati ]

  * SAUCE: powerpc: Make unaligned accesses endian-safe for powerpc

  [ Tim Gardner ]

  * [Config] CONFIG_REGULATOR_S2MPS11=n for FTBS

  [ Upstream Kernel Changes ]

  * rebase to v3.13-rc4
    - LP: #1259790
    - LP: #1259437
    - LP: #1259435

linux (3.13.0-0.6) trusty; urgency=low

  [ Paolo Pisati ]

  * [Co...

Read more...

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Hui Wang (hui.wang) wrote :

More Dell machine models report the same problem:
Vendor Id: Subsystem Id:
0x10ec0292 0x1028060f
0x10ec0292 0x10280610
0x10ec0668 0x1028064e
0x10ec0255 0x10280651
0x10ec0255 0x10280652
0x10ec0255 0x10280653
0x10ec0255 0x10280662
0x10ec0283 0x10280658

summary: - No external microphone detected on the machines with codec alc269 family
+ No external microphone detected on the Dell machines with realtek codec
Hui Wang (hui.wang) wrote :

One more machine:

Vendor Id: Subsystem Id:
0x10ec0255 0x1028064d

Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-saucy' to 'verification-done-saucy'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-saucy
Brad Figg (brad-figg) on 2014-02-11
tags: added: verification-done-saucy
removed: verification-needed-saucy
Hui Wang (hui.wang) wrote :

Two more machines:
(Vendor ID:0x10ec0255, Subsystem ID: 0x10280657; Vendor ID: 0x10ec0255, Subsystem ID: 0x1028065f)

Andy Whitcroft (apw) on 2014-03-08
Changed in linux (Ubuntu Saucy):
status: New → Fix Released
Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.13.0-17.37

---------------
linux (3.13.0-17.37) trusty; urgency=low

  [ Andy Whitcroft ]

  * Release Tracking Bug
    - LP: #1290484
  * Revert "SAUCE: hv: Add vss daemon to Makefile"
  * Revert "SAUCE: (no-up) tools/hv: add basic Makefile"
  * Revert "SAUCE: (no-up) hv -- bodge hv_kvp_daemon so it can use the
    local linux/hyperv.h"
  * Revert "SAUCE: (no-up) hv -- bodge hv_vss_daemon so it can use the
    local linux/hyperv.h"
  * Revert "SAUCE: SELinux: security_load_policy: Silence frame-larger-than
    warning"
  * Revert "SAUCE: ARM: OMAP4460: cpuidle: Extend
    PM_OMAP4_ROM_SMP_BOOT_ERRATUM_GICD on cpuidle"
  * ubuntu: overlayfs -- use kernel service credentials for copy up and
    xattr manipulations
  * [Packaging] tools -- hv tools build correctly against the built headers
  * [Packaging] cloud-tools -- add the hv_fcopy_daemon to the package
  * rebase to v3.13.6

  [ Anton Blanchard ]

  * SAUCE: ibmveth: Fix endian issues with MAC addresses

  [ Bjarke Istrup Pedersen ]

  * SAUCE: hv: Add hyperv.h to uapi headers
    - LP: #1282700

  [ Fengguang Wu ]

  * SAUCE: Drivers: hv: fcopy_open() can be static
    - LP: #1282700

  [ K. Y. Srinivasan ]

  * SAUCE: Drivers: hv: Implement the file copy service
    - LP: #1282700

  [ Tim Gardner ]

  * SAUCE: (no-up) mei: Fix stable update misapplication
  * SAUCE: (no-up) mei_me: Add module parameter to disable MSI

  [ Upstream Kernel Changes ]

  * arm64: KVM: Add Kconfig option for max VCPUs per-Guest
  * arm64: KVM: Support X-Gene guest VCPU on APM X-Gene host
  * ACPI / EC: Clear stale EC events on Samsung systems
  * drm/ttm: Fix TTM object open regression
  * SELinux: security_load_policy: Silence frame-larger-than warning
  * ARM: OMAP4460: cpuidle: Extend PM_OMAP4_ROM_SMP_BOOT_ERRATUM_GICD on
    cpuidle

  [ Upstream Kernel Changes ]

  * rebase to v3.13.6
    - LP: #1282369
    - LP: #1260303
 -- Tim Gardner <email address hidden> Wed, 05 Mar 2014 06:52:34 -0700

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers