[Dell XPS 8700] ubuntu 13.10 install on usb drive fails on uefi system

Bug #1259047 reported by dss1873 on 2013-12-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

Trying to install Ubuntu 13.10 on Dell with Windows 8 preloaded. UEFI system with secure boot turned off (for this instance). Have many other failures when also trying install with UEFI and secure boot on. Recieved the message "Executing 'grub-install dummy' failed.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: ubiquity 2.15.26 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
ApportVersion: 2.12.5-0ubuntu2
Architecture: amd64
CasperVersion: 1.336ubuntu1
Date: Sun Dec 8 21:26:21 2013
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi persistent file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash --
LiveMediaBuild: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)
---
ApportVersion: 2.12.5-0ubuntu2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 4587 F.... pulseaudio
 /dev/snd/controlC0: ubuntu 4587 F.... pulseaudio
CasperVersion: 1.336ubuntu1
DistroRelease: Ubuntu 13.10
LiveMediaBuild: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MachineType: Dell Inc. XPS 8700
MarkForUpload: True
Package: linux (not installed)
ProcFB: 0 nouveaufb
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi persistent file=/cdrom/preseed/username.seed boot=casper quiet splash --
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-12-generic N/A
 linux-backports-modules-3.11.0-12-generic N/A
 linux-firmware 1.116
Tags: saucy
Uname: Linux 3.11.0-12-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 05/16/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A01
dmi.board.name: 0KWVT8
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA01:bd05/16/2013:svnDellInc.:pnXPS8700:pvr:rvnDellInc.:rn0KWVT8:rvrA00:cvnDellInc.:ct3:cvr:
dmi.product.name: XPS 8700
dmi.sys.vendor: Dell Inc.

dss1873 (dshah-4002) wrote :
dss1873 (dshah-4002) wrote :

I should add that in other instances of trying to install, the install would complete, but without installing the necessary boot files in the efi system partition. See the following thread where I asked for advice:

http://ubuntuforums.org/showthread.php?t=2189194

NOTE: I'm a completely novice and this is my first attempt to install and try Ubuntu. So know nothing about Linux.

Exception during installation:
Dec 5 12:21:26 ubuntu /plugininstall.py: Traceback (most recent call last):
Dec 5 12:21:26 ubuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1780, in <module>
Dec 5 12:21:26 ubuntu /plugininstall.py: install.run()
Dec 5 12:21:26 ubuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 78, in wrapper
Dec 5 12:21:26 ubuntu /plugininstall.py: func(self)
Dec 5 12:21:26 ubuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 242, in run
Dec 5 12:21:26 ubuntu /plugininstall.py: self.configure_bootloader()
Dec 5 12:21:26 ubuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1036, in configure_bootloader
Dec 5 12:21:26 ubuntu /plugininstall.py: "GrubInstaller failed with code %d" % ret)
Dec 5 12:21:26 ubuntu /plugininstall.py: ubiquity.install_misc.InstallStepError: GrubInstaller failed with code 1
Dec 5 12:21:26 ubuntu /plugininstall.py:

tags: added: installer-crash
Download full text (3.7 KiB)

This looks like a kernel issue trying to read the drive:

Dec 8 21:26:21 ubuntu kernel: [ 6113.809465] EXT2-fs (sda3): error: can't find an ext2 filesystem on dev sda3.
Dec 8 21:26:21 ubuntu kernel: [ 6113.810214] XFS (sda3): bad magic number
Dec 8 21:26:21 ubuntu kernel: [ 6113.810218] ffff8803c80a9000: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
Dec 8 21:26:21 ubuntu kernel: [ 6113.810220] ffff8803c80a9010: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
Dec 8 21:26:21 ubuntu kernel: [ 6113.810221] ffff8803c80a9020: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
Dec 8 21:26:21 ubuntu kernel: [ 6113.810223] ffff8803c80a9030: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
Dec 8 21:26:21 ubuntu kernel: [ 6113.810226] XFS (sda3): Internal error xfs_sb_read_verify at line 780 of file /build/buildd/linux-3.11.0/fs/xfs/xfs_mount.c. Caller 0xffffffffa0849b75
Dec 8 21:26:21 ubuntu kernel: [ 6113.810226]
Dec 8 21:26:21 ubuntu kernel: [ 6113.810229] CPU: 7 PID: 9416 Comm: kworker/7:1H Tainted: GF 3.11.0-12-generic #19-Ubuntu
Dec 8 21:26:21 ubuntu kernel: [ 6113.810231] Hardware name: Dell Inc. XPS 8700/0KWVT8, BIOS A01 05/16/2013
Dec 8 21:26:21 ubuntu kernel: [ 6113.810249] Workqueue: xfslogd xfs_buf_iodone_work [xfs]
Dec 8 21:26:21 ubuntu kernel: [ 6113.810251] 0000000000000001 ffff8803c9a81d68 ffffffff816e547a ffff88040f338800
Dec 8 21:26:21 ubuntu kernel: [ 6113.810255] ffff8803c9a81d80 ffffffffa084c25b ffffffffa0849b75 ffff8803c9a81db8
Dec 8 21:26:21 ubuntu kernel: [ 6113.810258] ffffffffa084c2b5 0000030c00000000 ffff880410a21200 0000000000000016
Dec 8 21:26:21 ubuntu kernel: [ 6113.810261] Call Trace:
Dec 8 21:26:21 ubuntu kernel: [ 6113.810267] [<ffffffff816e547a>] dump_stack+0x45/0x56
Dec 8 21:26:21 ubuntu kernel: [ 6113.810279] [<ffffffffa084c25b>] xfs_error_report+0x3b/0x40 [xfs]
Dec 8 21:26:21 ubuntu kernel: [ 6113.810289] [<ffffffffa0849b75>] ? xfs_buf_iodone_work+0x85/0xf0 [xfs]
Dec 8 21:26:21 ubuntu kernel: [ 6113.810300] [<ffffffffa084c2b5>] xfs_corruption_error+0x55/0x80 [xfs]
Dec 8 21:26:21 ubuntu kernel: [ 6113.810319] [<ffffffffa089e413>] xfs_sb_read_verify+0x113/0x130 [xfs]
Dec 8 21:26:21 ubuntu kernel: [ 6113.810329] [<ffffffffa0849b75>] ? xfs_buf_iodone_work+0x85/0xf0 [xfs]
Dec 8 21:26:21 ubuntu kernel: [ 6113.810334] [<ffffffff81091420>] ? finish_task_switch+0x50/0xf0
Dec 8 21:26:21 ubuntu kernel: [ 6113.810343] [<ffffffffa0849b75>] xfs_buf_iodone_work+0x85/0xf0 [xfs]
Dec 8 21:26:21 ubuntu kernel: [ 6113.810347] [<ffffffff8107d05c>] process_one_work+0x17c/0x430
Dec 8 21:26:21 ubuntu kernel: [ 6113.810350] [<ffffffff8107dcac>] worker_thread+0x11c/0x3c0
Dec 8 21:26:21 ubuntu kernel: [ 6113.810353] [<ffffffff8107db90>] ? manage_workers.isra.24+0x2a0/0x2a0
Dec 8 21:26:21 ubuntu kernel: [ 6113.810357] [<ffffffff810847b0>] kthread+0xc0/0xd0
Dec 8 21:26:21 ubuntu kernel: [ 6113.810360] [<ffffffff810846f0>] ? kthread_create_on_node+0x120/0x120
Dec 8 21:26:21 ubuntu kernel: [ 6113.810363] [<ffffffff816f516c>] ret_from_fork+0x7c/0xb0
Dec 8 21:26:21 ubuntu kernel: [ 6113.810366] [<ffffffff810846f0>] ? kt...

Read more...

affects: ubiquity (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1259047

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

Can you see if this issue also happens with the latest Development release, which can be downloaded from:

http://cdimage.ubuntu.com/daily-live/current/

Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: kernel-da-key

apport information

tags: added: apport-collected
description: updated

apport information

dss1873 (dshah-4002) wrote : CRDA.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

In response to post #5
----------------
ran apport-collect 1259047 as requested.
Terminal seems hung at
dpkg-query: no packages found matching linux

Ran it a second time with same result.

in repsponse to post #6
-------------------------
Are you asking me to download the latest release, burn to a CD or something (instructions for that?), and then try the install again (using the live image from the CD)?? Please remember I'm completely new to Linux. Thanks.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
dss1873 (dshah-4002) wrote :

Tried installing from 12/15/13 build of 14.04 burned to CD. Same error ('grub-install dummy' failed).

summary: - ubuntu 13.10 install on usb drive fails on uefi system
+ [Dell XPS 8700] ubuntu 13.10 install on usb drive fails on uefi system
tags: added: trusty
tags: added: bios-outdated-a06
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
dss1873 (dshah-4002) wrote :

I updated my bios and tried the install again. I received the same error as before: "Executing 'grub-install dummy' failed."

The result of the command "sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date" was:
A06
11/18/2013

tags: added: latest-bios-a06
removed: bios-outdated-a06
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
description: updated

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.13.0-6.23
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
tags: added: bot-stop-nagging
removed: kernel-request-3.13.0-6.23
Changed in linux (Ubuntu):
status: Expired → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers