rtl8188ee wireless driver unusable: 25-30% packet loss. 13.10 Saucy

Bug #1258870 reported by Greg on 2013-12-08
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

I'm seeing a consistent packet loss problem with the rtl8188ee Realtek wireless driver. Long sequences of pings to the access point IP show 25-30% packet loss. Downloads get 'stuck', pages don't load, it's generally unusable.

I've tried the following kernels:

/boot/initrd.img-3.11.0-12-generic /boot/initrd.img-3.12.3-031203-generic
/boot/initrd.img-3.11.0-14-generic /boot/initrd.img-3.13.0-031300rc3-generic

all with the same result. Packet capture shows lots of dup ACKs, some retransmits.

I suspected 802.11n might be the culprit, but I've disabled it at the AP, and the driver seems to respect that judging by these log lines:

Dec 7 21:50:52 congo kernel: [13812.218008] rtl8188ee 0000:01:00.0 wlan0: disabling HT as WMM/QoS is not supported by the
AP
Dec 7 21:50:52 congo kernel: [13812.218011] rtl8188ee 0000:01:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the
 AP

Other than those lines there isn't anything noteworthy in syslog.

Very interested in getting this fixed, please let me know how I can help debug.

$ lsb_release -rd
Description: Ubuntu 13.10
Release: 13.10

$ uname -a
Linux congo 3.13.0-031300rc3-generic #201312061335 SMP Fri Dec 6 18:37:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

$ sudo lshw -C network
  *-network
       description: Wireless interface
       product: RTL8188EE Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: wlan0
       version: 01
       serial: 34:23:87:0d:23:85
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8188ee driverversion=3.13.0-031300rc3-generic firmware=N/A ip=192.168.1.68 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:18 ioport:5000(size=256) memory:b2600000-b2603fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: eth0
       version: 0c
       serial: 9c:b6:54:c1:7d:36
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168g-2_0.0.1 02/06/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:43 ioport:3000(size=256) memory:b2500000-b2500fff memory:b2400000-b2403fff

Greg (g6) wrote :

I tried installing the latest proprietary driver and firmware, although I had to use Freedom Ben's modified version:

https://github.com/FreedomBen/rtl8188ce-linux-driver

since the code provided by Realtek doesn't even compile with any kernel after 2.9 :(

Anyway, that didn't help. Continued to experience large amounts of packet loss, up to 80%. I eventually just bought a new card with good linux support for $24, and I'd suggest anyone trying to make this card work on linux just do the same. More details documented here:

http://ilostmynotes.blogspot.com/2013/12/windows-8-and-ubuntu-1304-with.html

As expected, the new card works perfectly: 0% loss using the same network, access point, sitting in the same position in the room etc. It's easy to blame bugs like these on RF signal problems, interference etc. but in this case the performance of the driver is just terrible. I dual boot windows and it seemed OK there, but I didn't use it extensively.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-lts-saucy (Ubuntu):
status: New → Confirmed

Greg, thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 1258870
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: linux-lts-saucy (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Greg (g6) wrote :

Sorry, as I noted in the bug I had to replace the hardware since it was completely unusable and I don't have it anymore.

Greg, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1258870/comments/4 regarding you no longer have the hardware. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Eric Monson (ericjmonson) wrote :

I still have the hardware that is experiencing this problem. I'm going to see if I can run the command apport-collect 1258870.

Changed in linux (Ubuntu):
status: Invalid → Confirmed
tags: added: apport-collected staging third-party-packages trusty

ApportVersion: 2.14.1-0ubuntu3.5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: emonson 2654 F.... pulseaudio
                      emonson 3013 F.... pulseaudio
CurrentDesktop: KDE
DistroRelease: Ubuntu 14.04
HibernationDevice: RESUME=UUID=e5d648bc-65ed-4ba2-a8ed-4ff492323be8
InstallationDate: Installed on 2013-09-05 (414 days ago)
InstallationMedia: Kubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MachineType: TOSHIBA Satellite C55-A
Package: linux 3.11.0.12.13 [origin: unknown]
PackageArchitecture: amd64
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-37-generic root=UUID=c0c12f63-a551-4329-bf37-6bafcbd7992a ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.13.0-37.64-generic 3.13.11.7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-37-generic N/A
 linux-backports-modules-3.13.0-37-generic N/A
 linux-firmware 1.127.7
RfKill:
 23: phy23: Wireless LAN
  Soft blocked: no
  Hard blocked: no
StagingDrivers: rts5139
Tags: trusty third-party-packages staging
Uname: Linux 3.13.0-37-generic x86_64
UnreportableReason: This is not an official Ubuntu package. Please remove any third party package and try again.
UpgradeStatus: Upgraded to trusty on 2014-04-03 (205 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 09/16/2013
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: 1.30
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: MP
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: OEM Chassis Manufacturer
dmi.chassis.version: OEM Chassis Version
dmi.modalias: dmi:bvnInsydeCorp.:bvr1.30:bd09/16/2013:svnTOSHIBA:pnSatelliteC55-A:pvrPSCF6U-01D00C:rvnTOSHIBA:rnPortablePC:rvrMP:cvnOEMChassisManufacturer:ct10:cvrOEMChassisVersion:
dmi.product.name: Satellite C55-A
dmi.product.version: PSCF6U-01D00C
dmi.sys.vendor: TOSHIBA

apport information

Eric Monson (ericjmonson) wrote :

FYI, this wireless driver works better than it did a year ago when this bug was initially submitted. At that time, I was seeing the same results as Greg reported. At this point, the wireless driver will work for a few minutes with 0 packet loss, then complete stop sending any packets.

For me, this is the integrated WIFI on my laptop. If I disable then re-enable the WIFI on the laptop (using the special WIFI button above F12), it will being working again for another few minutes.

Let me know what other information I can provide to help with this bug.

Eric

Eric Monson, please do not open a closed report, nor apport-collect to a report you are not the original reporter of. Instead, so your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

As well, please do not announce in this report you created a new bug report.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in linux (Ubuntu):
status: Confirmed → Invalid
tags: removed: apport-collected staging third-party-packages trusty
Bryan Quigley (bryanquigley) wrote :

Just FYI, reported a new bug on this here - https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1401741

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers