[Lenovo ThinkPad X230] suspend/resume failure

Bug #1258838 reported by Xavier Claessens on 2013-12-07
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Linux
Unknown
Unknown
linux (Ubuntu)
Medium
Unassigned

Bug Description

I'm using a docking station. If I suspend the laptop when it is docked and resume after undocking it, the screen stay blank. I have to long-press the power button to reboot.

This is a regression in 13.10, was working fine on 13.04 with the same laptop.

WORKAROUND: If I remove the DVD reader from the docking station, then the issue is solved.

ProblemType: KernelOops
DistroRelease: Ubuntu 13.10
Package: linux-image-3.11.0-15-generic
ProcVersionSignature: Ubuntu 3.11.0-15.22-generic 3.11.10
Uname: Linux 3.11.0-15-generic x86_64
Annotation: This occured during a previous suspend and prevented it from resuming properly.
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: xclaesse 2545 F.... pulseaudio
Date: Fri Dec 6 19:20:26 2013
ExecutablePath: /usr/share/apport/apportcheckresume
ExecutableTimestamp: 1382617300
Failure: suspend/resume
InstallationDate: Installed on 2012-09-29 (434 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20120929)
InterpreterPath: /usr/bin/python3.3
MachineType: LENOVO 23252EG
MarkForUpload: True
ProcCmdline: /usr/bin/python3 /usr/share/apport/apportcheckresume
ProcCwd: /
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.11.0-15-generic root=UUID=c4842ed7-a8fc-40fd-8c31-909f1a5ce55a ro quiet splash vt.handoff=7
PulseList:
 Error: command ['pacmd', 'list'] failed with exit code 1: Home directory not accessible: Permission denied
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-15-generic N/A
 linux-backports-modules-3.11.0-15-generic N/A
 linux-firmware 1.116
SourcePackage: linux
Title: [LENOVO 23252EG] suspend/resume failure
UpgradeStatus: Upgraded to saucy on 2013-09-27 (71 days ago)
UserGroups:

dmi.bios.date: 05/24/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: G2ET31WW (1.11 )
dmi.board.asset.tag: Not Available
dmi.board.name: 23252EG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG2ET31WW(1.11):bd05/24/2012:svnLENOVO:pn23252EG:pvrThinkPadX230:rvnLENOVO:rn23252EG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 23252EG
dmi.product.version: ThinkPad X230
dmi.sys.vendor: LENOVO

Xavier Claessens (zdra) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: saucy

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.12 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.13-rc3-trusty/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Xavier Claessens (zdra) wrote :

Booted on 3.13.0-031300rc3-generic from the link above and system crash on resume still happens.

tags: added: kernel-bug-exists-upstream
Xavier Claessens (zdra) wrote :
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Xavier Claessens (zdra) wrote :

This upstream kernel bug seems to describe the same symptoms: https://bugzilla.kernel.org/show_bug.cgi?id=62801. If you can provide .deb packages with 839a8e8660b6777e7fe4e80af1a048aebe2b5977 reverted, I'll test it.

tags: added: bios-outdated-2.57
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
summary: - [LENOVO 23252EG] suspend/resume failure
+ [LENOVO ThinkPad X230] suspend/resume failure
summary: - [LENOVO ThinkPad X230] suspend/resume failure
+ [Lenovo ThinkPad X230] suspend/resume failure
Xavier Claessens (zdra) wrote :

I upgraded the BIOS with the bootable CD from the page you linked, did not change anything to the issue.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Xavier Claessens (zdra) wrote :

G2ET97WW (2.57 )
10/25/2013

If I remove the DVD reader from the docking station, then the issue is solved. That really sounds like upstream bug https://bugzilla.kernel.org/show_bug.cgi?id=62801. There is a patch attached that I can test if needed, but I'm not sure how to build ubuntu kernel with that patch...

Xavier Claessens (zdra) on 2013-12-17
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: latest-bios-2.57
removed: bios-outdated-2.57
description: updated
tags: added: kernel-bug-exists-upstream-v3.13-rc3
removed: kernel-bug-exists-upstream
Xavier Claessens (zdra) wrote :

I've rebuild ubuntu kernel 3.11.0-14 with the upstream patch applied[1] and that fixed the issue.

[1] https://bugzilla.kernel.org/attachment.cgi?id=118791&action=diff

Marking Triaged as upstream fix commit identified.

tags: added: cherry-pick
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Xavier Claessens (zdra) wrote :

Note that the upstream patch says it's an ugly hack. I don't know if they'll apply that or work on better solution.

David Ing (divirtual) wrote :

I have an X230T with the UltraBase 3 dock. The problem is reproduced exactly for me, that ...

> If I suspend the laptop when it is docked and resume after undocking it, the screen stay blank.

I can also verify the ....

> WORKAROUND: If I remove the DVD reader from the docking station, then the issue is solved.

David Ing, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

David Ing (divirtual) wrote :

Thanks, when I ran ...
ubuntu-bug linux
... I was directed back to this bug.

Version log said: Ubuntu 3.11.0-15.23-generic 3.11.10

David Ing, yeah it wasn't supposed to do that. Could you please file a bug via https://bugs.launchpad.net/ubuntu/+source/linux/+filebug and subscribe me to it, and we can take it from there.

Xavier Claessens (zdra) wrote :

Upstream fixed this bug with commit 85fbd722ad0f5d64d1ad15888cd1eb2188bfb557. I didn't test that myself yet, but if that commit can be included in an ubuntu kernel package, I'll be happy to test to confirm if it works.

Xavier Claessens (zdra) wrote :

Actually that's the patch I tested earlier (minus small detail). So I can confirm it does fix the bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.