[Acer Aspire E1-572] Freezes at shutdown screen when attempting to shutdown

Bug #1257338 reported by Tarpoon on 2013-12-03
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

I am using Kubuntu, and the screen freezes on shutdown with the kubuntu logo showing. Tried kernel parameters reboot=pci and reboot=bios but didn't change anything.

WORKAROUND: Suspend to ram, suspend to disk and rebooting works fine.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: linux-image-3.11.0-13-generic 3.11.0-13.20
ProcVersionSignature: Ubuntu 3.11.0-13.20-generic 3.11.6
Uname: Linux 3.11.0-13-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: christian 1853 F.... pulseaudio
 /dev/snd/controlC0: christian 1853 F.... pulseaudio
Date: Tue Dec 3 16:27:24 2013
HibernationDevice: RESUME=UUID=d6cedfb1-95fc-451c-81f6-480008d8ef40
InstallationDate: Installed on 2013-12-01 (2 days ago)
InstallationMedia: Kubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MachineType: Acer Aspire E1-572
MarkForUpload: True
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-13-generic root=UUID=20d2d081-e8c6-4e7e-9c59-0398d081c3b5 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-13-generic N/A
 linux-backports-modules-3.11.0-13-generic N/A
 linux-firmware 1.116
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/21/2013
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: V2.04
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: EA50_HW
dmi.board.vendor: Acer
dmi.board.version: V2.04
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsydeCorp.:bvrV2.04:bd05/21/2013:svnAcer:pnAspireE1-572:pvrV2.04:rvnAcer:rnEA50_HW:rvrV2.04:cvnAcer:ct10:cvrChassisVersion:
dmi.product.name: Aspire E1-572
dmi.product.version: V2.04
dmi.sys.vendor: Acer

Tarpoon (tarpoon) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.12 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.13-rc2-trusty/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Tarpoon (tarpoon) wrote :

Thanks for your reply.
Sadly using that kernel does not fix the bug. Added the tag as requested.

tags: added: kernel-bug-exists-upstream
tags: added: kernel-bug-exists-upstreamv3.13-rc2
removed: kernel-bug-exists-upstream
Tarpoon (tarpoon) wrote :

Sure, no problem.
Tried both with the upstream kernel.
Neither parameter had any effect on the shutting down problem.

description: updated
tags: added: kernel-bug-exists-upstream-v3.13-rc2 latest-bios-2.04 trusty unable-to-test-regression
removed: kernel-bug-exists-upstreamv3.13-rc2
summary: - Acer Aspire E1-572 doesn't shutdown properly
+ [Acer Aspire E1-572] Freezes at shutdown screen when attempting to
+ shutdown

Tarpoon, the issue you are reporting is an upstream one. Could you please report this problem through the appropriate channel by following the instructions _verbatim_ at https://wiki.ubuntu.com/Bugs/Upstream/kernel#KernelTeam.2BAC8-KernelTeamBugPolicies.Overview_on_Reporting_Bugs_Upstream ?

Please provide a direct URL to your post once you have made it so that it may be tracked.

Thank you for your understanding.

Changed in linux (Ubuntu):
importance: Medium → Low
status: Incomplete → Triaged
description: updated

Anca Emanuel, so your hardware may be tracked, could you please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Tarpoon (tarpoon) wrote :

Just reported the bug:
http://marc.info/?l=linux-acpi&m=138668019226185&w=2 (redid the test with the upstream rc3 kernel to make sure, it wasn't fixed already)

tags: added: kernel-bug-exists-upstream-v3.13-rc3
removed: kernel-bug-exists-upstream-v3.13-rc2
Anca Emanuel (anca-emanuel) wrote :

The above patch queued for 3.13 in for-linus branch from Bjorn Helgaas
https://git.kernel.org/cgit/linux/kernel/git/helgaas/pci.git/commit/?h=for-linus&id=4fc9bbf98fd66f879e628d8537ba7c240be2b58e

@Tarpoon: is not upstream yet, but you can git cherry-pick, or manual apply, etc.

[quote]
PCI: Disable Bus Master only on kexec reboot
Add a flag to tell the PCI subsystem that kernel is shutting down in
preparation to kexec a kernel. Add code in PCI subsystem to use this flag
to clear Bus Master bit on PCI devices only in case of kexec reboot.

This fixes a power-off problem on Acer Aspire V5-573G and likely other
machines and avoids any other issues caused by clearing Bus Master bit on
PCI devices in normal shutdown path. The problem was introduced by
b566a22c2332 ("PCI: disable Bus Master on PCI device shutdown").

This patch is based on discussion at
http://marc.info/?l=linux-pci&m=138425645204355&w=2

Link: https://bugzilla.kernel.org/show_bug.cgi?id=63861
Reported-by: Chang Liu <email address hidden>
Signed-off-by: Khalid Aziz <email address hidden>
Signed-off-by: Bjorn Helgaas <email address hidden>
Acked-by: Konstantin Khlebnikov <email address hidden>
Cc: <email address hidden> # v3.5+
[/quote]

Joseph Salisbury (jsalisbury) wrote :

The fix mentioned in comment #11 is now in upstream v3.13-rc4. Can you test this kernel to confirm if this fixes the bug or not:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.13-rc4-trusty/

Joshua (njj) wrote :

There is not v3.13-rc4 to download... build failed with two errors.

Tarpoon, given the mainline debs are not available for rc4, could you please execute the following in a terminal, boot into the new kernel, and advise if this is reproducible:
cd ~/Desktop && git clone git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git linux-stable && cd linux-stable && git checkout 9199c4caa1315c31d160abbd166df0b9a9e8551e && cp /boot/config-`uname -r` .config && yes '' | make oldconfig && make-kpkg clean && CONCURRENCY_LEVEL=`getconf _NPROCESSORS_ONLN` fakeroot make-kpkg --initrd --append-to-version=-custom2 kernel_image kernel_headers && cd .. && sudo dpkg -i *.deb

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Tarpoon (tarpoon) wrote :

Tried the command. Sadly it doesn't finish building, ending with the following output:

  CC [M] drivers/net/wireless/rtlwifi/rtl8723ae/trx.o
  LD [M] drivers/net/wireless/rtlwifi/rtl8723ae/rtl8723ae.o
make[1]: *** [drivers] Fehler 2
make[1]: Verlasse Verzeichnis '/home/christian/Schreibtisch/linux-stable'
make: *** [debian/stamp/build/kernel] Fehler 2

Won't the rc4 become available within a few days?

Tarpoon, your build failure against the potential fix commit is indicative of why rc4 is not available via debs, due to painful building. :) I'll mark this Triaged for now.

Changed in linux (Ubuntu):
status: Incomplete → Triaged
Joshua (njj) wrote :

Problem is finally solved with 3.13-rc5 mainline kernel!

Joshua (njj) wrote :

I already did, but mine was marked as a duplicate of this one. https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1245904

tags: added: kernel-fixed-upstream-v3.13.-rc5

Joshua, thank you for testing the latest mainline kernel. Would you be able to reverse bisect in order to identify the commit that fixed this issue following https://wiki.ubuntu.com/Kernel/KernelBisection ?

Tarpoon (tarpoon) wrote :

I can confirm the bug being fixed in RC5. However I won't be able to do that bisecting stuff within the next few weeks.

Tarpoon, thank you for testing v3.13-rc5. At this point, we could put a bisect for the regression on hold, and refocus onto a reverse bisect on the the fix commit. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection#How_do_I_reverse_bisect_the_upstream_kernel.3F ?

Tarpoon (tarpoon) wrote :

Trying to do as asked I get the following messages:

First try: (as I could not test rc4 I tried to mark rc3 as bad and rc5 as good)
Zweigspitze (HEAD) ist jetzt bei 413541d... Linux 3.13-rc5
~/Downloads/kernelbisect/linux$ git bisect start
~/Downloads/kernelbisect/linux$ git bisect bad v3.13-rc3
~/Downloads/kernelbisect/linux$ git bisect good v3.13-rc5
Some good revs are not ancestor of the bad rev.
git bisect cannot work properly in this case.
Maybe you mistake good and bad revs?

Second try:
~/Downloads/kernelbisect/linux$ git bisect start
Zweigspitze (HEAD) ist jetzt bei 413541d... Linux 3.13-rc5
~/Downloads/kernelbisect/linux$ git bisect bad v3.13-rc4
~/Downloads/kernelbisect/linux$ git bisect good v3.13-rc5
Some good revs are not ancestor of the bad rev.
git bisect cannot work properly in this case.
Maybe you mistake good and bad revs?

Trying to reverse the order of "good" and "bad" I get the same message.

Tarpoon, as outlined in https://wiki.ubuntu.com/Kernel/KernelBisection#Reverse_commit_bisecting_upstream_kernel_versions git is not designed to do a reverse bisect where one marks a later tag good, and an earlier tag bad. Hence, you would want to do:
git bisect bad v3.13-rc5
git bisect good v3.13-rc3
Bisecting: 433 revisions left to test after this (roughly 9 steps)
[908bfda754a9e972c4728832513b11153bd3a140] Merge branch 'x86/urgent' of git://git.kernel.org/pub/scm/linux/kernel/git/tip/tip

If the bug is reproducible, then you mark it good. If it's not reproducible, mark it bad.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.