Ubuntu

Switch device from Internal-Mic (with Mute Status) to Headset-Mic for record, recording is silent.

Reported by David Henningsson on 2013-12-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
David Henningsson
linux (Ubuntu)
Undecided
David Henningsson

Bug Description

This bug is for tracking purposes. Please do not triage.

Changed in linux (Ubuntu):
status: New → In Progress
assignee: nobody → David Henningsson (diwic)
tags: added: blocks-hwcert-enablement

By trial and error, I found this patch could work around an issue
where the headset mic would stop working if you switch between the
internal mic and the headset mic, and the internal mic was muted.

It still takes a second or two before the headset mic actually starts
working, but still better than nothing.

I'd like to add stable to this patch, but I'd like Kailang's ack first
because I don't know what the verbs really do.

BugLink: https://bugs.launchpad.net/bugs/1256840
Signed-off-by: David Henningsson <email address hidden>
---
 sound/pci/hda/patch_realtek.c | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
index 537991c..85d1c8b 100644
--- a/sound/pci/hda/patch_realtek.c
+++ b/sound/pci/hda/patch_realtek.c
@@ -3338,6 +3338,7 @@ static void alc_headset_mode_ctia(struct hda_codec *codec)
   alc_write_coef_idx(codec, 0x18, 0x7388);
   break;
  case 0x10ec0668:
+ alc_write_coef_idx(codec, 0x11, 0x0001);
   alc_write_coef_idx(codec, 0x15, 0x0d60);
   alc_write_coef_idx(codec, 0xc3, 0x0000);
   break;
@@ -3366,6 +3367,7 @@ static void alc_headset_mode_omtp(struct hda_codec *codec)
   alc_write_coef_idx(codec, 0x18, 0x7388);
   break;
  case 0x10ec0668:
+ alc_write_coef_idx(codec, 0x11, 0x0001);
   alc_write_coef_idx(codec, 0x15, 0x0d50);
   alc_write_coef_idx(codec, 0xc3, 0x0000);
   break;
--
1.7.9.5

Takashi Iwai (tiwai) wrote :

At Mon, 2 Dec 2013 18:06:20 +0800,
David Henningsson wrote:
>
> By trial and error, I found this patch could work around an issue
> where the headset mic would stop working if you switch between the
> internal mic and the headset mic, and the internal mic was muted.
>
> It still takes a second or two before the headset mic actually starts
> working, but still better than nothing.
>
> I'd like to add stable to this patch, but I'd like Kailang's ack first
> because I don't know what the verbs really do.

OK, I'll keep this pending for a day or two until Kailang's ack.

thanks,

Takashi

>
> BugLink: https://bugs.launchpad.net/bugs/1256840
> Signed-off-by: David Henningsson <email address hidden>
> ---
> sound/pci/hda/patch_realtek.c | 2 ++
> 1 file changed, 2 insertions(+)
>
> diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
> index 537991c..85d1c8b 100644
> --- a/sound/pci/hda/patch_realtek.c
> +++ b/sound/pci/hda/patch_realtek.c
> @@ -3338,6 +3338,7 @@ static void alc_headset_mode_ctia(struct hda_codec *codec)
> alc_write_coef_idx(codec, 0x18, 0x7388);
> break;
> case 0x10ec0668:
> + alc_write_coef_idx(codec, 0x11, 0x0001);
> alc_write_coef_idx(codec, 0x15, 0x0d60);
> alc_write_coef_idx(codec, 0xc3, 0x0000);
> break;
> @@ -3366,6 +3367,7 @@ static void alc_headset_mode_omtp(struct hda_codec *codec)
> alc_write_coef_idx(codec, 0x18, 0x7388);
> break;
> case 0x10ec0668:
> + alc_write_coef_idx(codec, 0x11, 0x0001);
> alc_write_coef_idx(codec, 0x15, 0x0d50);
> alc_write_coef_idx(codec, 0xc3, 0x0000);
> break;
> --
> 1.7.9.5
>

Changed in hwe-next:
assignee: nobody → David Henningsson (diwic)
status: New → In Progress
David Henningsson (diwic) wrote :

The patch was acked by Realtek and committed upstream today.

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Changed in hwe-next:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.8 KiB)

This bug was fixed in the package linux - 3.13.0-1.16

---------------
linux (3.13.0-1.16) trusty; urgency=low

  * First 3.13 upload.
  * Release tracker
    - LP: #1266852

linux (3.13.0-0.15) trusty; urgency=low

  [ Tim Gardner ]

  * rebase to v3.13-rc7

  [ Upstream Kernel Changes ]

  * rebase to v3.13-rc7

linux (3.13.0-0.14) trusty; urgency=low

  [ Andy Whitcroft ]

  * rebase to 7a262d2ed9fa42fad8c4f243f8025580b58cf2f6

  [ Tim Gardner ]

  * Remove ubuntu/dm-raid4-5 in favor of CONFIG_MD_RAID456
  * Update lttng to Version 2.4.0-rc2
  * lttng: Disabled trace_kvm_async_pf_completed
  * [Config] CONFIG_IMA=y
    - LP: #1244627

  [ Upstream Kernel Changes ]

  * rebase to 7a262d2ed9fa42fad8c4f243f8025580b58cf2f6

linux (3.13.0-0.13) trusty; urgency=low

  [ Andy Whitcroft ]

  * ubuntu: aufs3 -- (no-up) aufs3-base.patch
  * ubuntu: aufs3 -- (no-up) aufs3-mmap.patch
  * ubuntu: aufs3 -- (no-up) aufs3-standalone.patch
  * ubuntu: AUFS (no-squash): basic framework and update machinary
  * ubuntu: AUFS -- update to 7b136a27b021da9010d8b6c101939dd298e46be7
  * ubuntu: aufs3 -- enable
  * ubuntu: aufs3 -- update configs

linux (3.13.0-0.12) trusty; urgency=low

  [ Upstream Kernel Changes ]

  * rebase to v3.13-rc6

linux (3.13.0-0.11) trusty; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: suspicious unlocked ->status reading and writing in ipc/sem.c
  * [Config] ppc64el -- initial defconfig based -generic flavour
  * [Config] initial defconfig for ppc64el
  * [Config] ubuntuise ppc64el config
  * [Config] ubuntuise ppc64el config part 2
  * [Config] d-i -- update empty udebs list
  * [Config] ppc64el -- split extras package

  [ Anton Blanchard ]

  * SAUCE: KVM: PPC: Book3S HV: Add little-endian guest support

  [ Benjamin Herrenschmidt ]

  * SAUCE: powerpc/powernv: Add calls to support little endian

  [ Cédric Le Goater ]

  * SAUCE: KVM: PPC: Book3S: add helper routine to load guest instructions
  * SAUCE: KVM: PPC: Book3S: add helper routines to detect endian order
  * SAUCE: KVM: PPC: Book3S: MMIO emulation support for little endian
    guests

  [ Paul E. McKenney ]

  * SAUCE: powerpc: Make 64-bit non-VMX copy_tofrom_user() bi-endian

linux (3.13.0-0.10) trusty; urgency=low

  [ Andy Whitcroft ]

  * rebase to v3.13-rc5
  * [Config] updateconfigs following rebase to v3.13-rc5

  [ Upstream Kernel Changes ]

  * rebase to v3.13-rc5
    - LP: #1260303
    - LP: #1260303
    - LP: #1260225

linux (3.13.0-0.9) trusty; urgency=low

  [ Andy Whitcroft ]

  * [Config] d-i -- allow missing firmware

linux (3.13.0-0.8) trusty; urgency=low

  [ Andy Whitcroft ]

  * [Config] annotations -- first pass over entire config
  * [Config] drop libunwind8-dev from Build-Depends for ppc64el

  [ Tim Gardner ]

  * [Config] Add arm64 device tree files
    - LP: #1262901

linux (3.13.0-0.7) trusty; urgency=low

  [ Rajesh B Prathipati ]

  * SAUCE: powerpc: Make unaligned accesses endian-safe for powerpc

  [ Tim Gardner ]

  * [Config] CONFIG_REGULATOR_S2MPS11=n for FTBS

  [ Upstream Kernel Changes ]

  * rebase to v3.13-rc4
    - LP: #1259790
    - LP: #1259437
    - LP: #1259435

linux (3.13.0-0.6) trusty; urgency=low

  [ Paolo Pisati ]

  * [Co...

Read more...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-saucy' to 'verification-done-saucy'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-saucy
Brad Figg (brad-figg) on 2014-02-11
tags: added: verification-done-saucy
removed: verification-needed-saucy
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers