Ubuntu

Dell inspiron 5439 has mono speakers

Reported by David Henningsson on 2013-11-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
David Henningsson

Bug Description

This bug is for tracking purposes, please do not triage.

Changed in linux (Ubuntu):
status: New → In Progress
assignee: nobody → David Henningsson (diwic)

This machine also has mono output if run through DAC node 0x03.

Cc: <email address hidden> (v3.10+)
BugLink: https://bugs.launchpad.net/bugs/1256212
Tested-by: David Chen <email address hidden>
Signed-off-by: David Henningsson <email address hidden>
---
 sound/pci/hda/patch_realtek.c | 1 +
 1 file changed, 1 insertion(+)

diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
index 2ad568e..8099200 100644
--- a/sound/pci/hda/patch_realtek.c
+++ b/sound/pci/hda/patch_realtek.c
@@ -4243,6 +4243,7 @@ static const struct snd_pci_quirk alc269_fixup_tbl[] = {
  SND_PCI_QUIRK(0x1028, 0x0614, "Dell Inspiron 3135", ALC269_FIXUP_DELL1_MIC_NO_PRESENCE),
  SND_PCI_QUIRK(0x1028, 0x0616, "Dell Vostro 5470", ALC290_FIXUP_MONO_SPEAKERS),
  SND_PCI_QUIRK(0x1028, 0x061f, "Dell", ALC255_FIXUP_DELL1_MIC_NO_PRESENCE),
+ SND_PCI_QUIRK(0x1028, 0x0638, "Dell Inspiron 5439", ALC290_FIXUP_MONO_SPEAKERS),
  SND_PCI_QUIRK(0x1028, 0x063f, "Dell", ALC255_FIXUP_DELL1_MIC_NO_PRESENCE),
  SND_PCI_QUIRK(0x1028, 0x15cc, "Dell X5 Precision", ALC269_FIXUP_DELL2_MIC_NO_PRESENCE),
  SND_PCI_QUIRK(0x1028, 0x15cd, "Dell X5 Precision", ALC269_FIXUP_DELL2_MIC_NO_PRESENCE),
--
1.7.9.5

Takashi Iwai (tiwai) wrote :

At Fri, 29 Nov 2013 15:10:20 +0800,
David Henningsson wrote:
>
> This machine also has mono output if run through DAC node 0x03.
>
> Cc: <email address hidden> (v3.10+)
> BugLink: https://bugs.launchpad.net/bugs/1256212
> Tested-by: David Chen <email address hidden>
> Signed-off-by: David Henningsson <email address hidden>

Thanks, applied. But I already composed a pull request for 3.13-rc2,
so this is slipped from it.

Takashi

> ---
> sound/pci/hda/patch_realtek.c | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
> index 2ad568e..8099200 100644
> --- a/sound/pci/hda/patch_realtek.c
> +++ b/sound/pci/hda/patch_realtek.c
> @@ -4243,6 +4243,7 @@ static const struct snd_pci_quirk alc269_fixup_tbl[] = {
> SND_PCI_QUIRK(0x1028, 0x0614, "Dell Inspiron 3135", ALC269_FIXUP_DELL1_MIC_NO_PRESENCE),
> SND_PCI_QUIRK(0x1028, 0x0616, "Dell Vostro 5470", ALC290_FIXUP_MONO_SPEAKERS),
> SND_PCI_QUIRK(0x1028, 0x061f, "Dell", ALC255_FIXUP_DELL1_MIC_NO_PRESENCE),
> + SND_PCI_QUIRK(0x1028, 0x0638, "Dell Inspiron 5439", ALC290_FIXUP_MONO_SPEAKERS),
> SND_PCI_QUIRK(0x1028, 0x063f, "Dell", ALC255_FIXUP_DELL1_MIC_NO_PRESENCE),
> SND_PCI_QUIRK(0x1028, 0x15cc, "Dell X5 Precision", ALC269_FIXUP_DELL2_MIC_NO_PRESENCE),
> SND_PCI_QUIRK(0x1028, 0x15cd, "Dell X5 Precision", ALC269_FIXUP_DELL2_MIC_NO_PRESENCE),
> --
> 1.7.9.5
>

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.8 KiB)

This bug was fixed in the package linux - 3.13.0-1.16

---------------
linux (3.13.0-1.16) trusty; urgency=low

  * First 3.13 upload.
  * Release tracker
    - LP: #1266852

linux (3.13.0-0.15) trusty; urgency=low

  [ Tim Gardner ]

  * rebase to v3.13-rc7

  [ Upstream Kernel Changes ]

  * rebase to v3.13-rc7

linux (3.13.0-0.14) trusty; urgency=low

  [ Andy Whitcroft ]

  * rebase to 7a262d2ed9fa42fad8c4f243f8025580b58cf2f6

  [ Tim Gardner ]

  * Remove ubuntu/dm-raid4-5 in favor of CONFIG_MD_RAID456
  * Update lttng to Version 2.4.0-rc2
  * lttng: Disabled trace_kvm_async_pf_completed
  * [Config] CONFIG_IMA=y
    - LP: #1244627

  [ Upstream Kernel Changes ]

  * rebase to 7a262d2ed9fa42fad8c4f243f8025580b58cf2f6

linux (3.13.0-0.13) trusty; urgency=low

  [ Andy Whitcroft ]

  * ubuntu: aufs3 -- (no-up) aufs3-base.patch
  * ubuntu: aufs3 -- (no-up) aufs3-mmap.patch
  * ubuntu: aufs3 -- (no-up) aufs3-standalone.patch
  * ubuntu: AUFS (no-squash): basic framework and update machinary
  * ubuntu: AUFS -- update to 7b136a27b021da9010d8b6c101939dd298e46be7
  * ubuntu: aufs3 -- enable
  * ubuntu: aufs3 -- update configs

linux (3.13.0-0.12) trusty; urgency=low

  [ Upstream Kernel Changes ]

  * rebase to v3.13-rc6

linux (3.13.0-0.11) trusty; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: suspicious unlocked ->status reading and writing in ipc/sem.c
  * [Config] ppc64el -- initial defconfig based -generic flavour
  * [Config] initial defconfig for ppc64el
  * [Config] ubuntuise ppc64el config
  * [Config] ubuntuise ppc64el config part 2
  * [Config] d-i -- update empty udebs list
  * [Config] ppc64el -- split extras package

  [ Anton Blanchard ]

  * SAUCE: KVM: PPC: Book3S HV: Add little-endian guest support

  [ Benjamin Herrenschmidt ]

  * SAUCE: powerpc/powernv: Add calls to support little endian

  [ Cédric Le Goater ]

  * SAUCE: KVM: PPC: Book3S: add helper routine to load guest instructions
  * SAUCE: KVM: PPC: Book3S: add helper routines to detect endian order
  * SAUCE: KVM: PPC: Book3S: MMIO emulation support for little endian
    guests

  [ Paul E. McKenney ]

  * SAUCE: powerpc: Make 64-bit non-VMX copy_tofrom_user() bi-endian

linux (3.13.0-0.10) trusty; urgency=low

  [ Andy Whitcroft ]

  * rebase to v3.13-rc5
  * [Config] updateconfigs following rebase to v3.13-rc5

  [ Upstream Kernel Changes ]

  * rebase to v3.13-rc5
    - LP: #1260303
    - LP: #1260303
    - LP: #1260225

linux (3.13.0-0.9) trusty; urgency=low

  [ Andy Whitcroft ]

  * [Config] d-i -- allow missing firmware

linux (3.13.0-0.8) trusty; urgency=low

  [ Andy Whitcroft ]

  * [Config] annotations -- first pass over entire config
  * [Config] drop libunwind8-dev from Build-Depends for ppc64el

  [ Tim Gardner ]

  * [Config] Add arm64 device tree files
    - LP: #1262901

linux (3.13.0-0.7) trusty; urgency=low

  [ Rajesh B Prathipati ]

  * SAUCE: powerpc: Make unaligned accesses endian-safe for powerpc

  [ Tim Gardner ]

  * [Config] CONFIG_REGULATOR_S2MPS11=n for FTBS

  [ Upstream Kernel Changes ]

  * rebase to v3.13-rc4
    - LP: #1259790
    - LP: #1259437
    - LP: #1259435

linux (3.13.0-0.6) trusty; urgency=low

  [ Paolo Pisati ]

  * [Co...

Read more...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-saucy' to 'verification-done-saucy'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-saucy
Brad Figg (brad-figg) on 2014-02-11
tags: added: verification-done-saucy
removed: verification-needed-saucy
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers