Daily, random hard freeze/lock up during idle since 13.10

Bug #1255531 reported by Torsten Römer on 2013-11-27
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

Since about the final version of 13.10 (using it since Beta 2), my Lenovo L420 which was running stable until then randomly hard freezes/locks up about once a day while idling.

It never happens while I am using the PC, only when I am away. It sometimes runs through a whole night, and sometimes it freezes when I leave it idle for just an hour or so. Once it froze while the screen was not blank yet, same situation.

I have tried to disable power management in KDE and run without external screen and external harddisks, just on battery with nothing connected, then it also happens.

The screen is usually blank, there is no reaction to either mouse or keyboard, switching to a console not possible, connection through VNC or SSD not possible. I need to hard-shutdown by long-pressing the power button.

There is nothing in dmesg or syslog, it just ends and continues with the restarts. No kernel panics or something like that.

Any advice on how to trace down the issue or similar experience?

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: linux-image-3.11.0-13-generic 3.11.0-13.20
ProcVersionSignature: Ubuntu 3.11.0-13.20-generic 3.11.6
Uname: Linux 3.11.0-13-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dode 2185 F.... pulseaudio
Date: Wed Nov 27 14:06:00 2013
HibernationDevice: RESUME=UUID=3f651677-4186-4f48-b0f8-c20b56dbb2e8
InstallationDate: Installed on 2013-09-08 (80 days ago)
InstallationMedia: Kubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130902.2)
MachineType: LENOVO 78545HG
MarkForUpload: True
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-13-generic root=UUID=5aa9fd7d-cb84-4ab2-90f3-514b79fa541d ro quiet splash
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-13-generic N/A
 linux-backports-modules-3.11.0-13-generic N/A
 linux-firmware 1.116
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/12/2013
dmi.bios.vendor: LENOVO
dmi.bios.version: 8GET44WW (1.21 )
dmi.board.name: 78545HG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8GET44WW(1.21):bd04/12/2013:svnLENOVO:pn78545HG:pvrThinkPadL420:rvnLENOVO:rn78545HG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 78545HG
dmi.product.version: ThinkPad L420
dmi.sys.vendor: LENOVO

Torsten Römer (dode) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Torsten Römer (dode) wrote :

I have done a memory test as suggested in https://help.ubuntu.com/community/DebuggingSystemCrash - sorry for not reading it earlier.

Errors were found at four addresses in the memory area of the second 4 GB module. After removing it and running with only the first 4 GB, no more errors were found.

I will test for a week without the second module and report back if the freeze is solved with that.

For anyone with a similar problem:
It seems really worth running the memory test! With 8 GB it took just about 50 min for one complete pass.
Just press (right) shift on startup to get the GRUB boot menu, and start the memory test from there.

Cheers,
Torsten

Joseph Salisbury (jsalisbury) wrote :

I'll mark this as invalid for now, since it appears to be due to bad memory. Just change the status back to confirmed if you find the issue still happens after fixing the memory issue.

Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → Incomplete
status: Incomplete → Invalid
Torsten Römer (dode) wrote :

Thank you Joseph.

After running about one week without the bad memory module and another week with a new 2nd 4GB module without any freeze I think we can assume this bug is invalid :-)

Torsten

Torsten Römer (dode) wrote :

Unfortunately I still have this problem, by the time with kubuntu 14.04. Often when the system is idling for some hours, it eventually freezes.

I again let Memtest86 running, it did 9 passes in more than 13 hours without error, so it is probably not a memory issue.

There is usually an external screen connected via VGA, but I have seen the freeze also when running on battery with no external devices connected, that time while I was working. However, connecting an external screen prevents the system from suspending - for a reasoning that I can't follow - so this is why the system may idle for hours and eventually freeze, while normally it would suspend after half an hour.

The syslog does not show anything besides a line of garbage at the point where it crashed:

ul 20 18:40:01 linus CRON[5077]: (www-data) CMD ([ -x /usr/share/awstats/tools/update.sh ] && /usr/share/awstats/tools/update.sh)
Jul 20 18:40:01 linus CRON[5076]: (smmsp) CMD (test -x /etc/init.d/sendmail && /usr/share/sendmail/sendmail cron-msp)
Jul 20 18:40:01 linus sm-msp-queue[5093]: My unqualified host name (linus) unknown; sleeping for retry
^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@Jul 20 20:26:39 linus rsyslogd: [origin software="rsyslogd" swVersion="7.4.4" x-pid="969" x-info="http://www.rsyslog.com"] start
Jul 20 20:26:39 linus rsyslogd: rsyslogd's groupid changed to 103
Jul 20 20:26:39 linus rsyslogd: rsyslogd's userid changed to 101
Jul 20 20:26:39 linus kernel: [ 0.000000] Initializing cgroup subsys cpuset
Jul 20 20:26:39 linus kernel: [ 0.000000] Initializing cgroup subsys cpu
Jul 20 20:26:39 linus kernel: [ 0.000000] Initializing cgroup subsys cpuacct
Jul 20 20:26:39 linus kernel: [ 0.000000] Linux version 3.13.0-32-generic (buildd@kissel) (gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1) ) #57-Ubuntu SMP Tue Jul 15 03:51:08 UTC 2014 (Ubuntu 3.13.0-32.57-generic 3.13.11.4)

Any advice on what I could do to find out what the reason for the freezes is?

Cheers,
Torsten

Changed in linux (Ubuntu):
status: Invalid → New
Brad Figg (brad-figg) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Přemysl Čermák (premyslc) wrote :

Is there any workaround? It's little critical for my (Kubuntu 14.04) workstation, because i use it also for remote access thru SSH and computer is completely unreachable due this bug. Thanks

Torsten Römer (dode) wrote :

I am not aware of any workaround and I wonder if our freezes are related or if we have individual hardware issues. But I am pretty sure I did not have theses issues before 13.10 on the same hardware.

Přemysl Čermák (premyslc) wrote :

It seems, that problem has been solved when i try to disable CPU C states and extended C states in bios in my case. It's about one month without freeze. May be that it's relates to CPU C states VS power supply, which has problems with lowered power consumption or simly doesn't support this feature correctly.

My PC CASE with power-supply and MB ASUS J1900I-C

http://www.eurocase.cz/index.php?gid=1979

Torsten Römer (dode) wrote :

Following your experience, I have disabled "CPU Power Management" and "PCI Express Power Management" in the BIOS of my Lenovo L420.

I did not have a single freeze in one month now (before about once a week), so I suppose this solved my freezing issues as well. The fact that the freezes occurred only during idle (power management kicking in?) seems to confirm this.

BIOS or kernel bugs?

Glad I have a stable system again - Thanks for sharing!

Xiaochuan Yu (xcyu-se) wrote :

My laptop freezes after idling over night at lockscreen. I have Lenovo y410p on Ubuntu 14.04.
So far I've been able to "revive" it by going into tty (ctrl+alt+f2) and then do `unity start` which prints some some errors and then brings me to the lockscreen not frozen. The first time I login, screen will flash black for a sec and brings me back to lockscreen and I login again and it works (strange).
I haven't tried disabling CPU Power Management yet.

Torsten Römer (dode) wrote :

With the freezes I had it was not possible to "revive" from, all I could do is long-press the power button.

So maybe the freezes you encounter are another issue, maybe this bug: https://bugs.launchpad.net/kubuntu-ppa/+bug/1384512

It is about KDE but sounds similar and might be related to the video driver, so maybe Unity suffers from the same issue?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers