Mute off doesn't work

Bug #125446 reported by tmp on 2007-07-12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

Pressing the "mute" button on my IBM Y60 laptop makes the sound mute just fine and the speaker icon turns gray in the task bar as it should (I'm running Kubuntu/Feisty).
But pressing the "mute" button again only displays the "Mute off" on-screen-display in approximately 1 out of 20 times. I have to alter the volume up/down in order to un-mute.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in recently. We were wondering if this is still an issue for you? Thanks in advance.

Brian Murray (brian-murray) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and feel free to submit bug reports in the future.

tmp (skrald) wrote :

It is still an issue so I hereby reopen the bug.

Brian Murray (brian-murray) wrote :

Are you still using Feisty at this point in time?

tmp (skrald) wrote :

No I use Gutsy

Changed in kdemultimedia:
assignee: brian-murray → nobody
status: Incomplete → New

Care to try installing 'linux-backports-modules' and see if it helps.

Also, the Hardy Heron Alpha series was recently released which contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha release from . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: . Thanks.

Changed in linux-source-2.6.22:
status: New → Incomplete
Denis Rut'kov (dendron2000) wrote :

I have a RoverBook NSZ550 notebook and encountered a similar problem. The unmute never worked, and I wonder if it even could work. The aumix program, which volume control seems to use, does not offer this functionality. I fixed this by reassigning media key 'XF86AusioMute' manually to:
amixer set -c0 Master playback toggle

Changed in linux-source-2.6.22:
status: Incomplete → Confirmed

Hi tmp,

This bug report is being closed because we received no response to the last inquiry for information. Please reopen it if this is still an issue in the current Ubuntu release: .

Denis, if you still experience issues with the latest Hardy Alpha release please open a new bug report.


Changed in linux-source-2.6.22:
status: Confirmed → Won't Fix
Denis Rut'kov (dendron2000) wrote :

I confirm, that this bug is fixed in Hardy. Nice work.

tmp (skrald) wrote :

I am still experiencing this problem with the lastest version of Kubuntu Hardy. :-(

Changed in linux-source-2.6.22:
status: Won't Fix → Confirmed

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.


2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Prathap (jayaprathap) wrote :

I am still seeing this issue on ubuntu 8.10 kernal 2.6.27-7-generic. i try to mute from the keyboard but the audio is not muted. i tried manually right clicking the volume control on the system tray and muted from their, but still i hear the audio. even i tried muting the master control from the volume control still the same. only when i mute the pcm from the volume control i dont hear any audio. any suggestion to fix it?

Denis Rut'kov (dendron2000) wrote :

Prathap, certain sound 'channels' are sometimes not controlled by master volume, like MIDI (timidity). What do you use to test the volume?

i have the same problem, with ubuntu 9.04 - Jaunty kernel 2.6.28-15-generic

tmp, thank you for reporting this and helping make Ubuntu better. Hardy desktop reached EOL on May 12, 2011.
Please see this document for currently supported Ubuntu releases:

We were wondering if this is still an issue on a supported release? If so, can you try with the latest development release of Ubuntu? ISO CD images are available from .

If it remains an issue, could you run the following command in a supported release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: gutsy needs-upstream-testing
tags: added: hardy
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers