package linux-image-3.12.0-3-generic 3.12.0-3.8 failed to install/upgrade: intentando sobreescribir `/lib/modules/3.12.0-3-generic/kernel/net/openvswitch/openvswitch.ko', que está también en el paquete linux-image-extra-3.12.0-3-generic 3.12.0-3.8

Bug #1253498 reported by Alan on 2013-11-21
52
This bug affects 16 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Tim Gardner

Bug Description

Failure while updating.

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: linux-image-3.12.0-3-generic 3.12.0-3.8
ProcVersionSignature: Ubuntu 3.12.0-3.8-generic 3.12.0
Uname: Linux 3.12.0-3-generic i686
NonfreeKernelModules: wl
ApportVersion: 2.12.7-0ubuntu1
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: alan 1801 F.... pulseaudio
 /dev/snd/pcmC0D0p: alan 1801 F...m pulseaudio
Date: Thu Nov 21 00:21:10 2013
DuplicateSignature: package:linux-image-3.12.0-3-generic:3.12.0-3.8:intentando sobreescribir `/lib/modules/3.12.0-3-generic/kernel/net/openvswitch/openvswitch.ko', que está también en el paquete linux-image-extra-3.12.0-3-generic 3.12.0-3.8
ErrorMessage: intentando sobreescribir `/lib/modules/3.12.0-3-generic/kernel/net/openvswitch/openvswitch.ko', que está también en el paquete linux-image-extra-3.12.0-3-generic 3.12.0-3.8
HibernationDevice: RESUME=UUID=35f10121-fabd-4d6a-89d3-5c21760421f7
InstallationDate: Installed on 2013-11-08 (12 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release i386 (20131016.1)
MachineType: Acer Aspire 5734Z
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.12.0-3-generic root=UUID=9ceec552-587c-4fb5-8a3e-a7727cd98cc2 ro quiet splash vt.handoff=7
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions: grub-pc 2.00-20
SourcePackage: linux
Title: package linux-image-3.12.0-3-generic 3.12.0-3.8 failed to install/upgrade: intentando sobreescribir `/lib/modules/3.12.0-3-generic/kernel/net/openvswitch/openvswitch.ko', que está también en el paquete linux-image-extra-3.12.0-3-generic 3.12.0-3.8
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/25/2011
dmi.bios.vendor: Acer
dmi.bios.version: V1.06
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Aspire 5734Z
dmi.board.vendor: Acer
dmi.board.version: V1.06
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.06
dmi.modalias: dmi:bvnAcer:bvrV1.06:bd04/25/2011:svnAcer:pnAspire5734Z:pvrV1.06:rvnAcer:rnAspire5734Z:rvrV1.06:cvnAcer:ct10:cvrV1.06:
dmi.product.name: Aspire 5734Z
dmi.product.version: V1.06
dmi.sys.vendor: Acer

Alan (alanjas) wrote :
tags: removed: need-duplicate-check

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Brad Figg (brad-figg) on 2013-11-21
Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Tim Gardner (timg-tpi)
importance: Undecided → Critical
James P. Carter (jpcarter) wrote :

Start-Date: 2013-11-21 16:02:05
Commandline: apt-get dist-upgrade -y
Upgrade: gnome-calculator:amd64 (3.8.2-1ubuntu4, 3.10.2-0ubuntu1), linux-headers-3.12.0-3:amd64 (3.12.0-3.8, 3.12.0-3.9), gcalctool:amd64 (3.8.2-1ubuntu4, 3.10.2-0ubuntu1), linux-headers-3.12.0-3-generic:amd64 (3.12.0-3.8, 3.12.0-3.9), linux-image-extra-3.12.0-3-generic:amd64 (3.12.0-3.8, 3.12.0-3.9), xubuntu-restricted-addons:amd64 (16, 17), linux-image-3.12.0-3-generic:amd64 (3.12.0-3.8, 3.12.0-3.9), linux-libc-dev:amd64 (3.12.0-3.8, 3.12.0-3.9), libkgapi2-2:amd64 (2.0.1-0ubuntu1, 2.0.1-0ubuntu3)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2013-11-21 16:03:06

Start-Date: 2013-11-21 16:03:50
Commandline: apt-get dist-upgrade -y
Upgrade: linux-image-3.12.0-3-generic:amd64 (3.12.0-3.8, 3.12.0-3.9)
End-Date: 2013-11-21 16:04:58

Received the error on the first attempt to upgrade:

Examining /etc/kernel/preinst.d/
run-parts: executing /etc/kernel/preinst.d/amd64-microcode 3.12.0-3-generic /boot/vmlinuz-3.12.0-3-generic
Done.
Unpacking replacement linux-image-3.12.0-3-generic ...
dpkg: error processing /var/cache/apt/archives/linux-image-3.12.0-3-generic_3.12.0-3.9_amd64.deb (--unpack):
 trying to overwrite '/lib/modules/3.12.0-3-generic/kernel/net/openvswitch/openvswitch.ko', which is also in package linux-image-extra-3.12.0-3-generic 3.12.0-3.8
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.12.0-3-generic /boot/vmlinuz-3.12.0-3-generic
run-parts: executing /etc/kernel/postrm.d/zz-extlinux 3.12.0-3-generic /boot/vmlinuz-3.12.0-3-generic
P: Checking for EXTLINUX directory... found.
P: Writing config for /boot/vmlinuz-3.12.0-3-generic...
P: Writing config for /boot/vmlinuz-3.12.0-2-generic...
P: Installing debian theme... done.
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.12.0-3-generic /boot/vmlinuz-3.12.0-3-generic

Re-ran the update and received the following output:
Examining /etc/kernel/preinst.d/
run-parts: executing /etc/kernel/preinst.d/amd64-microcode 3.12.0-3-generic /boot/vmlinuz-3.12.0-3-generic
Done.
Unpacking replacement linux-image-3.12.0-3-generic ...
dpkg: error processing /var/cache/apt/archives/linux-image-3.12.0-3-generic_3.12.0-3.9_amd64.deb (--unpack):
 trying to overwrite '/lib/modules/3.12.0-3-generic/kernel/net/openvswitch/openvswitch.ko', which is also in package linux-image-extra-3.12.0-3-generic 3.12.0-3.8
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.12.0-3-generic /boot/vmlinuz-3.12.0-3-generic
run-parts: executing /etc/kernel/postrm.d/zz-extlinux 3.12.0-3-generic /boot/vmlinuz-3.12.0-3-generic
P: Checking for EXTLINUX directory... found.
P: Writing config for /boot/vmlinuz-3.12.0-3-generic...
P: Writing config for /boot/vmlinuz-3.12.0-2-generic...
P: Installing debian theme... done.
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.12.0-3-generic /boot/vmlinuz-3.12.0-3-generic

Tim Gardner (timg-tpi) wrote :

As soon as linux 3.12.0-4.10 is in -updates:

sudo apt-get update
sudo apt-get -f install
sudo apt-get -u dist-upgrade

description: updated
tags: added: amd64
Tim Gardner (timg-tpi) on 2013-11-25
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers