8086:0152 [Dell OptiPlex 9010] Display is heavily distorted after kernel upgrades

Bug #1251580 reported by Antoine on 2013-11-15
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

The bug is present already at boot (even from a USB stick boot without installing) in all Ubuntu (and variants) relying on Linux kernels 3.10 to 3.12 (-> still present in 3.13).

Because it's so easy to boot via USB, I tried it on 7 computers (all of them Dell Optiplex 9010). The upshot is that old distros boot correctly, with working displays. The new 13.10 distros doesn't work (i.e. the display is distorted) on 3 computers.

On my computer (which is one of the 3 malfunctioning), recovery mode also always display correctly. Playing around with xrandr and the xorg.conf turoned out to be of no avail. I tried changing the Linux kernels (after indications from this Ubuntu forums thread: http://ubuntuforums.org/showthread.php?t=2186873 ). It turns out that kernels of version <= 3.9 are OK. Kernels >= 3.10.19 are not OK. I'm willing to bisect in the 3.10.x range if deemed of interest.

I kept the lshw, lspci, xdpyinfo, ddcprobe and Xorg.0.log of all these 7 boots from USB stick. I put all those log files in a zip file availiable at http://dfiles.eu/files/njfpo8b4k

Here are the main differences I found in those files (except the Xorg.0.log which are not so handy to compare as the beginning of lines are always different).

I guess that the most telling is the following line from ddcprobe. For non-correctly-displaying computers: dtiming: 1920x1080@68

For correctly-displaying computers: dtiming: 1920x1080@60

For the record, there is no other ctiming or dtiming line in the output of ddcprobe.

The configuration are otherwise strikingly similar. The other differences which seemed of significance (i.e. not mentionning hard drives partitions and serial numbers) is that uncorrectly working computers have the following extra line in lspci

00:16.3 Serial controller: Intel Corporation 7 Series/C210 Series Chipset Family KT Controller (rev 04)

Correspondingly, the lshw of these computers have the following extra section:

        *-communication:1
             description: Serial controller
             product: 7 Series/C210 Series Chipset Family KT Controller
             vendor: Intel Corporation
             physical id: 16.3
             bus info: pci@0000:00:16.3
             version: 04
             width: 32 bits
             clock: 66MHz
             capabilities: pm msi 16550 bus_master cap_list
             configuration: driver=serial latency=0
             resources: irq:19 ioport:f0e0(size=8) memory:f7d3a000-f7d3afff

Lastly, in the *-pci section. Also, the *-memory *-bank:n (for n an integer) are not of the same vendor (Samsung or Nanya technologies for correctly-displaying computers and Hynix/Hyundai for non-correctly-displaying ones).

The visual distortion is roughly as follows: every line gets horizontally enlarged by a factor t. This factor varies with time and with the height of the line to make nice sine curves out of straight vertical lines. Actually there is a phase difference between even and odd lines. The leftmost part of the screen remains legible as the distortion effect is smaller there but the rightmost part is impossible to read. A straight vertical line looks like sine wave, the time frequency of this wave varies with time, the amplitude is always increasing linearly as one moves to the right of the screen. See also the first post in http://ubuntuforums.org/showthread.php?t=2186040

Do not hesitate to contact me if further testing is of interest.

Cheers,

X.
---
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 2324 F.... pulseaudio
CasperVersion: 1.340
CurrentDesktop: Unity
DistroRelease: Ubuntu 14.04
IwConfig:
 eth0 no wireless extensions.

 lo no wireless extensions.
LiveMediaBuild: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: Dell Inc. OptiPlex 9010
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-24-generic N/A
 linux-backports-modules-3.13.0-24-generic N/A
 linux-firmware 1.127
RfKill:

Tags: trusty
Uname: Linux 3.13.0-24-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 09/19/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A07
dmi.board.name: 0CRWCR
dmi.board.vendor: Dell Inc.
dmi.board.version: A01
dmi.chassis.type: 13
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA07:bd09/19/2012:svnDellInc.:pnOptiPlex9010:pvr01:rvnDellInc.:rn0CRWCR:rvrA01:cvnDellInc.:ct13:cvr:
dmi.product.name: OptiPlex 9010
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

summary: - Display is heavily distorted on some Dell Optiplex 9010
+ Display is heavily distorted on some Dell Optiplex 9010 after kernel
+ upgrades
summary: - Display is heavily distorted on some Dell Optiplex 9010 after kernel
- upgrades
+ Display is heavily distorted after kernel upgrades
description: updated

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-lts-saucy (Ubuntu):
status: New → Confirmed

mtornos, thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 1251580
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in linux (Ubuntu):
status: New → Confirmed
affects: linux-lts-trusty (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → High
status: New → Incomplete
no longer affects: linux-lts-saucy (Ubuntu)

apport information

tags: added: apport-collected trusty
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

tags: added: bios-outdated-a17
tags: added: bios-outdated-a16
removed: bios-outdated-a17
Antoine (antoine-gournay) wrote :

Dear Christopher,
  many thanks for your help and (probable) identification of the problem.
  I tried to follows the instructions for the various option to install the update via FreeDOS. I can run the update .exe (obtained from the Dell website) but then I get the error message
  "Cannot update a OptiPlex 9010 with a BIOS for OptiPlex 9010"
  Do you have any other suggestions on how to make those update package run (without installing windows)? Otherwise, I'll try and find a way to install windows...
  many thanks again,
  Antoine

Antoine (antoine-gournay) wrote :

Dear Christopher,
  I made a mistake by not quoting precisely enough the machine type: 41R66X1 This is(are) an Optiplex 9010 AIO (All-in-one) and was the reason for the strange error message "Cannot update a OptiPlex 9010 with a BIOS for OptiPlex 9010" from my previous comment.
  I made the BIOS update to the latest available on
  http://www.dell.com/support/home/us/en/19/product-support/servicetag/41R66X1/drivers
  namely version A15. The bug is intact and persists; nothing changed.
  The output of
  sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
  is
A15
05/05/2014
  Please keep me posted on what I could do further.
  Many thanks,
  Antoine

Antoine, could you please test the latest upstream kernel available (the one all the way at the top, and not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-3.15-rc8

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: latest-bios-a15
removed: bios-outdated-a16
tags: added: kernel-bug-exists-upstream-3.15-rc5 kernel-fixed-upstream kernel-fixed-upstream-3.15-rc6
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Antoine, could you please test http://cdimage.ubuntu.com/daily-live/current/ and advise if this is reproducible?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Antoine (antoine-gournay) wrote :

Christopher, tested the daily build (utopic, written on a USB stick) a few minutes ago and the bug is still present. The command uname -a yields

Linux ubuntu 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

which seems coherent with the fact that the bug is fixed upstream in 3.15-rc6

Antoine, the next step is to fully reverse commit bisect the kernel in order to identify the fix commit. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection#How_do_I_reverse_bisect_the_upstream_kernel.3F ?

tags: added: utopic
Antoine (antoine-gournay) wrote :

Christopher, upon trying to follow the instructions there and getting the first bisect point I get a mess of error messages when running

mainline-build-one 60b5f90d0fac7585f1a43ccdad06787b97eda0ab utopic

in order to make the first build... (see attached .txt)

what did I miss?

Antoine, unfortunately I couldn't speak to mainline-build-one, as I frankly don't use it when bisecting, and I didn't write that section. I would recommend using the bisect procedure above that section, or if you would like to work it out with mainline-build-one, ping Joseph Salisbury.

Antoine (antoine-gournay) wrote :

Christopher, many thanks. If I did not mess up the bisecting, the bug is fixed by commit 56071a207602a451f0c46d3dcc8379b59ef576e2

drm/i915: use lane count and link rate from VBT as minimums for eDP

I attached the log file of the bisection (and the last output after identifying the commit). If I understood correctly, the meaning of good and bad have to be reversed in this kind of situation.

tags: added: reverse-bisect-done
Changed in linux (Ubuntu):
status: Incomplete → Triaged
tags: added: cherry-pick
Michael Greene (commod0re) wrote :

Is there any progress on publishing a fix to this in the lts-trusty HWE for precise (or alternately providing lts-utopic for precise)? This is currently an issue for some systems I am supporting. Downgrading them to a 3.11 kernel or changing distributions is not currently an option for me, and it looks like lts-utopic is not available for precise.

Michael Greene (commod0re) wrote :

er, 3.09, not 3.11, but yeah

Antoine (antoine-gournay) wrote :

The solution I used (as an idiotic layman) was to upgrade (instead of downgrading) the kernel to a version >=3.15 by using the deb files which may be found at

http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D

Pick a subdirectory with high enough version (e.g. v3.15.3-utopic/ ). You need 3 .deb's from that page: the headers-all package and the image and headers packages appropriate for your architecture (presumably x86_64 if you are using the same Optiplexs as above). Download the .deb's and install them by typing (from the directory where you downloaded them):

sudo dpkg -i linux*

Even if this version is not intended for the distribution I had, it still worked perfectly (my distribution was a "quantic" and the kernel says it goes for "utopic"). You do not need to reinstall anything. From the post mtornos made on the Ubuntu forums, I gather it worked for him too.

This update will (but again I am speaking as an idiotic layman, so maybe it won't) be automatic at some point: the kernel version keeps being updated via official updates. For example, on my other computer I am now at kernel 3.13 by just keeping to the official updates. The problem is that you might have to wait for a year or two before it reaches 3.15.x, unless you do not do it manually.

Michael Greene, it will help immensely if you filed a new report via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

summary: - Display is heavily distorted after kernel upgrades
+ 8086:0152 [Dell OptiPlex 9010] Display is heavily distorted after kernel
+ upgrades
Michael Greene (commod0re) wrote :

I don't actually have direct access to the box in question, unfortunately, and it is a very pared down install (it is at one of our clients' locations, and they are particular enough about their network that I'm not sure the machine in question would even be able to submit that report)

I am working on obtaining similar hardware. If I manage to do so, I will be more than happy to submit such a report myself.

In the meantime, I will see if I can update the kernel using the same solution Antoine used. Thanks for the responses, guys :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers