Ubuntu

Automute broken with Realtek multifunction headset jacks

Reported by David Henningsson on 2013-11-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Medium
David Henningsson
linux (Ubuntu)
Undecided
David Henningsson

Bug Description

In case there is both a multifunction headset jack and a Line Out jack, automuting was not working properly from the Line Out jack.

This bug is for tracking purposes, please do not triage.

In case there is both a multifunction headset jack and a Line Out
jack, automuting was not working properly from the Line Out jack.
This patch fixes that issue.

Cc: <email address hidden> (3.10+)
BugLink: https://bugs.launchpad.net/bugs/1250377
Tested-by: Cyrus Lien <email address hidden>
Signed-off-by: David Henningsson <email address hidden>
---
 sound/pci/hda/patch_realtek.c | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
index 24d924d..04d1e6b 100644
--- a/sound/pci/hda/patch_realtek.c
+++ b/sound/pci/hda/patch_realtek.c
@@ -3344,8 +3344,10 @@ static void alc_update_headset_mode(struct hda_codec *codec)
  else
   new_headset_mode = ALC_HEADSET_MODE_HEADPHONE;

- if (new_headset_mode == spec->current_headset_mode)
+ if (new_headset_mode == spec->current_headset_mode) {
+ snd_hda_gen_update_outputs(codec);
   return;
+ }

  switch (new_headset_mode) {
  case ALC_HEADSET_MODE_UNPLUGGED:
--
1.7.9.5

Changed in linux (Ubuntu):
status: New → In Progress
assignee: nobody → David Henningsson (diwic)
Takashi Iwai (tiwai) wrote :

At Tue, 12 Nov 2013 11:10:57 +0100,
David Henningsson wrote:
>
> In case there is both a multifunction headset jack and a Line Out
> jack, automuting was not working properly from the Line Out jack.
> This patch fixes that issue.
>
> Cc: <email address hidden> (3.10+)
> BugLink: https://bugs.launchpad.net/bugs/1250377
> Tested-by: Cyrus Lien <email address hidden>
> Signed-off-by: David Henningsson <email address hidden>

Thanks, applied.

Takashi

> ---
> sound/pci/hda/patch_realtek.c | 4 +++-
> 1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
> index 24d924d..04d1e6b 100644
> --- a/sound/pci/hda/patch_realtek.c
> +++ b/sound/pci/hda/patch_realtek.c
> @@ -3344,8 +3344,10 @@ static void alc_update_headset_mode(struct hda_codec *codec)
> else
> new_headset_mode = ALC_HEADSET_MODE_HEADPHONE;
>
> - if (new_headset_mode == spec->current_headset_mode)
> + if (new_headset_mode == spec->current_headset_mode) {
> + snd_hda_gen_update_outputs(codec);
> return;
> + }
>
> switch (new_headset_mode) {
> case ALC_HEADSET_MODE_UNPLUGGED:
> --
> 1.7.9.5
>

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
tags: added: blocks-hwcert-enablement
Changed in hwe-next:
status: New → Fix Committed
assignee: nobody → David Henningsson (diwic)
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.12.0-5.13

---------------
linux (3.12.0-5.13) trusty; urgency=low

  [ Tim Gardner ]

  * Rebase to v3.12.2
  * Release tracker
    - LP: #1257003

  [ Upstream Kernel Changes ]

  * rebase to v3.12.2
    - LP: #1253636
    - LP: #1250377
    - LP: #1248465
 -- Tim Gardner <email address hidden> Mon, 02 Dec 2013 09:26:35 -0700

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-saucy' to 'verification-done-saucy'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-saucy
Brad Figg (brad-figg) on 2014-02-11
tags: added: verification-done-saucy
removed: verification-needed-saucy
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers