please enable CONFIG_RT2800USB_RT3573 in kernel 3.12

Bug #1247784 reported by Gianfranco Costamagna on 2013-11-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Debian)
Fix Released
Unknown
linux (Ubuntu)
Wishlist
Unassigned

Bug Description

As said into the title, in the new 3.12 this option is disabled in ubuntu

quoting the .config file
# CONFIG_RT2800USB_RT3573 is not set

I have a device using this module, and I did recompile the kernel (enabling it) successfully.

Please consider enabling it.

Thanks
---
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
DistroRelease: Ubuntu 13.10
InstallationDate: Installed on 2013-10-18 (16 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MarkForUpload: True
Package: linux (not installed)
Tags: saucy
Uname: Linux 3.12.0 x86_64
UnreportableReason: The running kernel is not an Ubuntu kernel
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm lpadmin sambashare sudo vboxusers

tags: added: apport-collected saucy
description: updated

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1247784

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
importance: Undecided → Wishlist
tags: added: kernel-da-key trusty
Changed in linux (Ubuntu):
status: Incomplete → Triaged
tags: removed: saucy

The hardware is the Edimax EW-7733UnD usb dongle

Changed in linux (Debian):
status: Unknown → New
Seth Forshee (sforshee) wrote :

The first Ubuntu development kernel for 3.12 was just recently uploaded and has the option enabled, so I'm not really sure what kernel you're referring to with this bug report. Seeing how it is enabled though I'm marking this bug invalid.

Changed in linux (Ubuntu):
status: Triaged → Invalid

Hi Seth, I was referring to http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-saucy/
the /boot/config doesn't have this option enabled.

(maybe this kernel is handled differently because if from saucy? Is it handled by a different team?)

Seth Forshee (sforshee) wrote :

Our team does generate those kernels, but they are for test purposes only and are not meant for day-to-day use. As such they are not officially supported. The option here was new in 3.12 and for whatever reason got defaulted to off, but as soon as those builds start using the trusty kernel packaging the option will be enabled in the mainline builds.

Andy Whitcroft (apw) wrote :

@seth -- confirmed I have just switched the mainline builds over to the trusty sources and config.

Changed in linux (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.