Laptop built-in keyboard is not working after ubuntu 13.10 upgrade and using kernel 3.11.0-12-generic

Bug #1247396 reported by Saiph Kappa on 2013-11-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I have an LG S1 Express Dual laptop and after upgrading to ubuntu 13.10 my keyboard stopped working when the default kernel is used (3.11.0-12-generic). Even the ESC key does not work during the boot phase to see the booting messages. Basically I can't do anything, I get stuck in the login screen. If I choose the old kernel 3.8.0-31-generic, it works without any problem.

Philip Peitsch (philip-peitsch) wrote :

Saiph, have you seen this link: http://stevesubuntutweaks.blogspot.com.au/2013/10/laptop-keyboard-stopped-working-after.html?

From that article:

A bit of head scratching, and plugging in a separate USB keyboard allowed me to type again. But that isn't quite an optimal solution. A bit of Googling led me to the following bug report for someone else with an LG laptop. Going by the eighth comment in that, it turns out a couple of options have to be added to the grub menu, by editing the /etc/default/grub file. In my case, the file had the following line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

I added two options to the end, so it became:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nopnp=1 i8042.dumbkbd=1"

Saved the file, and ran sudo update-grub to let the changes apply, and rebooted. I am now typing this blog post on the working laptop keyboard!

Saiph Kappa (saiph-kappa) wrote :

I haven't seen that post. Thank you very much Philip. It worked.

Michael Dunetas (mdunetas) wrote :

That worked for me to.

Andy Whitcroft (apw) on 2015-08-16
affects: initramfs-tools (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1247396

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: saucy
Joseph Salisbury (jsalisbury) wrote :

Is this still an issue with the latest supported release?

Changed in linux (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers