8086:0106 [Lenovo B570] Brightness is at 100 percent and will not change

Bug #1244645 reported by James Ramsay
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
X.Org X server
New
Undecided
Unassigned
linux (Ubuntu)
Low
Unassigned

Bug Description

I have seen this issue before as it was in the 13.10 betas. When I try any setting and method to change the brigtness it fails and remains at 100%. PLease feel free to contact me to get more information

WORKAROUND: Create /usr/share/X11/xorg.conf.d/20-intel.conf with the following text:
Section "Device"
    Identifier "card0"
    Driver "intel"
    Option "Backlight" "intel_backlight"
    BusID "PCI:0:2:0"

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xorg 1:7.7+1ubuntu6
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
NonfreeKernelModules: wl
.tmp.unity.support.test.0:

ApportVersion: 2.12.6-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDmesg:
 [ 22.303888] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
 [ 22.304339] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
 [ 54.899779] ISO 9660 Extensions: Microsoft Joliet Level 3
 [ 54.952839] ISO 9660 Extensions: RRIP_1991A
Date: Fri Oct 25 07:36:52 2013
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
DkmsStatus: bcmwl, 6.30.223.141+bdcom, 3.11.0-12-generic, x86_64: installed
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0106] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:3975]
InstallationDate: Installed on 2013-10-25 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20131021.1)
MachineType: LENOVO 1068BAU
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_US
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-12-generic.efi.signed root=UUID=96b54589-c267-4291-b79c-3ff62dddb522 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/27/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 44CN43WW
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Emerald Lake
dmi.board.vendor: LENOVO
dmi.board.version: FAB1
dmi.chassis.asset.tag: Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnLENOVO:bvr44CN43WW:bd10/27/2011:svnLENOVO:pn1068BAU:pvrLenovoB570:rvnLENOVO:rnEmeraldLake:rvrFAB1:cvnLENOVO:ct10:cvr0.1:
dmi.product.name: 1068BAU
dmi.product.version: Lenovo B570
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.46-3ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.2.2-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.2.2-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.14.3-3ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu10
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.904-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.9-2ubuntu1
xserver.bootTime: Fri Oct 25 07:34:51 2013
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 826
 vendor LGD
xserver.version: 2:1.14.3-3ubuntu3

Revision history for this message
James Ramsay (f-jack) wrote :
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Jack Ramsay, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc7

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: saucy
tags: added: latest-bios-44cn43ww
affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
James Ramsay (f-jack) wrote : Re: [Bug 1244645] Re: Brightness is at 100 percent and will not change
Download full text (5.8 KiB)

I found the fix myself, Create /usr/share/X11/xorg.conf.d/20-intel.conf
with the following text:

Section "Device"
    Identifier "card0"
    Driver "intel"
    Option "Backlight" "intel_backlight"
    BusID "PCI:0:2:0"

EndSection

On Tue, Jan 7, 2014 at 4:45 PM, Christopher M. Penalver <
<email address hidden>> wrote:

> Jack Ramsay, could you please test the latest upstream kernel available
> (not the daily folder) following
> https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional
> upstream developers to examine the issue. Once you've tested the upstream
> kernel, please comment on which kernel version specifically you tested. If
> this bug is fixed in the mainline kernel, please add the following tags:
> kernel-fixed-upstream
> kernel-fixed-upstream-VERSION-NUMBER
>
> where VERSION-NUMBER is the version number of the kernel you tested. For
> example:
> kernel-fixed-upstream-v3.13-rc7
>
> This can be done by clicking on the yellow circle with a black pencil icon
> next to the word Tags located at the bottom of the bug description. As
> well, please remove the tag:
> needs-upstream-testing
>
> If the mainline kernel does not fix this bug, please add the following
> tags:
> kernel-bug-exists-upstream
> kernel-bug-exists-upstream-VERSION-NUMBER
>
> As well, please remove the tag:
> needs-upstream-testing
>
> Once testing of the upstream kernel is complete, please mark this bug's
> Status as Confirmed. Please let us know your results. Thank you for your
> understanding.
>
> ** Tags added: saucy
>
> ** Tags added: latest-bios-44cn43ww
>
> ** Package changed: xserver-xorg-video-intel (Ubuntu) => linux (Ubuntu)
>
> ** Changed in: linux (Ubuntu)
> Importance: Undecided => Low
>
> ** Changed in: linux (Ubuntu)
> Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1244645
>
> Title:
> Brightness is at 100 percent and will not change
>
> Status in “linux” package in Ubuntu:
> Incomplete
>
> Bug description:
> I have seen this issue before as it was in the 13.10 betas. When I try
> any setting and method to change the brigtness it fails and remains at
> 100%. PLease feel free to contact me to get more information
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: xorg 1:7.7+1ubuntu6
> ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
> Uname: Linux 3.11.0-12-generic x86_64
> NonfreeKernelModules: wl
> .tmp.unity.support.test.0:
>
> ApportVersion: 2.12.6-0ubuntu1
> Architecture: amd64
> CompizPlugins: No value set for
> `/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: compiz
> CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
> CompositorUnredirectFSW: true
> CurrentDmesg:
> [ 22.303888] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
> [ 22.304339] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
> [ 54.899779] ISO 9660 Extensions: Microsoft Joliet Level 3
> [ 54.952839] ISO 9660 Extensions: RRIP_1991A
> Date: Fri Oct 25 07:36:52 2013
> DistUpgraded: Fresh install
> Di...

Read more...

Changed in linux (Ubuntu):
assignee: nobody → Jack Ramsay (f-jack)
status: Incomplete → Fix Released
Revision history for this message
James Ramsay (f-jack) wrote : Re: Brightness is at 100 percent and will not change

I found the fix myself, Create /usr/share/X11/xorg.conf.d/20-intel.conf with the following text:

Section "Device"
    Identifier "card0"
    Driver "intel"
    Option "Backlight" "intel_backlight"
    BusID "PCI:0:2:0"

EndSection

We just need to implement this into the kernel to where it is done automatically for intel backlight. I will notify the x server team

Revision history for this message
James Ramsay (f-jack) wrote :

I don't know how to forward it upstream I would apreciate it if you did that.

Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Jack Ramsay, thank you for your comment. Before anything would be upstreamed, the information in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1244645/comments/2 would need to be provided.

Revision history for this message
James Ramsay (f-jack) wrote :

I have tested the mainline kernel and the bug still exists. I removed the tag like you said to and added the two others. It is ready to be upstreamed

tags: added: kernel-bug-exists-upstream
tags: added: kernel-bug-exists-upstream-3.12.0-031200
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Jack Ramsay, thank you for your comment. Unfortunately, 3.12.x is not the latest mainline kernel. Could you please test the latest mainline kernel -> http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.13-rc7-trusty/ and advise to the results?

Changed in linux (Ubuntu):
assignee: Jack Ramsay (f-jack) → nobody
status: Fix Released → Incomplete
tags: added: needs-upstream-testing
removed: kernel-bug-exists-upstream kernel-bug-exists-upstream-3.12.0-031200
Revision history for this message
James Ramsay (f-jack) wrote : Re: [Bug 1244645] Re: Brightness is at 100 percent and will not change

I am running saucy so do I need to install the trusty-daily version of
ubuntu and then the kernel?
On 01/07/2014 07:43 PM, Christopher M. Penalver wrote:
> Jack Ramsay, thank you for your comment. Unfortunately, 3.12.x is not
> the latest mainline kernel. Could you please test the latest mainline
> kernel -> http://kernel.ubuntu.com/~kernel-
> ppa/mainline/v3.13-rc7-trusty/ and advise to the results?
>
> ** Changed in: linux (Ubuntu)
> Status: Fix Released => Incomplete
>
> ** Changed in: linux (Ubuntu)
> Assignee: Jack Ramsay (f-jack) => (unassigned)
>
> ** Tags removed: kernel-bug-exists-upstream kernel-bug-exists-upstream-3.12.0-031200
> ** Tags added: needs-upstream-testing
>

Revision history for this message
James Ramsay (f-jack) wrote : Re: Brightness is at 100 percent and will not change

and also the link you gave me also just gave me a error 404

Revision history for this message
James Ramsay (f-jack) wrote :

I got it and the bug is still present in the RC7 kernel

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-bug-exists-upstream kernel-bug-exists-upstream-3.13.0-031300rc7
removed: needs-upstream-testing
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Jack Ramsay, thank you for performing the requested test. Could you please advise if any of the following kernel parameters individually provide a WORKAROUND following https://help.ubuntu.com/community/BootOptions :
acpi_backlight=vendor
video.use_bios_initial_backlight=0
thinkpad-acpi.brightness_enable=1

tags: added: kernel-bug-exists-upstream-v3.13-rc7
removed: kernel-bug-exists-upstream-3.13.0-031300rc7
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
James Ramsay (f-jack) wrote :

I tried those but it is not a Thinkpad. What is happening is the drivers for intel backlight are not loading. That is why adding that file works. I don't know who it needs to be reported to I will ask my team as it looks not to be an issue with the kernel but with X11.

Revision history for this message
James Ramsay (f-jack) wrote :

What package do you think this should be filed against?

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Phill Whiteside (phillw) wrote :

Brightening and darkening is working fine with lubuntu 14.04 My hardware is http://phillw.net/hardware/aDU4RVzY If you want to let the devs know more of your system please do have a read of https://wiki.ubuntu.com/QATeam/Hardware This actually makes the tasks of the devs a little easier as they may even actually ping you back to try some thing..... And, yes, they do.

Revision history for this message
James Ramsay (f-jack) wrote :

Phil, You have an AMD system. This is for an Intel system with Intel Graphics. This hasn't worked in saucy or trusty for a number of people as there are posts on ask ubuntu and the ubuntu forums about this issue

Revision history for this message
James Ramsay (f-jack) wrote :

And actually I am on that list as I am part of QA my machine is here http://phillw.net/hardware/ssd5MXw0

Revision history for this message
Phill Whiteside (phillw) wrote :

https://launchpad.net/~f-jack My dear friend... My reply to the bug was such that I know it is a bug (and I have asked others to verify). Using #15 does make things easier as the devs can see who has what and ask if they can check out things :) Go rally some troups for the bug, go see if you can find a way around the bug... but never leave a bug alone... There are two types of bugs..... those that can be hugged and leave peacefully, and those bugs that need jumping over.
f-jack, if you get the report written up fully (ask on #ubuntu-bugs) your bug should get looked after and leave peacefully with a number against its name :)https://launchpad.net/~f-jack

summary: - Brightness is at 100 percent and will not change
+ 8086:0106 [Lenovo B570] Brightness is at 100 percent and will not change
description: updated
Revision history for this message
James Ramsay (f-jack) wrote :

Here's the thread from ubuntu forums where this has been disscussed http://ubuntuforums.org/showthread.php?t=2181534.
Christopher, This is more than an issue with the B570 as this is happening to most computers with Intel Graphics. The workaround is written here https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1244645/comments/4 as all it does is load an x11 module for the Intel Backlight device wich for some reason is not loaded upon installation by default.

Revision history for this message
Phill Whiteside (phillw) wrote :

it may be worth asking the x-server team if they have received the proposed fix and what their attitude of implementing it is so that it lands with the kernel team. I've never had communication with the x-server team, but have found the kernel team to be absolute stars of the first magnitude in helping explain how to get a patch in.

Revision history for this message
James Ramsay (f-jack) wrote :

Thanks Phil. Christopher, How would I go about doing that?

Revision history for this message
Joseph Salisbury (jsalisbury) wrote : Test with newer development kernel (3.13.0-24.46)

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

  With the recent release of this Ubuntu release, would like to confirm if this bug is still present. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.13.0-24.46
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers