Server 13.10 Install Fails with USB Keyboard (Appears to Hang)

Bug #1244176 reported by Jeffrey Walton on 2013-10-24
148
This bug affects 29 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
High
Unassigned
Saucy
Undecided
Unassigned
Trusty
High
Unassigned
Utopic
High
Unassigned
linux (Ubuntu)
High
Stefan Bader
Saucy
High
Stefan Bader
Trusty
High
Stefan Bader
Utopic
High
Stefan Bader

Bug Description

A fresh install of Server 13.10 on old hardware fails when a USB keyboard is present. The installation succeeds when a PS/2 keyboard is installed.

The installation appears to hang at the third screen, which is "Select Language". The screen does not respond to keyboard or mouse events.

The issue was experienced independently on HP/Compag dc5850 with Athlon X2 2.3 GHz dual core, 4GB RAM; and DELL Optiplex 755. See "Server 13.10 Install Hangs", http://askubuntu.com/questions/364945/server-13-10-install-hangs/364949.

The issue was not present on Server 12.04.3 LTS or 13.04.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) on 2013-11-06
affects: apport (Ubuntu) → linux (Ubuntu)
Joseph Salisbury (jsalisbury) wrote :

If possible, can you also test the latest Trusty daily image:

http://cdimage.ubuntu.com/daily-live/current/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: saucy
tags: added: kernel-da-key
Orcie (mef-vanschalkwijk) wrote :

Also present in mini.iso 64bit. If I was Ubuntu I would fix this asap. I am already considering another distro.

Joseph Salisbury (jsalisbury) wrote :

Were you able to confirm this also happens with the Trusty daily image?

Changed in linux (Ubuntu):
importance: Medium → High

Hi Joseph,

> Were you able to confirm this also happens with the Trusty daily image?
I've got some cycles and I can test it.

So I'm clear: there are only desktop builds; and not server builds,
which the bug report was written against. Do you still want the
testing to proceed?

If so, I will be using the following. Is it correct?

    trusty-desktop-i386.iso
    08-Nov-2013 07:51 905M
    Desktop image for PC (Intel x86) computers (standard download)

Jeff

On Fri, Nov 8, 2013 at 11:50 AM, Joseph Salisbury
<email address hidden> wrote:
> Were you able to confirm this also happens with the Trusty daily image?
>
> ** Changed in: linux (Ubuntu)
> Importance: Medium => High
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1244176
>
> Title:
> Server 13.10 Install Fails with USB Keyboard (Appears to Hang)
>
> Status in “linux” package in Ubuntu:
> Confirmed
>
> Bug description:
> A fresh install of Server 13.10 on old hardware fails when a USB
> keyboard is present. The installation succeeds when a PS/2 keyboard is
> installed.
>
> The installation appears to hang at the third screen, which is "Select
> Language". The screen does not respond to keyboard or mouse events.
>
> The issue was experienced independently on HP/Compag dc5850 with
> Athlon X2 2.3 GHz dual core, 4GB RAM; and DELL Optiplex 755. See
> "Server 13.10 Install Hangs",
> http://askubuntu.com/questions/364945/server-13-10-install-
> hangs/364949.
>
> The issue was not present on Server 12.04.3 LTS or 13.04.

Joseph Salisbury (jsalisbury) wrote :

Sorry, I have you the wrong link. The daily Trusty server image is available at:

http://cdimage.ubuntu.com/ubuntu-server/daily/current/

Thanks again!

Jeffrey Walton (noloader) wrote :

Hi Joseph,

> http://cdimage.ubuntu.com/ubuntu-server/daily/current/
I can confirm the issue is still present with:

    trusty-server-i386.iso
    09-Nov-2013 06:52 668M
    Server install image for PC (Intel x86) computers

Oddly, the first two screens (CD-Language and Install) do accept input
with USB mouse/keyboard. Its the third screen (Install-Language)
that's causing the troubles.

If it matters, I'm burning the image to a DVD. I'm not booting from a
thumb drive.

Jeff

On Fri, Nov 8, 2013 at 3:46 PM, Joseph Salisbury
<email address hidden> wrote:
> Sorry, I have you the wrong link. The daily Trusty server image is
> available at:
>
> http://cdimage.ubuntu.com/ubuntu-server/daily/current/
>
> Thanks again!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1244176
>
> Title:
> Server 13.10 Install Fails with USB Keyboard (Appears to Hang)
>
> Status in “linux” package in Ubuntu:
> Confirmed
>
> Bug description:
> A fresh install of Server 13.10 on old hardware fails when a USB
> keyboard is present. The installation succeeds when a PS/2 keyboard is
> installed.
>
> The installation appears to hang at the third screen, which is "Select
> Language". The screen does not respond to keyboard or mouse events.
>
> The issue was experienced independently on HP/Compag dc5850 with
> Athlon X2 2.3 GHz dual core, 4GB RAM; and DELL Optiplex 755. See
> "Server 13.10 Install Hangs",
> http://askubuntu.com/questions/364945/server-13-10-install-
> hangs/364949.
>
> The issue was not present on Server 12.04.3 LTS or 13.04.

Joseph Salisbury (jsalisbury) wrote :

Are you able to get to any of the other virtual terminals when this issue happens(By pressing CTRL + ALT + F1)? If so, can you capture a dmesg output from a vt after reproducing the bug?

Marc (theprofessor21) wrote :

I'm also experiencing the same problem with a USB keyboard on a Dell Inspiron desktop with Ubuntu Server and netboot install images for 13.10 as well as the latest trusty daily images. The keyboard works fine in BIOS and Grub but when the install image is booted the keyboard is disabled after a few seconds (indicator lights turn off, no response to capslock etc.) just before the Language selection menu is displayed. Unplugging and re-plugging the keyboard doesn't help either. I plugged in a USB fan and the USB ports are powered on, but the keyboard doesn't work. This issue does not happen with the regular Desktop installer, just with the Server and netboot versions. The motherboard doesn't have a PS2 port to workaround this problem.

Marc (theprofessor21) wrote :

If someone can provide me a preseed config which can upload the output of dmesg to a remote server, I can post the dmesg of the failed installer for 13.10/trusty.

toolib (toolib) wrote :

I have the same problem. The USB keyboard and mouse just power off, no light any more when step in Language selection menu.

Marc (theprofessor21) wrote :

Okay so I figured out the problem. The kernel module ohci-pci is seperated from ohci-hcd in 3.11 but is not included in the initramfs. I compiled the module myself and inserted it into the initramfs and now the installer works just fine. Here's the debian bug: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=726957

cpburnz (cpburnz) wrote :

I am experiencing this same issue trying to install Ubuntu Server 13.10 with ASRock E350M1 motherboard using a USB wired keyboard.

Changed in initramfs-tools (Ubuntu):
importance: Undecided → High
tags: added: kernel-key
removed: kernel-da-key
Stefan Bader (smb) wrote :

As said in comment #13, I think this is related to the ohci-pci module. All other usb hcd drivers are built-in but this one was missed after upstream split it off the ohci_hcd driver. Initramfs-tools cannot help there for the installer at least.

Changed in linux (Ubuntu):
assignee: nobody → Stefan Bader (smb)
status: Confirmed → In Progress
Changed in initramfs-tools (Ubuntu):
status: New → Invalid
Stefan Bader (smb) on 2013-12-04
Changed in initramfs-tools (Ubuntu Saucy):
status: New → Invalid
Stefan Bader (smb) wrote :

Proposing to build the driver into the kernel (again). Though for Saucy this would only help the installation when the image would get re-spun with the new kernel. This is normally not done. But we will have to see.

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Saucy):
status: New → In Progress
importance: Undecided → High
Tim Gardner (timg-tpi) on 2013-12-04
Changed in linux (Ubuntu Saucy):
assignee: nobody → Stefan Bader (smb)
Dave (dlgawley) wrote :

Problem as of 2013-12-06 Ubuntu 14.04 daily build is still present when trying to install on Dell 515 with IDrac6 Enterprise.
http://cdimage.ubuntu.com/ubuntu-server/daily/current/trusty-server-amd64.iso

Stefan Bader (smb) wrote :

Fix committed does not mean its available. It just means it was added to the git repo. If a kernel gets available there should be an automatic release notice and the status changing to fix released.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.12.0-7.15

---------------
linux (3.12.0-7.15) trusty; urgency=low

  [ Tim Gardner ]

  * Rebase to v3.12.4
  * Release tracker
    - LP: #1258947

  [ Upstream Kernel Changes ]

  * rebase to v3.12.4
 -- Tim Gardner <email address hidden> Sun, 08 Dec 2013 10:22:23 -0700

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

g 'verification-needed-saucy' to 'verification-done-saucy'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Changed in linux (Ubuntu Saucy):
status: In Progress → Fix Committed
tags: added: verification-needed-saucy
Jeffrey Walton (noloader) wrote :

> If verification is not done by 5 working days from today,
> this fix will be dropped from the source code, and this bug
> will be closed.

Forgive my ignorance, but how do I test the fix. Adding a repo does not seem to apply since I fetch prebuilt ISO's from Ubuntu. That is, "selective upgrading from -proposed" does not seem to apply. (I do understand how it applies to a package like OpenSSL).

MTO (emteeoh) wrote :

 > Forgive my ignorance, but how do I test the fix.
 > Adding a repo does not seem to apply since I fetch prebuilt ISO's from Ubuntu.

It looks to me like you want to go to https://wiki.ubuntu.com/Testing/ISO and follow the instructions.

MTO (emteeoh) wrote :

I can verify that on my machine (Zotac Zbox Nano), that http://cdimage.ubuntu.com/ubuntu-server/daily/current/trusty-server-amd64.iso , dated 16-Dec-2013 06:48, this bug is fixed.

MTO (emteeoh) wrote :

I mean, I "confirm". it works. bug fixed. My wording above was ambiguous.

Stefan Bader (smb) on 2013-12-17
tags: added: verification-done-saucy
removed: verification-needed-saucy
Stefan Bader (smb) wrote :

I set the saucy confirmation to done because a real verification is hard there. ISO images are usually not re-created after release and even less likely with a kernel still in proposed. So I just checked that the deb packages for 3.11.0-15.23 contain no ohci-pci module and the contained config has "CONFIG_USB_OHCI_HCD_PCI".

Stefan Bader (smb) wrote :

... has "CONFIG_USB_OHCI_HCD_PCI=y" was what I tried to write...

alx kouks (alxkouks) on 2013-12-24
Changed in linux (Ubuntu Saucy):
status: Fix Committed → Fix Released
Steve Smith (yo-ste9a-s9) wrote :

As stated above, the problem persists in the main Ubuntu Server 12.04 LTS and 13.10 ISOs from the main Ubuntu website. Unfortunately, it also still appears to be in the daily builds (pending and current) of Ubuntu Server 14.04 and the 12.04.3 LTS dated today 29th Dec 2013. Tested today on an Acer Aspire Revo R3600 with a USB keyboard.

Mathijs Veen (matv1) wrote :

Problem persists confirmed on both 13.10 and 14.04 dailys. So I am not really getting what the scenario is to get this fix into a stable ISO: Do I understand correctly that 13.10 won't be respun because of this? Does that mean that to get a supported Ubuntu server ISO that can be installed, we will have to wait for Trusty? And if so: when will this be introduced into the dailys?

Secondly it is also not clear to me if this is restricted to certain keyboards or all?
Debian testing seems to sugest some usb keyboards work:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=726957#17
But that seems weird to me since CONFIG_USB_OHCI_HCD_PCI looks to me like a generic parameter.
Please advise. thnks!

phromo (phromo) wrote :

Where do I find the 13.10 daily referred to in this log?

My ubuntu server install is completely blocked due to this, no PS/2 on my server :/

I can support the statement of comment #23. The bug seems to be fixed in the latest daily Trusty Tahr build from: http://cdimage.ubuntu.com/ubuntu-server/daily/current/trusty-server-amd64.iso

The current 13.10 download off of the Ubuntu homepage still hangs.

Thanks for the quick fix though :-)

tags: removed: kernel-key
swissinvestor (wern1) wrote :

I can confirm comments # 23 and 30.

The official server download from the Ubuntu homepage however still hangs at "Language" because both keyboard and mouse stop working because of failed USB support.

John Mahoney IV (jjmiv) wrote :

i am installing 13.10 Server on a Dell Optiplex 740 with an AMD Athlon and Dynex USB keyboard. no response at language screen. any workarounds or is there another build i should use?

Stefan Bader (smb) wrote :

Pragmatically I would just go for a 14.04 (LTS) install. It is pretty stable already and following updates you would end up with a long-term supported install. If it has to be 13.10 then its either a netinstall with a preseed (so no interaction is required), but that is slightly complicated. Or use a 13.04 install media and upgrade from there. A bit tedious.

Michael Flaig (mflaig) wrote :

Just tested trusty server amd64 (20140413) and the installation did in fact hang. No keyboard interaction, no caps lock, num lock reaction either. Trusty Live did work however. Keyboard is a Lenovo Thinkpad keyboard Model SK-8855

Stefan Bader (smb) wrote :

But the Trusty kernel has the CONFIG_USB_OHCI_HCD_PCI=y set (which was the problem reported here) and I just checked the iso with the virtual keyboard/monitor over lan which was failing before. And that is reacting on the keyboard.
Michael, from the little info in your comment its unclear whether there was a kernel panic and a resulting hang or just the usb keyboard had an issue. But since things seem to work here, it is very likely a different issue to this. Could you file a new bug ("ubuntu-bug linux" from the live iso, then you can manually update the report with the details of the server install). Subscribe me to the new report, then I will see it. And add more details on how this happens (always the same place, a certain menu or when). Thanks.

Don Bowman (donbowman) wrote :

I also observe this on trusty server amd64 (release).
Its a bit hard to diagnose, it just locks up.

two systems... one is zotac z77-itx, and the other is gigabyte brix. in both cases, only usb keyboard is available. both hang the same way.

Stefan Bader (smb) wrote :

a) Please open a new bug report.
b) If you do describe _in what_ way they hang.

Peter Hidasi (hidasip) wrote :

It might be useful to know: with IBM blade centers the remote access wasn't working also from 13.10. A colleague found out that if we change the power saving options for the relevant usb devices in /lib/udev/rules.d/42-usb-hid-pm.rules from "auto" to "on", it works fine again.

gian (glsarto) wrote :

trying to install latest (today June 23rd) Ubuntu 14.04 server iso on HP ML110 G7, and can't go past the Language screen.

How can this be still an issue without fix after such a long time?

Switching USB ports doesn't work for me.

Should I give up installing TT?!

Stefan Bader (smb) wrote :

Really you should file a new bug report (like anybody else still running into keyboard issues). Like I said in comment #35 the symptoms may be the same but the missing module of _this_ bug report is included in 14.04. Make sure to describe the environment with as much detail as possible (keyboard locally attached or a (v)KVM, locally attached at usb2 or 3 port (usually black or blue sockets). Post the new bug number here to make the report easily findable. Thanks.

gian (glsarto) wrote :

sorry if my post wasn't detailed, but essentially:

- the hw is an HP ML110 G7 with USB keyboard
- the iso is the daily current Ubuntu server 64 bit
- when you get to the language page, the keyboard stops reacting and all you can do is power off the machine.
- ALL usb ports were tried, being those USB2 or USB3

I think that this is the same issue as described above, and I would like to add that Ubuntu server 12.04 LTS was previously installed without a problem, using the very same keyboard.

Amedeo (vanitas66) wrote :

I also had the same issue installing Ubuntu 14.10 mini.iso (07 september 2014). My Microsoft Wireless Keyboard 800 freezes at "Select a language".

Stefan Bader (smb) wrote :

For 14.10 you this looks to be reasonable because for some odd reason the ohci-pci code was again made a module. :/ Seeing to get this fixed before release.

Tim Gardner (timg-tpi) on 2014-09-18
Changed in linux (Ubuntu Utopic):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.16.0-17.23

---------------
linux (3.16.0-17.23) utopic; urgency=low

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #1371614
  * [Config] CONFIG_USB_OHCI_HCD_PCI=y
    - LP: #1244176

  [ Andy Whitcroft ]

  * rebase to v3.16.3
  * updateconfigs following rebase to v3.16.3

  [ John Johansen ]

  * SAUCE: (no-up) apparmor: Sync to apparmor3 - RC1 snapshot
    - LP: #1362199

  [ Upstream Kernel Changes ]

  * rebase to v3.16.3
 -- Andy Whitcroft <email address hidden> Thu, 18 Sep 2014 13:09:25 +0100

Changed in linux (Ubuntu Utopic):
status: Fix Committed → Fix Released
jf (jfs-world+ubuntuone) wrote :

So it seems that a fix has been incorporated into the kernel package. When is it going to actually make it into the install iso (which is what caused folks to come here in the first place)? Still not working with the latest ubuntu-server trusty daily as of Oct 2 2014 (using "trusty-server-amd64.iso / 25-Sep-2014 05:52 / 574M / Server install image for 64-bit PC (AMD64) computers (standard download)")

jf (jfs-world+ubuntuone) wrote :

is this in the iso already?

Changed in initramfs-tools (Ubuntu Trusty):
status: Invalid → Confirmed
jf (jfs-world+ubuntuone) wrote :

has a new iso been released containing this fix?

BarthV (barthv) wrote :

Bump.

Please release this fix on Netboot imgs.

#45 : It hurts to ask again for an update in netboot img :'(

BarthV (barthv) wrote :

Bump

BarthV (barthv) wrote :

Still not working with the 06-Jun-2015 Trusty Netboot installer.

Jordan (jordanu) wrote :

Note that while this particular bug, about missing ohci-pci in the initramfs, is fixed in Ubuntu 15.04 another similar bug, missing xhci-pci, is still present. The debian bug report about, and fix for, missing xhci-pci is here: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=773250

If you are experiencing these symptoms on Ubuntu 15.04 (USB keyboard working in installed and Live systems, but not debian-installer / early boot initramfs), you are probably hitting the xhci-pci bug.

BarthV (barthv) wrote :

Bump !

Is there any possible workaround ?
I can't even install from usb / Cdrom or PXE ...

Trying to use a seamless install "may" work but i didn't have found a good preseed file that pass over this bug.

Is there a way to build a initramfs from aa laptop and put it in the bootable usb key ? Does that works ?

For what I can experience, this bug is STILL PRESENT, both in Ubuntu Server 14.04.3 AMD64 and in Ubuntu Server 15.04 AMD64.

I tried this both on a HP Micro Proliant N56L (dualcore AMD 64 based) and Asus M3N78-VM AM2/AM3 mobo.

Each of these 2 distributions have been tested on each of the 2 PCs with both a Logitech MK710 and a Logitech K400r keyboards.

I have tested bootable USB drives prepared with: usb-creator-gtk, unetbootin and dd.

All of these tests FAILED at the Language selection; I suceed in passing the first menu selection, I choose "Install Ubuntu Server", and it all freezes due to "missing" keyboard on the Language selection menù.

There is no way even of changing to other virtual TTY (ctrl-alt-f2, etc.) nor reboot with ctrl-alt-del.

prasanna (prasanna) wrote :

Same issue but with an Intel NUC DC53427HYE. Attempting install of 14.04 AMD64 Server build. Cannot get keyboard to work in the language selection screen.

Stefan Bader (smb) wrote :

Please, anybody having still the symptom of a not working keyboard, file a new bug and do not add comments to this one. This bug is fixed and the necessary USB OHCI drivers are built in. It might me something related to USB3 but this will need further debugging and that is better done in a new bug report without all the information from this case. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.