Activity log for bug #124406

Date Who What changed Old value New value Message
2007-07-06 13:58:54 Guy Gur-Ari bug added bug
2007-07-06 17:26:36 Jérôme Guelfucci None: status New Invalid
2007-07-06 17:26:36 Jérôme Guelfucci None: statusexplanation Thank you for your bug report. Compiz Fusion is not part of Feisty official packages so we can't support it, I'm closing this. If this happens with Feisty's default compiz or with the compiz fusion's official packages in Gutsy, please reopen.
2007-07-30 08:08:53 Guy Gur-Ari None: status Invalid New
2007-07-30 08:08:53 Guy Gur-Ari None: statusexplanation Thank you for your bug report. Compiz Fusion is not part of Feisty official packages so we can't support it, I'm closing this. If this happens with Feisty's default compiz or with the compiz fusion's official packages in Gutsy, please reopen. Several people confirmed the problem who aren't using compiz fusion.
2007-07-31 22:27:29 Brian Murray None: status New Incomplete
2007-07-31 22:27:29 Brian Murray None: assignee brian-murray
2007-07-31 22:27:29 Brian Murray None: statusexplanation Several people confirmed the problem who aren't using compiz fusion. Thank you for taking the time to report this bug and helping to make Ubuntu better. JeDi seems to indicate that this started happening after a kernel update so it would be useful to know what kernel everyone is experiencing this with. Thanks in advance.
2007-08-31 17:27:35 Erkin Bahceci bug added attachment 'key-stuck-dmesg.log' (dmesg log right after the problem appeared)
2007-09-05 05:35:58 Steve Perry bug added attachment 'dmesg.txt' (dmesg.txt)
2007-09-17 20:10:56 Brian Murray None: status Incomplete Confirmed
2007-09-17 20:10:56 Brian Murray None: assignee brian-murray
2007-11-10 20:58:28 Guy Gur-Ari description Keyboard keys such as the arrows, Alt-F4, PageUp/PageDown, etc. often get 'stuck' and continue being 'clicked' even after they are physically released. For example when clicking Alt-F4, sometimes it gets stuck so all the windows are closed instead of just one. My configuration is Feisty + Xgl + Compiz Fusion. My previous configuration was Edgy + Xgl + Beryl, where this didn't happen. The Compiz Fusion folks said this is a well-known Xgl problem, but I couldn't find supporting evidence for that. The keyboard itself isn't the problem. When dual-booting to Windows, everything works fine. Also, the problem happens with two different keyboards (internal laptop, external USB). See also this forum thread for other people with the same problem: http://ubuntuforums.org/showthread.php?t=432057 Keyboard keys such as the arrows, Alt-F4, PageUp/PageDown, etc. often get 'stuck' and continue being 'clicked' even after they are physically released. For example when clicking Alt-F4, sometimes it gets stuck so all the windows are closed instead of just one. My configuration is Feisty + Xgl + Compiz Fusion. My previous configuration was Edgy + Xgl + Beryl, where this didn't happen. Others have reported the same problem without using either Xgl or Compiz. The Compiz Fusion folks said this is a well-known Xgl problem, but I couldn't find supporting evidence for that. The keyboard itself isn't the problem. When dual-booting to Windows, everything works fine. Also, the problem happens with two different keyboards (internal laptop, external USB). See also this forum thread for other people with the same problem: http://ubuntuforums.org/showthread.php?t=432057
2007-11-10 20:58:28 Guy Gur-Ari title Keyboard keys stuck using Feisty + Xgl + Compiz Fusion Keyboard keys get stuck and repeat (Feisty)
2007-11-10 21:13:38 Guy Gur-Ari description Keyboard keys such as the arrows, Alt-F4, PageUp/PageDown, etc. often get 'stuck' and continue being 'clicked' even after they are physically released. For example when clicking Alt-F4, sometimes it gets stuck so all the windows are closed instead of just one. My configuration is Feisty + Xgl + Compiz Fusion. My previous configuration was Edgy + Xgl + Beryl, where this didn't happen. Others have reported the same problem without using either Xgl or Compiz. The Compiz Fusion folks said this is a well-known Xgl problem, but I couldn't find supporting evidence for that. The keyboard itself isn't the problem. When dual-booting to Windows, everything works fine. Also, the problem happens with two different keyboards (internal laptop, external USB). See also this forum thread for other people with the same problem: http://ubuntuforums.org/showthread.php?t=432057 Keyboard keys such as the arrows, Alt-F4, PageUp/PageDown, etc. often get 'stuck' and continue being 'clicked' even after they are physically released. For example when clicking Alt-F4, sometimes it gets stuck so all the windows are closed instead of just one. My configuration is Feisty + Xgl + Compiz Fusion. My previous configuration was Edgy + Xgl + Beryl, where this didn't happen. Others have reported the same problem without using either Xgl or Compiz. The keyboard itself isn't the problem. When dual-booting to Windows, everything works fine. Also, the problem happens with two different keyboards (internal laptop, external USB). My best guess is that the problem occurs at time of high system load. Somehow during these times the key-release signal gets lost and the key-press is repeated indefinitely. This happens more often with Compiz configurations because Compiz tends to increase system load. It also happens more often with power-hungry apps like Firefox and Acrobat Reader for similar reasons. See also this forum thread for other people with the same problem: http://ubuntuforums.org/showthread.php?t=432057
2007-11-10 21:13:38 Guy Gur-Ari title Keyboard keys get stuck and repeat (Feisty) Keyboard keys get stuck and repeat (Feisty, Gutsy)
2007-11-15 18:01:43 no_treble bug added attachment 'dmesg.txt' (dmesg.txt)
2007-12-03 18:53:48 Krucova bug added attachment '2.6.22-gentoo-r9.config.txt' (.config / =sys-kernel/gentoo-sources-2.6.22-gentoo-r9)
2007-12-03 18:54:59 Krucova bug added attachment '2.6.21-gentoo-r4.config.txt' (.config / =sys-kernel/gentoo-sources-2.6.21-gentoo-r4)
2008-03-04 12:07:45 stathissideris marked as duplicate 194214
2008-03-19 15:15:58 MrAnt description Keyboard keys such as the arrows, Alt-F4, PageUp/PageDown, etc. often get 'stuck' and continue being 'clicked' even after they are physically released. For example when clicking Alt-F4, sometimes it gets stuck so all the windows are closed instead of just one. My configuration is Feisty + Xgl + Compiz Fusion. My previous configuration was Edgy + Xgl + Beryl, where this didn't happen. Others have reported the same problem without using either Xgl or Compiz. The keyboard itself isn't the problem. When dual-booting to Windows, everything works fine. Also, the problem happens with two different keyboards (internal laptop, external USB). My best guess is that the problem occurs at time of high system load. Somehow during these times the key-release signal gets lost and the key-press is repeated indefinitely. This happens more often with Compiz configurations because Compiz tends to increase system load. It also happens more often with power-hungry apps like Firefox and Acrobat Reader for similar reasons. See also this forum thread for other people with the same problem: http://ubuntuforums.org/showthread.php?t=432057 Keyboard keys such as the arrows, Alt-F4, PageUp/PageDown, etc. often get 'stuck' and continue being 'clicked' even after they are physically released. For example when clicking Alt-F4, sometimes it gets stuck so all the windows are closed instead of just one. My configuration is Feisty + Xgl + Compiz Fusion. My previous configuration was Edgy + Xgl + Beryl, where this didn't happen. Others have reported the same problem without using either Xgl or Compiz. The keyboard itself isn't the problem. When dual-booting to Windows, everything works fine. Also, the problem happens with two different keyboards (internal laptop, external USB). My best guess is that the problem occurs at time of high system load. Somehow during these times the key-release signal gets lost and the key-press is repeated indefinitely. This happens more often with Compiz configurations because Compiz tends to increase system load. It also happens more often with power-hungry apps like Firefox and Acrobat Reader for similar reasons. PS: When the keys would repeat all input devices would be locked up. ie. mouse won't move, clicks don't do anything, keyboard presses don't register. Then when it becomes unstuck, the mouse moves around and everything. Hope this helps. See also this forum thread for other people with the same problem: http://ubuntuforums.org/showthread.php?t=432057
2008-04-05 15:41:57 Cruncher removed duplicate marker 194214
2008-04-05 17:54:12 Tom Jaeger bug added attachment 'xserver-xorg-input-kbd_1.2.2-3ubuntu1-mt1_i386.deb' (xserver-xorg-input-kbd_1.2.2-3ubuntu1-mt1_i386.deb)
2008-04-05 17:55:59 Tom Jaeger bug added attachment 'mt1.debdiff' (mt1.debdiff)
2008-04-07 04:47:11 Tom Jaeger bug added attachment 'stuck-2.6.24.4.patch' (stuck-2.6.24.4.patch)
2008-04-07 06:47:53 Tom Jaeger bug added attachment 'linux-image-2.6.24-15-generic_2.6.24-15.26ubuntu1_i386.deb' (linux image package with backported changes)
2008-04-07 06:48:23 Tom Jaeger bug added attachment 'stuck.debdiff' (debdiff)
2008-04-07 06:49:26 Tom Jaeger bug added attachment 'linux-headers-2.6.24-15-generic_2.6.24-15.26ubuntu1_i386.deb' (linux-headers-2.6.24-15-generic_2.6.24-15.26ubuntu1_i386.deb)
2008-04-07 06:58:51 Timo Aaltonen None: importance Undecided High
2008-04-07 06:58:51 Timo Aaltonen None: status Confirmed Triaged
2008-04-07 06:59:03 Timo Aaltonen linux: assignee ubuntu-kernel-team
2008-04-07 06:59:39 Timo Aaltonen bug assigned to linux
2008-04-07 06:59:50 Timo Aaltonen xorg-server: status New Invalid
2008-04-07 15:18:48 Bug Watch Updater linux: status Unknown Confirmed
2008-04-18 13:24:24 Harvey Muller bug added attachment 'repeat.key' (repeat.key)
2008-04-29 11:43:09 Harvey Muller bug added attachment 'od.log' (od.log)
2008-04-29 15:22:38 Pete Setchell bug added attachment 'stuckshiftkey.txt' (od -x trace showing a stuck shift key)
2008-07-29 17:03:58 sawk bug added attachment 'mkinitcpio.conf' (mkinitcpio.conf file)
2008-08-28 15:58:13 Leann Ogasawara bug added subscriber Leann Ogasawara
2008-10-08 20:25:39 Tommaso Cucinotta bug added attachment 'installed-apps.txt' (installed-apps.txt)
2008-10-08 21:14:01 Tommaso Cucinotta bug added attachment 'config-2.6.26.5' (config-2.6.26.5)
2008-10-08 22:04:02 Tommaso Cucinotta bug assigned to emacs
2009-02-24 16:24:03 Cruncher emacs: status New Invalid
2009-02-24 16:24:03 Cruncher emacs: statusexplanation This can't be a bug in Emacs, since I never used Emacs on my machine, and never will. To my knowledge it has been established that this bug affects *many* applications, and also seems to be more frequent in certain hardware setups. All this points to it being a deeply embedded problem, most likely of the kernel, and not a bug of any application sitting several layers above the keyboard handling.
2009-04-14 15:09:33 Tim Gardner linux (Ubuntu): importance High Medium
2009-04-14 15:09:33 Tim Gardner linux (Ubuntu): status Triaged In Progress
2009-04-14 15:09:33 Tim Gardner linux (Ubuntu): assignee Tim Gardner (timg-tpi)
2009-04-14 15:41:16 mati removed subscriber mati
2009-04-14 17:34:27 Tim Gardner linux (Ubuntu): status In Progress Fix Released
2009-04-14 17:34:27 Tim Gardner linux (Ubuntu): assignee Tim Gardner (timg-tpi)
2009-04-14 17:34:46 Tim Gardner bug task added linux (Ubuntu Jaunty)
2009-04-14 17:34:46 Tim Gardner bug task added xorg-server (Ubuntu Jaunty)
2009-04-14 19:31:34 Anders Kaseorg linux (Ubuntu Jaunty): status Fix Released In Progress
2009-04-14 19:31:34 Anders Kaseorg linux (Ubuntu Jaunty): assignee timg-tpi
2009-04-14 21:05:59 Anders Kaseorg tags cft-2.6.27 fixed-2.6.27 keys regression repeat stuck keys regression repeat stuck
2009-04-16 17:33:59 Leann Ogasawara linux (Ubuntu Jaunty): status In Progress Incomplete
2009-04-16 17:33:59 Leann Ogasawara linux (Ubuntu Jaunty): assignee Tim Gardner (timg-tpi)
2009-04-27 19:05:26 Mike removed subscriber Mike
2009-04-28 07:38:18 Xavier Aragon bug watch added https://bugs.freedesktop.org/show_bug.cgi?id=21454
2009-05-27 10:30:45 François Rey attachment added Output of dmesg, lspci, lsusb, and uname http://launchpadlibrarian.net/27199848/output.tgz
2009-05-27 12:55:30 Doughy removed subscriber Doughy
2009-05-27 20:36:14 Brian removed subscriber Brian
2009-05-30 23:59:55 François Rey attachment added output from uname -a, dmesg, lspci -vv and lsusb -vv. http://launchpadlibrarian.net/27315380/output-arch.tgz
2009-05-31 00:50:35 K Runge removed subscriber K Runge
2009-06-03 18:50:24 Forest removed subscriber Forest
2009-06-03 19:13:44 Leann Ogasawara linux (Ubuntu): status Incomplete Won't Fix
2009-06-03 19:14:04 Leann Ogasawara linux (Ubuntu Jaunty): status Incomplete Won't Fix
2009-06-03 21:19:56 François Rey bug watch added http://bugzilla.kernel.org/show_bug.cgi?id=11159
2009-06-04 03:16:00 positivek removed subscriber positivek
2009-08-14 19:04:59 Paul Jaros removed subscriber Paul Jaros
2009-10-09 11:00:06 Arne Fahrenwalde removed subscriber Arne Fahrenwalde
2009-11-11 16:14:11 Daniel Rozsnyo bug task added gentoo
2009-11-11 19:40:51 Jason Straight removed subscriber Jason Straight (LeeJunFan)
2009-11-19 09:25:44 Mark Schreiber removed subscriber Mark Schreiber
2010-01-17 12:34:16 Cruncher xorg-server (Ubuntu): status Invalid New
2010-01-18 12:51:00 Harvey Muller removed subscriber Harvey Muller
2010-01-18 14:56:12 Pete Setchell removed subscriber Pete Setchell
2010-01-19 11:21:32 sawk removed subscriber sawk
2010-01-19 13:01:27 Rolf Leggewie bug watch added https://bugs.freedesktop.org/show_bug.cgi?id=23938
2010-01-19 13:01:27 Rolf Leggewie bug task added xorg-server
2010-01-22 14:42:56 Bug Watch Updater xorg-server: status Unknown In Progress
2010-05-04 11:07:22 MacRules attachment added smolt.txt http://launchpadlibrarian.net/47786366/smolt.txt
2010-05-05 19:59:59 Bryce Harrington xorg-server (Ubuntu): status New Incomplete
2010-05-05 20:00:06 Bryce Harrington tags keys regression repeat stuck keys needs-retested-on-lucid-by-june regression repeat stuck
2010-05-09 23:03:12 Denis Haskin removed subscriber Denis Haskin
2010-05-21 14:18:43 Bryce Harrington tags keys needs-retested-on-lucid-by-june regression repeat stuck feisty gutsy keys needs-retested-on-lucid-by-june regression repeat stuck
2010-05-21 16:42:40 mirage removed subscriber mirage
2010-08-25 00:21:33 Cinquero bug watch added http://code.google.com/p/synergy-plus/issues/detail?id=9
2010-08-26 10:11:19 Salva removed subscriber Salva
2010-09-10 12:53:39 Bug Watch Updater xorg-server: importance Unknown Medium
2010-09-20 14:16:00 tdn bug added subscriber tdn
2010-09-21 14:51:03 Paul Crawford bug added subscriber Paul Crawford
2010-10-23 11:06:42 François Pernoud removed subscriber François Pernoud
2010-11-02 23:14:08 Grant Bowman bug added subscriber Grant Bowman
2010-12-20 14:31:27 Mathieu Comandon bug added subscriber Mathieu Comandon
2011-01-13 19:52:31 Andrea Amoroso bug added subscriber Andrea Amoroso
2011-01-14 10:20:39 Jan Roelofs bug added subscriber Jan Roelofs
2011-01-23 17:54:42 Ankur Dave removed subscriber Ankur Dave
2011-01-24 11:08:38 Bug Watch Updater xorg-server: importance Medium Unknown
2011-02-03 18:16:59 Bug Watch Updater linux: importance Unknown High
2011-03-18 22:32:01 Marius B. Kotsbak bug added subscriber Marius Kotsbak
2011-03-18 22:35:47 Marius B. Kotsbak summary Keyboard keys get stuck and repeat (Feisty, Gutsy) Keyboard keys get stuck and repeat
2011-03-18 22:38:13 Marius B. Kotsbak tags feisty gutsy keys needs-retested-on-lucid-by-june regression repeat stuck feisty gutsy keys maverick natty needs-retested-on-lucid-by-june regression repeat stuck
2011-03-19 05:31:29 Bryce Harrington xorg-server (Ubuntu): status Incomplete Confirmed
2011-03-19 05:31:34 Bryce Harrington xorg-server (Ubuntu): importance Undecided Medium
2011-03-21 13:12:17 Bug Watch Updater xorg-server: importance Unknown Medium
2011-03-21 21:51:38 Bryce Harrington xorg-server (Ubuntu): status Confirmed Incomplete
2011-03-21 21:54:13 Bryce Harrington tags feisty gutsy keys maverick natty needs-retested-on-lucid-by-june regression repeat stuck feisty gutsy keys maverick needs-retested-on-lucid-by-june regression repeat stuck
2011-04-23 18:52:52 Marius B. Kotsbak bug task added hundredpapercuts
2011-04-27 15:10:29 Daniel Jost bug added subscriber Daniel Jost
2011-04-28 14:50:23 :murb: removed subscriber :murb:
2011-04-28 19:53:46 Bryce Harrington xorg-server (Ubuntu): importance Medium Wishlist
2011-04-28 19:53:46 Bryce Harrington xorg-server (Ubuntu): status Incomplete Triaged
2011-04-28 19:54:53 Bryce Harrington hundredpapercuts: status New Invalid
2011-04-28 20:02:38 arbeck removed subscriber arbeck
2011-04-28 20:20:39 Cruncher removed subscriber Cruncher
2011-04-29 08:25:23 Gerv bug added subscriber Gerv
2011-04-29 08:26:11 Gerv removed subscriber Gerv
2011-04-29 15:01:00 Gerv removed subscriber Gerv
2011-04-30 12:53:02 Russ removed subscriber Russ
2011-05-07 14:46:12 Steve Davison removed subscriber Steve Davison
2011-05-11 14:44:53 Bryce Harrington xorg-server (Ubuntu): assignee Bryce Harrington (bryce)
2011-05-12 10:23:20 Bryce Harrington xorg-server (Ubuntu): status Triaged Won't Fix
2011-05-23 13:51:51 Dan Quade bug added subscriber unimatrix
2011-05-27 14:59:04 Fausto Piovesan removed subscriber Fausto Piovesan
2011-05-31 02:37:51 BobRoss removed subscriber BobRoss
2011-06-05 00:05:06 Noskov Alexey removed subscriber Noskov Alexey
2011-07-16 16:52:34 PabloRQ bug added subscriber parq
2011-07-16 17:57:19 Bryce Harrington xorg-server (Ubuntu): assignee Bryce Harrington (bryce)
2011-07-26 11:02:06 Marcus Haslam attachment added unnamed https://bugs.launchpad.net/bugs/124406/+attachment/2233544/+files/unnamed
2011-07-26 13:17:51 no_treble removed subscriber no_treble
2011-08-15 14:55:24 Leann Ogasawara removed subscriber Leann Ogasawara
2011-12-16 07:57:55 Wojciech Musial bug added subscriber Wojciech Musial
2012-02-22 10:07:45 Cinquero bug watch added https://bugs.freedesktop.org/show_bug.cgi?id=46281
2012-04-10 11:09:45 Vladimir Rutsky bug added subscriber Vladimir Rutsky
2012-04-14 16:11:36 Marius B. Kotsbak tags feisty gutsy keys maverick needs-retested-on-lucid-by-june regression repeat stuck feisty gutsy keys maverick needs-retested-on-lucid-by-june oneiric precise regression repeat stuck
2012-04-14 17:27:15 PabloRQ removed subscriber parq
2013-02-22 11:43:39 Chris Wilson bug task deleted hundredpapercuts
2013-02-25 03:51:41 Mads Chr. Olesen removed subscriber Mads Chr. Olesen
2013-04-18 12:52:47 Mathieu Comandon removed subscriber Mathieu Comandon
2013-04-18 12:58:13 Martin Gruner removed subscriber Martin Gruner
2013-04-20 17:19:34 pauls removed subscriber pauls
2013-10-11 21:11:45 Artyom Kazak bug added subscriber Artyom Kazak
2013-10-11 21:12:17 Artyom Kazak tags feisty gutsy keys maverick needs-retested-on-lucid-by-june oneiric precise regression repeat stuck feisty gutsy keys maverick needs-retested-on-lucid-by-june oneiric precise regression repeat saucy stuck
2013-10-19 08:45:43 Matthew Fedderly removed subscriber Matthew Fedderly
2014-03-19 20:24:47 Olivier Cortès bug added subscriber Olivier Cortès
2014-07-07 09:54:00 dcam removed subscriber dcam
2014-10-16 22:44:49 Abhirav Kumar bug added subscriber Abhirav Kumar
2014-11-16 13:29:28 Brent Gardner bug added subscriber Brent G. Gardner
2015-08-08 08:04:40 Will Hui removed subscriber Will Hui
2018-04-06 12:27:28 Mehmet Soyturk bug added subscriber Mehmet Soyturk
2018-04-06 15:57:13 raphenry removed subscriber raphenry
2019-01-27 23:15:03 Pascal Vandeputte removed subscriber Pascal Vandeputte