dmraid-4-5 is not built for Saucy

Bug #1241086 reported by Tim Gardner on 2013-10-17
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Tim Gardner
Saucy
Undecided
Tim Gardner
Trusty
Undecided
Tim Gardner

Bug Description

dm-raid45 depended on EXPERIMENTAL which was removed in 3.10

Tim Gardner (timg-tpi) on 2013-10-17
Changed in linux (Ubuntu Saucy):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Stefan Bader (smb) on 2013-10-18
Changed in linux (Ubuntu Saucy):
status: In Progress → Fix Committed
vvro (vvro) wrote :

I got an intel software raid, running a raid 5
And updated to saucy.
I think it maybe related.
I can no longer boot with the new kernel 3.11. Only the 3.8 from precise.

When it drops to the initramfs command-line and i issue a dmraid -a y for my raid I get this:

device-mapper: table252:0:raid45:unknown target type
device-mapper: ioctl:error adding target in table
error: device-mapper target type raid45 is not in the kernel

I activated the proposed package source and did the updates, but also doesn't work.

vvro (vvro) wrote :

I was checking the patch, In the vanilla kernel 3.11.6 the symbols have changed

 Symbol: MD_RAID456 [=m]
  │ Type : tristate
  │ Prompt: RAID-4/RAID-5/RAID-6 mode
  │ Location:
  │ -> Device Drivers
  │ -> Multiple devices driver support (RAID and LVM) (MD [=y])
  │ -> RAID support (BLK_DEV_MD [=y])
  │ Defined at drivers/md/Kconfig:121
  │ Depends on: MD [=y] && BLK_DEV_MD [=y]
  │ Selects: RAID6_PQ [=m] && ASYNC_MEMCPY [=m] && ASYNC_XOR [=m] && ASYNC_PQ [=m] && ASYNC_RAID6_RECOV[=m] │
 Selected by: DM_RAID [=m] && MD [=y] && BLK_DEV_DM [=y]

and on the mainline 3.12-rc6 there are some modifications to raid5
https://www.kernel.org/diff/diffview.cgi?file=%2Fpub%2Flinux%2Fkernel%2Fv3.x%2Ftesting%2Fpatch-3.12-rc6.xz;z=3624

building a mainline 3.12-rc6 kernel package to see if any of the changes, bring my raid5 back online

vvro (vvro) wrote :

I think this is the problem in dmraid/lib/activate/activate.c

static struct type_handler {
 const enum type type;
 int (*f) (struct lib_context * lc, char **table, struct raid_set * rs);
} type_handler[] = {
 { t_undef, dm_undef }, /* Needs to stay here! */
 { t_partition, dm_partition },
 { t_spare, dm_spare },
 { t_linear, dm_linear },
 { t_raid0, dm_raid0 },
 { t_raid1, dm_raid1 },
 { t_raid4, dm_raid45 },
 { t_raid5_ls, dm_raid45 },
 { t_raid5_rs, dm_raid45 },
 { t_raid5_la, dm_raid45 },
 { t_raid5_ra, dm_raid45 },
 /* RAID types below not supported (yet) */
 { t_raid6, dm_unsup },
};

instead of dm_raid45 should be dm_raid456

I'll try and patch it after I finish my current work as a waiter :-P

Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-saucy' to 'verification-done-saucy'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-saucy
vvro (vvro) wrote :

kernel linux-image-3.11.0-13-generic doesn't solve the problem, continue to get the device-mapper: table252:0:raid45:unknown target type

Dor A. (dor-a) on 2013-11-01
tags: added: verification-done-saucy
removed: verification-needed-saucy
Dor A. (dor-a) wrote :

I can confirm that 3.11.0-13-generic fixes the issue and that dmraid once again allows mapping what it calls a raid45.

I'm using an Intel FakeRAID (isw), and since 13.10 dmraid has been claiming that raid45 is not in the kernel. Enabling -proposed and upgrading the kernel fixed the issue; dmraid now allows mapping my RAID both from terminal using "dmraid -ay" and during boot automatically.

Changed the tag to "verification-done-saucy" accordingly.

vvro (vvro) wrote :

Could the signed version for UEFI ( linux-signed-image-3.11.0-13-generic ) of the same kernel, not have been updated with the patch in proposed?

Launchpad Janitor (janitor) wrote :
Download full text (18.4 KiB)

This bug was fixed in the package linux - 3.11.0-13.20

---------------
linux (3.11.0-13.20) saucy; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #1242793

  [ Paolo Pisati ]

  * [Config] amhf: VIRTIO_CONSOLE=y
    - LP: #1237982
  * [Config] AHCI_IMX=y
    - LP: #1240038

  [ Tim Gardner ]

  * [Config] CONFIG_USB_OTG=n for all arches
    - LP: #1047527
  * dm-raid4-5: Fix compile issues
    - LP: #1241086
  * [Config] CONFIG_DM_RAID45=m
    - LP: #1241086

  [ Upstream Kernel Changes ]

  * Revert "cw1200: Don't perform SPI transfers in interrupt context"
    - LP: #1237530
  * block: Fix bio_copy_data()
    - LP: #1237530
  * sysv: Add forgotten superblock lock init for v7 fs
    - LP: #1237530
  * bcache: Fix a dumb journal discard bug
    - LP: #1237530
  * bcache: Strip endline when writing the label through sysfs
    - LP: #1237530
  * bcache: Fix for when no journal entries are found
    - LP: #1237530
  * bcache: Fix a writeback performance regression
    - LP: #1237530
  * bcache: Fix a flush/fua performance bug
    - LP: #1237530
  * bcache: Fix a dumb CPU spinning bug in writeback
    - LP: #1237530
  * bcache: Fix a shrinker deadlock
    - LP: #1237530
  * bcache: Fix for handling overlapping extents when reading in a btree
    node
    - LP: #1237530
  * bcache: Fix flushes in writeback mode
    - LP: #1237530
  * kernel/reboot.c: re-enable the function of variable reboot_default
    - LP: #1237530
  * x86/reboot: Add quirk to make Dell C6100 use reboot=pci automatically
    - LP: #1237530
  * tools lib lk: Uninclude linux/magic.h in debugfs.c
    - LP: #1237530
  * x86, efi: Don't map Boot Services on i386
    - LP: #1237530
  * mei: make me client counters less error prone
    - LP: #1237530
  * mei: bus: stop wait for read during cl state transition
    - LP: #1237530
  * mei: cancel stall timers in mei_reset
    - LP: #1237530
  * tty: Fix SIGTTOU not sent with tcflush()
    - LP: #1237530
  * serial: tegra: fix tty-kref leak
    - LP: #1237530
  * serial: pch_uart: fix tty-kref leak in rx-error path
    - LP: #1237530
  * serial: pch_uart: fix tty-kref leak in dma-rx path
    - LP: #1237530
  * ARM: 7837/3: fix Thumb-2 bug in AES assembler code
    - LP: #1237530
  * staging: vt6656: [BUG] main_usb.c oops on device_close move flag
    earlier.
    - LP: #1237530
  * staging: vt6656: [BUG] iwctl_siwencodeext return if device not open
    - LP: #1237530
  * drm/i915/tv: clear adjusted_mode.flags
    - LP: #1237530
  * cw1200: Use a threaded oneshot irq handler for cw1200_spi
    - LP: #1237530
  * xhci: Ensure a command structure points to the correct trb on the
    command ring
    - LP: #1237530
  * xhci: Fix oops happening after address device timeout
    - LP: #1237530
  * USB: fix PM config symbol in uhci-hcd, ehci-hcd, and xhci-hcd
    - LP: #1237530
  * xhci: Fix race between ep halt and URB cancellation
    - LP: #1237530
  * USB: OHCI: accept very late isochronous URBs
    - LP: #1237530
  * USB: UHCI: accept very late isochronous URBs
    - LP: #1237530
  * USB: Fix breakage in ffs_fs_mount()
    - LP: #1237530
  * fsl/usb: Resolve PHY_CLK_VLD instability issue for ULPI phy
    - LP: #1237530
  *...

Changed in linux (Ubuntu Saucy):
status: Fix Committed → Fix Released

Tim Gardner, given the following for Trusty, anything further that would need to be checked into or may the linux (Ubuntu) task be closed out:
grep -r CONFIG_DM_RAID45
ubuntu/Makefile:obj-$(CONFIG_DM_RAID45) += dm-raid4-5/
ubuntu/dm-raid4-5/Makefile:obj-$(CONFIG_DM_RAID45) := dm-raid45.o
debian.master/changelog: * Revert "[Config] Disable CONFIG_DM_RAID45"
debian.master/changelog: * [Config] Disable CONFIG_DM_RAID45
debian.master/changelog: * [Config] disable CONFIG_DM_RAID45 on powerpc
debian.master/config/annotations:CONFIG_DM_RAID45 p policy<(arch i386 amd64 &/ value m) | value n> note<PC BIOS specific> mark<MD>

vvro, you would have a completely different problem not scoped under this report as per the Bug Description. If you have a bug in Ubuntu, so your problem may be tracked, please feel free to file a new report with Ubuntu by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://help.ubuntu.com/community/ReportingBugs

Tim Gardner (timg-tpi) wrote :

Christopher - thanks for the reminder. I'm removing ubuntu/dm-raid4-5 in favor of CONFIG_MD_RAID456 in the mainline 3.13 kernel.

Tim Gardner (timg-tpi) wrote :

Remove ubuntu/dm-raid4-5 in favor of CONFIG_MD_RAID456 for linux v3.13

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers