No wireless support for Realtek RTL8192EE [10ec:818b]

Bug #1239578 reported by Adam Lee on 2013-10-14
426
This bug affects 65 people
Affects Status Importance Assigned to Milestone
HWE Next
Medium
Adam Lee
linux (Ubuntu)
Medium
Adam Lee
Trusty
Medium
Adam Lee
Utopic
Medium
Unassigned

Bug Description

Open this bug to trace device driver RTL8192EE.

We have seen this wireless card on some laptops, id is [10ec:818b], driver is RTL8192EE.

This bug is only for the initial support of this WiFi adapter, it's not working 100% well yet, please report new "not working bug" or contact upstream but not keep posting comments, thanks.

Status:

pull-request for trusty was NAKed because next minor Trusty release will use Utopic LTS kernel, which had already fixed this issue.

please wait it or upgrade your whole distro to Utopic.

Adam Lee (adam8157) wrote :

Set to incomplete, waiting the driver shows up in mainline.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Changed in hwe-next:
status: New → Incomplete
assignee: nobody → Adam Lee (adam8157)
importance: Undecided → Medium
tags: added: blocks-hwcert-enablement
Adam Lee (adam8157) wrote :

still not in wireless-next by now.

Sascha Grossenbacher (berdir) wrote :

I have this card in a new Thinkpad T440s.

Elliott Conant (elliottcon) wrote :

Similarly, I have this in a Thinkpad T540p.

Yvon Xiao (yvonxiao) wrote :

I also have this card in Thinkpad T440p

William Oprandi (woprandi) wrote :

Same for T440s

K Xu (kx-anticss) wrote :

Also have this problem.

Naohiro hayashi (n-hayashi1134) wrote :

I have this problem in Thinkpad T440p

Ara Pulido (ara) on 2014-01-16
tags: added: blocks-hwcert
caobenzhi (caobenzhi0915) wrote :

I have the same problem in Thinkpad T440.

German (gergilar) wrote :

I have the same problem in Thinkpad L440

Xprogrammer (programmer-x) wrote :

I've same problem with my t440s.

K Xu (kx-anticss) wrote :

Any thoughts on when this will be fixed?

Adam Lee (adam8157) wrote :

we are working on a solution now.

Xprogrammer (programmer-x) wrote :

After continous search for RTL8192EE driver, I found it here.

http://netbook-remix.archive.canonical.com/updates/pool/public/o/oem-wireless-rtl-92ce-92se-92de-8723ae-88ee-8723be-92ee-dkms/

I'm able to compile and load rtl8192ee on my lenovo t440s laptop.

However, transmitt speed very slow. For couple of times I got too many Invalid misc: and practically the connection is useless.

After few reboots and it seems to be fine. I'm sending this note from t440s loaded with 8192ee internet connection. Main drawback right now, I'm able to get only at max 60kB/s.

~$ iwconfig
wlan1 IEEE 802.11bgn ESSID:"myap"
          Mode:Managed Frequency:2.462 GHz Access Point: 58:6D:8F:64:22:FF
          Bit Rate=144.4 Mb/s Tx-Power=20 dBm
          Retry long limit:7 RTS thr=2347 B Fragment thr:off
          Power Management:off
          Link Quality=70/70 Signal level=-34 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:247 Missed beacon:0

$ uptime
 23:28:08 up 15 min, 3 users, load average: 0.39, 0.61, 0.45

$ ifconfig wlan1
wlan1 Link encap:Ethernet HWaddr XXXXXXXXXX
          inet addr:192.168.1.92 Bcast:192.168.1.127 Mask:255.255.255.128
          inet6 addr: XXXXXXXXXXXX/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:35328 errors:0 dropped:0 overruns:0 frame:0
          TX packets:26022 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:49315226 (49.3 MB) TX bytes:3186066 (3.1 MB)

Jody McIntyre (scjody) wrote :

I was able to build and install the driver Xprogrammer found, but it does not work for me at all. It can get an address via DHCP but after that I can't even ping the default gateway.

There were several warnings produced during the build, lots of dmesg output, and a stack dump triggered in net/mac80211/rate.c:518 (a comment in rate.c indicates "RC is busted".

I can send along all of that if it's useful to anyone, but unless you have access to hardware documentation I doubt you'll be able to fix the driver. Based on the volume of the dmesg output, it appears to be an internal or alpha driver that escaped rather than something that's intended for production. I will contact the driver authors to see if they have a newer version (the version Xprogrammer found dates from October 22).

Xprogrammer (programmer-x) wrote :

http://www.spinics.net/lists/linux-wireless/msg118429.html

https://kernel.googlesource.com/pub/scm/linux/kernel/git/firmware/linux-firmware/+/4164c23d2e3b4863ca42d72f40dc7cc5d9fb8c6c

This commit is made in to firmware mainstream branch. Would that help ? However I don't see source code, it has put only the firmware files.

Adam Lee (adam8157) wrote :

Realtek hasn't officially released the driver in website or kernel mainline yet.

Abe Handler (akh2103) wrote :

I am also having trouble with this wireless card on 12.04

wapingguo (wapingguo) wrote :

My laptop is Lenovo ThinkPad T440p,I have the same problem on Ubuntu 12.04.
I found the device is 2x2 11b/g/n wireless M.2 adapter.

Xiaojun Chen (xiaojunch) wrote :

Yes, I have the same problem.

My laptop is T440s, and the wireless card is the same one, Realtek RTL8192EE [10ec:818b].

Look forward to solutions!

mingkedu@gmail.com (mingkedu) wrote :

I've been waiting this for almost a month, really need the driver

Siu On Chan (sochan) wrote :

The problem may go away starting kernel 3.14. See comments #16 in
https://bbs.archlinux.org/viewtopic.php?id=174082

Haven't tested it myself, but I'm optimistic.

Adam Lee (adam8157) on 2014-03-17
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
1 comments hidden view all 368 comments
William Oprandi (woprandi) wrote :

Does someone has succeeded to build and run the staging driver ?

Vipin (v-rathor) wrote :

Guys,
Just sharing my experience with this issue.
I've got Lenovo Thinkpad L440 recently which has this realtek network device. Installed 12.04 LTS and all I could see was "no network device available". So no wired & wireless connection could be made. Then I read various solutions over web and then found this bug filed.
Later I tried installing 3.14-rc7 and rebooted. Now my wired connection (ethX) is up but still no wireless support. Now I see only one UNCLAIMED (earlier there were 2) h/w in 'lshw' output.
$ sudo lshw -C network -numeric
  *-network
       description: Ethernet interface
       product: Intel Corporation [8086:153B]
       vendor: Intel Corporation [8086]
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eth9
       version: 05
       serial: 3c:97:0e:e8:0a:25
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k duplex=full firmware=0.13-3 ip=192.168.1.126 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:42 memory:f2500000-f251ffff memory:f253f000-f253ffff ioport:6080(size=32)
  *-network UNCLAIMED
       description: Network controller
       product: Realtek Semiconductor Co., Ltd. [10EC:818B]
       vendor: Realtek Semiconductor Co., Ltd. [10EC]
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: ioport:5000(size=256) memory:f2400000-f2403fff

I just hope this might be of use to someone. Thanks.

Adam Lee (adam8157) on 2014-03-18
description: updated
Adam Lee (adam8157) on 2014-03-19
Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Adam Lee (adam8157) on 2014-03-19
Changed in linux (Ubuntu):
status: Fix Committed → Confirmed
Adam Lee (adam8157) on 2014-03-19
description: updated
3 comments hidden view all 368 comments
Adam Lee (adam8157) wrote :

For the record, I analyzed the code, that RTL8821AE driver only supports 8812 and 8821, pci ids in headfile means nothing. RTL8192EE has not been upstreamed yet.

rtl8821ae/sw.c
420: {RTL_PCI_DEVICE(PCI_VENDOR_ID_REALTEK, 0x8812, rtl8821ae_hal_cfg)},
421: {RTL_PCI_DEVICE(PCI_VENDOR_ID_REALTEK, 0x8821, rtl8821ae_hal_cfg)},
426: {RTL_PCI_DEVICE(PCI_VENDOR_ID_REALTEK, 0x8812, rtl8821ae_hal_cfg)},
427: {RTL_PCI_DEVICE(PCI_VENDOR_ID_REALTEK, 0x8821, rtl8821ae_hal_cfg)},

Bruce D'Arcus (bdarcus) wrote :

So we're waiting on Realtek to release the driver, with no ETA?

Just got a Thinkpad T440s, and bummed to see no wireless.

Mike McNally (emmecinque) wrote :

Also built the oem-rtl-etc. driver on 13.10 for a T440p; module loads and looks like it connects to a hub, and *sometimes* some traffic makes it through, but it basically doesn't work.

Josh Arenson (josharenson) wrote :

Why is this part Ubuntu certified (http://www.ubuntu.com/certification/catalog/component/pci/10ec%3A818b/) if it doesn't work at all?

Adam Lee (adam8157) wrote :

@Josh, our preload image contains out-of-kernel-tree driver, which is provided by realtek.

Vipin (v-rathor) wrote :

@Adam, may I know where can I get the driver you are talking about? preload images?
Pardon my orientataion, can you please point me in right direction? Thanks.

FWIW, I'm using (x)ubuntu.
On Mar 31, 2014 1:35 PM, "Adam Lee" <email address hidden> wrote:

> @Josh, our preload image contains out-of-kernel-tree driver, which is
> provided by realtek.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1239578
>
> Title:
> No wireless support for Realtek RTL8192EE [10ec:818b]
>
> Status in HWE Next Project:
> Incomplete
> Status in HWE Next trusty series:
> Confirmed
> Status in “linux” package in Ubuntu:
> Confirmed
>
> Bug description:
> Open this bug to trace device driver RTL8192EE.
>
> We have seen this wireless card on some laptops, id is [10ec:818b],
> driver is RTL8192EE.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hwe-next/+bug/1239578/+subscriptions
>

Sharon Talbot (sharon-talbot) wrote :

As a point of policy, it may not make sense to utilize images that are not available to the general public, or that are older than the most recent LTE release.

Adam Lee (adam8157) wrote :

This is the driver package we used in OEM preload image.

Please notice, the source is from RealTek, canonical has no ability to provide support(debugging or fixing). If you are not using OEM preload image and this driver is not working, please contact RealTek. Thanks.

Bruce D'Arcus (bdarcus) wrote :

@Adam - thanks. I get an error when trying to install the package, so
am contacting Realtek.

Adam Lee (adam8157) wrote :

This is the original driver source tarball from RealTek. You can try this one if there are some issues while installing that deb package.

Same situation, please notice that Ubuntu couldn't do anything with this tarball's issues before it's upstreamed by RealTek. Thanks.

Yung Shen (kaxing) on 2014-04-01
tags: added: 201310-14260
Changed in hwe-next:
status: Incomplete → Confirmed
Adam Lee (adam8157) on 2014-07-07
description: updated
Po-Hsu Lin (cypressyew) on 2014-08-20
tags: added: taipei-lab
Adam Lee (adam8157) on 2014-11-03
description: updated
Adam Lee (adam8157) on 2014-11-03
description: updated
description: updated
Adam Lee (adam8157) on 2014-11-03
Changed in hwe-next:
status: Confirmed → In Progress
Changed in linux (Ubuntu):
status: Confirmed → In Progress
Changed in hwe-next:
assignee: nobody → Adam Lee (adam8157)
Adam Lee (adam8157) on 2014-11-03
Changed in linux (Ubuntu Trusty):
status: New → In Progress
assignee: nobody → Adam Lee (adam8157)
importance: Undecided → Medium
Adam Lee (adam8157) on 2014-11-03
no longer affects: hwe-next/trusty
Changed in linux (Ubuntu Trusty):
status: In Progress → Won't Fix
status: Won't Fix → In Progress
Adam Lee (adam8157) on 2014-11-03
Changed in linux (Ubuntu Utopic):
status: New → Fix Released
importance: Undecided → Medium
Adam Lee (adam8157) on 2014-11-04
Changed in linux (Ubuntu Trusty):
status: In Progress → Won't Fix
Changed in linux (Ubuntu):
status: In Progress → Fix Released
Changed in hwe-next:
status: In Progress → Fix Released
description: updated
Adam Lee (adam8157) on 2015-01-05
description: updated
288 comments hidden view all 368 comments

Kernel 3.19.1 will have some additional fixes needed for the RTL8192EE that should fix the freezes. That hardware uses a completely new method for RX and TX descriptors, and it has taken a while to get it right.

The troy branch of the rtlwifi_new repo at GitHub has corrected code.

I'm using the troy branch... I did the same as #322 (except for blacklisting r8192 since I don't have that module here)
The connection kind of works but very often is dropped (it appears to be connected but not works).
Is there any feedback that I can give you to help?
Thanks

Have you loaded with the "ips=0" option?

Christian Pinto (chrpinto) wrote :

I am now trying the latest changes in the troy branch, and experiencing the same behavior as ivanalejandro0. The connection works, but it drops from time to time. Definitely better than previous versions. This is anyway annoying because i cannot have a skype call without interruptions.

Regarding the ips option, I think that it is set as zero by default (even if modinfo says the opposite), or at least if I execute:

cat /sys/module/rtl8192ee/parameters/ips

it returns N, which I suppose to be 0.

Christian

You are correct that ips is false (or 0 or N) by default. In fact, it seems that the driver never even uses that one. It does enable and use firmware-controlled power save. Load withe "fwlps=0" to completely disable power saving.

Thanks for the tip Larry!
As Christian said, ips is 0 by default. using "fwlps=0" seems to do the trick :D ... I'm doing some extra tests with downloads, audio conversations and so on, and it works so far!

Some extra notes in case of this is useful to someone else:

# change to load the module with "fwlps=0"
$ cat /etc/modprobe.d/rtl8192ee.conf
options rtl8192ee fwlps=0

I'm using tlp for power management optimizations and I had also some extra settings to disable:

$ grep -i wifi /etc/default/tlp
# WiFi power saving mode: 1=disable, 5=enable; not supported by all adapters.
WIFI_PWR_ON_AC=1
WIFI_PWR_ON_BAT=1 # This is set to 5 by default

I imagine that since the driver does not uses "ips" these last changes don't matter.

I was having problems on resuming after suspend (no connection), and removing/adding the module causes the system to freeze. I've fixed with this:
cat /etc/pm/sleep.d/10_reset_wifi
#! /bin/sh

# This script reload the wifi module on resume since most of the times it won't
# work as espected otherwise.

case $1 in
     suspend|suspend_hybrid|hibernate)
         # do nothing
         ;;
     resume|thaw)
         sudo rmmod rtl8192ee && sudo modprobe rtl8192ee
         ;;
esac

Download full text (6.3 KiB)

I'm having problems again, this fix kind of worked the first two days (maybe I didn't use my laptop intensively).

I'm having on and off connection.

These are the settings for the driver right now:

$ for f in /sys/module/rtl8192ee/parameters/*; do echo $f - `cat $f`; done;
/sys/module/rtl8192ee/parameters/debug - 1
/sys/module/rtl8192ee/parameters/disable_watchdog - N
/sys/module/rtl8192ee/parameters/fwlps - N
/sys/module/rtl8192ee/parameters/ips - N
/sys/module/rtl8192ee/parameters/msi - Y
/sys/module/rtl8192ee/parameters/swenc - N
/sys/module/rtl8192ee/parameters/swlps - N
i

Here is a ping output (with a wifi dongle all of these are below 100ms):

# [...] are the ones with "normal" ping times, 20~45 ms
$ ping www.google.com
PING www.google.com (173.194.42.113) 56(84) bytes of data.
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=1 ttl=53 time=64.4 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=2 ttl=53 time=23.7 ms
[...]
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=26 ttl=53 time=22.4 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=27 ttl=53 time=19.9 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=28 ttl=53 time=150 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=29 ttl=53 time=21.7 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=30 ttl=53 time=35.5 ms
[...]
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=41 ttl=53 time=54.5 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=42 ttl=53 time=4535 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=43 ttl=53 time=3535 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=44 ttl=53 time=2535 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=45 ttl=53 time=1538 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=46 ttl=53 time=538 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=48 ttl=53 time=19.5 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=49 ttl=53 time=21.9 ms
[...]
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=94 ttl=53 time=21.2 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=95 ttl=53 time=131 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=96 ttl=53 time=18.9 ms
[...]
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=157 ttl=53 time=33.3 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=158 ttl=53 time=163 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=159 ttl=53 time=4766 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=160 ttl=53 time=3760 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=161 ttl=53 time=2756 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=162 ttl=53 time=1748 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=163 ttl=53 time=740 ms
64 bytes from eze03s16-in-f17.1e100.net (173.194.42.113): icmp_seq=164 ttl=53 time=50.7 ms
[...]
64 bytes from eze03s16-in-f17.1...

Read more...

Christian Pinto (chrpinto) wrote :

I confirm what Ivan is experiencing, I am still not able to make a simple voice call. Hope this will be solved soon.

I saw in the repo two different versions of the firmware, should we try to test rtl8192eefw_new.bin ?

Chrsitian

Also, when I reload the module (neccesary since otherwise I don't get connection after suspend/resume), most of the times the system freezes forcing me to restart. I don't know if this is a problem of the driver itself though.

Unless you post the console traceback when the system freezes, how can we tell if it is the driver?

If you can reliable force the freeze with a particular command, put a "sleep 5; " before that command. During that 5 seconds delay, switch to the logging console (CTRL/ALT/F10 on my system). When the system freezes, there should be a display on the screen. Take a picture and post it.

This morning, a bug was found that could cause an oops on the RTL8192EE. All branches of the repo have been fixed.

cool, I've updated the troy branch and installed the new kernel module.

I'm still having the connection on&off issue, some pings over 2000ms as well like before.
The system freeze happens on module reload so I'll make some time to try to reproduce the problem and post an image.

Download full text (11.7 KiB)

Here is a dmesg log that has a traceback.
Is the result of a clean power on, suspend and resume.
I didn't have a freeze this time but maybe the problem is related to this.

[ 39.996883] ACPI: Preparing to enter system sleep state S3
[ 40.028699] PM: Saving platform NVS memory
[ 40.028705] Disabling non-boot CPUs ...
[ 40.028734] intel_pstate CPU 1 exiting
[ 40.029899] kvm: disabling virtualization on CPU1
[ 40.029907] smpboot: CPU 1 is now offline
[ 40.030237] intel_pstate CPU 2 exiting
[ 40.031404] kvm: disabling virtualization on CPU2
[ 40.031411] smpboot: CPU 2 is now offline
[ 40.031688] intel_pstate CPU 3 exiting
[ 40.031813] Broke affinity for irq 16
[ 40.031821] Broke affinity for irq 23
[ 40.031822] Broke affinity for irq 24
[ 40.031823] Broke affinity for irq 27
[ 40.031824] Broke affinity for irq 32
[ 40.032826] kvm: disabling virtualization on CPU3
[ 40.032835] smpboot: CPU 3 is now offline
[ 40.034143] ACPI: Low-level resume complete
[ 40.034179] PM: Restoring platform NVS memory
[ 40.034510] Enabling non-boot CPUs ...
[ 40.034544] x86: Booting SMP configuration:
[ 40.034544] smpboot: Booting Node 0 Processor 1 APIC 0x1
[ 40.046530] kvm: enabling virtualization on CPU1
[ 40.048794] CPU1 is up
[ 40.048813] smpboot: Booting Node 0 Processor 2 APIC 0x2
[ 40.060800] kvm: enabling virtualization on CPU2
[ 40.063061] CPU2 is up
[ 40.063081] smpboot: Booting Node 0 Processor 3 APIC 0x3
[ 40.075084] kvm: enabling virtualization on CPU3
[ 40.077362] CPU3 is up
[ 40.080842] ACPI: Waking up from system sleep state S3
[ 40.190171] acpi LNXPOWER:00: Turning OFF
[ 40.234221] xhci_hcd 0000:00:14.0: System wakeup disabled by ACPI
[ 40.254241] ehci-pci 0000:00:1a.0: System wakeup disabled by ACPI
[ 40.274259] ehci-pci 0000:00:1d.0: System wakeup disabled by ACPI
[ 40.274303] PM: noirq resume of devices complete after 64.031 msecs
[ 40.442614] PM: early resume of devices complete after 168.104 msecs
[ 40.442780] e1000e 0000:00:19.0: System wakeup disabled by ACPI
[ 40.442926] rtlwifi: wireless switch is on
[ 40.443022] rtc_cmos 00:02: System wakeup disabled by ACPI
[ 40.446194] sd 4:0:0:0: [sda] Starting disk
[ 40.718975] usb 1-7: reset full-speed USB device number 2 using xhci_hcd
[ 40.762816] ata5: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[ 40.763412] ata5.00: ACPI cmd ef/02:00:00:00:00:a0 (SET FEATURES) succeeded
[ 40.763414] ata5.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
[ 40.764971] ata5.00: ACPI cmd ef/02:00:00:00:00:a0 (SET FEATURES) succeeded
[ 40.764973] ata5.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
[ 40.765900] ata5.00: configured for UDMA/133
[ 40.770826] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 40.772866] ata1.00: ACPI cmd e3/00:00:00:00:00:a0 (IDLE) succeeded
[ 40.773877] ata1.00: ACPI cmd e3/00:00:00:00:00:a0 (IDLE) succeeded
[ 40.779535] ata1.00: ACPI cmd e3/00:00:00:00:00:a0 (IDLE) succeeded
[ 40.780542] ata1.00: ACPI cmd e3/00:00:00:00:00:a0 (IDLE) succeeded
[ 40.782414] ata1.00: configured for UDMA/133
[ 40.849102] xhci_hcd 0000:00:14.0: xHCI...

Hanson.diao (changlelele) wrote :

dmesg information

[ 1189.347194] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 1219.856463] rtlwifi-0:rtl_pci_start():<0-0> rtl_pci_start
[ 1219.862483] rtl8192ee-0:rtl92ee_download_fw():<0-0> normal Firmware SIZE 32754
[ 1219.862488] rtl8192ee-0:rtl92ee_download_fw():<0-0> Firmware Version(14), Signature(0x92e1),Size(32)
[ 1220.370714] rtl8192ee-0:rtl92ee_enable_hw_security_config():<0-0> PairwiseEncAlgorithm = 0 GroupEncAlgorithm = 0
[ 1220.370727] rtl8192ee-0:rtl92ee_enable_hw_security_config():<0-0> The SECR-value cc
[ 1220.505206] rtlwifi-0:rtl_pci_start():<0-0> rtl_pci_start OK
[ 1220.509288] !!!write point is 0x0, reg 0x3B4 value is 0x50000
[ 1220.523932] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

root@Hanson:~/Downloads/rtlwifi_new-master# uname -a
Linux Hanson 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

root@Hanson:~/Downloads/rtlwifi_new-master# for f in /sys/module/rtl8192ee/parameters/*; do echo $f - `cat $f`; done;
/sys/module/rtl8192ee/parameters/fwlps - Y
/sys/module/rtl8192ee/parameters/ips - N
/sys/module/rtl8192ee/parameters/swenc - N
/sys/module/rtl8192ee/parameters/swlps - N
root@Hanson:~/Downloads/rtlwifi_new-master#

root@Hanson:~/Downloads/rtlwifi_new-master# sudo lshw -C network -numeric
  *-network
       description: Ethernet interface
       product: Ethernet Connection I218-LM [8086:155A]
       vendor: Intel Corporation [8086]
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eth0
       version: 04
       serial: 28:d2:44:65:07:dc
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k duplex=full firmware=0.6-3 ip=192.168.1.102 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:61 memory:f0600000-f061ffff memory:f063e000-f063efff ioport:4080(size=32)
  *-network DISABLED
       description: Wireless interface
       product: RTL8192EE PCIe Wireless Network Adapter [10EC:818B]
       vendor: Realtek Semiconductor Co., Ltd. [10EC]
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 00
       serial: 48:5a:b6:93:a0:71
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8192ee driverversion=3.13.0-24-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:66 ioport:3000(size=256) memory:f0400000-f0403fff

Something is messed up. Those dmesg outputs are not coming from the driver in the rtlwifi_new repo. What other drivers have you installed?

Krzysztof Janowicz (janowicz) wrote :

Still the same, despite a new kernel (3.19) running on 14.10. Essentially, Lenovo T440(s) and T540 don't have wifi on Linux.

That is the early adopter's problem. For me, any branch of the rtlwifi_new git repo, or the kernel work. Are you sure it is not a problem with Ubuntu user space?

Simon Déziel (sdeziel) wrote :

Users of Trusty should give a try to the HWE kernel (3.16 ATM) that is officially supported.

For details on how to enable this: https://wiki.ubuntu.com/Kernel/LTSEnablementStack

William Oprandi (woprandi) wrote :

I'm using Fedora with kernel 3.19.3 (which use the latest rtlwifi_new if I well understood) but I'm unable to use wifi, I can connect to an access point (sometimes with difficulty) but unable to surf without wait a (very) long time to load a web page. I was forced to use a ethernet wire just to go here to write this comment.... Since end of 2013 we're waiting a decent driver (just stable to surf correctly) and still not...

Damian Only (damian-only) wrote :

@Simon: I tried with kernel 3.16 in Utopic with the drivers shipped with the kernel, and the wireless works quite bad (very low speeds, pages take several minutes to load). Won't Trusty users experience the same?

Adam Lee (adam8157) wrote :

@Damian, please report a new bug.

This bug is only for the initial support of this WiFi adapter, it's not working 100% well yet, please report new "not working bug" or contact upstream but not keep posting comments, thanks.

BTW, if anyone's case is Larry's github version works well but Ubuntu built-in doesn't, please report here with the realtek section in the output of `lspci -vvv`, thanks.

Hello again, I just installed the linux kernel 4.0 in my Thinkpad L440 and I'm still having the delayed pings and on&off connection problem. Should I install the driver from the rtl_wifi repo?
@larry, you asked about the weird dmesg to me or to Hanson.diao?

How can I figure out if the problem is the Ubuntu user space?
Is there any other information I can give you or any other test that I can do to figure out where the problem may be?

Damian Only (damian-only) wrote :

@Adam: you're right. I didn't realize that. Sorry for the spam. I'll take the issues to the places you proposed.

freeware2000 (freeware2000) wrote :

Work well:
+Linux Mint 17.1
+ Kernel 3.13.0-37

sudo apt-get install git
sudo git clone http://github.com/lwfinger/rtlwifi_new.git
cd ./rtlwifi_new
sudo make
sudo make install
sudo modprobe -v rtl8192ee

Lee Zamparo (zamparo) wrote :

A few errors in the previous message:

git repo is at https://github.com/lwfinger/rtlwifi_new.git
module is named r8192ee, not rtl8192ee

Lee.

On Mon, May 18, 2015 at 4:23 AM, freeware2000 <email address hidden> wrote:
> Work well:
> +Linux Mint 17.1
> + Kernel 3.13.0-37
>
> sudo apt-get install git
> sudo git clone http://github.com/lwfinger/rtlwifi_new.git
> cd ./rtlwifi_new
> sudo make
> sudo make install
> sudo modprobe -v rtl8192ee
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1239578
>
> Title:
> No wireless support for Realtek RTL8192EE [10ec:818b]
>
> Status in HWE Next Project:
> Fix Released
> Status in linux package in Ubuntu:
> Fix Released
> Status in linux source package in Trusty:
> Won't Fix
> Status in linux source package in Utopic:
> Fix Released
>
> Bug description:
> Open this bug to trace device driver RTL8192EE.
>
> We have seen this wireless card on some laptops, id is [10ec:818b],
> driver is RTL8192EE.
>
> This bug is only for the initial support of this WiFi adapter, it's
> not working 100% well yet, please report new "not working bug" or
> contact upstream but not keep posting comments, thanks.
>
>
> Status:
>
> pull-request for trusty was NAKed because next minor Trusty release
> will use Utopic LTS kernel, which had already fixed this issue.
>
> please wait it or upgrade your whole distro to Utopic.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hwe-next/+bug/1239578/+subscriptions

Driver r8192ee is from the staging directory for kernels older than 3.18. It is *not* the one in rtlwifi_new. You need to blacklist r8192ee!

Lee Zamparo (zamparo) wrote :

Indeed you’re right; my apologies for confusing the issue.

--
Lee

On May 26, 2015 at 12:00:59 AM, Larry Finger (<email address hidden>) wrote:

Driver r8192ee is from the staging directory for kernels older than
3.18. It is *not* the one in rtlwifi_new. You need to blacklist r8192ee!

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1239578

Title:
No wireless support for Realtek RTL8192EE [10ec:818b]

Status in HWE Next Project:
Fix Released
Status in linux package in Ubuntu:
Fix Released
Status in linux source package in Trusty:
Won't Fix
Status in linux source package in Utopic:
Fix Released

Bug description:
Open this bug to trace device driver RTL8192EE.

We have seen this wireless card on some laptops, id is [10ec:818b],
driver is RTL8192EE.

This bug is only for the initial support of this WiFi adapter, it's
not working 100% well yet, please report new "not working bug" or
contact upstream but not keep posting comments, thanks.

Status:

pull-request for trusty was NAKed because next minor Trusty release
will use Utopic LTS kernel, which had already fixed this issue.

please wait it or upgrade your whole distro to Utopic.

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1239578/+subscriptions

Dear Larry and other troubled souls,

Thank you very much for your efforts in getting this working. I can happily report that finally this seems to be working smoothly on an L440, with Trusty and 3.18 Kernel, r8192 blacklisted. Here are some log files for info.

wlan0 IEEE 802.11bgn ESSID:"AirMac0856442"
          Mode:Managed Frequency:2.462 GHz Access Point: 80:EA:96:EE:83:7E
          Bit Rate=144.4 Mb/s Tx-Power=20 dBm
          Retry short limit:7 RTS thr=2347 B Fragment thr:off
          Power Management:off
          Link Quality=70/70 Signal level=-32 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:284 Missed beacon:0

And the initial set-up

[ 0.000000] PERCPU: Embedded 30 pages/cpu @ffff88011f200000 s82880 r8192 d31808 u262144
[ 0.000000] pcpu-alloc: s82880 r8192 d31808 u262144 alloc=1*2097152
[ 0.045733] Mount-cache hash table entries: 8192 (order: 4, 65536 bytes)
[ 0.045738] Mountpoint-cache hash table entries: 8192 (order: 4, 65536 bytes)
[ 5.884637] rtlwifi: module verification failed: signature and/or required key missing - tainting kernel
[ 5.959874] Using firmware rtlwifi/rtl8192eefw_new.bin
[ 5.980581] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[ 5.980859] rtlwifi: wireless switch is on
[ 5.980951] rtl8192ee 0000:02:00.0: irq 30 for MSI/MSI-X

Lee Zamparo (zamparo) wrote :

I'd like to echo #356, the QOS of this card is pretty good now over WPA2 connections, thanks so much @lwfinger and the Realtek engineers for all your hard work.

I must also echo the concerns of #193 (@dreamcontrol8000), and state that I'm not able to connect to 802.11x networks that use PEAP/MSCHAPv2 authentication. Maybe this is asking too much, since most users don't have to authenticate under this protocol. I imagine it's difficult to test, given the substantial work to create a test environment that operates under PEAP. But I'll log this anyhow, since it's an issue for me.

Lee Zamparo (zamparo) wrote :

Sigh. Scratch #357, it was down to a detection issue by network-manager trying Tunneled TLS rather than PEAP. After correcting that, I'm able to connect first try just fine. So, thanks once again for all your diligent work.

I certainly do not have the test environment to test 802.11x networks. I tried once to implement a radius server to check WPA2 Enterprise, and was never able to get it going.

That said, from the driver's standpoint, it is just passing packets and should not care how the AP is getting its authentication. If you are able to capture the over-the-air packets during the authentication process, or detailed logs from the AP or authentication server, then we might be able to find out what is going wrong

Feer (r-feer) wrote :

Good evening

I am an owner of a T440 with a rtl card. I had to wait a long time for
Wifi as a simple user. I was a listener to your blog. With your
publication how to install I have now a working cableless internet
connection, stable.
I wish to express you my thanks.

kind regards

Rudolf Feer, MD
Switzerland

On 25.06.2015 19:02, Larry Finger wrote:
> I certainly do not have the test environment to test 802.11x networks. I
> tried once to implement a radius server to check WPA2 Enterprise, and
> was never able to get it going.
>
> That said, from the driver's standpoint, it is just passing packets and
> should not care how the AP is getting its authentication. If you are
> able to capture the over-the-air packets during the authentication
> process, or detailed logs from the AP or authentication server, then we
> might be able to find out what is going wrong
>

Hi,

After running the commands listed in #352, I still have no wifi connectivity. (Network Manager shows SSIDs but won't connect to any of them.)

There is relevant output from dmesg:

[ 6.651450] rtl8192ee:_rtl92ee_fw_free_to_go():<0-0> chksum report faill ! REG_MCUFWDL:0x00070600 .
[ 6.651454] rtl8192ee:rtl92ee_download_fw():<0-0> Firmware is not ready to run!

Does anyone have any advice how to fix what's causing these errors?

Thanks.

Is the firmware installed? What is the output of the command 'ls /lib/firmware/rtlwifi/*'?

I'm not certain how to tell whether it's installed, but the output of the command is

/lib/firmware/rtlwifi/Realtek-Firmware-License.txt /lib/firmware/rtlwifi/rtl8192cufw_TMSC.bin /lib/firmware/rtlwifi/rtl8723aufw_B.bin
/lib/firmware/rtlwifi/rtl8188efw.bin /lib/firmware/rtlwifi/rtl8192defw_12.bin /lib/firmware/rtlwifi/rtl8723aufw_B_NoBT.bin
/lib/firmware/rtlwifi/rtl8188eufw.bin /lib/firmware/rtlwifi/rtl8192defw.bin /lib/firmware/rtlwifi/rtl8723befw.bin
/lib/firmware/rtlwifi/rtl8192cfw.bin /lib/firmware/rtlwifi/rtl8192eefw.bin /lib/firmware/rtlwifi/rtl8723fw_B.bin
/lib/firmware/rtlwifi/rtl8192cfwU_B.bin /lib/firmware/rtlwifi/rtl8192eefw_new.bin /lib/firmware/rtlwifi/rtl8723fw.bin
/lib/firmware/rtlwifi/rtl8192cfwU.bin /lib/firmware/rtlwifi/rtl8192sefw.bin /lib/firmware/rtlwifi/rtl8812aefw.bin
/lib/firmware/rtlwifi/rtl8192cufw_A.bin /lib/firmware/rtlwifi/rtl8192sefw.old.bin /lib/firmware/rtlwifi/rtl8812aefw_wowlan.bin
/lib/firmware/rtlwifi/rtl8192cufw_B.bin /lib/firmware/rtlwifi/rtl8712u.bin /lib/firmware/rtlwifi/rtl8821aefw.bin
/lib/firmware/rtlwifi/rtl8192cufw.bin /lib/firmware/rtlwifi/rtl8723aufw_A.bin /lib/firmware/rtlwifi/rtl8821aefw_wowlan.bin

You have the firmware. Perhaps you have wireless disabled with some switch.

What does 'rfkill list all' show?

rfkill list all shows:

1: tpacpi_bluetooth_sw: Bluetooth
 Soft blocked: no
 Hard blocked: no
2: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
44: hci0: Bluetooth
 Soft blocked: no
 Hard blocked: no

I have no idea what your problem is. When I reboot with the RTL8192EE installed, it connects quickly to one of my APs.

The output of 'dmesg | grep rtl' is

[ 10.146821] rtl8192ee: Using firmware rtlwifi/rtl8192eefw.bin
[ 10.242108] ieee80211 phy1: Selected rate control algorithm 'rtl_rc'
[ 10.283731] rtlwifi: rtlwifi: wireless switch is on
[ 10.297365] rtl8192ee 0000:02:00.0 wlp2s0: renamed from wlan0
[ 20.079071] rtl8192ee 0000:02:00.0 wlp2s0: disabling HT/VHT due to WEP/TKIP use

The last line is because it connected with an 802.11g AP.. To check your firmware, the command 'md5sum /lib/firmware/rtlwifi/rtl8192eefw.bin' should return

c8ced945fe922aa0cdff91f40a77bf12 /lib/firmware/rtlwifi/rtl8192eefw.bin

I get the same results for either the 4.5-rc5 kernel from wireless-drivers-next or the drivers from the rtlwifi_new GitHub repo.

Download full text (248.7 KiB)

When I run your second command md5sum /lib/firmware/rtlwifi/rtl8192eefw.bin, I get what you say. But, when I run your first command, I get a really long string of errors which all look the same:

[247589.091374] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247589.147927] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247589.205146] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247589.261660] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247589.318961] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247589.375469] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247589.432705] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247589.489215] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247589.546472] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247589.603012] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247589.660306] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247589.716834] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247589.774080] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247589.830580] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247589.887764] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247589.944263] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247590.001544] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247590.058067] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247590.115331] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247590.171845] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247590.229082] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247590.285600] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247590.342842] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247590.399350] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247590.456888] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247590.513408] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247590.570984] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247590.627507] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247590.685079] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247590.741614] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247590.799105] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247590.855616] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247590.913115] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247590.969632] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247591.027117] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247591.083647] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247591.141120] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247591.197651] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247591.255155] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247591.311712] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247591.369410] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247591.425953] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247591.483186] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247591.539686] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247591.596980] rtl8192ee:rtl92ee_hw_init():<0-0> Init MAC failed
[247591.653498] rtl8192ee:rtl92ee_...

I am experiencing the same problem as aaronlandesman on a Lenovo x240 running Ubuntu 16.04, kernel 4.4.0-24-generic.

Displaying first 40 and last 40 comments. View all 368 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.