8086:0a16 [Acer Aspire V5-573G] Black screen on boot due to low brightness setting

Bug #1224415 reported by Erno Kuusela on 2013-09-12
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Linux
Unknown
Unknown
linux (Ubuntu)
Medium
Unassigned

Bug Description

On boot the screen is completely black, but the fn-arrow keys can be used to turn the backlight up. This is on Asus Aspire V5 573G. Same problem with mainline kernel.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: linux-image-3.11.0-7-generic 3.11.0-7.13
ProcVersionSignature: Ubuntu 3.11.0-7.13-generic 3.11.0
Uname: Linux 3.11.0-7-generic x86_64
ApportVersion: 2.12.1-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: erno 1825 F.... pulseaudio
 /dev/snd/controlC0: erno 1825 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory: 'iw'
Date: Thu Sep 12 13:49:55 2013
HibernationDevice: RESUME=/dev/mapper/kobol--vg-swap_1
MachineType: Acer Aspire V5-573G
MarkForUpload: True
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.11.0-7-generic root=/dev/mapper/hostname--vg-root ro splash quiet vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-7-generic N/A
 linux-backports-modules-3.11.0-7-generic N/A
 linux-firmware 1.113
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/28/2013
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: V2.13
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: Dazzle_HW
dmi.board.vendor: Acer
dmi.board.version: Type2 - A01 Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsydeCorp.:bvrV2.13:bd06/28/2013:svnAcer:pnAspireV5-573G:pvrTBDbyOEM:rvnAcer:rnDazzle_HW:rvrType2-A01BoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: Aspire V5-573G
dmi.product.version: TBD by OEM
dmi.sys.vendor: Acer

Erno Kuusela (erno-iki) wrote :
Erno Kuusela (erno-iki) on 2013-09-12
tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: bios-outdated-v2.20 needs-kernel-fixed-upstream-version regression-potential
removed: kernel-bug-exists-upstream
summary: - Black screen on boot due to low brightness setting
+ 8086:0a16 Black screen on boot due to low brightness setting
summary: - 8086:0a16 Black screen on boot due to low brightness setting
+ 8086:0a16 [Acer Aspire V5-573G] Black screen on boot due to low
+ brightness setting
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
tags: added: needs-upstream-testing
removed: needs-kernel-fixed-upstream-version

Erno Kuusela, in addition to https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1224415/comments/2 , was this problem not reproducible in a release prior to Saucy?

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Erno Kuusela (erno-iki) wrote :

It's a new laptop and I haven't tried old releases on it. In the upstream bugzilla (marked duplicate now, but if you follow the master bug) it's said that the general problem started in linux v3.7 when the Linux started advertising itself as "Windows 2012" (Windows 8) to ACPI.

Erno Kuusela (erno-iki) wrote :

Looks like the bug affects so many laptops that it should be fixed regardless this machine. So I'm not going to spend the effort to experiment with the the BIOS.

Changed in linux (Ubuntu):
status: Incomplete → New

Erno Kuusela, for regression testing purposes, could you please test for this with Quantal via http://releases.ubuntu.com/quantal/ and advise on if this is reproducible for your hardware?

Changed in linux (Ubuntu):
status: New → Incomplete
Erno Kuusela (erno-iki) wrote :

Booting 12.10 from a stick resulted in backlight on regular brightness but showing black image after the language selection. I still got sound feedback from volume adjustment fn-keys.

Changed in linux (Ubuntu):
status: Incomplete → New

Erno Kuusela, as per http://us.acer.com/ac/en/US/content/drivers an update is available for your BIOS (2.20). If you update to this, does it change anything?

If not, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful.

Thank you for your understanding.

Changed in linux (Ubuntu):
status: New → Incomplete
Erno Kuusela (erno-iki) wrote :

I'm sorry but I won't in the near future have time to figure out the BIOS upgrade procedure (no Windows on this machine).

bp0 (bullet-proof-0) wrote :

I have the same machine and the same bug, and just updated my bios to 2.20. The black screen problem still occurs. Here is my output from sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date:

V2.20
08/29/2013

Erno Kuusela (erno-iki) on 2013-10-05
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Erno Kuusela (erno-iki) on 2013-10-05
tags: removed: bios-outdated-v2.20 needs-upstream-testing

bp0, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

No need exists to comment here at this time. After reading the above documentation in it's entirety, if you have further questions, you are welcome to redirect them to the appropriate mailing list or forum via http://www.ubuntu.com/support/community/mailinglists , or you may contact me directly.

Thank you for your understanding.

Erno Kuusela, please follow https://help.ubuntu.com/community/BiosUpdate in order to perform the actions requested in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1224415/comments/8 .

tags: added: bios-outdated-v2.20 needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Erno Kuusela (erno-iki) wrote :

Like I said, I don't have a chance to try the BIOS update currently.

Hello!

I am facing the same issue on my Acer Aspire 573g with Kubuntu 13.10. I've upgraded my bios to the actual offical supported Acer bios version 2.22. The problem remains, after booting the screen stays black until I use the FN-Keys raise the screen brightnes.

....@Fenrir:~$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
[sudo] password for ....:
V2.22
09/30/2013

Please tell me if I should file a new bug or if you need any futher information.

MarioKleinsasser, please file a new report so your hardware may be tracked via a terminal:
ubuntu-bug linux

Erno Kuusela (erno-iki) wrote :

FYI therer's a fix in upstream now (see http://bugzilla.kernel.org/show_bug.cgi?id=61231)

Erno Kuusela, thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Trusty Tahr:
http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-trusty.git;a=commit;h=76641adddc5dc634cb7759dfa95d3d5a545678d1

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please perform as much as possible of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.