syslog filled with urb status code

Bug #1222850 reported by David Tremblay on 2013-09-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Tim Gardner
Saucy
Medium
Tim Gardner

Bug Description

my syslog is filled with those entries.

Sep 9 08:08:48 davidubuntupc kernel: [344002.932702] cm109 8-2:1.3: cm109_urb_ctl_callback: urb status -71
Sep 9 08:08:48 davidubuntupc kernel: [344003.026654] cm109 8-2:1.3: cm109_urb_irq_callback: urb status -84
Sep 9 08:08:48 davidubuntupc kernel: [344003.028619] cm109 8-2:1.3: cm109_urb_ctl_callback: urb status -71
Sep 9 08:08:48 davidubuntupc kernel: [344003.122624] cm109 8-2:1.3: cm109_urb_irq_callback: urb status -84
Sep 9 08:08:48 davidubuntupc kernel: [344003.124590] cm109 8-2:1.3: cm109_urb_ctl_callback: urb status -71
Sep 9 08:08:48 davidubuntupc kernel: [344003.218587] cm109 8-2:1.3: cm109_urb_irq_callback: urb status -84
Sep 9 08:08:48 davidubuntupc kernel: [344003.220558] cm109 8-2:1.3: cm109_urb_ctl_callback: urb status -71

kern.log can grow in gigabyte because of those entries

I do have problem with two USB devices, I often have to disconnect/connect the mouse, the headphones or the keyboard to make them work again (especially after screenlocks) The USB devices are connected through usb-ethernet extender.

I suspect it is usb-ethernet extender that does something

David Tremblay (david-tremblay) wrote :
William Grant (wgrant) on 2013-09-09
affects: launchpad → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1222850

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.11 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11-saucy/

Changed in linux (Ubuntu):
importance: Undecided → Medium
Tim Gardner (timg-tpi) on 2013-09-10
Changed in linux (Ubuntu Saucy):
assignee: nobody → Tim Gardner (timg-tpi)
status: Incomplete → In Progress
Tim Gardner (timg-tpi) on 2013-09-10
Changed in linux (Ubuntu Saucy):
status: In Progress → Fix Committed
Tim Gardner (timg-tpi) wrote :

Joe - I sent a patch upstream that ratelimits this log noise. We'll carry a SAUCE patch until it is merged upstream.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.11.0-7.13

---------------
linux (3.11.0-7.13) saucy; urgency=low

  * Release tracker
    - LP: #1223545

  [ Andy Whitcroft ]

  * SAUCE: (no-up) scsi: add scsi device flag to request VPD pages be used at SPC-2
    - LP: #1223499
  * SAUCE: (no-up) scsi: add scsi device flag to request READ CAPACITY (16) be preferred
    - LP: #1223499
  * SAUCE: (no-up) scsi: hyper-v storage -- mark as VPD capable at SPC-2
    - LP: #1223499
  * SAUCE: (no-up) scsi: hyper-v storage -- mark as preferring READ CAPACITY (16) at SPC-2
    - LP: #1223499

  [ Maximiliano Curia ]

  * SAUCE: (no-up) Only let characters through when there are active readers.
    - LP: #1208740

  [ Tim Gardner ]

  * [Debian] getabis: Commit new ABI directory, remove the old
  * [Config] CONFIG_EFIVAR_FS=y
    - LP: #1223195
  * [Config] CONFIG_EFI_VARS_PSTORE=m,
    CONFIG_EFI_VARS_PSTORE_DEFAULT_DISABLE=n
  * SAUCE: (no-up) USB: input: cm109.c: Convert high volume dev_err() to dev_err_ratelimited()
    - LP: #1222850

  [ Upstream Kernel Changes ]

  * Intel xhci: refactor EHCI/xHCI port switching
    - LP: #1210858
 -- Tim Gardner <email address hidden> Tue, 10 Sep 2013 09:00:19 -0600

Changed in linux (Ubuntu Saucy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments