Wifi and bluetooth disabled at boot and hard to re-enable

Bug #1214059 reported by Nicolas Delvaux on 2013-08-19
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Network Manager says either "Device not ready" or "wireless is disabled by hardware switch" (it depends).
Enabling Bluetooth in the control-center just enable it for like half a second and then it's switched off again.

I have a combined hardware button for both Wifi and Bluetooth, it's red when it's disabled and blue when enabled.
In this case it stays red even when I repeatedly press it (though the Bluetooth setting panel reliably indicate when it is hardware disabled, so I guess the color is only related to software lock).

I manage to make it work again after playing with "rfkill [block|unblock] all" and messing around with network manager (disabling network and then re-enabling it...). I usually need around 5 minutes to make it work.

I did not have this problem on Raring. I had it on saucy with the 3.10 kernel but it seems to be worse with 3.11 (I need to mess around for more time in order to make it work again).

Feel free to ask if you need any additional test.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: linux-image-3.11.0-2-generic 3.11.0-2.5
ProcVersionSignature: Ubuntu 3.11.0-2.5-generic 3.11.0-rc5
Uname: Linux 3.11.0-2-generic x86_64
ApportVersion: 2.12-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: nicolas 1670 F.... pulseaudio
 /dev/snd/controlC0: nicolas 1670 F.... pulseaudio
Date: Mon Aug 19 19:20:56 2013
HibernationDevice: RESUME=UUID=7e493485-d08d-4944-8362-444f69fd1e08
InstallationDate: Installed on 2013-07-10 (39 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130710)
MachineType: Hewlett-Packard HP EliteBook 8530p
MarkForUpload: True
PccardctlStatus:
 Socket 0:
   3.3V
  16-bit
  PC Card
   Subdevice 0 (function 0) bound to driver "pata_pcmcia"
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-2-generic root=UUID=821ce4aa-35e4-436c-93cc-c8c2d9aba532 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-2-generic N/A
 linux-backports-modules-3.11.0-2-generic N/A
 linux-firmware 1.113
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/08/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68PDV Ver. F.11
dmi.board.name: 30E7
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 90.26
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68PDVVer.F.11:bd12/08/2009:svnHewlett-Packard:pnHPEliteBook8530p:pvrF.11:rvnHewlett-Packard:rn30E7:rvrKBCVersion90.26:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP EliteBook 8530p
dmi.product.version: F.11
dmi.sys.vendor: Hewlett-Packard

Nicolas Delvaux (malizor) wrote :
Nicolas Delvaux (malizor) wrote :

Some interesting things in the WifiSyslog.txt file it seems (where you can see my various attempt before finally connecting)

iwlwifi seems to often fails to load the firmware...

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.11 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11-rc6-saucy/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Nicolas Delvaux (malizor) wrote :

Tested with the 09/18 kernel, same problem.

Perhaps there is some relation with Network Manager somewhere, because, among other things (see above), I always have to disable/enable the network from the NM indicator before being able to connect...

tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Nicolas Delvaux (malizor) wrote :

*08/18 kernel

Nicolas Delvaux, as per http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=3782359&prodTypeId=321957&prodSeriesId=3782310&swLang=13&taskId=135&swEnvOID=4060#120 an update is available for your BIOS (F.20). If you update to this, does it change anything?

If not, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful.

Thank you for your understanding.

tags: added: bios-outdated-f.20 regression-potential
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Nicolas Delvaux (malizor) wrote :

I did the Bios upgrade but it changed nothing. I still get the same behaviour as the one I described above.

~$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
68PDV Ver. F.20
12/08/2011

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: removed: bios-outdated-f.20

Nicolas Delvaux, did this problem not occur in a release prior to Saucy?

tags: added: latest-bios-f.20
tags: added: kernel-bug-exists-upstream-v3.11-rc6
removed: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Nicolas Delvaux (malizor) wrote :

Yes, it worked fine before Saucy.
For example, this laptop is dual-booting with Ubuntu 12.04 (3.2 kernel I think) and I don't have this problem with it.
Before Saucy I was testing Raring and it worked fine (so 3.8 kernel).

Is there an easy way to install older kernels on Saucy so that we can find out if this is really a kernel regression or rather something user-space related?
(I can also install a newer kernel on my 12.04 partition if you think this is more relevant)

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Nicolas Delvaux, the next step would be to bisect the kernel from Raring to Saucy, in order to identify the offending commit. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection ?

tags: added: regression-release
removed: regression-potential
tags: added: needs-bisect
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Nicolas Delvaux (malizor) wrote :

3.11.0-* (starting from 3.11.0-0) -> not ok, see bug description

3.10.0-* -> ok but wifi is *sometime* turned off at boot (I have to check "Enable Wifi network" in NM)
In this case I see a "RF_KILL bit toggled to disable radio" in dmesg with no visible error.
The fact that this is random is quite strange.

3.9.0-* -> work perfectly (Wifi already connected when lightdm appears on screen)

So the big thing seems to be with 3.11 (at least >= rc4, which is 3.11.0-0 AFAIK).

Now trying to narrow the scope with mainline kernels:
v3.11-rc1-saucy -> It works!
v3.11-rc2-saucy -> It works!
v3.11-rc3-saucy -> It works!
v3.11-rc4-saucy -> FAIL

So the problem is between rc3 and rc4.

Now it's going to be more complicated because this laptop is not suited for building kernels. It will take forever.
(I have a more powerful desktop, but it's not running Saucy)

Could someone help me find a potential faulty commit in order to speed up the bisecting process?
Thanks.

Nicolas Delvaux (malizor) wrote :

Ok, after a lot of time git bisect tell me that the bad commit is a53ee0a308b16e392e0219c585b10f329345766b.

It turns out this commit was reverted yesterday in e2982a04ede454b23ea2f5af11ba4d77d8a70155.
My problem is indeed gone in the HEAD kernel.

I guess it's a good news but I'm still a bit disappointed to have wasted so much time...

Changed in linux (Ubuntu):
status: Incomplete → Fix Committed

Nicolas Delvaux, the issue you are reporting is an upstream one. Could you please report this problem through the appropriate channel by following the instructions _verbatim_ at https://wiki.ubuntu.com/Bugs/Upstream/kernel#KernelTeam.2BAC8-KernelTeamBugPolicies.Overview_on_Reporting_Bugs_Upstream ?

Thank you for your understanding.

tags: added: bisect-done
removed: needs-bisect
Changed in linux (Ubuntu):
status: Fix Committed → Confirmed
Nicolas Delvaux (malizor) wrote :

Christopher M. Penalve, in my last comment I explained that this bug was already fixed upstream (the faulty commit was reverted).
So it will be "fix-released" in the next RC.

Changed in linux (Ubuntu):
status: Confirmed → Fix Committed

Nicolas Delvaux, please stop toggling this as it is not Fix Committed. For more on Status, please see https://wiki.ubuntu.com/Bugs/Status .

Changed in linux (Ubuntu):
status: Fix Committed → Confirmed
Nicolas Delvaux (malizor) wrote :

Christopher M. Penalve, here is a quote of this very link:

Fix Committed:
[...]
    Upstream bug task: the fix is in CVS/SVN/bzr or committed to some place

Which is actually the case since this is fixed upstream.

Changed in linux (Ubuntu):
status: Confirmed → Fix Committed

Nicolas Delvaux, quoting from https://wiki.ubuntu.com/Bugs/Status :
Fix Committed is also used when an updated package exists in a -proposed repository i.e. hardy-proposed
Fix Committed is not to be used when a patch is attached to a bug

Again, please stop toggling this to Fix Committed. It being committed upstream has nothing to do with downstream/Ubuntu process. When the commit noted is in the -Proposed repository, then it would be Fix Committed, not before.

Changed in linux (Ubuntu):
status: Fix Committed → Confirmed

Given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We are approaching release and would like to confirm if this bug is still present. Please test again with the latest development kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.11.0-7.14
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Markcortbass (markcortbass) wrote :

I confirm that this is still a bug in Ubuntu 13.10

Mark, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

No need exists to comment here at this time. After reading the above documentation in it's entirety, if you have further questions, you are welcome to redirect them to the appropriate mailing list or forum via http://www.ubuntu.com/support/community/mailinglists , or you may contact me directly.

Thank you for your understanding.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers