Lenovo Thinkpad Twist: Suspend does not work

Bug #1213233 reported by Till Kamppeter on 2013-08-16
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I am using Saucy with the standard Unity desktop, in XMir mode (https://wiki.ubuntu.com/Mir/Installing).

If I suspend the machine by selecting "Suspend" in the system menu (Gear in the upper right corner), the suspend sequence get started but immediately after the sequence completing the machine wakes up again. So I am not able to suspend my computer.

This is independent whether I am in laptop mode and operating the machine with a mouse or in tablet mode with the touch screen.

Changed in unity (Ubuntu):
importance: Undecided → High
importance: High → Critical
Till Kamppeter (till-kamppeter) wrote :

This problem only occurs in XMir mode, when deactivating XMir as described in the section "Removing unity-system-compositor", subsection "temporarily", suspend works.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
James Ramsay (f-jack) on 2013-08-19
Changed in unity:
status: New → Incomplete
status: Incomplete → Confirmed
Till Kamppeter (till-kamppeter) wrote :

After doing the tests I got asked for in bug 1213239, suspend started to work correctly with all kernels, especially with the newest ones of Saucy (3.11.0-3-generic and 3.11.0-2-generic). So with the current, fully up-to-date Saucy suspend works.

Stephen M. Webb (bregma) wrote :

This bug report is being closed due to your last comment.

Changed in unity:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Matteo Dell'Amico (della) wrote :

I had the same problem, with Lenovo Thinkpad Twist and Saucy Salamander. It's kind of intermittent, I'm now trying to understand whether "echo LID0 | sudo tee /proc/acpi/wakeup" solves the problem.

Matteo Dell'Amico (della) wrote :

The problem happens after every reboot. The computer would go in standby mode only once. Doing

echo EHC1 | sudo tee /proc/acpi/wakeup

solves this.

Matteo Dell'Amico (della) wrote :

I reopened the bug (I hope I did it right). The bug is still present on the released Saucy, and I fixed it on my laptop by adding

if grep -q "EHC1.*enabled" /proc/acpi/wakeup then
 echo EHC1 > /proc/acpi/wakeup
fi

to /etc/rc.local.

The problem happens when I'm not running Mir, but rather a default Saucy installation. I guess this bug should be moved to a different package.

Changed in unity:
status: Invalid → Confirmed
Changed in unity (Ubuntu):
status: Invalid → Confirmed
Matteo Dell'Amico (della) wrote :

Just a minor note: missing semicolon in the above snippet. The correct snippet is

if grep -q "EHC1.*enabled" /proc/acpi/wakeup; then
 echo EHC1 > /proc/acpi/wakeup
fi

Aaron Wolf (wolftune) wrote :

Hi, just to note: this is not just Saucy, not just Unity. I am running 12.04.3 with the backport of kernel 3.11 from Saucy, and I am using KDE. I *still* get the same issue and the same fix from Matteo works for me!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in meta-kde (Ubuntu):
status: New → Confirmed
no longer affects: meta-kde (Ubuntu)
no longer affects: unity (Ubuntu)
affects: unity → unity (Ubuntu)
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Aaron Wolf (wolftune) on 2013-12-26
Changed in unity (Ubuntu):
status: Invalid → Confirmed
Aaron Wolf (wolftune) wrote :

I don't know why you marked this invalid, Christopher. This is definitely affecting me still on kernel 3.11.0-11. There was no indication of a fix.

Aaron Wolf, thank you for your comment. I marked this Invalid as per the original reporter's comments that this is resolved for him. Given this, the fact you are not the original reporter, this is not your bug, and this report is not tracking your problem, this report is closed.

Despite this, if you have a bug in Ubuntu, please feel free to file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://help.ubuntu.com/community/ReportingBugs

affects: unity (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers