[Sony VAIO SVT15117CXS] USB 2.0 ports not working with any USB device

Bug #1210858 reported by Combat on 2013-08-10
78
This bug affects 15 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Tim Gardner
Saucy
High
Tim Gardner

Bug Description

VaioT Series Ultrabook laptap USB 2.0 ports not working. They have power (as evidenced when plugging in phone) but no events are "firing" once device is plugged in. They appear in lsusb and lspci, watching dmesg and udev when plugging in a device yields no results/events. USB 3.0 works perfectly.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: linux-image-3.10.0-6-generic 3.10.0-6.17 [modified: boot/vmlinuz-3.10.0-6-generic]
ProcVersionSignature: Ubuntu 3.10.0-6.17-generic 3.10.3
Uname: Linux 3.10.0-6-generic x86_64
ApportVersion: 2.12-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: kevin 1683 F.... pulseaudio
 /dev/snd/pcmC0D0p: kevin 1683 F...m pulseaudio
Date: Sat Aug 10 16:27:49 2013
HibernationDevice: RESUME=UUID=93e4d74d-7a03-45ae-9ccd-6f7ce496ee0a
InstallationDate: Installed on 2013-08-10 (0 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130810)
MachineType: Sony Corporation SVT15117CXS
MarkForUpload: True
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.10.0-6-generic.efi.signed root=UUID=d992d9d0-4638-491c-b05b-c7e36d9128fd ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.10.0-6-generic N/A
 linux-backports-modules-3.10.0-6-generic N/A
 linux-firmware 1.113
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/14/2012
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: R1100D4
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnInsydeCorp.:bvrR1100D4:bd11/14/2012:svnSonyCorporation:pnSVT15117CXS:pvrC9055N7A:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: SVT15117CXS
dmi.product.version: C9055N7A
dmi.sys.vendor: Sony Corporation

Combat (combatb2) wrote :

Combat, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11-rc4

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: latest-bios-r1100d4 needs-upstream-testing regression-potential
description: updated
Changed in linux (Ubuntu):
status: New → Incomplete
summary: - Vaio T Series ultrabook USB 2.0 ports not working
+ [Sony VAIO SVT15117CXS] USB 2.0 ports not working

Tested against v3.10-rc7 - Confirmed. This also did not work for 12.04, 12.10

tags: added: kernel-bug-exists-upstream-v3.10-rc7
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Combat, could you please test the latest mainline kernel via http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11-rc4-saucy/ ?

tags: added: needs-upstream-testing precise quantal
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Combat (combatb2) wrote :

Tested against v3.11-rc4 - Confirmed

tags: added: kernel-bug-exists-upstream-v3.11-rc4-saucy
removed: kernel-bug-exists-upstream-v3.10-rc7
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Combat, did this problem not occur in a release prior to Precise?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Combat (combatb2) wrote :

Christopher -
Not sure - I started with precise.
But it appears from other posts that this problem
Exists with this laptop in most flavors of linux.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Combat, for regression testing purpose, could you please test Lucid via http://old-releases.ubuntu.com/releases/lucid/ ?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Combat (combatb2) wrote :

tested against lucid v2.6.33-02063305
Couldn't get X working but did get to prompt.

USB 2.0 did appear to recognize installing flash drive and uninstalling flash drive.
I wasn't able to get it mounted though.

I have included dmesg, lsusb and lspci logs

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Combat (combatb2) wrote :

Sorry dmesg_lucid was overwritten.
here is correct lucid dmesg file

Combat, thank for posting the Lucid logs, as it did help immensely in revealing the true root cause. In your current Saucy install, could you please add to your kernel boot parameters the following:
irqpoll

One may do this via a terminal:
sudo gedit /etc/default/grub

and change:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash irqpoll"

execute at a terminal:
sudo update-grub

restart your computer, and advise if anything changes.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Combat (combatb2) wrote :

Christopher -
No change - attaching dmesg.txt --- lsusb and lspci are the same as before.
udevadm monitor sees nothing either.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Combat, does this problem happen with any USB device you plugin, or only certain ones?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Combat (combatb2) wrote :

It fails to register with any device.

Combat, for regression testing purposes, could you please test for this in Natty via http://old-releases.ubuntu.com/releases/natty/ ?

summary: - [Sony VAIO SVT15117CXS] USB 2.0 ports not working
+ [Sony VAIO SVT15117CXS] USB 2.0 ports not working with any USB device
tags: added: lucid
removed: regression-potential
tags: added: regression-potential
removed: lucid
tags: removed: needs-upstream-testing
tags: added: kernel-bug-exists-upstream-v3.11-rc4
removed: kernel-bug-exists-upstream-v3.11-rc4-saucy
Combat (combatb2) wrote :

Ok same results as lucid - X didn't work but I got to a prompt.
Attached are the dmesg, udevadm logs

Thanks

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Combat (combatb2) wrote :

Christopher,

Take a look a the PNP sections of original dmesg and natty/lucid
2 more IDs are located in the older versions than the newer versions
ie [ 1.032703] pnp 00:00: Plug and Play ACPI device, IDs PNP0a08 PNP0a03 (active) <== natty (not in 12.04,12.10,13.04)

Could this be a pointer to the issue?

Thanks

Combat, for regression testing purposes could you please test http://old-releases.ubuntu.com/releases/oneiric/ ? As well, please to don't compress/tar files together, as this is frowned upon. Instead, attach them as separate attachments.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Combat (combatb2) wrote :

It did not work.
I logged dmesg and noticed irqpoll was not in the boot params
so I added it and restarted - still did not work

attaching dmesg with and without irqpoll.

Thanks

Combat (combatb2) wrote :
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium

Combat, could you please boot into the newest mainline kernel via http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11-rc5-saucy/ , and gather a USB trace for a more in depth analysis following http://www.kernel.org/doc/Documentation/usb/usbmon.txt ?

Thank you for your understanding.

tags: added: needs-upstream-testing oneiric
removed: regression-potential
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Changed in linux (Ubuntu):
importance: Medium → High
Combat (combatb2) wrote :

v3.11_rc5_saucy did not fix the problem.
Logs attached

Thanks

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Combat, could you please provide the usbmon output via https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1210858/comments/21 ?

As well, no need to post lsusb and lspci as we already have that from your original bug submission attachments.

tags: added: kernel-bug-exists-upstream-v3.11-rc5
removed: kernel-bug-exists-upstream-v3.11-rc4 needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Combat (combatb2) wrote :

I wasnt sure which bus/device so I used cat 0u into a text file.
I tried mutiple usb devices on both USB 2.0 ports and usbmon yielded nothing.
usbmon with v3.11-rc5 saw nothing plugging into the ports.

I did this with the USB 3.0 port and there was a lot of data, but as you know the 3.0 port works just fine.

Combat, in your Saucy install, could you please run through https://help.ubuntu.com/community/DebuggingIRQProblems and test each kernel boot parameter individually and advise if anything changes?

Combat (combatb2) wrote :

tried setting each of these parameters individually with no changes in usb 2.0 ports

Thanks

Combat (combatb2) on 2013-08-17
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Combat, the issue you are reporting is an upstream one. Could you please report this problem through the appropriate channel by following the instructions _verbatim_ at https://wiki.ubuntu.com/Bugs/Upstream/kernel#KernelTeam.2BAC8-KernelTeamBugPolicies.Overview_on_Reporting_Bugs_Upstream ?

Thank you for your understanding.

Combat (combatb2) wrote :

Found the problem.

changed pci-quirks.c in v3.11 with
--- pci-quirks.c~ 2013-08-06 07:25:47.000000000 -0400
+++ pci-quirks.c 2013-08-30 14:23:47.597891192 -0400
@@ -921,9 +921,10 @@
  writel(val, base + ext_cap_offset + XHCI_LEGACY_CONTROL_OFFSET);

 hc_init:
+ /*
  if (usb_is_intel_switchable_xhci(pdev))
   usb_enable_xhci_ports(pdev);
-
+ */
  op_reg_base = base + XHCI_HC_LENGTH(readl(base));

  /* Wait for the host controller to be ready before writing any

rebuilt the kernel and the USB 2.0 ports now work!

Combat (combatb2) wrote :

 there is already a change in this area scheduled for the 3.12 kernel release:

https://git.kernel.org/cgit/linux/kernel/git/gregkh/usb.git/commit?id=26b76798e0507429506b93cd49f8c4cfdab06896

Combat, following up on https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1210858/comments/31 would you have a URL of your upstream discussion?

Regarding https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1210858/comments/33 do you know the commit referenced to have the same outcome as https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1210858/comments/32 , or are you speculating to this?

ATIpro (somebody2112) wrote :

I've just built kernel with fix above and USB 2.0 port is back with me. Fantastic. Hope that 3.12 kernel will work out of the box.

Joseph Salisbury (jsalisbury) wrote :

Upstream commit 26b7679 was not cc'd to stable. When this fix lands in 3.12, we will need to perform a cherry pick and confirm it resolves this bug. If it does, we can request that it be included in upstream stable and submit and SRU for Ubuntu stable kernels.

Changed in linux (Ubuntu):
status: Confirmed → Triaged
tags: added: kernel-da-key
Tim Gardner (timg-tpi) on 2013-09-09
Changed in linux (Ubuntu Saucy):
assignee: nobody → Tim Gardner (timg-tpi)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.11.0-7.13

---------------
linux (3.11.0-7.13) saucy; urgency=low

  * Release tracker
    - LP: #1223545

  [ Andy Whitcroft ]

  * SAUCE: (no-up) scsi: add scsi device flag to request VPD pages be used at SPC-2
    - LP: #1223499
  * SAUCE: (no-up) scsi: add scsi device flag to request READ CAPACITY (16) be preferred
    - LP: #1223499
  * SAUCE: (no-up) scsi: hyper-v storage -- mark as VPD capable at SPC-2
    - LP: #1223499
  * SAUCE: (no-up) scsi: hyper-v storage -- mark as preferring READ CAPACITY (16) at SPC-2
    - LP: #1223499

  [ Maximiliano Curia ]

  * SAUCE: (no-up) Only let characters through when there are active readers.
    - LP: #1208740

  [ Tim Gardner ]

  * [Debian] getabis: Commit new ABI directory, remove the old
  * [Config] CONFIG_EFIVAR_FS=y
    - LP: #1223195
  * [Config] CONFIG_EFI_VARS_PSTORE=m,
    CONFIG_EFI_VARS_PSTORE_DEFAULT_DISABLE=n
  * SAUCE: (no-up) USB: input: cm109.c: Convert high volume dev_err() to dev_err_ratelimited()
    - LP: #1222850

  [ Upstream Kernel Changes ]

  * Intel xhci: refactor EHCI/xHCI port switching
    - LP: #1210858
 -- Tim Gardner <email address hidden> Tue, 10 Sep 2013 09:00:19 -0600

Changed in linux (Ubuntu Saucy):
status: Fix Committed → Fix Released
ATIpro (somebody2112) wrote :

I've just downloaded
linux-headers-3.11.0-7_3.11.0-7.13_all.deb,
linux-headers-3.11.0-7-generic_3.11.0-7.13_i386.deb,
linux-image-3.11.0-7-generic_3.11.0-7.13_i386.deb,
linux-image-extra-3.11.0-7-generic_3.11.0-7.13_i386.deb
from this url https://launchpad.net/ubuntu/+source/linux/3.11.0-7.13/+build/4952971 and installed them on my Precise system. And actually USB 2.0 port is NOT working. Can someone confirm that? Did you use here patches from 3.12 kernel? Before that I've only tested Combat's fix and it does the trick.

ATIpro, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

No need exists to comment here at this time. After reading the above documentation in it's entirety, if you have further questions, you are welcome to redirect them to the appropriate mailing list or forum via http://www.ubuntu.com/support/community/mailinglists , or you may contact me directly.

Thank you for your understanding.

FlashBuster (flashbuster) wrote :

Hi,

so, what did work is to use the patch supplied here on a self-compiled linux-3.11.

The patch from: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1210858/comments/32
The Sources build from the guide: https://wiki.ubuntu.com/Kernel/BuildYourOwnKernel
With the checkout: git clone git://kernel.ubuntu.com/ubuntu/ubuntu-saucy.git

And built with:
fakeroot debian/rules clean
fakeroot debian/rules binary-headers binary-generic

What DID NOT work was to install linux-3.12-rc7 from mainline ppa: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-rc7-saucy/
My understanding was that linux 3.12 includes the patch for this problem.
This is obviously not the case.

FlashBuster (flashbuster) wrote :

Also, the problem still exists with the default kernel of Ubuntu Saucy linux-image-3.11.0-12.

FlashBuster, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

No need exists to comment here at this time. After reading the above documentation in it's entirety, if you have further questions, you are welcome to redirect them to the appropriate mailing list or forum via http://www.ubuntu.com/support/community/mailinglists , or you may contact me directly.

Thank you for your understanding.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers