Nouveau crashes at nouveau_object_decf on logout and system hangs on restarting lightdm

Bug #1205329 reported by Prem Anand on 2013-07-26
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I am seeing nouveau consistently crashing @ nouveau_object_decf on logging out. On trying to restart the display manager, it hangs

[29140.815287] nouveau E[ I2C][0000:01:00.0] AUXCH(1): begin idle timeout 0xffffffff
[29140.816398] nouveau E[ I2C][0000:01:00.0] AUXCH(1): begin idle timeout 0xffffffff
[29140.817495] nouveau E[ I2C][0000:01:00.0] AUXCH(3): begin idle timeout 0xffffffff
[29140.819535] nouveau E[ I2C][0000:01:00.0] AUXCH(3): begin idle timeout 0xffffffff
[29140.821547] nouveau E[ I2C][0000:01:00.0] AUXCH(2): begin idle timeout 0xffffffff
[29140.823558] nouveau E[ I2C][0000:01:00.0] AUXCH(2): begin idle timeout 0xffffffff
[29264.387025] BUG: unable to handle kernel NULL pointer dereference at (null)
[29264.387062] IP: [< (null)>] (null)
[29264.387081] PGD 0
[29264.387090] Oops: 0010 [#1] SMP
[29264.387105] Modules linked in: snd_hda_codec_hdmi intel_powerclamp coretemp lib80211_crypt_tkip kvm_intel kvm crc32_pclmul ghash_clmulni_intel aesni_intel aes_x86_64 lrw gf128mul glue_helper ablk_helper cryptd joydev applesmc input_polldev snd_hda_codec_cirrus parport_pc ppdev uvcvideo snd_hda_intel wl(POF) microcode snd_hda_codec videobuf2_vmalloc videobuf2_memops snd_hwdep videobuf2_core snd_seq_midi bnep snd_seq_midi_event rfcomm videodev snd_rawmidi snd_pcm bluetooth bcm5974 snd_seq snd_page_alloc lib80211 lpc_ich cfg80211 mei_me mei snd_seq_device snd_timer snd apple_gmux soundcore apple_bl mac_hid binfmt_misc nls_iso8859_1 lp parport hid_apple nouveau mxm_wmi hid_generic i915 wmi sdhci_pci tg3 ttm ahci i2c_algo_bit sdhci usbhid drm_kms_helper libahci ptp hid drm pps_core video [last unloaded: btusb]
[29264.387428] CPU: 3 PID: 1337 Comm: Xorg Tainted: PF W O 3.10.2-031002-generic #201307212216
[29264.387460] Hardware name: Apple Inc. MacBookPro10,1/Mac-C3EC7CD22292981F, BIOS MBP101.88Z.00EE.B03.1212211437 12/21/2012
[29264.387498] task: ffff880452ea5dc0 ti: ffff8804570c2000 task.ti: ffff8804570c2000
[29264.387524] RIP: 0010:[<0000000000000000>] [< (null)>] (null)
[29264.387551] RSP: 0018:ffff8804570c3af0 EFLAGS: 00010246
[29264.387570] RAX: ffffffffa02c0020 RBX: ffff88045717eb00 RCX: 00000000e0000000
[29264.387595] RDX: 0000000000000005 RSI: 0000000000000000 RDI: ffff88045717eb00
[29264.387620] RBP: ffff8804570c3b08 R08: 0000000000000000 R09: 00000000ffffffff
[29264.387645] R10: ffffffffa021cb37 R11: 0000000000000002 R12: 0000000000000001
[29264.387671] R13: 0000000000000000 R14: ffff880458354688 R15: 0000000000000000
[29264.387696] FS: 0000000000000000(0000) GS:ffff88046f2c0000(0000) knlGS:0000000000000000
[29264.387725] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[29264.387745] CR2: 0000000000000000 CR3: 0000000002c0d000 CR4: 00000000001407e0
[29264.387770] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[29264.387795] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[29264.387819] Stack:
[29264.387827] ffffffffa01fb83a 0000000000000000 ffff88045717eb00 ffff8804570c3b38
[29264.387857] ffffffffa01fb7dd ffff880458354670 ffff880458354670 0000000000000000
[29264.387885] ffff880458354660 ffff8804570c3b98 ffffffffa01fa0db ffffffffa02b3c31
[29264.387913] Call Trace:
[29264.387939] [<ffffffffa01fb83a>] ? nouveau_object_decf+0x3a/0xd0 [nouveau]
[29264.387972] [<ffffffffa01fb7dd>] nouveau_object_dec+0x6d/0x90 [nouveau]
[29264.388005] [<ffffffffa01fa0db>] nouveau_handle_fini+0x13b/0x2b0 [nouveau]
[29264.388039] [<ffffffffa01f8221>] nouveau_client_fini+0x61/0xa0 [nouveau]
[29264.388081] [<ffffffffa0271adf>] nouveau_cli_destroy+0x2f/0x50 [nouveau]
[29264.388119] [<ffffffffa0271b99>] nouveau_drm_postclose+0x19/0x20 [nouveau]
[29264.388152] [<ffffffffa001a0b0>] drm_release+0x340/0x520 [drm]
[29264.388176] [<ffffffff811a1e9a>] __fput+0xba/0x240
[29264.388195] [<ffffffff811a202e>] ____fput+0xe/0x10
[29264.388215] [<ffffffff8107cda8>] task_work_run+0xc8/0xf0
[29264.388235] [<ffffffff8105f6ae>] do_exit+0x19e/0x480
[29264.388256] [<ffffffff810b919f>] ? __unqueue_futex+0x3f/0x80
[29264.388278] [<ffffffff8106c4db>] ? __dequeue_signal+0x6b/0xb0
[29264.388299] [<ffffffff8105fa24>] do_group_exit+0x44/0xa0
[29264.388320] [<ffffffff8106f621>] get_signal_to_deliver+0x231/0x480
[29264.388345] [<ffffffff81013bc7>] do_signal+0x47/0x140
[29264.388366] [<ffffffff8109350c>] ? account_user_time+0x9c/0xb0
[29264.388387] [<ffffffff81093b34>] ? vtime_account_user+0x74/0x90
[29264.388410] [<ffffffff81013d48>] do_notify_resume+0x88/0xc0
[29264.388433] [<ffffffff8172231a>] int_signal+0x12/0x17
[29264.388451] Code: Bad RIP value.
[29264.388467] RIP [< (null)>] (null)
[29264.388487] RSP <ffff8804570c3af0>
[29264.388499] CR2: 0000000000000000
[29264.388525] ---[ end trace 4ca6bffe89780c0c ]---
[29264.388543] Fixing recursive fault but reboot is needed!

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: xorg 1:7.7+1ubuntu4
Uname: Linux 3.10.2-031002-generic x86_64
NonfreeKernelModules: wl
.tmp.unity.support.test.0:

ApportVersion: 2.9.2-0ubuntu8.3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Fri Jul 26 14:16:04 2013
DistUpgraded: Fresh install
DistroCodename: raring
DistroVariant: ubuntu
DkmsStatus: bcmwl, 6.30.223.30+bdcom, 3.10.2-031002-generic, x86_64: installed
ExtraDebuggingInterest: Yes, if not too technical
GpuHangFrequency: Several times a day
GpuHangReproducibility: Yes, I can easily reproduce it
GpuHangStarted: Immediately after installing this version of Ubuntu
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Apple Inc. Device [106b:00f7]
 NVIDIA Corporation GK107M [GeForce GT 650M Mac Edition] [10de:0fd5] (rev ff) (prog-if ff)
InstallationDate: Installed on 2013-07-11 (14 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MachineType: Apple Inc. MacBookPro10,1
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: ro root=/dev/sda4 initrd=\EFI\Ubuntu\initrd.img-3.10.2-031002-generic
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/21/2012
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP101.88Z.00EE.B03.1212211437
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-C3EC7CD22292981F
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookPro10,1
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-C3EC7CD22292981F
dmi.modalias: dmi:bvnAppleInc.:bvrMBP101.88Z.00EE.B03.1212211437:bd12/21/2012:svnAppleInc.:pnMacBookPro10,1:pvr1.0:rvnAppleInc.:rnMac-C3EC7CD22292981F:rvrMacBookPro10,1:cvnAppleInc.:ct10:cvrMac-C3EC7CD22292981F:
dmi.product.name: MacBookPro10,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
version.compiz: compiz 1:0.9.9~daily13.06.19~13.04-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.43-0ubuntu1.1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.1.4-0ubuntu0.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.1.4-0ubuntu0.1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.3-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2b2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.6-0ubuntu4.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.7-0ubuntu1
xserver.bootTime: Fri Jul 26 13:58:40 2013
xserver.configfile: default
xserver.errors:
 Failed to load module "nvidia" (module does not exist, 0)
 Failed to load module "nvidia" (module does not exist, 0)
 NOUVEAU(G0): [XvMC] Failed to initialize extension.
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.3-0ubuntu6
xserver.video_driver: intel

Prem Anand (h.prem.anand) wrote :
Prem Anand (h.prem.anand) wrote :
Prem Anand (h.prem.anand) wrote :
Prem Anand (h.prem.anand) wrote :
sjlevine (sjlevine) wrote :

Hello all,

I was wondering if anyone has made any progress on this, or figured out what is going on? I am getting nearly the same error message when either logging out or shutting own. I've attached the relevant section of /var/log/kern.log.

Interestingly, I also have MacbookPro10,1. I never encountered this issue until I just recently switched from using my discrete graphics chip (with either propietary nVidia or the nouveau driver), to using the integrated graphics card. That's when this message started appearing.

Thanks so much!

Prem Anand, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux REPLACE-WITH-BUG-NUMBER

If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc6

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: latest-bios-b03
Changed in xorg (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
affects: xorg (Ubuntu) → linux (Ubuntu)
Prem Anand (h.prem.anand) wrote :

I dont see this crash with 3.13.0-4-generic (14.04) and 3.13.0-6-generic (13.10) kernel version. Both logout/login and supend/resume works perfectly fine.

Though I do have problems now with switching off the dedicated video card. Though the integrated card powers the display, still on switching off the dedicated card, the screen turn blank. But thats a different issue

Prem Anand, would you need a backport to a release prior to Trusty, or may this be closed as Status Invalid?

Prem Anand (h.prem.anand) wrote :

Please feel free to close this issue

Prem Anand, this bug report is being closed https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1205329/comments/10 due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.