Ubuntu

Modprobe doesn't recognize any parameters on 3.10.0-4

Reported by Kelly Hyde on 2013-07-19
144
This bug affects 26 people
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Critical
Andy Whitcroft

Bug Description

After updating today to kernel 3.10.0-4 on Ubuntu GNOME 13.10 (Macbook Pro 8,2), I am unable to boot graphically. Recovery mode boot works fine. When attempting to boot using integrated graphics, the syslog gets spammed with this sequence of errors over and over:

Jul 19 19:07:09 polarimetric-MacBookPro acpid: 1 client rule loaded
Jul 19 19:07:09 polarimetric-MacBookPro kernel: [ 26.475546] i915: Unknown parameter `modeset'
Jul 19 19:07:09 polarimetric-MacBookPro gdm-simple-slave[1426]: Child process 1432 was already dead.
Jul 19 19:07:09 polarimetric-MacBookPro gdm-simple-slave[1426]: GLib-GObject: g_object_ref: assertion 'object->ref_count > 0' failed
Jul 19 19:07:09 polarimetric-MacBookPro gdm-simple-slave[1426]: GLib-GObject: g_object_unref: assertion 'object->ref_count > 0' failed
Jul 19 19:07:09 polarimetric-MacBookPro gdm[1189]: GdmDisplay: display lasted 0.096139 seconds
Jul 19 19:07:09 polarimetric-MacBookPro gdm[1189]: GdmDisplay: display lasted 0.097622 seconds
Jul 19 19:07:09 polarimetric-MacBookPro acpid: client 1432[0:0] has disconnected

This error only occurs if modprobe parameters are passed at boot, so the problem appears to be with modprobe. All module parameters are said to be invalid. After boot, attempting to insert a module results in the same error.

EDIT: Please ignore the version string in the below information; I'm reporting this bug from 3.10.0-3 but it only affects 3.10.0-4.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: linux-image-3.10.0-3-generic 3.10.0-3.12
ProcVersionSignature: Ubuntu 3.10.0-3.12-generic 3.10.1
Uname: Linux 3.10.0-3-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.11-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: polarimetric 1862 F.... pulseaudio
Date: Fri Jul 19 19:35:57 2013
HibernationDevice: RESUME=UUID=8b32a68d-d883-4492-8fa1-a2cf30529ec6
InstallationDate: Installed on 2013-06-06 (43 days ago)
InstallationMedia: Ubuntu-GNOME 13.04 "Raring Ringtail" - Release amd64 (20130424)
MachineType: Apple Inc. MacBookPro8,2
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB:
 0 EFI VGA
 1 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.10.0-3-generic root=UUID=070a2baf-a3a7-4034-aeaf-419e7b9df4f7 ro quiet splash i915.modeset=1 i915.lvds_channel_mode=2 i915.lvds_use_ssc=0 intel_pstate=enable vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.10.0-3-generic N/A
 linux-backports-modules-3.10.0-3-generic N/A
 linux-firmware 1.112
SourcePackage: linux
UpgradeStatus: Upgraded to saucy on 2013-06-28 (21 days ago)
dmi.bios.date: 01/24/12
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP81.88Z.0047.B27.1201241646
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-94245A3940C91C80
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookPro8,2
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-94245A3940C91C80
dmi.modalias: dmi:bvnAppleInc.:bvrMBP81.88Z.0047.B27.1201241646:bd01/24/12:svnAppleInc.:pnMacBookPro8,2:pvr1.0:rvnAppleInc.:rnMac-94245A3940C91C80:rvrMacBookPro8,2:cvnAppleInc.:ct10:cvrMac-94245A3940C91C80:
dmi.product.name: MacBookPro8,2
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Kelly Hyde (polarimetric) wrote :
summary: - Kernel 3.10.0-4 fails on graphical boot with i915
+ Kernel 3.10.0-4 fails on graphical boot with i915 (MacBook Pro 8,2)
description: updated

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

also problems with nvidia and new kernel 3.10.0-4 x64 on ubuntu saucy (unity). with previous kernel 3.10.0-3 there were no errors.
really strage behaviour with keyboard, mouse. system is unusable. had to revert to 3.10.0-3.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdm (Ubuntu):
status: New → Confirmed
Jean-Louis Dupond (dupondje) wrote :

Same here with Optimus system:
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 540M] (rev a1)

3.10.0-4 is broken, 3.10.0-3 works fine.

The -4 kernel gives following error:
Jul 20 22:08:03 laptop-jl kernel: [ 22.626903] i915: Unknown parameter `i915_enable_rc6'

summary: - Kernel 3.10.0-4 fails on graphical boot with i915 (MacBook Pro 8,2)
+ Kernel 3.10.0-4 fails on graphical boot with i915

@Jean-Louis Dupond, are you using GDM or are you using a different display manager? If you're experiencing the same thing and not using GDM/Ubuntu GNOME, I'll mark the bug as not affecting GDM.

Jean-Louis Dupond (dupondje) wrote :

I'm using Lightdm, so set gdm bug as invalid.

Changed in gdm (Ubuntu):
status: Confirmed → Invalid
Robert Hooker (sarvatt) wrote :

There were absolutely no changes that would cause this in 3.10.0-4 compared to -3 (only 3 patches, one for hyperv, one to enable dynamic debugging, and one adding a pci id for a realtek sd card reader..). Can you attach /var/log/kern.log and /var/log/kern.log.1 that will have historical dmesg info from the failure?

Jul 19 19:07:09 polarimetric-MacBookPro kernel: [ 26.475546] i915: Unknown parameter `modeset'

This seems to be the problem, passing invalid module parameters prevents a module from loading but that is not an invalid parameter so this is the mystery..

Kelly Hyde (polarimetric) wrote :

Yeah, I thought it was strange because I looked at the changelog for 3.10.0-4 and nothing logically corresponded with this. Since I'm getting "modeset" is an invalid parameter and Jean-Louis is getting that "i915_enable_rc6" is invalid, I'm guessing i915 is completely broken (or modprobe, but I assume that would affect all modules and not just i915).

I've attached the kernel log. All of the relevant boots occurred on July 19 at around 7:00 pm (the error messages that I pasted into the original bug report occurred at Jul 19 19:07:09).

Robert Hooker (sarvatt) wrote :

So its pretty clear i915 not loading is the problem from that, if you sudo upgrade-initramfs -u -k 3.10.0-3-generic does it break the -3 kernel too? 3.11 allows invalid module parameters instead of preventing the module from loading so whatever is broken here will be "fixed" soon when saucy is updated. I'm at a loss at what is going wrong there though.. Hopefully someone else has more insight into it.

Robert Hooker (sarvatt) wrote :

update-initramfs I meant there, not upgrade..

Jean-Louis Dupond (dupondje) wrote :

Ok I did some additional debugging.

update-initramfs -u -k 3.10.0-3-generic:
3.10.0-3 still boots fine, so update-initramfs doesn't break it.

update-initramfs -u -k 3.10.0-4-generic:
Neither does it fix the problem on -4 kernel

boot arguments:
The defaults are:
linux /boot/vmlinuz-3.10.0-4-generic root=UUID=af3a67b1-5cbf-48f1-b0b7-0848ae3017b4 ro quiet splash modeset=1 pcie_aspm=force i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1 $vt_handoff

When changing it to:
linux /boot/vmlinuz-3.10.0-4-generic root=UUID=af3a67b1-5cbf-48f1-b0b7-0848ae3017b4 ro quiet splash $vt_handoff
the -4 kernel boots fine ...

What I also noticed it the following error:
[ 23.139890] kvm_intel: Unknown parameter `nested'

This does NOT happen on -3 kernel. So it seems like modprobe or so is broken for -4 kernel?!

Jean-Louis Dupond (dupondje) wrote :

Booted system.

Kernel -3:
jean-louis@laptop-jl:~$ sudo modprobe kvm_intel nested=1
jean-louis@laptop-jl:~$

=> Works fine, no errors.

Kernel -4:
jean-louis@laptop-jl:~$ sudo modprobe kvm_intel nested=1
ERROR: could not insert 'kvm_intel': Unknown symbol in module, or unknown parameter (see dmesg)
jean-louis@laptop-jl:~$

[ 73.489551] kvm_intel: Unknown parameter `nested'

Modinfo shows it correctly:
jean-louis@laptop-jl:~$ sudo modinfo kvm_intel
filename: /lib/modules/3.10.0-4-generic/kernel/arch/x86/kvm/kvm-intel.ko
license: GPL
author: Qumranet
srcversion: 9D8476E87E7863E3B6491DF
alias: x86cpu:vendor:*:family:*:model:*:feature:*0085*
depends: kvm
intree: Y
vermagic: 3.10.0-4-generic SMP mod_unload modversions
parm: vpid:bool
parm: flexpriority:bool
parm: ept:bool
parm: unrestricted_guest:bool
parm: eptad:bool
parm: emulate_invalid_guest_state:bool
parm: vmm_exclusive:bool
parm: fasteoi:bool
parm: enable_apicv:bool
parm: enable_shadow_vmcs:bool
parm: nested:bool
parm: ple_gap:int
parm: ple_window:int

Jean-Louis Dupond (dupondje) wrote :

Daily build is also fine:
jean-louis@laptop-jl:~$ uname -a
Linux laptop-jl 3.11.0-999-generic #201307210423 SMP Sun Jul 21 08:24:50 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Kelly Hyde (polarimetric) wrote :

Yeah, my system boots fine with 3.10.0-4 if I remove all of the i915 parameters in GRUB too. Those parameters used to be required to get a working framebuffer on the MBP 8,2 but I guess they aren't anymore.

I'll update the description and title based on the new information.

description: updated
summary: - Kernel 3.10.0-4 fails on graphical boot with i915
+ Modprobe doesn't recognize any parameters on 3.10.0-4
Jean-Louis Dupond (dupondje) wrote :

Did rebuild both kernels with pbuilder-dist.

But it remains the same:
3.10.0-4: broken
3.10.0-3: ok

Andy Whitcroft (apw) on 2013-07-22
Changed in linux (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Andy Whitcroft (apw)
importance: Undecided → Critical
Andy Whitcroft (apw) wrote :

This was triggered by a SAUCE patch which now has a bad interaction with mainline. Pulled it out until we resolve the issue.

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
tags: added: kernel-key
tags: added: regression-update
Haw Loeung (hloeung) wrote :

Hi,

FYI, 3.10.0-5 works fine for me. Thanks.

tags: removed: kernel-key
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.10.0-5.14

---------------
linux (3.10.0-5.14) saucy; urgency=low

  [ Andy Whitcroft ]

  * Release Tracking Bug
    - LP: #1203779

  * Revert "SAUCE: (no-up) add option to hand off all kernel parameters to
    init"
    - LP: #1203211
  * [Packaging] generate a SRCPKGNAME-udebs-FLAVOUR-di depending on all
    built udebs
  * [Config] enable SRCPKG-udeb-FLAVOUR-di for master
  * [Config] enforcer -- relax CONFIG_INIT_PASS_ALL_PARAMS until we fix the
    associated patch
    - LP: #1203211
  * rebase to v3.10.2

  [ Stephen Warren ]

  * add missing i2c-tegra module into armhf udebs

  [ Upstream Kernel Changes ]

  * rebase to v3.10.2
 -- Andy Whitcroft <email address hidden> Mon, 22 Jul 2013 16:09:25 +0100

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1203211

tags: added: iso-testing
axeoth (axeoth) wrote :

Not sure if it is the same problem, but:

$ modprobe -l
modprobe: invalid option -- 'l'

$ modprobe --list
modprobe: unrecognized option '--list'

$ uname -a
Linux saucy64 3.10.0-6-generic #17-Ubuntu SMP Fri Jul 26 18:29:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Apparently, modprobe does not recognize the "--list" option.

axeoth (axeoth) wrote :

More: the "--list" and "-l" options do not even appear in the help:

$modprobe --help
Usage:
 modprobe [options] [-i] [-b] modulename
 modprobe [options] -a [-i] [-b] modulename [modulename...]
 modprobe [options] -r [-i] modulename
 modprobe [options] -r -a [-i] modulename [modulename...]
 modprobe [options] -c
 modprobe [options] --dump-modversions filename
Management Options:
 -a, --all Consider every non-argument to
                             be a module name to be inserted
                             or removed (-r)
 -r, --remove Remove modules instead of inserting
     --remove-dependencies Also remove modules depending on it
 -R, --resolve-alias Only lookup and print alias and exit
     --first-time Fail if module already inserted or removed
 -i, --ignore-install Ignore install commands
 -i, --ignore-remove Ignore remove commands
 -b, --use-blacklist Apply blacklist to resolved alias.
 -f, --force Force module insertion or removal.
                             implies --force-modversions and
                             --force-vermagic
     --force-modversion Ignore module's version
     --force-vermagic Ignore module's version magic

Query Options:
 -D, --show-depends Only print module dependencies and exit
 -c, --showconfig Print out known configuration and exit
 -c, --show-config Same as --showconfig
     --show-modversions Dump module symbol version and exit
     --dump-modversions Same as --show-modversions

General Options:
 -n, --dry-run Do not execute operations, just print out
 -n, --show Same as --dry-run
 -C, --config=FILE Use FILE instead of default search paths
 -d, --dirname=DIR Use DIR as filesystem root for /lib/modules
 -S, --set-version=VERSION Use VERSION instead of `uname -r`
 -s, --syslog print to syslog, not stderr
 -q, --quiet disable messages
 -v, --verbose enables more messages
 -V, --version show version
 -h, --help show this help

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers